Studio
2022.10
false
重要 :
このコンテンツの一部は機械翻訳によって処理されており、完全な翻訳を保証するものではありません。
Studio ガイド
Last updated 2024年7月15日

キーボード ショートカット

UiPath Studio のキーボード ショートカットのリストを次に示します。

ファイルの管理

Ctrl + Shift + N - 新しい空のプロセスを作成します。

Ctrl + C - [プロジェクト] パネルからクリップボードにファイルをコピーします。Ctrl + V を使用して、ツリーの任意の場所に貼り付けます。

Ctrl + O - 過去に作成したワークフローを開くことができます。.xaml または project.json ファイルです。

Ctrl + L - ログ ファイルが格納されているフォルダーを開きます。

Ctrl + S - 現在開いているワークフローを保存します。

Ctrl + Shift + S - 現在開いているすべてのワークフローを保存します。

Ctrl + V - クリップボードから [プロジェクト] パネルにファイルを貼り付けます。

Ctrl + Tab - デザイナー パネルで開いているワークフロー間でフォーカスを移動します。

Ctrl + W - デザイナー パネルでフォーカスされているワークフロー ファイルを閉じます。

Alt + F7 - Studio パネル間のフォーカスを移動します。Ctrl + Tab または Alt + F7 を使用して修飾キー (Ctrl または Alt) を押したままにすると、次のウィンドウが表示され、Studio でアクティブなファイルやパネルを切り替えられます。



コメント

Ctrl + D - 現在選択しているアクティビティを [コメント アウト] コンテナーに配置して無視します。

Ctrl + E - [コメント アウト] コンテナーに配置されているアクティビティをコンテナーから削除します。

デバッグ

F9 - 選択したアクティビティにブレークポイントのマークを付けます。

Ctrl + Shift + B - [ブレークポイント] パネルを開きます。

Ctrl + Alt + E - [エラー リスト] パネルを開きます。

F10 - デバッグ時に、現在選択しているワークフロー内のアクティビティのブロックをステップ オーバー実行します。

F11 - デバッグ時に、アクティビティのブロックにステップ インして 1 つ目のアクティビティを実行できます。

Shift + F11 - デバッグ時に、最後のアクティビティが実行された後に現在のコンテナーからステップ アウトします。

レコーディング

Ctrl + Alt + B - [ベーシック レコーディング] ツールバーを開きます。

Ctrl + Alt + C - [Citrix レコーディング] ツールバーを開きます。

Ctrl + Alt + D - [デスクトップ レコーディング] ツールバーを開きます。

Ctrl + Alt + W - [Web レコーディング] ツールバーを開きます。

F2 - 記録操作中に遅延を追加します。

F3 - 独自の記録領域を指定できます。

F4 - 記録する UI フレームワークを 既定値、AA、および UIA から選択できます。

ワークフローの分析と実行

F5 - メインとして .xaml ファイル セットから始めて、デバッグ モードで現在のプロジェクトを実行します。

Ctrl + F5 - 現在のプロジェクトを実行します。

F6 - デバッグ モードで現在開いている .xaml ファイルを実行します。
Ctrl + F6 - 現在開いている .xaml ファイルを実行します。

F7 - ファイルに検証エラーとワークフロー アナライザーの違反があるかチェックします。

Shift + F7 - プロジェクト全体に検証エラーとワークフロー アナライザーの違反があるかチェックします。

F8 - 現在開いているワークフローに検証エラーがないかチェックします。

Shift + F8 - すべてのプロジェクト ファイルの検証エラーをチェックします。

Pause - 現在のワークフローの実行を一時停止します (標準モードとデバッグ モードの両方)。

F12 - 現在のワークフローの実行を停止します (標準モードとデバッグ モードの両方)。

選択したアクティビティ

Ctrl + T - アクティビティを [トライ キャッチ] アクティビティの [Try] セクション内に配置します。

Ctrl + N - 新しいシーケンス ダイアグラムを現在のプロジェクトに作成します。

Ctrl + C - 選択した 1 つ以上のアクティビティをクリップボードにコピーします。

Ctrl + V - コピーした 1 つ以上のアクティビティを選択した項目の中に貼り付けます。

Ctrl + K - 入力フィールドまたは式エディターで使用すると、アクティビティの必須の型と同じ型の変数を作成します。フィールドに式が既に存在する場合は、Ctrl + K を押す前にその式または式の一部を選択し、選択したテキストを新しい変数の名前として使用できます。

Ctrl + M - 入力フィールドまたは式エディターで使用すると、アクティビティの必須の型と同じ型の入力引数を作成します。フィールドに式が既に存在する場合は、Ctrl + M を押す前にその式または式の一部を選択し、選択したテキストを新しい引数の名前として使用できます。

Ctrl + Shift + M - 入力フィールドまたは式エディターで使用すると、アクティビティの必須の型と同じ型の出力引数を作成します。フィールドに式が既に存在する場合、Ctrl + Shift + M を押す前にその式または式の一部を選択し、選択したテキストを新しい引数の名前として使用できます。

Ctrl + Shift + E - アクティビティの入力フィールド内で使用すると、式エディターが開きます。

Ctrl + Space - IntelliPrompt ウィンドウを開きます。

F2 - 選択されたアクティビティの名前の変更を可能にします。

Shift + F2 - 選択したアクティビティに注釈を追加します。

Enter - アクティビティ入力フィールドに追加されたデータを保存します。

Shift + Enter - アクティビティの入力フィールドに新しい行を追加します。

Tab - 入力フィールド上でマウスをホバーすると表示される メニューなどの、アクティビティのフィールドやボタンの間を移動します。

テスト オートメーション

Ctrl + Alt + T - [テスト エクスプローラー] パネルを開きます。これは、デザイナー パネルの任意の場所で使用できます。

Alt + T - テスト エクスプローラー[テスト結果] サブパネルを開きます。これは、[テスト エクスプローラー] パネルでのみ使用できます。

Alt + A - テスト エクスプローラー[アクティビティ] サブパネルを開きます。これは、[テスト エクスプローラー] パネルでのみ使用できます。

引数ダイアログ

[ワークフロー ファイルを呼び出し] および [.NET コードを挿入] などのアクティビティで使用できる [引数] ダイアログ ボックスでは、以下のキーボード ショートカットを使用できます。

Tab - グリッド内の項目間を移動します。

Delete - グリッドで選択した項目を削除します。

F2 - 編集のために現在のセルを強調表示して、カーソルを行の末尾に置きます。

Ctrl + Tab - グリッドで選択した項目について、ウィンドウ内で使用可能なオプション間を移動します (削除、上に移動、下に移動)。

ステータス バー

Alt + D - ステータス バーの [ソース管理]、Orchestrator のフォルダー、[Orchestrator/Cloud の接続] メニューにアクセスし、Shift + Tab キーを使用してメニューを切り替えます。メニューを選択したら、Enter キーを押して開きます。

Backstage ビュー

Ctrl + Tab - タブ間のフォーカスを移動します。[ツール] タブと [設定] タブ内のサブタブにも適用されます。

Tab - タブ内のコンテンツ間でフォーカスを移動します。

その他

F1 - 選択した要素に関連したヘルプ トピックにアクセスできます。

Alt + F4 - 現在のウィンドウを閉じます。

Alt + - 現在選択しているパネルのタイトル バーで [オプション] コンテキスト メニューを開きます。この操作は、テンキー内のマイナス記号キーではなく、文字キー上のハイフン キーを使用することで可能になります。

Windows キー + 上矢印 - 現在のウィンドウを最大化します。

Windows キー + 下矢印 - 現在のウィンドウを元に戻します。

Ctrl + P - [パッケージを管理] ウィンドウを開きます。

Esc - [パブリッシュ][パッケージを管理]ファイル差分検出の各ウィンドウを閉じます。

Ctrl + F1 - リボンを最小化または展開します。

Ctrl + Shift + R - 未使用のプロジェクト依存関係をすべて削除します。

Shift + Tab - [アクティビティ] パネル内の前のアクティビティまたはノードに移動します。

Ctrl + Z - 直前の操作を元に戻します。

Ctrl + Y - 直前に元に戻した操作をやり直します。

Shift + F10 - 選択した項目のコンテキスト メニューを開きます (右クリック)。

Ctrl + Tab - Tab キーを押すとタブが挿入される複数行のテキスト ボックスからフォーカスを移動します。

Ctrl + Shift + F10 - 選択した項目のツールチップ コンテンツを閉じます。

Ctrl + Shift + Q - キーボードを使用してテキスト エディター内を移動する場合に、ツールチップに追加情報を表示します。

リボンと [ホーム] タブのショートカット キー

Alt キーを押して放した後、1 つ以上のキーを押すことで、[ホーム] タブ (Studio の Backstage ビュー) のほとんどのオプション、および [デザイン] タブと [デバッグ] タブのリボンにすばやくアクセスできます。

Alt キーを押して放すと、1 つ以上の文字または数字が現在のビューのオプションの上に表示されます。オプションを使用するには、該当するキー (複数可) を押します。最初のキーの組み合わせを押した後に、追加のキーを使用できるオプションもあります。



ショートカットのリストについては、以下のセクションをご覧ください。

[デザイン] タブのリボンのキー

[デザイン] タブまたは [デバッグ] タブを表示している場合は、Alt + D を押して、[デザイン] タブのリボンのショートカット キーにアクセスします。

キー

実行する操作

追加のキーとアクション

n

[新規] ドロップダウンを開く

S

[保存] ドロップダウンを開く

S - 名前を付けて保存

L - すべて保存

ET

[テンプレートとしてエクスポート] ウィンドウを開く

R

[ファイルをデバッグ] ドロップダウンを開く

C - ファイルを実行

B - プロジェクトをデバッグ

D - プロジェクトを実行

X

選択したアクティビティを切り取り

C

選択したアクティビティをコピー

V

コピーしたアクティビティを貼り付け

MP

[パッケージを管理] ウィンドウを開く

ME

[エンティティを管理] ウィンドウを開く

EW

[サービス エディター] ウィンドウを開く

U

[UI Explorer] ウィンドウを開く

IU

[未使用を削除] ドロップダウンを開く

F - 未使用のワークフローを削除

A - 未使用の変数を削除

B - 未使用の引数を削除

C - 未使用の依存関係を削除

D - 未使用のインポートを削除

E - 未使用のスクリーンショットを削除

A

[ファイルを分析] ドロップダウンを開く

B - プロジェクトを分析

C - ファイルを検証

D - プロジェクトを検証

S - ワークフロー アナライザーの設定

EX

[Excel にエクスポート] ウィンドウを開く

p

[パブリッシュ] ウィンドウを開く

[デバッグ] タブのリボンのキー

[デザイン] タブまたは [デバッグ] タブを表示している場合は、Alt + E を押して、[デバッグ] タブのリボンのショートカット キーにアクセスします。

キー

実行する操作

追加のキーとアクション

R

[ファイルをデバッグ] ドロップダウンを開く

C - ファイルを実行

B - プロジェクトをデバッグ

D - プロジェクトを実行

B

実行を中断

T

実行を停止

S

ステップ イン

V

ステップ オーバー

O

ステップ アウト

ER

リトライ

EI

無視

ES

再実行

F

フォーカス

p

[ブレークポイント] ドロップダウンを開く

T - ブレークポイントを切り替え

P - ブレークポイント パネルを表示

LS

低速ステップの速度を設定

LE

実行証跡を有効化/無効化

LH

要素の強調表示を有効化/無効化

LA

アクティビティをログを有効化/無効化

LC

[例外発生時に続行] を有効化/無効化

LP

ピクチャ イン ピクチャを有効化/無効化

LR

[リモート デバッグ] ドロップダウンを開く

C - リモート デバッグを設定

LO

ログ フォルダーを開く

タイトル バーのキー

(ウィンドウの右上隅の) Studio のタイトル バーにあるボタンのキーにアクセスするには、Alt キーを押します。

キー

実行する操作

追加のキーとアクション

F

[フィードバックを送る] ウィンドウを開く

 

L

[ヘルプ] ドロップダウンを開く

 

I

[サインイン]/[サインアウト] メニューを開く

 
[ホーム] タブのキー

[デザイン] タブまたは [デバッグ] タブを表示している場合は、Alt + H を押して [ホーム] タブ (Studio の Backstage ビュー) を開き、[ホーム] タブのショートカット キーにアクセスします。[ホーム] タブを既に開いている場合は、Alt キーを押すだけです。

キー

実行する操作

追加のキーとアクション

Z

プロジェクトが開いている場合、前のタブに戻る

O

プロジェクトを開く

C

現在開いているプロジェクトを閉じる

S

[開始] タブを開く

O - ローカル プロジェクトを開く

C - プロジェクトを複製またはチェック アウト

P - プロセスを作成

L - ライブラリを作成

A - テスト オートメーションを作成

T - テンプレートを作成

1...9 - 直近の 9 つのプロジェクトのいずれかを開く

T

[テンプレート] タブを開く

M

[チーム] タブを開く

L

[ツール] タブを開く

U - UI Explorer を開く

M - プロジェクト依存関係一括更新ツールを開く

R - Microsoft Office 修復ツールを開く

C - Chrome 拡張機能をインストール

F - Firefox 拡張機能をインストール

E - Edge 拡張機能をインストール

J - Java 拡張機能をインストール

S - Silverlight 拡張機能をインストール

T - Citrix 拡張機能をインストール

W - Windows リモート デスクトップ拡張機能をインストール

V - VMware Horizon 拡張機能をインストール

E

[設定] タブを開く

G - [全般] タブを開く

D - [デザイン] タブを開く

L - [場所] タブを開く

M - [パッケージ ソースを管理] タブを開く

P - [ライセンスとプロファイル] タブを開く

T - [チーム] タブを開く

B - [Labs] タブを開く

H

[ヘルプ] タブを開く

D - 製品ドキュメントのリンクを開く

F - コミュニティ フォーラムのリンクを開く

M - ヘルプ センターのリンクを開く

A - アカデミーのリンクを開く

R - リリース ノートのリンクを開く

S - 簡単なアンケートに回答するのリンクを開く

T - クイック チュートリアルのリンクを開く

C - ライセンス情報をコピー

このページは役に立ちましたか?

サポートを受ける
RPA について学ぶ - オートメーション コース
UiPath コミュニティ フォーラム
Uipath Logo White
信頼とセキュリティ
© 2005-2024 UiPath. All rights reserved.