- リリース ノート
- 基本情報
- セットアップと構成
- オートメーション プロジェクト
- 依存関係
- ワークフローの種類
- ファイルの比較
- オートメーションのベスト プラクティス
- ソース管理との連携
- デバッグ
- 診断ツール
- ワークフロー アナライザー
- 変数
- 引数
- インポートされた名前空間
- コード化されたオートメーション
- トリガーベースの有人オートメーション
- 制御フロー
- オブジェクト リポジトリ
- ログ
- ScreenScrapeJavaSupport ツール
- Studio でのテスト
- 拡張機能
- トラブルシューティング

Studio ガイド
トラブルシューティング
このページでは、Citrix 環境でオートメーションを実行するときに発生する可能性のある問題の修正方法について説明します。
仮想チャネルが既定でブロックされる
説明
Citrix Virtual Apps and Desktops 7 2109 以降、カスタム仮想チャネルはすべて既定でブロックされます。
この新しいバージョンの Citrix にアップグレードすると、UiPath リモート ランタイムを使用する Citrix の既存のオートメーションは停止します。
解決策
UiPath 仮想チャネルを許可リスト ポリシーに追加する必要があります。この操作は、こちらの手順に従って実行できます。
以下の値を許可リスト ポリシーに追加する必要があります。
UIPCTX,<UiPathRemoteRuntime-Install_Path>\UiPathRemoteRuntime.exe
例:
UIPCTX,C:\Program Files (x86)\UiPath\RemoteRuntime\UiPathRemoteRuntime.exe
Citrix App で対話型の選択がフリーズし、何も選択されない
現象
UiPath Citrix 拡張機能のインストール後に Citrix App から UI 要素を選択しようとすると、対話型の選択が 1 分間フリーズし、何も選択されません。
原因
この現象は、UiPath リモート ランタイムが Citrix App セッションで実行されていない場合に発生します。
解決策
-
Citrix アプリが開かれている Citrix アプリケーション サーバーに UiPathRemoteRuntime.msi がインストールされているかどうかを確認します。
-
Citrix アプリケーション サーバーで、UiPathRemoteRuntime.exe プロセスが実行中であるかどうかを確認します。UiPathRemoteRuntime.msi がインストールされ、Citrix App セッションのログインでプロセスが自動的に開始されます。
注:Citrix アプリケーション サーバーに UiPathRemoteRuntime.msi をインストールできない場合は、 こちらに記載されているとおり、クライアント マシンから UiPath Citrix 拡張機能をアンインストールすることをお勧めします。
「C:\Program Files (x86)\Citrix\ICA Client\UIPathPluginCitrix.dll"」ファイルにコピーできない。このファイルは別のプロセスで使用されている。
現象
UiPath Citrix 拡張機能をインストールしようとすると、次のエラーが表示されます。

原因
これは、UiPath Citrix 拡張機能がインストールされていて、開いている Citrix App がこれを使用している場合に発生します。
解決策
すべてのアクティブな Citrix App セッションを閉じ (手順についてはこちらを参照)、UiPath Citrix 拡張機能を再インストールします。
次の Citrix レジストリ キーを読み取れない: 'SOFTWARECitrixInstallICA Client' Value: 'InstallFolder'
現象
UiPath Citrix 拡張機能をインストールしようとすると、次のエラーが表示されます。

原因
このエラー メッセージは、Citrix Receiver がインストールされていない場合に表示されます。また、Citrix Receiver for Universal Windows Platform がインストールされている場合にも表示されます。
解決策
Citrix Receiver または Citrix Workspace をダウンロードしてインストールします。
wfica32.exe での処理されない例外 0xC0000094: ゼロによる整数の除算
現象
ターゲットの Citrix アプリが起動に失敗し、Citrix ICA クライアントがクラッシュしました。
原因
Citrix アプリが読み込まれる前に、GetWindowText 関数を使用するアクティビティ ([要素の存在を確認]など) が実行されました。
解決策
このアクティビティの前に遅延を追加して、Citrix アプリを読み込む時間を確保します。
高 DPI で対話型の選択と要素の識別が機能しない
現象
Windows 向け Citrix Workspace アプリ (CWA) 2206 以降では、高 DPI ポリシー設定が適用されていない場合、ディスプレイの DPI スケールが 100% を超えると、Citrix アプリで対話型の選択や要素識別が機能しないことがあります。
原因
これは、Windows 向け Citrix Workspace アプリ 2206 での DPI サポートの変更が原因で発生します。
解決策
Enable_DPI レジストリ値を Computer\HKEY_CURRENT_USER\SOFTWARE\Citrix\ICA Client\DPI から削除します。

- 仮想チャネルが既定でブロックされる
- 説明
- 解決策
- Citrix App で対話型の選択がフリーズし、何も選択されない
- 現象
- 原因
- 解決策
- 「C:\Program Files (x86)\Citrix\ICA Client\UIPathPluginCitrix.dll"」ファイルにコピーできない。このファイルは別のプロセスで使用されている。
- 現象
- 原因
- 解決策
- 次の Citrix レジストリ キーを読み取れない: 'SOFTWARECitrixInstallICA Client' Value: 'InstallFolder'
- 現象
- 原因
- 解決策
- wfica32.exe での処理されない例外 0xC0000094: ゼロによる整数の除算
- 現象
- 原因
- 解決策
- 高 DPI で対話型の選択と要素の識別が機能しない
- 現象
- 原因
- 解決策