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Studio ガイド
最終更新日 2023年12月20日

Microsoft Office Interop の問題

問題

Microsoft Office アプリケーション、特に Excel でオートメーションを構築または実行するときに、さまざまなエラーが発生する可能性があります。

Excel

  • StudioX プロファイルでアクティビティを設定し、プラス メニューの [Excel 内で示す] を選択するときに、以下のいずれかのエラーが発生します。

    • ブックを開くときにエラーが発生しました。Excel がインストールされていることをご確認ください。
    • Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).::(ライブラリが登録されていません。(HRESULT からの例外: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).::)



  • Excel アクティビティの実行時に以下のエラーが発生します。

ブックを開くときにエラーが発生しました。Excel がインストールされていることをご確認ください。Unable to cast COM object of type 'Microsoft.Office.Interop.Excel.ApplicationClass' to interface type 'Microsoft.Office.Interop.Excel._Application'. ('Microsoft.Office.Interop.Excel.ApplicationClass' の種類の COM オブジェクトを 'Microsoft.Office.Interop.Excel._Application' の種類のインターフェイスにキャストできません。)

Word

  • Word アクティビティの実行時に以下のエラーが発生します。

ドキュメントを開くときにエラーが発生しました。Word アプリケーションがインストールされていることをご確認ください。既にインストールされている場合は、Office の修復が必要な可能性があります。

Outlook

  • Outlook アクティビティの実行時、または StudioX プロファイル内でアクティビティを設定し、プラス docs image メニューからフォルダーやアカウントなどの Outlook データにアクセスしようとすると、以下のエラーが発生します。

Property accessor 'Account' on object 'UiPath.Mail.Activities.Business.OutlookApplicationCard' threw the following exception:'Unable to cast COM object of type 'Microsoft.Office.Interop.Outlook.ApplicationClass' to interface type 'Microsoft.Office.Interop.Outlook._Application'... (オブジェクト 'UiPath.Mail.Activities.Business.OutlookApplicationCard' に対するプロパティ アクセサー 'Account' が次の例外をスローしました。'Microsoft.Office.Interop.Outlook.ApplicationClass' の種類の COM オブジェクトを 'Microsoft.Office.Interop.Outlook._Application' の種類のインターフェイスにキャストできません。...)

PowerPoint

  • プレゼンテーション アクティビティの実行時に以下のエラーが発生します。

Cannot open PowerPoint RemoteException wrapping UiPath.Presentations.PowerPointException: Please make sure PowerPoint is installed. (PowerPoint を開けません。RemoteException wrapping UiPath.Presentations.PowerPointException: PowerPoint がインストールされていることを確認してください。)

原因

Microsoft Office のインストールの問題により、Windows レジストリの COM 相互運用の設定が適切に行われなくなる可能性があります。これは、以下の場合に発生します。

  • Microsoft Office をインストールし、その後削除してから、旧バージョンの Office をインストールした場合。
  • Microsoft Office が既にインストールされているところに、既にインストールされているバージョンの Office のものとは異なる Office コンポーネントが付属する Skype for Business がインストールされた場合。

解決策

Microsoft Office Interop 修復ツールを使用して Windows レジストリをチェックし、オートメーション構築時のエラーの原因となる Microsoft Office の一般的な問題を修復します。このツールにより、お使いのマシンに対して実行したり、他のマシンにデプロイ可能な .reg ファイルとしてエクスポートしたりすることのできる、修復計画が生成されます。
注: 修復の実行には管理者権限が必要ですが、修復計画の生成には必要ありません。

Microsoft Office Interop 修復ツールを使用する

  1. [ホーム] (Studio の Backstage ビュー) > [ツール] > [Microsoft Office Interop 修復ツール] の順に選択します。修復ツールが開きます。


  2. ウィンドウの最上部にあるタブを使用し、修復する Microsoft Office アプリケーション (Excel、Outlook、Word、または PowerPoint) を選択します。
  3. アプリケーションのインストール パスバージョン32 ビット版か 64 ビット版かの情報が、修復ツールによって自動的に検出されます。検出された情報が正しいことを確認し、必要に応じて修正します。
  4. [修復計画を生成] をクリックします。実行すべきアクションのリストが表示されます。



  5. 以下のいずれかのオプションを選択します。
    • .reg ファイルを作成 - 複数のマシンにデプロイ可能な修復アクションを使用して、.reg ファイルを生成します。
    • 修復操作を実行 - マシン上でアクションを実行します。

      選択したアクションを実行すると、その結果がウィンドウの下部に表示されます。

Microsoft Office 修復ツールを使用する

Microsoft Office Interop 修復ツールで問題が解決しない場合は Microsoft Office 修復ツールを実行してみてください。

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