Abonnieren

UiPath Studio

UiPath Studio-Anleitung

Über Automatisierungsprojekte

UiPath Studio ermöglicht die Erstellung folgender Projekttypen:

  • Prozess – Entwerfen Sie einen Automatisierungsprozess und veröffentlichen Sie ihn, damit er von Robotern ausgeführt werden kann.
  • Library - Design workflows as reusable components and publish the project as a library that can be added as a dependency to multiple processes. For more information, see About Libraries.
  • Test Automation - Design a test automation project. For more information about test automation, see the Test Suite section.
  • Template - Design a process and publish it as a template that other processes which share common characteristics can then be based on. For more information, see Project Templates.

Um ein neues leeres Projekt zu erstellen, wechseln Sie zu Start (Studio Backstage-Ansicht) > Starten und wählen Sie den Projekttyp aus, der unter Neues Projekt erstellt werden soll. Alternativ können Sie mit einer der Standardvorlagen beginnen, die unter Neu aus Vorlage verfügbar sind, oder zur Registerkarte Vorlagen wechseln, um nach weiteren Vorlagen aus verschiedenen Quellen zu suchen.

563

Konfigurieren Sie im neuen Projektfenster für jedes Projekt Folgendes:

  • Geben Sie einen Namen für das neue Projekt (bis zu 128 Zeichen) und eine Beschreibung ein, die zusammenfasst, was Sie mit diesem Automatisierungsprojekt erreichen möchten (bis zu 500 Zeichen).
  • Wählen Sie den Speicherort aus, an dem das Projekt erstellt werden soll. Der Standardspeicherort, an dem Projekte erstellt werden, lautet %USERPROFILE%\Documents\UiPath.
  • Select the compatibility and language.
    :information-source: Note: The compatibility and language cannot be changed after you create a project. However, you can convert your Windows - Legacy projects to the Windows compatibility.

Standardmäßig enthält der Projektordner die folgenden Dateien und Unterordner:

  • Files
    • Main.xaml - Created by default to hold your main workflow. In addition, all the other automation XAML files you add to the project are stored in the project folder. Optionally, you can set a different file as main. All the files must be linked through the Invoke Workflow File activity to the file set as main or to a file marked as an entry point to the project. For test automation projects, a TestCase.xaml file is created by default instead of Main.xaml.
    • project.json – Enthält Informationen über Ihr Automatisierungsprojekt.
  • Subfolders
    • .entities – Enthält Daten über Entitäten, die aus dem Data Service importiert wurden, falls diese im Projekt verwendet werden.
    • .local – Enthält lokal für das Projekt zwischengespeicherte Daten.
      :information-source: Note: The .local folder is hidden. You can enable viewing hidden items from the Windows File Explorer settings.
    • .objects – Enthält Daten im Zusammenhang mit Elementen, die dem Object Repository hinzugefügt wurden, falls diese im Projekt verwendet werden.
    • .project – Enthält Tags, die zum Projekt hinzugefügt wurden.
    • .screenshots – Enthält informative Screenshots, die in UI-Automatisierungsaktivitäten generiert werden, falls welche im Projekt verwendet werden.
    • .settings – Enthält Aktivitätsprojekteinstellungen, die zur Laufzeit verwendet werden.
    • .templates – Enthält Dateivorlagen, die dem Projekt hinzugefügt wurden.
    • .tmh – Enthält Daten im Zusammenhang mit Testfällen, falls diese im Projekt verwendet werden.

📘

Wichtig:

Projekte, die mit neueren Versionen von Studio erstellt wurden, funktionieren möglicherweise nicht mit älteren Studio-Versionen. Lesen Sie mehr über Ab- und Aufwärtskompatibilität.

You cannot use the following characters in file names: ", <, >, |, :, *, ?, \, /, ;. These characters come from Microsoft Windows restrictions and from other special character restrictions.

Festlegen der Projektkompatibilität

Wenn Sie ein neues Projekt erstellen, wählen Sie die Kompatibilität basierend auf der Umgebung aus, in der das Projekt ausgeführt wird:

  • Windows – Verwendet .NET 6 mit Windows-Unterstützung. Dies ist die Standardoption.
  • Plattformübergreifend – Verwendet .NET 6 mit plattformübergreifender Unterstützung.
  • Windows – Legacy – Verwendet .NET Framework 4.6.1., die Kompatibilität, die in Versionen vor 2021.10 verwendet wurde.

🚧

Wichtig

To learn about the differences between compatibilities, see the following table. To find out more about the design experience in each compatibility, see Designing Automations.

Windows - LegacyWindowsCross-platform
Process execution32-bit64-bit64-bit
Supported platforms for executionWindows (32-bit and 64-bit)Windows (64-bit)Windows, Linux, and macOS (64-bit)
Processes are compiled when publishedNo. Published packages contain the project source files.Yes. Published packages contain compiled DLL files.Yes. Published packages contain compiled DLL files.

Only the activities packages that support the selected compatibility can be installed from the package manager.

Die Kompatibilität jedes Projekts wird rechts neben der Studio-Statusleiste und im Panel Projekt > Abhängigkeiten-Knoten angezeigt. Die Kompatibilität wird auch im Eintrag jedes Projekts in der Liste Zuletzt verwendete öffnen unter Start (Studio Backstage-Ansicht) > Registerkarte Starten angezeigt.

Entwerfen plattformübergreifender Projekte

Mit plattformübergreifenden Projekten können Sie Automatisierungen, die keine Benutzerinteraktion erfordern, und Webbrowser-Automatisierungen mit Chrome erstellen. Plattformübergreifende Automatisierungen können auf Windows und Unix-ähnlichen Betriebssystemen wie Linux und macOS ausgeführt werden.

So erstellen Sie Unattended-Projekte mit plattformübergreifender Unterstützung:

  1. Erstellen Sie ein neues Projekt in Studio und wählen Sie die Option für die Plattformübergreifende Kompatibilität aus. Diese Option ist für alle Projekttypen verfügbar. Bei Prozessen, welche die VB-Sprache für Ausdrücke verwenden, haben Sie die Möglichkeit, in Studio sowie in Studio Web zu arbeiten (derzeit in der Vorschau verfügbar).
  2. Entwerfen Sie die Automatisierung. Bitte beachten Sie, dass nicht alle Aktivitätspakete mit plattformübergreifenden Projekten kompatibel sind, sodass im Paketmanager nur eine Auswahl der Pakete verfügbar ist. Hier erfahren Sie mehr über die Designerfahrung in plattformübergreifenden Projekten.
    Die Standardabhängigkeiten für ein plattformübergreifendes Projekt sind:
    • Im Studio-Profil: UiPath.System.Activities, UiPath.Testing.Activities, UiPath.WebApi.Activities und UiPath.UIAutomation.Activities.
    • Im StudioX-Profil: UiPath.System.Activities, Microsoft Office 365, Google Workspace und UiPath.UIAutomation.Activities.
  3. Testen Sie die Automatisierung. Es wird empfohlen, Automatisierungen auf den Maschinen zu testen, auf denen sie ausgeführt werden. Verwenden Sie dazu Remote-Debugging, das mit Windows-, Linux- und macOS-Robotern funktioniert.
  4. Veröffentlichen Sie das Projekt nach dem Testen der Automatisierung im Orchestrator. Das Verfahren zum Ausführen von Unattended-Aufträgen ist für Windows, macOS und Linux identisch.

🚧

Wichtig:

Diese Version von Studio ist nicht kompatibel mit älteren Versionen von plattformübergreifenden Aktivitätspaketen, die in Studio 2022.4 oder früher verfügbar waren. Wenn Sie plattformübergreifende Projekte in Studio-Versionen vor 2022.10 erstellt haben, aktualisieren Sie die installierten Pakete auf die neuesten Versionen, bevor Sie sie in Studio 2022.10 oder höher bearbeiten. Einige Eigenschaften können möglicherweise nicht mehr bearbeitet werden.

Wechsel zwischen Studio und Studio Web

📘

Hinweis:

Studio Web ist derzeit als Vorschau verfügbar.

Wenn Sie Ihre plattformübergreifenden Projekte unterwegs von einem beliebigen Gerät aus direkt über den Browser entwickeln möchten, können Sie Projekte zur Cloud hinzufügen und sie in Studio Web, dem Automatisierungsdesigner in der UiPath Automation Cloud, bearbeiten. Wenn Sie ein Projekt zur Cloud hinzufügen, werden Änderungen immer synchronisiert, sodass Sie nahtlos zwischen Desktop und Web wechseln und dort weitermachen können, wo Sie aufgehört haben.

Um mit Studio Web kompatibel zu sein, muss ein plattformübergreifendes Projekt die folgenden Anforderungen erfüllen:

  • Der Projekttyp ist „Prozess“.
  • Die Sprache für Ausdrücke ist „VB“.
  • Das Projekt enthält eine einzelne Workflowdatei.

Wenn ein Projekt mit Studio Web kompatibel ist, wird die Beschriftung Mit Cloud kompatibel auf der rechten Seite der Statusleiste angezeigt. Um das Projekt in Studio Web verfügbar zu machen, klicken Sie auf die Beschriftung und wählen Sie dann In Cloud speichern aus.

📘

Hinweis:

Projekte, welche die Sprache C# für Ausdrücke verwenden, werden in Studio Web nicht unterstützt. Ein Fehler tritt auf, wenn Sie In Cloud speichern bei einem C#-Projekt auswählen.

Nachdem ein Projekt in Studio Web gespeichert wurde, ändert sich die Beschriftung in der Statusleiste zu Cloud-Projekt. Klicken Sie auf die Beschriftung, um ein Dropdownmenü mit Optionen zum Verwalten des Projekts zu öffnen:

  • In Cloud speichern – Speichern Sie die neuesten Änderungen, die Sie in Studio Desktop am Projekt in Studio Web vorgenommen haben. Wenn das Remote-Projekt Änderungen enthält, müssen Sie zuerst bestätigen, dass Sie diese überschreiben möchten. Sie können das Projekt nicht in der Cloud speichern, wenn es in Studio Web geöffnet ist.
  • In Studio Web öffnen – Öffnen Sie das Projekt in Studio Web.
  • Eine Kopie speichern – Speichern Sie das aktuelle Projekt lokal als neues Projekt. Sie können den Namen bearbeiten, einen Speicherort auswählen und eine Projektbeschreibung eingeben.
  • Aktuelle Version abrufen – Rufen Sie die neuesten Änderungen ab, die Sie in Studio Web vorgenommen haben. Wenn Unterschiede zwischen dem Remote-Projekt und dem lokalen Projekt bestehen, müssen Sie zuerst bestätigen, dass Sie die lokale Version überschreiben möchten.
492

Wenn Sie ein Projekt in Studio Web erstellen, haben Sie ebenfalls die Möglichkeit, die Arbeit in Studio fortzusetzen. Öffnen Sie auf der Projekte-Seite in Studio Web das Menü auf der rechten Seite eines Projekts und wählen Sie dann In Desktop öffnen aus.

Wenn Sie ein Cloudprojekt auf dem Desktop speichern und schließen, werden die Änderungen auch im Remoteprojekt gespeichert. Wenn Sie ein Cloudprojekt auf dem Desktop öffnen, wird das Projekt mit den neuesten Änderungen aus der Cloud aktualisiert. In beiden Fällen werden Sie, wenn Unterschiede zwischen dem lokalen Projekt und dem Remoteprojekt vorliegen, zur Bestätigung aufgefordert, bevor Sie fortfahren.

Einstellung der Projektsprache

Wenn Sie ein neues Projekt im Studio-Profil erstellen, können Sie auswählen, welche Sprache für Ausdrücke verwendet werden soll – entweder VB oder C#. VB ist die standardmäßig ausgewählte Sprache, aber Sie können C# als Standardsprache für neue Projekte festlegen, indem Sie zu Start (Studio-Backstage-Ansicht) > Einstellungen > Design gehen. Bei Projekten, die im StudioX-Profil erstellt werden, wird die VB.NET-Sprache für Ausdrücke verwendet.

Die Verwendung von VB- und C#-Ausdrücken im selben Projekt wird nicht unterstützt. Ebenso wenig wird die Verwendung von VB-Ausdrücken in C#-Workflows unterstützt und umgekehrt. Stellen Sie beim Kopieren und Einfügen der Aktivitäten von anderen Projekten und Aufrufen oder Importieren von Workflows sicher, dass sie dieselbe Sprache wie Ihr Projekt verwenden.

Sie können C#-Bibliotheken als Abhängigkeiten in VB-Projekten installieren und umgekehrt. Auf Standardwerte, die für Argumente im Bibliotheksprojekt unter Verwendung sprachspezifischer Ausdrücke definiert sind, kann jedoch nicht vom Projekt aus zugegriffen werden, in dem die Bibliothek installiert ist.

Einschränkungen von C#

  • Die aktuelle C#-Implementierung basiert auf dem C#-Compiler, der die C#-Version 5 verwendet, daher ist der Zugriff auf neuere Funktionen wie Coalescing-Zuweisung, Null-Bedingungsoperator, Null-Coalescing-Operator, String-Interpolation und andere nur eingeschränkt möglich.
  • Projekte, die Ausdrücke mit Inkrementen enthalten, sind ungültig.
  • Ausdrücke, die den Operator nameof() enthalten, werden als ungültig markiert und sind mit der aktuellen Implementierung von C# nicht erlaubt.
  • Ausdrücke, die Aufrufe von Methoden mit optionalen Argumenten enthalten, müssen Werte für die optionalen Argumente enthalten.
  • Die Entwurfszeit- und Laufzeitleistung von C#-Projekten ist im Vergleich zu VB.NET niedriger. Wenn Laufzeitleistung ausschlaggebend ist, empfehlen wir die Verwendung VB.NET anstelle von C#.

Einstellen der Projektversion

Semantikversionen

Das Schema der Semantikversionen hat das Format Major.Minor.Patch[-Suffix], wobei:

  • Haupt (Major) die Hauptversion ist.
  • Neben (Minor) die Nebenversion ist.
  • Patch (Patch) die Patch-Version ist.
  • Suffix (Suffix) (optional) ein Bindestrich gefolgt von einer Reihe durch Punkt getrennter Identifier unmittelbar hinter der Patch-Version ist. Damit wird eine frühere Version bezeichnet.

Identifier dürfen nur aus alphanumerischen ASCII-Zeichen und Bindestrich bestehen und nicht leer sein. Numerische Identifier dürfen nicht mit Nullen beginnen. Außerdem kann das Aufbauen von Metadaten durch Anhängen eines Plus-Zeichens und einer Reihe von durch Punkte getrennten Identifiern gekennzeichnet sein, die unmittelbar auf den Patch oder die frühere Version folgen, zum Beispiel 1.0.0-alpha+1.

Beim Erstellen eines neuen Prozesses oder einer Bibliothek ist das Standardversionsschema Semantik. Es kann im Fenster Veröffentlichen (Publish) geändert werden. Dazu hängt man einfach eine weitere Ziffer an die Versionsnummer an. Die Semantikversion des Projekts kann ebenfalls über die project.json-Datei geändert werden. Die Patch-Nummer 0 wird automatisch an Projekte mit der Versionsnummer major.minor angehängt.

Veraltete Versionen

Die für das Projekt generierte veraltete Versionsnummer hat das Format M.m.bbbb.rrrrr, wobei:

  • M ist die Hauptversion.
  • m ist die Nebenversion.
  • bbbb ist die Buildversion.
  • rrrrr ist die Revisionsversion.

Die Haupt- und Nebenversionen in der Datei project.json bearbeitet werden können, während die Build- und Revisionsversionen gemäß einem Algorithmus generiert werden. Der Build-Wert ist die Anzahl der seit dem 01.01.2000 vergangenen Tage. Der Revisionswert die Anzahl der Sekunden ist, die am aktuellen Tag bis zum Moment der Freigabe vergangen sind. Das Ergebnis wird durch 2 dividiert, sodass die maximale Revisionsanzahl nicht höher als 65535 ist.

Die vorgeschlagene Versionsnummer im Fenster Veröffentlichen (Publish) basierend auf dem vorherigen Versionsschema des Projekts generiert wird, während das aktuelle Datum und der Zeitstempel für Projekte berücksichtigt werden, die das 4-stellige Versionsschema verwenden.

Verwalten von Projekten

393

Im Panel Projekt (Project)können Sie den Inhalt des aktuellen Projekts anzeigen, Ordner hinzufügen, den Speicherort der Datei öffnen, Abhängigkeiten verwalten und Prozesseinstellungen anpassen.

1444

Fügen Sie aus dem Datei-Explorer kopierte Dateien direkt in das Projekt-Panel ein. Dieselbe Aktion kann per Drag & Drop für eine oder mehrere Dateien durchgeführt werden, einschließlich .xaml-Workflows. Sie können auch die Tastenkombinationen Strg + C und Strg + V oder die Optionen Kopieren und Einfügen im Kontextmenü verwenden, um Dateien oder Ordner innerhalb des Panels zu kopieren und zu duplizieren.
Mit einem Doppelklick auf TXT-, CS-, VB-, JSON- (außer „project.json“) und XML-Dateien, die kleiner als 10 MB sind, können Sie diese in Studio in einem Texteditor mit Syntaxhervorhebung bearbeiten.

OptionDescription
Expand Allexpand_allExpands all nodes in the automation project.
Collapse Allcollapse_allCollapses all nodes in the automation project.
RefreshrefreshRefreshes the project.
Show All Filesshow_filesShows all files belonging to the automation project, including the project.json.
File Explorerfile_explorerOpens the project's location on the machine.
Project Settingsproject_settingsOpens the Project Settings window for processes or libraries.

Kontextmenü für Projekte

Klicken Sie mit der rechten Maustaste im Projektfenster auf eine beliebige Stelle, um das Kontextmenü mit den in der folgenden Tabelle beschriebenen Optionen zu öffnen. Die verfügbare Gruppe von Optionen hängt von der mit der rechten Maustaste angeklickten Stelle im Fenster, vom Projekttyp sowie davon ab, ob das Projekt zu Source Control hinzugefügt wird.

OptionDescription
Open Project FolderOpens the local folder containing the project.
Project SettingsOpens the Project Settings window for adjusting project preferences.
AddOpens a list of items that can be added to the project: folder, sequence, flowchart, state machine, global handler, workflow, or, in test automation projects, test case.

Use workflow to create a workflow file based on built-in templates (sequence, flowchart, state machine) or local file templates.
Import FilesOpens the File Explorer window to import files into your project. By default, the *.xaml filter is applied to list only workflow files, but you can change it to all files to import other file types. Imported is added to the imported file name if it coincides with the name of a workflow from the current project.

You can only import workflow files that use the same language for expressions as the current project. When you import a workflow file, the dependencies of the current project are compared to the ones in the source project file, if one is available. If there are any discrepancies, the Import Workflow window is displayed with information about changes needed to avoid unresolved activities. Available dependency updates are selected by default and are installed when you select Import.
The icon add indicates a missing dependency that should be installed.
The icon change indicates a newer version used in the source project that you should update to.
The icon warning is displayed if a missing dependency is not available for the current project, or if the available version is different than the one in the source project.
Optionally, you can indicate a project.json file to use as a reference and select whether to search in prerelease package versions.
Convert to WindowsIn a Windows - Legacy project, opens the Convert to Windows window where you can convert the project to the Windows compatibility.
Extract as LibraryExtracts a process or test automation project as a library.
Add to Source ControlAdds the current project to source control using Git Init, Copy to Git, Add to TFS, or Add to SVN options. Please note that this option is only visible when right-clicking the project node.
When a project is added to source control, additional options are available in the context menu. See the options for GIT and the options for SVN and TFS.
OpenOpens the selected files using the default program.
Open File LocationOpens the local folder containing the file.
RenameEnables you to rename the selected file or folder, and opens the Rename Item window. The item is renamed in all occurrences. Note: The full path of the new file must not exceed 258 characters.
CopyCopies the selected files or folders to the clipboard. You can then paste them in the project panel or in the Windows file explorer.
PastePastes files or folders that were copied to the clipboard.
DeleteDeletes the selected item only from your local machine.
Select for CompareSelects the current file for comparison.
Compare with SelectedCompares the current file with the previously selected file using Compare Files.
Find ReferencesFinds all references to the file in the project. The results are displayed in the Find References panel.
Open in Text EditorOpens the selected text file in a text editor inside Studio in read-only mode.
To open a text file in edit mode, double-click it. You can double-click TXT, CS, VB, JSON (excluding the project.json file), and XML files smaller than 10 MB to edit them inside Studio in a text editor with syntax highlighting.
Debug FileDebugs the selected .xaml file.
Set as MainSets the selected .xaml file as Main in the project definition, meaning that the project execution starts with that file. There can only be one Main project file. The name of the file set as main appears in bold in the Project panel.
Activity LayoutOpen the Properties window for files in library projects, where you can customize the design of the generated activity.
Set as Global HandlerSets the .xaml file as the Global Exception Handler for the project. This is applicable to one workflow per project/process.
Remove HandlerRemoves the Global Exception Handler tag from the .xaml file.
Enable Entry PointMarks the selected workflow file as an entry point for the process, making it possible to select it as the workflow to run first when using the Invoke Process and Run Parallel Process activities in other processes, or when starting a job from Orchestrator.
Notes:
When a file is marked as an entry point, an arrow is displayed on the icon next to the file name icon_enable_entry_point.
Enabling a file that is ignored from publishing as an entry point sets the file as publishable.
This option is not available for test case files.
This option is not available in library projects.
Disable Entry PointNo longer marks the selected workflow file as an entry point for the process. This option is not available for the workflow file that is set as Main.
Extract as Template Saves the selected workflow or test case as a template on which you can then base other files in the project. Using a file template allows you to save time when you need to create multiple files with the same structure. When you add a new workflow or test case, you have the option to base it on any template of the same type that exists in the Templates project folder.
Ignore from Publish / Set as PublishableMarks one or more selected files as excluded from publishing or publishable.
Notes:
When a file is ignored from publishing, the icon next to the file name turns gray icon_ignore_publish.
Ignoring a file marked as an entry point from publishing disables the entry point.
These options are not available for workflow files in library projects.
In projects where XAML files are compiled when published, workflow and test case files that are excluded from publishing are not compiled.
Make Private / Make PublicMarks one or more selected files in a library project as private or public, A private workflow file is included in the published package, but no reusable component is created and made available in the Activities panel in projects where the library is installed as a dependency.
Notes:
When a file is marked as private, the icon next to the file name turns gray icon_ignore_publish.
These options are not available for test case files.
Create Test CaseCreates a test case that invokes the selected workflow file.
Convert to Test Case / Convert to WorkflowConverts the selected workflows to test cases or the selected test cases to workflows.
Import Test CasesImports test cases into the project as draft test cases.
Add Test DataOpens the Import Data Variation Source window that enables you to add test data to the project. This option is only available for test cases.
Link to Test ManagerOpens the Link to Test Manager window that enables you to link the selected test cases to Test Manager.
Run Test Cases / Debug Test CasesRuns or debugs multiple selected test cases.

Kontextmenüoptionen für GIT

In Projekten, die GIT-Repositorys hinzugefügt werden, wird neben jeder Datei im Projektfenster ein Symbol angezeigt, das den Dateistatus angibt:
git branch The file is synced with the repository.
git edited The file has been modified.
source control added The file has been added.

Right-click a file or project node in the Project panel to open the GIT-specific context menu for Managing Projects with GIT.

234
OptionDescription
CommitCommits current changes to the local GIT repository.
PushPushes the current version onto the remote repository.
Pull (rebase)Pulls remote files and rebases the current branch.
Manage BranchesOpens the GIT window with options for managing currently added branches.
Show ChangesOpens the File Diff window for comparing changes between the local version and the remote version of the file.
Show HistoryOpens the Show History window for comparing two versions of the same file.
UndoOpens the Undo Pending Changes window if the file was not committed or pushed to the remote repository.
Copy Repository URLCopies the repository URL of the project to the clipboard.

Kontextmenüoptionen für SVN und TFS

In Projekten, die GIT-Repositorys hinzugefügt werden, wird neben jeder Datei im Panel Projekt ein Symbol angezeigt, das den Dateistatus angibt:
svn locked The file is not checked out for editing.
svn checked out The file has been checked out for editing.
svn edited The file has been edited.
source control added The file has been added.

Right-click a file or project node in the Project panel to open the context menu with options specific to managing projects with TFS or SVN.

233
OptionDescription
Open Opens the selected .xaml file in the Designer panel, in read-only mode if it was not checked out for edit from the TFS/SVN repository.
Rename Enables you to rename the selected file or folder, and opens the Rename Item window. When checking in the renamed .xaml file, the previously modified version must also be checked in.
Delete Deletes the selected item only from your local machine. The latest checked in version of the file is still available in the TFS/SVN repository.
Check Out For EditMarks the selected file or folder as locked for editing. Checking out a file locks it on the server so that no one else can edit it.
Finish EditingChecks in the project.json file in the respository, together with changes and a commit message.
Add Uploads the selected item to the TFS/SVN server. This option is not available, if the item was previously uploaded to the server.
Get Latest Version Downloads the latest version of the selected item from the TFS/SVN repository.
Show changes...Opens the File Diff to compare changes between the versioned file and the one mapped locally.
Check In Displays the Check In Changes window and enables you to upload the selected item to the server as the newest version. The .xaml file must be saved before uploading it. After it’s checked in, the file becomes read-only in Studio.
Undo Displays the Undo Pending Changes window and enables you to Revert the changes done to the project, either revert modified files to previous or unversioned states, or retrieve files which were deleted from the local machine.

Changes cannot be reverted after the file was checked in.
RunRuns the selected workflow, even if it's not checked out or added to the repository.
Set as MainSets the selected .xaml file as Main in the project. The first created .xaml is set as Main by default.
Copy Repository URLCopies the repository URL of the project to the clipboard.

Anpassen der Projekteinstellungen

A set of individual settings can be established for each automation project that you’re working on. Such settings are available in the Project Settings window, which can be opened by clicking the settings_icon in the Project panel.

875

Feldbeschreibung für das Fenster „Einstellungen“

The following table describes the project settings for process, test automation, and template projects. For information about the settings available for libraries, see About Libraries.

FieldDescription
NameChange the name of the project. Such names may contain whitespace characters. When naming projects, keep in mind that whitespace characters are removed at publish time. This field accepts up to 128 characters.
DescriptionChange the project description. This field accepts up to 500 characters.
Project tagsYou can add one or more tags to the project, either by creating new ones or by reusing tags already defined in Orchestrator. There are two types of tags: labels and properties (key-value pairs). Tags are included in the published package and they help describe and categorize projects. For example, they can refer to the automated application (an Excel label) or the department (a department:accounting key-value property).

When you start typing, possible matches are suggested from already defined tags, and you can reuse one by selecting it from the list of matches. For a property match, the key followed by the : (colon) character is displayed first, and the associated values are displayed after you select the key,

To add a new tag, after you enter the name, click the entry with the plus sign next to the name. Separating strings with the : (colon) character enables you to add properties, while entries that don't contain a : add labels.

Labels and key-value properties are limited to 256 characters. Tag names can't contain these characters: <, >, %, &, \, ?, /, :.

Project tags can be automatically applied to processes in Orchestrator. For more information about using tags, see Organizing resources with tags in the Orchestrator guide.
Automation Hub URLURL of an Automation Hub idea linked to the project. For more information, see Linking a Project to an Idea in Automation Hub.
Package IconOptionally, define a custom icon for the project. You can browse to and select a file, or enter a path or public URL to a jpeg, jpg, or png file up to 1MB in size.

After the project is published, the icon is displayed as follows:
For processes, in the Assistant next to the process name, making it easier to identify it in the list of processes.
For templates, next to the template in Home (Studio Backstage View) > Templates.
For libraries, next to the package in the Manage Packages window in Studio.
:information-source: The icon is not visible in Manage Packages if a local file is used for a library published to Orchestrator or a feed that does not support embedded icons, In this case, specify the icon using a URL.
Disable PauseEnable or prevent users from pausing execution from the UiPath Assistant. Set to Yes if pausing the process during execution would result in crashing it. For example, if an activity in your workflow uses the Timeout property, pausing the execution might cause the timeout to expire, thus breaking the execution.
Attended AutomationSet to Yes to indicate that the project should only be executed in an attended context. Use this setting for projects that include UI Automation activities or other activities that require user interaction.
Starts in BackgroundSet to Yes to turn the project into a Background Process and allow it to run in the background concurrently with other processes, as long as it does not use UI interaction.
Supports PersistenceSet to Yes to turn the project into an Orchestration Process.
PiP OptionsIndicate whether the project was tested using Picture in Picture (PiP) and whether it should start in PiP by default.
Tested for PiP usage; Starting in PiP - The automation has been approved to run in PiP mode. When run, it starts in PiP by default.
Tested for PiP usage; Not starting in PiP by default - The automation has been approved to run in PiP mode. When run, it starts in the main session or desktop by default.
Not tested for PiP usage - The automation has not been approved to run in PiP mode. When run, it starts in the main session or desktop by default. If run in PiP, a dialog informs the user it was not tested using this feature and prompts for confirmation before proceeding.
PiP TypeSelect how to isolate the automation from the user session when running the project in PiP: New Session (child session on the machine) or New Desktop (virtual desktop in the user session).

Klicken Sie auf OK und die Änderungen werden im Panel Projekt (Project) und in der Datei project.json sichtbar gemacht.

Check out the Configuring Activity Project Settings page to read about how to adjust activity properties at project level.

📘

Hinweis:

Bitte berücksichtigen Sie, dass es sich empfiehlt, im Panel „Designer“ im Voraus nach unten zu scrollen, wenn Sie eine Vielzahl von Aktivitäten von einer Sequence in eine andere kopieren möchten. Dies ist durch die Begrenzung der Windows Workflow Foundation bedingt.

Entfernen nicht verwendeter Projektressourcen

Unnötige Ressourcen können die Verständlichkeit von Projekten erschweren und die Leistung beeinträchtigen. Um dieses Problem zu vermeiden, entfernen Sie nicht-verwendete Ressourcen aus Ihren Projekten, indem Sie im Studio-Menüband auf Nicht-verwendete entfernen klicken und dann auswählen, was entfernt werden soll:

  • Workflows – Entfernen Sie Workflow-Dateien, auf die im Projekt nicht verwiesen wird.
  • Variablen – Entfernen der Variablen, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Argumente – Entfernen Sie Argumente, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Abhängigkeiten – Entfernen Sie installierte Aktivitätspakete, aus denen keine Aktivitäten im Projekt verwendet werden.
  • Importe – Entfernen Sie importierte Namespaces, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Screenshots – Entfernen Sie informative Screenshots, die in keiner Aktivität im Projekt verwendet werden.

Updated 4 days ago


Über Automatisierungsprojekte


Auf API-Referenzseiten sind Änderungsvorschläge beschränkt

Sie können nur Änderungen an dem Textkörperinhalt von Markdown, aber nicht an der API-Spezifikation vorschlagen.