Studio
2023.4
False
Bannerhintergrundbild
Studio-Benutzerhandbuch
Letzte Aktualisierung 26. Apr. 2024

Fehlerbehebung für die Citrix-Erweiterung

Auf dieser Seite wird erläutert, wie Probleme behoben werden, die beim Ausführen der Automatisierung in Citrix-Umgebungen auftreten können.

Virtuelle Kanäle standardmäßig blockiert

Beschreibung

Ab Citrix Virtual Apps und Desktops 7 2109 werden standardmäßig alle benutzerdefinierten virtuellen Kanäle blockiert.

If you upgrade to this new Citrix version, the existing automation in Citrix via UiPath® Remote Runtime stops working.

Lösung

Der virtuelle UiPath-Kanal muss zur Zulassungslistenrichtlinie hinzugefügt werden. Folgen Sie dazu den Anweisungen hier.

Der folgende Wert muss zur Zulassungslistenrichtlinie hinzugefügt werden.

UIPCTX,<UiPathRemoteRuntime-Install_Path>\UiPathRemoteRuntime.exe

Zum Beispiel:

UIPCTX,C:\Program Files (x86)\UiPath\RemoteRuntime\UiPathRemoteRuntime.exe

Die interaktive Auswahl in Citrix Apps wird eingefroren und nichts wird ausgewählt

Beobachtetes Verhalten

Wenn Sie die UiPath-Erweiterung für Citrix installiert haben und versuchen, UI-Elemente in einer Citrix-App auszuwählen, friert die interaktive Auswahl eine Minute lang ein. Anschließend ist nichts ausgewählt.

Ursache

Dies ist der Fall, wenn UiPath Remote Runtime nicht in der Citrix App-Session läuft.

Lösung

  • Prüfen Sie, ob UiPathRemoteRuntime.msi auf dem Citrix-Anwendungsserver, von dem die Citrix-App geöffnet wird, installiert ist.
  • Prüfen Sie auf dem Citrix-Anwendungsserver, ob der Prozess UiPathRemoteRuntime.exe läuft. Wenn UiPathRemoteRuntime.msi installiert ist, wird der Prozess nach der Anmeldung für die Citrix-App-Sitzung automatisch gestartet.



    Hinweis: Falls Sie UiPathRemoteRuntime.msi nicht auf den Citrix-Anwendungsservern installieren können, sollten Sie die UiPath-Erweiterung für Citrix auf der Clientmaschine deinstallieren, wie hier beschrieben.

Die Datei "C:\Program Files (x86)\Citrix\ICA Client\UIPathPluginCitrix.dll“ konnte nicht kopiert werden. Sie wird von einem anderen Prozess verwendet.

Beobachtetes Verhalten

Wenn Sie versuchen, die UiPath-Erweiterung für Citrix zu installieren, wird der folgende Fehler angezeigt:



Ursache

Dies ist der Fall, wenn die UiPath-Erweiterung für Citrix bereits installiert ist und von einer offenen Citrix-App verwendet wird.

Lösung

Schließen Sie alle aktiven Citrix-App-Sitzungen, wie hier beschrieben, und versuchen Sie dann erneut, die UiPath-Erweiterung für Citrix zu installieren.

Der Citrix Registry-Schlüssel konnte nicht gelesen werden: Wert 'SOFTWARE\Citrix\Install\ICA Client': 'InstallFolder'

Beobachtetes Verhalten

Wenn Sie versuchen, die UiPath-Erweiterung für Citrix zu installieren, wird der folgende Fehler angezeigt:



Ursache

Diese Fehlermeldung wird eingeblendet, wenn der Citrix Receiver nicht installiert ist. Sie wird ebenfalls eingeblendet, wenn der Citrix Receiver for Universal Windows Platform installiert ist.

Lösung

Laden Sie den Citrix Receiver oder Citrix Workspace herunter und installieren Sie diese.

Nicht behandelte Ausnahme in wfica32.exe 0xC0000094: Teilung eines Integers durch Null

Beobachtetes Verhalten

Die Citrix-Ziel-App kann nicht gestartet werden, und der Citrix ICA-Client stürzt ab.

Ursache

Aktivitäten, die die GetWindowText-Funktion verwenden (z. B. Element Exists), werden ausgeführt, bevor die Citrix App geladen werden kann.

Lösung

Lassen Sie der Citrix-App Zeit zum Laden, indem Sie vor der Aktivität eine Verzögerung hinzufügen.

Interaktive Auswahl und Elementidentifizierung funktioniert nicht mit hohem DPI-Wert

Beobachtetes Verhalten

Ab der Citrix Workspace App (CWA) für Windows 2206 funktioniert die interaktive Auswahl und die Elementidentifizierung möglicherweise nicht für Citrix Apps, wenn keine Richtlinieneinstellungen für hohe DPI-Werte angewendet werden und die Display-DPI-Skalierung höher als 100 % ist.

Ursache

Dies wird durch die folgende Änderung bei Citrix verursacht: Änderungen der DPI-Unterstützung bei der Citrix Workspace App für Windows 2206.

Lösung

Löschen Sie den Registrierungswert Enable_DPI aus Computer\HKEY_CURRENT_USER\SOFTWARE\Citrix\ICA Client\DPI:


War diese Seite hilfreich?

Hilfe erhalten
RPA lernen – Automatisierungskurse
UiPath Community-Forum
UiPath Logo weiß
Vertrauen und Sicherheit
© 2005-2024 UiPath. All rights reserved.