UiPath Documentation
studio
2023.4
false
Studio-Benutzerhandbuch
Wichtig :
Es kann 1–2 Wochen dauern, bis die Lokalisierung neu veröffentlichter Inhalte verfügbar ist.

Über Automatisierungsprojekte

UiPath Studio ermöglicht die Erstellung folgender Projekttypen:

  • Prozess – Entwerfen Sie einen Automatisierungsprozess und veröffentlichen Sie ihn, damit er von Robotern ausgeführt werden kann.
  • Library - Design workflows as reusable components and publish the project as a library that can be added as a dependency to multiple processes. For more information, see About Libraries.
  • Test Automation - Design a test automation project. For more information about test automation, check the Studio testing section.
  • Template - Design a process and publish it as a template that other processes which share common characteristics can then be based on. For more information, see Project Templates.

Um ein neues leeres Projekt zu erstellen, wechseln Sie zu Start (Studio Backstage-Ansicht) > Starten und wählen Sie den Projekttyp aus, der unter Neues Projekt erstellt werden soll. Alternativ können Sie mit einer der Standardvorlagen beginnen, die unter Neu aus Vorlage verfügbar sind, oder zur Registerkarte Vorlagen wechseln, um nach weiteren Vorlagen aus verschiedenen Quellen zu suchen.

Konfigurieren Sie im neuen Projektfenster für jedes Projekt Folgendes:

  • Geben Sie einen Namen für das neue Projekt (bis zu 128 Zeichen) und eine Beschreibung ein, die zusammenfasst, was Sie mit diesem Automatisierungsprojekt erreichen möchten (bis zu 500 Zeichen).

  • Wählen Sie den Speicherort aus, an dem das Projekt erstellt werden soll. Der Standardspeicherort, an dem Projekte erstellt werden, lautet %USERPROFILE%\Documents\UiPath.

  • Select the compatibility and language.

    Hinweis:

    The compatibility and language cannot be changed after you create a project. However, you can convert your Windows - Legacy projects to the Windows compatibility.

Standardmäßig enthält der Projektordner die folgenden Dateien und Unterordner:

  • Dateien
    • Main.xaml – Standardmäßig erstellt, um Ihren Hauptworkflow zu speichern. Darüber hinaus werden alle anderen Automatisierungs-XAML-Dateien, die Sie dem Projekt hinzufügen, im Projektordner gespeichert. Optionalerweise können Sie eine andere Datei als Hauptdatei festlegen.Alle Dateien müssen über die Aktivität Invoke Workflow-Datei mit der als Hauptdatei festgelegten Datei oder mit einer Datei verknüpft werden, die als Einstiegspunkt für das Projekt markiert ist. Für Testautomatisierungsprojekte wird standardmäßig eine Standard-Datei TestCase.xamlanstelle von Main.xamlerstellt.

      Hinweis:
      • Sie können keine Windows-Projekte ausführen, die eine XAML-Datei mit dem Namen Init.xaml enthalten.
      • Eine XAML-Datei im Stammordner eines Projekts darf nicht den gleichen Namen wie ein Unterordner haben, der andere XAML-Dateien enthält.
    • project.json – Enthält Informationen über Ihr Automatisierungsprojekt.

  • Unterordner
    • .entities – Enthält Daten über Entitäten, die aus dem Data Service importiert wurden, falls diese im Projekt verwendet werden.

    • .local – Enthält lokal für das Projekt zwischengespeicherte Daten.

      Hinweis:
      • Der Ordner .local ist ausgeblendet. Sie können die Anzeige ausgeblendeter Elemente in den Einstellungen von Windows-Explorer aktivieren.
      • Der Ordner .local sollte nicht projektübergreifend genutzt werden.
    • .objects – Enthält Daten im Zusammenhang mit Elementen, die dem Object Repository hinzugefügt wurden, falls diese im Projekt verwendet werden.

    • .project – Enthält Tags, die zum Projekt hinzugefügt wurden.

    • .screenshots – Enthält informative Screenshots, die in UI-Automatisierungsaktivitäten generiert werden, falls welche im Projekt verwendet werden.

    • .settings – Enthält Aktivitätsprojekteinstellungen, die zur Laufzeit verwendet werden.

    • .templates – Enthält Dateivorlagen, die dem Projekt hinzugefügt wurden.

    • .tmh – Enthält Daten im Zusammenhang mit Testfällen, falls diese im Projekt verwendet werden.

      Hinweis:

      Projekte, die mit neueren Versionen von Studio erstellt wurden, funktionieren möglicherweise nicht mit älteren Studio-Versionen. Erfahren Sie mehr über die Rückwärts- und Vorwärtskompatibilität.

      Die folgenden Zeichen dürfen in Dateinamen nicht verwendet werden: ", <, >, |, :, *, ?, \, /,;. Diese Zeichen stammen aus Microsoft Windows-Einschränkungen und anderen Sonderzeicheneinschränkungen.

Wichtig:

Die Ausführung von Studio-Prozessen in Automatisierung Cloud™ Robots – VM und Automatisierung Cloud™ Robots – Serverless ist nicht für Development-Zwecke vorgesehen.

Festlegen der Projektkompatibilität

Wenn Sie ein neues Projekt erstellen, wählen Sie die Kompatibilität basierend auf der Umgebung aus, in der das Projekt ausgeführt wird:

  • Windows – Verwendet .NET 6 mit Windows-Unterstützung. Dies ist die Standardoption.

  • Plattformübergreifend – Verwendet .NET 6 mit plattformübergreifender Unterstützung.

  • Windows – Legacy – Verwendet .NET Framework 4.6.1., die Kompatibilität, die in Versionen vor 2021.10 verwendet wurde.

    Wichtig:
    • Windows- und plattformübergreifende Prozesse erfordern Orchestrator 2021.10 und höher zur Ausführung.
    • The Windows - Legacy option will no longer be available for new projects in the near future. We recommend selecting Windows or Cross-platform when creating a new project. You can convert your Windows - Legacy projects to the Windows compatibility.

To learn about the differences between compatibilities, see the following table. To find out more about the design experience in each compatibility, see Designing Automations.

Windows – LegacyWindowsPlattformübergreifend
Prozessausführung32-Bit64-Bit64-Bit
Unterstützte Plattformen für die AusführungWindows (64-Bit)Windows (64-Bit)Windows, Linux und macOS (64 Bit)
Prozesse werden beim Veröffentlichen kompiliertNein. Veröffentlichte Pakete enthalten die Projektquelldateien.Ja. Veröffentlichte Pakete enthalten kompilierte DLL-Dateien.Ja. Veröffentlichte Pakete enthalten kompilierte DLL-Dateien.

Only the activities packages that support the selected compatibility can be installed from the package manager.

Die Kompatibilität jedes Projekts wird rechts in der Studio-Statusleiste und im Projektbereich > Knoten Abhängigkeiten angezeigt. Die Kompatibilität wird auch im Eintrag jedes Projekts in der Liste Zuletzt geöffnet in der Registerkarte Start (Studio Backstage View) > Start angezeigt.

Hinweis:
  • Das Kopieren und Einfügen von Aktivitäten zwischen Projekten mit unterschiedlichen Kompatibilitäten wird nicht unterstützt.
  • Wenn Studio beim erneuten Öffnen oder Neuladen eines Windows- oder plattformübergreifenden Projekts Validierungsfehler findet, werden Sie aufgefordert, fehlende Verweise automatisch zu importieren.

Entwerfen plattformübergreifender Projekte

Mit plattformübergreifenden Projekten können Sie Automatisierungen, die keine Benutzerinteraktion erfordern, und Webbrowser-Automatisierungen mit Chrome erstellen. Plattformübergreifende Automatisierungen können auf Windows und Unix-ähnlichen Betriebssystemen wie Linux und macOS ausgeführt werden.

So erstellen Sie Unattended-Projekte mit plattformübergreifender Unterstützung:

  1. In Studio, create a new project and select the Cross-platform compatibility option. This option is available for all project types. For processes that use VB language for expressions, you have the option to work in both Studio and Studio Web.

  2. Design the automation. Please note that not all activities packages are compatible with cross-platform projects, so only a selection of packages is available in the package manager. Find out more about the design experience in cross-platform projects.

    Die Standardabhängigkeiten für ein plattformübergreifendes Projekt sind:

    • Im Studio-Profil: UiPath.System.Activities, UiPath.Testing.Activities, UiPath.WebApi.Activities und UiPath.UIAutomation.Activities.
    • Im StudioX-Profil: UiPath.System.Activities, Microsoft Office 365, Google Workspace und UiPath.UIAutomation.Activities.
  3. Test the automation. We recommend testing automations on the machines where they will run using remote debugging which works with Windows, Linux robots, and macOS robots.

  4. After testing the automation, publish the project to Orchestrator. The procedure for running unattended jobs is the same for Windows, macOS, and Linux.

    Wichtig:

    Diese Version von Studio ist nicht kompatibel mit älteren Versionen von plattformübergreifenden Aktivitätspaketen, die in Studio 2022.4 oder früher verfügbar waren. Wenn Sie plattformübergreifende Projekte in Studio-Versionen vor 2022.10 erstellt haben, aktualisieren Sie die installierten Pakete auf die neuesten Versionen, bevor Sie sie in Studio 2022.10 oder höher bearbeiten. Einige Eigenschaften können möglicherweise nicht mehr bearbeitet werden.

Öffnen eines Projekts in Studio Web
Hinweis:

Das Öffnen von Projekten in Studio Web wird nur für die neuesten Versionen der Enterprise- und Community-Editionen von Studio unterstützt.

Wenn Sie Ihre plattformübergreifenden Projekte unterwegs von einem beliebigen Gerät aus direkt über den Browser entwickeln möchten, können Sie Projekte zur Cloud hinzufügen und sie in Studio Web, dem Automatisierungsdesigner in der UiPath Automation Cloud, bearbeiten. Wenn Sie ein Projekt zur Cloud hinzufügen, werden Änderungen immer synchronisiert, sodass Sie nahtlos zwischen Desktop und Web wechseln und dort weitermachen können, wo Sie aufgehört haben.

Wenn ein Studio-Projekt mit Studio Web kompatibel ist, wird das Label Cloud-kompatibel auf der rechten Seite der Studio-Statusleiste angezeigt. Um das Projekt in Studio Web verfügbar zu machen, wählen Sie Cloud-kompatibel > In der Cloud speichern aus.

Hinweis:

Projekte, welche die Sprache C# für Ausdrücke verwenden, werden in Studio Web nicht unterstützt. Sie können ein C#-Projekt in der Cloud speichern, aber Sie können es in Studio Web nicht bearbeiten.

Verwalten eines Cloudprojekts in Studio

Um mit Studio Web kompatibel zu sein, muss ein plattformübergreifendes Projekt die folgenden Anforderungen erfüllen:

  • Der Projekttyp ist „Prozess“.
  • Die Sprache für Ausdrücke ist „VB“.
  • Das Projekt enthält eine einzelne Workflowdatei.

Nachdem ein Projekt in Studio Web gespeichert wurde, ändert sich die Beschriftung in der Statusleiste zu Cloud-Projekt. Klicken Sie auf die Beschriftung, um ein Dropdownmenü mit Optionen zum Verwalten des Projekts zu öffnen:

  • In der Cloud speichern – Speichern Sie die letzten Änderungen, die Sie in Studio Desktop am Projekt in Studio Web vorgenommen haben. Wenn das Remoteprojekt Änderungen enthält, müssen Sie zuerst bestätigen, dass Sie sie überschreiben möchten. Sie können nicht in der Cloud speichern, wenn das Projekt von Studio Web gesperrt ist.

  • In Studio Web öffnen – Öffnen Sie das Projekt in Studio Web. Wird das Projekt von Studio Web gesperrt, wird ein Fehler angezeigt und das Projekt auf einer neuen Registerkarte im schreibgeschützten Modus geöffnet.

  • Eine Kopie speichern – Speichern Sie das aktuelle Projekt lokal als neues Projekt. Sie können den Namen bearbeiten, einen Speicherort auswählen und eine Projektbeschreibung eingeben.

  • Aktuelle Version abrufen – Rufen Sie die neuesten Änderungen ab, die Sie in Studio Web vorgenommen haben. Wenn Unterschiede zwischen dem Remote-Projekt und dem lokalen Projekt bestehen, müssen Sie zuerst bestätigen, dass Sie die lokale Version überschreiben möchten.

Ebenso können Sie, wenn Sie ein Projekt in Studio Web erstellen, in Studio weiterarbeiten. Öffnen Sie auf der Seite Projekte in Studio Web das Menü auf der rechten Seite eines Projekts und wählen Sie dann In Studio Desktop öffnen aus.

So werden Änderungen zwischen Studio und Studio Web synchronisiert

Wenn Sie ein Cloudprojekt in Studio speichern und schließen, werden die Änderungen auch im Remoteprojekt gespeichert, wenn das Projekt nicht von Studio Web gesperrt ist. Wenn Sie das Projekt dann in Studio Web öffnen, wird das Projekt mit allen Änderungen aktualisiert, die Sie in Studio in der Cloud gespeichert haben.

Wenn Sie ein Cloud-Projekt in Studio öffnen, wird das Projekt mit allen Änderungen aktualisiert, die Sie in Studio Web vorgenommen haben. Um ein Projekt, das bereits in Studio geöffnet ist, mit den neuesten Änderungen aus Studio Web zu aktualisieren, wählen Sie in der Statusleiste von Studio die Option Cloud-Projekt > Neueste Version abrufen aus.

In beiden Fällen werden Sie, wenn Unterschiede zwischen dem lokalen Projekt und dem Remoteprojekt vorliegen, zur Bestätigung aufgefordert, bevor Sie fortfahren.

Einstellung der Projektsprache

Wenn Sie ein neues Projekt im Studio-Profil erstellen, können Sie auswählen, welche Sprache für Ausdrücke verwendet werden soll – entweder VB oder C#. VB ist die standardmäßig ausgewählte Sprache, aber Sie können C# als Standardsprache für neue Projekte festlegen, indem Sie zu Start (Studio-Backstage-Ansicht) > Einstellungen > Design gehen. Bei Projekten, die im StudioX-Profil erstellt werden, wird die VB.NET-Sprache für Ausdrücke verwendet.

Die Verwendung von VB- und C#-Ausdrücken im selben Projekt wird nicht unterstützt. Ebenso wenig wird die Verwendung von VB-Ausdrücken in C#-Workflows unterstützt und umgekehrt. Stellen Sie beim Kopieren und Einfügen der Aktivitäten von anderen Projekten und Aufrufen oder Importieren von Workflows sicher, dass sie dieselbe Sprache wie Ihr Projekt verwenden.

Sie können C#-Bibliotheken als Abhängigkeiten in VB-Projekten installieren und umgekehrt. Auf Standardwerte, die für Argumente im Bibliotheksprojekt unter Verwendung sprachspezifischer Ausdrücke definiert sind, kann jedoch nicht vom Projekt aus zugegriffen werden, in dem die Bibliothek installiert ist.

Einschränkungen von C#

  • Die aktuelle C#-Implementierung basiert auf dem C#-Compiler, der die C#-Version 5 verwendet, daher ist der Zugriff auf neuere Funktionen wie Coalescing-Zuweisung, Null-Bedingungsoperator, Null-Coalescing-Operator, String-Interpolation und andere nur eingeschränkt möglich.
  • Projekte, die Ausdrücke mit Inkrementen enthalten, sind ungültig.
  • Ausdrücke, die den Operator nameof() enthalten, werden als ungültig markiert und sind mit der aktuellen Implementierung von C# nicht erlaubt.
  • Ausdrücke, die Aufrufe von Methoden mit optionalen Argumenten enthalten, müssen Werte für die optionalen Argumente enthalten.
  • Die Entwurfszeit- und Laufzeitleistung von C#-Projekten ist im Vergleich zu VB.NET niedriger. Wenn Laufzeitleistung ausschlaggebend ist, empfehlen wir die Verwendung VB.NET anstelle von C#.
  • Bei jeder Ausführung eines „Windows – Legacy“-Projekts mit C# wird eine kompilierte DLL-Datei im Ordner %appdata%\Temp erstellt, die nach dem Ausführen des Projekts nicht automatisch gelöscht wird. Wenn Sie Speicherplatz benötigen, können Sie:
    • Verwenden Sie Windows- oder plattformübergreifende Projekte mit C#.
    • Verwenden Sie „Windows – Legacy“-Projekte mit VB.
    • Löschen Sie die nicht benötigten Dateien nach der Ausführung manuell.

Einstellen der Projektversion

Semantikversionen

Das Schema der Semantikversionen hat das Format Major.Minor.Patch[-Suffix], wobei:

  • Haupt (Major) die Hauptversion ist.
  • Neben (Minor) die Nebenversion ist.
  • Patch (Patch) die Patch-Version ist.
  • Suffix (Suffix) (optional) ein Bindestrich gefolgt von einer Reihe durch Punkt getrennter Identifier unmittelbar hinter der Patch-Version ist. Damit wird eine frühere Version bezeichnet.

Identifier dürfen nur aus alphanumerischen ASCII-Zeichen und Bindestrich bestehen und nicht leer sein. Numerische Identifier dürfen nicht mit Nullen beginnen. Außerdem kann das Aufbauen von Metadaten durch Anhängen eines Plus-Zeichens und einer Reihe von durch Punkte getrennten Identifiern gekennzeichnet sein, die unmittelbar auf den Patch oder die frühere Version folgen, zum Beispiel 1.0.0-alpha+1.

Beim Erstellen eines neuen Prozesses oder einer Bibliothek ist das Standardversionsschema Semantik. Es kann im Fenster Veröffentlichen (Publish) geändert werden. Dazu hängt man einfach eine weitere Ziffer an die Versionsnummer an. Die Semantikversion des Projekts kann ebenfalls über die project.json-Datei geändert werden. Die Patch-Nummer 0 wird automatisch an Projekte mit der Versionsnummer major.minor angehängt.

Veraltete Versionen

Die für das Projekt generierte veraltete Versionsnummer hat das Format M.m.bbbb.rrrrr, wobei:

  • M ist die Hauptversion.
  • m ist die Nebenversion.
  • bbbb ist die Buildversion.
  • rrrrr ist die Revisionsversion.

Die Haupt- und Nebenversionen in der Datei project.json bearbeitet werden können, während die Build- und Revisionsversionen gemäß einem Algorithmus generiert werden. Der Build-Wert ist die Anzahl der seit dem 01.01.2000 vergangenen Tage. Der Revisionswert die Anzahl der Sekunden ist, die am aktuellen Tag bis zum Moment der Freigabe vergangen sind. Das Ergebnis wird durch 2 dividiert, sodass die maximale Revisionsanzahl nicht höher als 65535 ist.

Die vorgeschlagene Versionsnummer im Fenster Veröffentlichen (Publish) basierend auf dem vorherigen Versionsschema des Projekts generiert wird, während das aktuelle Datum und der Zeitstempel für Projekte berücksichtigt werden, die das 4-stellige Versionsschema verwenden.

Verwalten von Projekten

Im Projektbereich können Sie den Inhalt des aktuellen Projekts anzeigen und filtern, Ordner hinzufügen, den Speicherort der Datei öffnen, Abhängigkeiten verwalten und Prozesseinstellungen anpassen.

Fügen Sie aus dem Datei-Explorer kopierte Dateien direkt in das Projekt-Panel ein. Dieselbe Aktion kann per Drag & Drop für eine oder mehrere Dateien durchgeführt werden, einschließlich .xaml-Workflows. Sie können auch die Tastenkombinationen Strg + C und Strg + V oder die Optionen Kopieren und Einfügen im Kontextmenü verwenden, um Dateien oder Ordner innerhalb des Panels zu kopieren und zu duplizieren.

Mit einem Doppelklick auf TXT-, CS-, VB-, JSON- (außer „project.json“) und XML-Dateien, die kleiner als 10 MB sind, können Sie diese in Studio in einem Texteditor mit Syntaxhervorhebung bearbeiten.

Option Beschreibung

Alle erweitern (Expand All) docs image

Erweitert alle Knoten in den Automationsprojekten.

Alle reduzieren (Collapse All) docs image

Reduziert alle Knoten in den Automationsprojekten.

Aktualisieren docs image

Aktualisiert das Projekt.

Mit aktivem Dokument synchronisierendocs imageFocuses on a project element that's active in the Designer panel.

Alle Dateien anzeigen docs image

Zeigt alle Dateien an, die zum Automationsprojekt gehören, einschließlich der Datei project.json.

Datei-Explorer docs image

Öffnet den Speicherort des Projekts auf dem Computer.

Projekteinstellungen docs image

Öffnet das Fenster Projekteinstellungen (Project Settings) für Prozesse und Bibliotheken.

Nach Dateityp filtern docs imageFilters the files of the current project by file type: Workflows, Test Cases, Forms, Text, Other (all file types that cannot be edited in Studio directly, off by default), Show hidden folders (off by default).

Kontextmenü für Projekte

Klicken Sie mit der rechten Maustaste im Projektfenster auf eine beliebige Stelle, um das Kontextmenü mit den in der folgenden Tabelle beschriebenen Optionen zu öffnen. Die verfügbare Gruppe von Optionen hängt von der mit der rechten Maustaste angeklickten Stelle im Fenster, vom Projekttyp sowie davon ab, ob das Projekt zu Source Control hinzugefügt wird.

Option Beschreibung

Projektordner öffnen (Open Project Folder)

Öffnet den lokalen Ordner mit dem Projekt.

Projekteinstellungen

Öffnet das Fenster Projekteinstellungen (Project Settings) zum Anpassen der Projekteinstellungen.

Hinzufügen

Opens a list of items that can be added to the project: folder, file, sequence, flowchart, state machine, form, workflow, global handler, or, in test automation projects, test case.

Use workflow to create a workflow file based on built-in templates (sequence, flowchart, state machine) or local file templates.

Dateien importieren

Öffnet das Datei-Explorer-Fenster zum Importieren von Dateien in Ihr Projekt. Standardmäßig wird der *.xaml-Filter angewendet, damit nur Workflow-Dateien aufgelistet werden, aber Sie können zu allen Dateien wechseln, um andere Dateitypen zu importieren. Importiert wird zum importierten Dateinamen hinzugefügt, wenn er mit dem Namen eines Workflows aus dem aktuellen Projekt übereinstimmt.

Sie können nur Workflow-Dateien importieren, welche die gleiche Sprache für Ausdrücke wie das aktuelle Projekt verwenden. Wenn Sie eine Workflow-Datei importieren, werden die Abhängigkeiten des aktuellen Projekts mit denen in der Quellprojektdatei verglichen, sofern eine verfügbar ist. Bei Diskrepanzen wird das Fenster Workflow importieren mit Informationen zu Änderungen angezeigt, die zur Vermeidung ungelöster Aktivitäten erforderlich sind. Verfügbare Aktualisierungen der Abhängigkeiten sind standardmäßig ausgewählt und werden installiert, wenn Sie Importieren auswählen.

  • The icon docs image indicates a missing dependency that should be installed.
  • The icon docs image indicates a newer version used in the source project that you should update to.
  • The icon docs image is displayed if a missing dependency is not available for the current project, or if the available version is different than the one in the source project.

Optional können Sie eine project.json-Datei angeben, die als Referenz verwendet werden soll, und auswählen, ob in Vorabversionen von Paketen gesucht werden soll.

In Windows konvertieren

Öffnet in einem „Windows – Legacy“-Projekt das Fenster In Windows konvertieren, in dem Sie das Projekt zur Kompatibilität mit Windows konvertieren können.

Zu Source Control hinzufügen

Adds the current project to source control using Git Init, Copy to Git, Add to TFS, or Add to SVN options. Please note that this option is only visible when right-clicking the project node.

When a project is added to source control, additional options are available in the context menu. See the options for GIT and the options for SVN and TFS.

Offen

Öffnet die ausgewählten Dateien mit dem Standardprogramm.

Dateispeicherort öffnen

Öffnet den lokalen Ordner mit der Datei.

Umbenennen

Ermöglicht das Umbenennen der ausgewählten Datei oder des ausgewählten Ordners und öffnet das Fenster Element umbenennen. Das Element wird in allen Vorkommen umbenannt. Hinweis: Der vollständige Pfad der neuen Datei darf höchstens 258 Zeichen lang sein.

Kopieren

Kopiert die ausgewählten Dateien oder Ordner in die Zwischenablage. Sie können sie dann im Projektfenster oder im Windows Datei-Explorer einfügen.

Einfügen

Fügt Dateien oder Ordner ein, die in die Zwischenablage kopiert wurden.

Löschen

Löscht nur das ausgewählte Element von Ihrem lokalen Computer.

Zum Vergleichen auswählen (Select for Compare)

Wählt die aktuelle Datei zum Vergleichen aus.

Mit ausgewählten vergleichen (Compare with Selected)

Compares the current file with the previously selected file using Compare Files.

Verweise suchen

Finds all references to the file in the project. The results are displayed in the Find References panel.

Im Text-Editor öffnen

Öffnet die ausgewählte Textdatei in einem Texteditor in Studio im schreibgeschützten Modus.

Um eine Textdatei im Bearbeitungsmodus zu öffnen, doppelklicken Sie darauf. Mit einem Doppelklick auf TXT-, CS-, VB-, JSON- (außer „project.json“) und XML-Dateien, die kleiner als 10 MB sind, können Sie diese in Studio in einem Texteditor mit Syntaxhervorhebung bearbeiten.

Datei debuggen

Debuggt die ausgewählte .xaml-Datei.

Als Haupt festlegen (Set as Main)

Legt die ausgewählte .xaml-Datei in der Projektdefinition als Hauptinstanz fest, d. h., die Projektausführung beginnt mit dieser Datei. Es kann nur eine Hauptprojektdatei geben. Der Name des als Hauptinstanz festgelegten Dateisatzes wird im Projektfenster fett angezeigt.

Aktivitätslayout

Öffnen Sie das Eigenschaften-Fenster für Dateien in Bibliotheksprojekten, in dem Sie das Design der generierten Aktivität anpassen können.

Als globale Bearbeitung festlegen

Legt die .xaml-Datei im Projekt als (Global Exception Handler für das Projekt fest. Dies gilt für einen Workflow bei jedem Projekt/Prozess.

Bearbeitung entfernen

Entfernt das Tag Global Exception Handler aus der .xaml-Datei.

Einstiegspunkt aktivieren

Marks the selected workflow file as an entry point for the process, making it possible to select it as the workflow to run first when using the Invoke Process and Run Parallel Process activities in other processes, or when starting a job from Orchestrator.

  • When a file is marked as an entry point, an arrow is displayed on the icon next to the file name docs image.
  • Wird eine beim Veröffentlichen ignorierte Datei als Einstiegspunkt aktiviert, wird sie veröffentlichbar.
  • Diese Option ist für Testfalldateien nicht verfügbar.
  • Diese Option ist in Bibliotheksprojekten nicht verfügbar.

Einstiegspunkt deaktivieren

Markiert die ausgewählte Workflowdatei nicht mehr als Einstiegspunkt für den Prozess. Diese Option ist für die Workflowdatei, die als Hauptdatei festgelegt ist, nicht verfügbar.

Als Vorlage extrahieren

Speichert den ausgewählten Workflow oder Testfall als Vorlage, auf der Sie dann andere Dateien im Projekt aufbauen können. Mithilfe einer Dateivorlage können Sie Zeit sparen, wenn Sie mehrere Dateien mit derselben Struktur erstellen müssen. Wenn Sie einen neuen Workflow oder Testfall hinzufügen, haben Sie die Möglichkeit, ihn auf einer beliebigen Vorlage desselben Typs aufzubauen, die im Projektordner Vorlagen vorhanden ist.

Bei Veröffentlichung ignorieren/Als veröffentlichbar festlegen

Markiert eine oder mehrere ausgewählte Dateien als von der Veröffentlichung ausgeschlossen oder veröffentlichbar.

  • When a file is ignored from publishing, the icon next to the file name turns gray docs image.
  • Das Ignorieren einer als Einstiegspunkt markierten Datei bei der Veröffentlichung deaktiviert den Einstiegspunkt.
  • Diese Optionen sind nicht für Workflowdateien in Bibliotheksprojekten verfügbar.
  • In Projekten, in denen XAML-Dateien bei der Veröffentlichung kompiliert werden, werden Workflow- und Testfalldateien, die von der Veröffentlichung ausgeschlossen sind, nicht kompiliert.

Als privat festlegen/Als öffentlich festlegen

Markiert eine oder mehrere ausgewählte Dateien in einem Bibliotheksprojekt als privat oder öffentlich. Eine private Workflowdatei ist im veröffentlichten Paket enthalten, aber es wird keine wiederverwendbare Komponente erstellt und im Panel Aktivitäten in Projekten zur Verfügung gestellt, in denen die Bibliothek als Abhängigkeit installiert wird.

  • When a file is marked as private, the icon next to the file name turns gray docs image.
  • Diese Optionen stehen nicht für Testfalldateien zur Verfügung.

Testfall erstellen

Creates a test case that invokes the selected workflow file.

In Testfall konvertieren/In Workflow konvertieren

Converts the selected workflows to test cases or the selected test cases to workflows.

Testfälle importieren

Importiert Testfälle als Entwurfstestfälle in das Projekt.

Testdaten hinzufügen

Opens the Import Data Variation Source window that enables you to add test data to the project. This option is only available for test cases.

Mit Test Manager verknüpfen

Opens the Link to Test Manager window that enables you to link the selected test cases to Test Manager.

Testfälle ausführen/Testfälle debuggen

Führt mehrere ausgewählte Testfälle aus oder debuggt sie.

Kontextmenüoptionen für GIT

In Projekten, die GIT-Repositorys hinzugefügt werden, wird neben jeder Datei im Projektfenster ein Symbol angezeigt, das den Dateistatus angibt:

Dokumentationsbild Die Datei ist mit dem Repository synchronisiert.

Dokumentationsbild Die Datei wurde geändert.

Dokumentationsbild Die Datei wurde hinzugefügt.

Dokumentationsbild Die Datei wurde entfernt.

Right-click a file or project node in the Project panel to open the GIT-specific context menu for Managing Projects with GIT.

OptionBeschreibung
CommitÜbergibt aktuelle Änderungen an das lokale GIT-Repository.
Verschieben (Push)Verschiebt die aktuelle Version auf das Remote-Repository.
Ziehen (Pull (rebase))Zieht Remote-Dateien und stellt eine neue Basis für die aktuelle Verzweigung her.
Verzweigungen verwalten (Manage Branches)Öffnet das Fenster GIT mit den Optionen zum Verwalten aktuell hinzugefügter Verzweigungen.
Änderungen anzeigen (Show Changes)Öffnet das Fenster Datei-Diff (File Diff) zum Vergleichen der Änderungen zwischen der lokalen Version und der Remote-Version der Datei.
Verlauf anzeigen (Show History)Öffnet das Fenster Verlauf anzeigen (Show History) zum Vergleichen von zwei Versionen derselben Datei.
Rückgängig machenÖffnet das Fenster Anstehende Änderungen rückgängig machen (Undo Pending Changes), wenn die Datei nicht übergeben oder in das Remote-Repository verschoben wurde.
Repository-URL kopierenKopiert die Repository-URL des Projekts in die Zwischenablage.
Kontextmenüoptionen für SVN und TFS

In Projekten, die GIT-Repositorys hinzugefügt werden, wird neben jeder Datei im Panel Projekt ein Symbol angezeigt, das den Dateistatus angibt:

Dokumentationsbild Die Datei ist nicht zur Bearbeitung ausgecheckt.

Dokumentationsbild Die Datei wurde zur Bearbeitung ausgecheckt.

Dokumentationsbild Die Datei wurde bearbeitet.

Dokumentationsbild Die Datei wurde hinzugefügt.

Right-click a file or project node in the Project panel to open the context menu with options specific to managing projects with TFS or SVN.

OptionBeschreibung
OffenÖffnet die ausgewählte .xaml-Datei im Designer-Panel im schreibgeschützten Modus, wenn sie nicht zum Bearbeiten aus dem TFS/SVN-Repository ausgecheckt wurde.
UmbenennenErmöglicht das Umbenennen der ausgewählten Datei oder des ausgewählten Ordners und öffnet das Fenster Objekt umbenennen (Rename Item). Beim Einchecken der umbenannten Datei .xaml muss auch die zuvor geänderte Version eingecheckt werden.
LöschenLöscht nur das ausgewählte Element von Ihrem lokalen Computer. Die neueste Check-In Version der Datei ist weiterhin im TFS/SVN-Repository verfügbar.
Für die Eingabe auscheckenMarkiert die ausgewählte Datei oder den ausgewählten Ordner als für die Bearbeitung gesperrt. Wenn Sie eine Datei auschecken, wird sie auf dem Server gesperrt, sodass sie niemand anders sie bearbeiten kann.
Bearbeitung abschließenCheckt die project.json-Datei zusammen mit Änderungen und einer Commit-Nachricht in das Repository ein.
HinzufügenLädt das ausgewählte Element auf den TFS/SVN-Server hoch. Diese Option ist nicht verfügbar, wenn das Objekt zuvor auf den Server hochgeladen wurde.
Neueste Version abrufenLädt die neueste Version des ausgewählten Elements vom TFS/SVN-Repository herunter.
Änderungen anzeigen (Show Changes)Öffnet die Datei-Diff (File Diff) zum Vergleichen der Änderungen zwischen der versionierten und der lokal zugeordneten Datei.
Check-InZeigt das Fenster Check In Changes und ermöglicht Ihnen einen Upload des ausgewählten Objekts als neueste Version auf den Server. Die Datei .xaml muss vor dem Hochladen gespeichert werden. Nach dem Einchecken wird die Datei in Studio schreibgeschützt.
Rückgängig machenZeigt das Fenster Anstehende Änderungen rückgängig machen (Undo Pending Changes) an und ermöglicht es Ihnen, entweder die geänderten Dateien in den früheren bzw. versionslosen Status zurückzuführen oder Dateien abzurufen, die aus dem lokalen Computer gelöscht wurden.

Änderungen können nach dem Einchecken der Datei nicht mehr rückgängig gemacht werden.
Ausführen (Run)Führt den ausgewählten Workflow aus, auch wenn dieser nicht ausgecheckt oder zum Repository hinzugefügt wurde.
Als Haupt festlegen (Set as Main)Legt die ausgewählte .xaml-Datei im Projekt als Haupt (Main) fest. Die erste erstellte .xaml wird standardmäßig als Haupt (Main) definiert.
Repository-URL kopierenKopiert die Repository-URL des Projekts in die Zwischenablage.

Anpassen der Projekteinstellungen

Für jedes Automationsprojekt, an dem Sie arbeiten, kann ein individueller Einstellungssatz festgelegt werden. Diese Einstellungen stehen im Fenster Projekteinstellungen (Project Settings) zur Verfügung, das durch Anklicken von Dokumentationsbild im Panel Projekt (Project) geöffnet werden kann.

Feldbeschreibung für das Fenster „Einstellungen“

The following table describes the project settings for process, test automation, and template projects. For information about the settings available for libraries, see About Libraries.

Feld Beschreibung

Name

Ändern Sie den Namen des Projekts. Solche Namen können Leerzeichen enthalten. Beachten Sie beim Benennen von Projekten, dass Leerzeichen zum Zeitpunkt der Veröffentlichung entfernt werden. Dieses Feld akzeptiert bis zu 128 Zeichen.

Beschreibung

Ändern Sie die Projektbeschreibung. Dieses Feld akzeptiert bis zu 500 Zeichen.

Projekt-Tags

Sie können ein oder mehrere Tags zum Projekt hinzufügen, indem Sie entweder neue erstellen oder bereits im Orchestrator definierte Tags wiederverwenden. Es gibt zwei Arten von Tags: Beschriftungen und Eigenschaften (Schlüssel-Wert-Paare). Tags sind im veröffentlichten Paket enthalten und helfen bei der Beschreibung und Kategorisierung von Projekten. Sie können beispielsweise auf die automatisierte Anwendung (eine Excel-Beschriftung) oder die Abteilung (eine department:accounting-Schlüssel-Wert-Eigenschaft) verweisen.

Wenn Sie mit der Eingabe beginnen, werden mögliche Übereinstimmungen aus bereits definierten Tags vorgeschlagen, und Sie können eines wiederverwenden, indem Sie es aus der Liste der Übereinstimmungen auswählen. Bei einer Eigenschaftsübereinstimmung wird zuerst der Schlüssel gefolgt vom Doppelpunkt : angezeigt. Die zugehörigen Werte werden angezeigt, nachdem Sie den Schlüssel ausgewählt haben.

Um ein neues Tag hinzuzufügen, klicken Sie nach der Eingabe des Namens auf den Eintrag mit dem Pluszeichen neben dem Namen. Trennen Sie Strings mit einem Doppelpunkt :, um Eigenschaften hinzuzufügen. Verwenden Sie keinen Doppelpunkt : bei den Einträgen, um Beschriftungen hinzuzufügen.

Beschriftungen und Schlüssel-Wert-Eigenschaften sind auf 256 Zeichen begrenzt. Tag-Namen dürfen diese Zeichen nicht enthalten: <, >, %, &, \, ?, /, :.

Projekt-Tags können automatisch auf Prozesse im Orchestrator angewendet werden. Weitere Informationen zur Verwendung von Tags finden Sie unter Organisieren von Ressourcen mit Tags im Orchestrator-Handbuch.

Automation Hub-URL

URL of an Automation Hub idea linked to the project. For more information, see Linking a Project to an Idea in Automation Hub.

Paketsymbol

Definieren Sie optional ein benutzerdefiniertes Symbol für das Projekt. Sie können nach einer Datei suchen und diese auswählen, oder Sie geben einen Pfad oder eine öffentliche URL zu einer jpeg-, jpg- oder png-Datei mit einer Größe von maximal 1 MB ein.

Nachdem das Projekt veröffentlicht wurde, wird das Symbol wie folgt angezeigt:

  • Bei Prozessen im Assistant neben dem Prozessnamen, sodass sie in der Liste der Prozesse leichter identifiziert werden können.
  • Für Vorlagen neben der Vorlage in Start (Studio Backstage View) > Vorlagen.
  • Für Bibliotheken neben dem Paket im Fenster Pakete verwalten in Studio.
Das Symbol ist in „Pakete verwalten“ nicht sichtbar, wenn eine lokale Datei für eine Bibliothek verwendet wird, die im Orchestrator veröffentlicht wurde, oder für einen Feed, der eingebettete Symbole nicht unterstützt. In diesem Fall geben Sie das Symbol mithilfe einer URL an.

Pause deaktivieren

Aktivieren oder verhindern Sie, dass Benutzer die Ausführung über den UiPath Assistant anhalten. Legen Sie Ja fest, wenn das Anhalten des Prozesses während der Ausführung zu einem Absturz führen würde. Wenn z. B. eine Aktivität in Ihrem Workflow die Timeout-Eigenschaft verwendet, kann das Anhalten der Ausführung dazu führen, dass das Timeout abläuft, wodurch die Ausführung abgebrochen wird.

Beaufsichtigte Automatisierung

Legen Sie Ja fest, um anzugeben, dass das Projekt nur in einem Attended-Kontext ausgeführt werden soll. Verwenden Sie diese Einstellung für Projekte, die UI-Automatisierungsaktivitäten oder andere Aktivitäten enthalten, die eine Benutzerinteraktion erfordern.

Wird im Hintergrund gestartet

Set to Yes to turn the project into a Background Process and allow it to run in the background concurrently with other processes, as long as it does not use UI interaction.

Unterstützt Persistenz

Set to Yes to turn the project into an Orchestration Process.

Separate Runtime-AbhängigkeitenUm die Roboterleistung zu steigern und die Größe der veröffentlichten Pakete zu reduzieren, werden Bibliotheken in Design- und Runtime-Pakete aufgeteilt. Das Designpaket wird von Studio und das schlankere Ausführungspaket vom Roboter verwendet.
Quellen einschließen Wählen Sie Ja aus, um alle .xaml-Quellen in das veröffentlichte Paket zu packen, einschließlich der Workflows, die zuvor privat waren. Für Windows – Legacy-Bibliotheken werden die Dateien in der generierten Assembly-Datei und im Ordner lib\net45 in der .nupkg-Datei gespeichert. Für Windows- und plattformübergreifende Bibliotheken und Prozesse werden die Dateien im content-Ordner in der .nupkg-Datei gespeichert.

BiB-Optionen

Indicate whether the project was tested using Picture in Picture (PiP) and whether it should start in PiP by default.

  • Für BiB-Verwendung getestet; in BiB starten – Die Automatisierung wurde für die Ausführung im BiB-Modus genehmigt. Wenn sie ausgeführt wird, startet sie standardmäßig im BiB-Modus.
  • Für BiB-Verwendung getestet; standardmäßig nicht in BiB starten – Die Automatisierung wurde für die Ausführung im BiB-Modus genehmigt. Sie wird standardmäßig in der Hauptsitzung oder auf dem Desktop gestartet.
  • Nicht für die BiB-Verwendung getestet – Die Automatisierung wurde nicht für die Ausführung im BiB-Modus genehmigt. Sie wird standardmäßig in der Hauptsitzung oder auf dem Desktop gestartet. Wenn der Benutzer sie im BiB-Modus ausführt, wird er in einem Dialogfeld darüber informiert, dass diese Funktion nicht getestet wurde, und muss dies bestätigen, bevor er fortfahren kann.

BiB-Typ

Wählen Sie aus, wie die Automatisierung von der Benutzersitzung isoliert werden soll, wenn das Projekt im BiB-Modus ausgeführt wird: Neue Sitzung (untergeordnete Sitzung auf der Maschine) oder Neuer Desktop (virtueller Desktop in der Benutzersitzung).

Klicken Sie auf OK und die Änderungen werden im Panel Projekt (Project) und in der Datei project.json sichtbar gemacht.

Check out the Configuring Activity Project Settings page to read about how to adjust activity properties at project level.

Hinweis:

Bitte berücksichtigen Sie, dass es sich empfiehlt, im Panel „Designer“ im Voraus nach unten zu scrollen, wenn Sie eine Vielzahl von Aktivitäten von einer Sequence in eine andere kopieren möchten. Dies ist durch die Begrenzung der Windows Workflow Foundation bedingt.

Entfernen nicht verwendeter Projektressourcen

Unnötige Ressourcen können die Verständlichkeit von Projekten erschweren und die Leistung beeinträchtigen. Um dieses Problem zu vermeiden, entfernen Sie nicht-verwendete Ressourcen aus Ihren Projekten, indem Sie im Studio-Menüband auf Nicht-verwendete entfernen klicken und dann auswählen, was entfernt werden soll:

  • Workflows – Entfernen Sie Workflow-Dateien, auf die im Projekt nicht verwiesen wird.
  • Variablen – Entfernen der Variablen, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Argumente – Entfernen Sie Argumente, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Abhängigkeiten – Entfernen Sie installierte Aktivitätspakete, aus denen keine Aktivitäten im Projekt verwendet werden.
  • Importe – Entfernen Sie importierte Namespaces, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Screenshots – Entfernen Sie informative Screenshots, die in keiner Aktivität im Projekt verwendet werden.

War diese Seite hilfreich?

Verbinden

Benötigen Sie Hilfe? Support

Möchten Sie lernen? UiPath Academy

Haben Sie Fragen? UiPath-Forum

Auf dem neuesten Stand bleiben