Studio
2022.10
False
Bannerhintergrundbild
Studio-Benutzerhandbuch
Letzte Aktualisierung 1. März 2024

Über Automatisierungsprojekte

UiPath Studio ermöglicht die Erstellung folgender Projekttypen:

  • Prozess – Entwerfen Sie einen Automatisierungsprozess und veröffentlichen Sie ihn, damit er von Robotern ausgeführt werden kann.
  • Bibliothek – Entwerfen Sie Workflows als wiederverwendbare Komponenten und veröffentlichen Sie das Projekt als Bibliothek, die als Abhängigkeit zu mehreren Prozessen hinzugefügt werden kann. Weitere Informationen finden Sie im Abschnitt Über Bibliotheken.
  • Testautomatisierung – Entwerfen Sie ein Testautomatisierungsprojekt. Weitere Informationen zur Testautomatisierung finden Sie im Abschnitt Test Suite.
  • Vorlage - Entwerfen Sie einen Prozess und veröffentlichen Sie ihn als Vorlage, auf der dann andere Prozesse mit gemeinsamen Eigenschaften basieren können. Weitere Informationen finden Sie unter Projektvorlagen.

Um ein neues leeres Projekt zu erstellen, wechseln Sie zu Start (Studio Backstage-Ansicht) > Starten und wählen Sie den Projekttyp aus, der unter Neues Projekt erstellt werden soll. Alternativ können Sie mit einer der Standardvorlagen beginnen, die unter Neu aus Vorlage verfügbar sind, oder zur Registerkarte Vorlagen wechseln, um nach weiteren Vorlagen aus verschiedenen Quellen zu suchen.



Konfigurieren Sie im neuen Projektfenster für jedes Projekt Folgendes:

  • Geben Sie einen Namen für das neue Projekt (bis zu 128 Zeichen) und eine Beschreibung ein, die zusammenfasst, was Sie mit diesem Automatisierungsprojekt erreichen möchten (bis zu 500 Zeichen).
  • Wählen Sie den Speicherort aus, an dem das Projekt erstellt werden soll. Der Standardspeicherort, an dem Projekte erstellt werden, lautet %USERPROFILE%\Documents\UiPath.
  • Wählen Sie Kompatibilität und Sprache aus.

    Note: The compatibility and language cannot be changed after you create a project. However, you can .

Standardmäßig enthält der Projektordner die folgenden Dateien und Unterordner:

  • Dateien

    • Main.xaml – Wird standardmäßig erstellt, um Ihren Hauptworkflow zu speichern. Darüber hinaus werden alle anderen Automatisierungs-XAML-Dateien, die Sie dem Projekt hinzufügen, im Projektordner gespeichert. Optional können Sie eine andere Datei als Hauptdatei festlegen. Alle Dateien müssen über die Aktivität Invoke Workflow File mit der Datei verknüpft werden, die als Hauptdatei festgelegt ist, oder mit einer Datei, die als Einstiegspunkt für das Projekt markiert ist. Für Testautomatisierungsprojekte wird standardmäßig eine TestCase.xaml-Datei anstelle von Main.xaml erstellt.
      Hinweis:
      • Sie können keine Windows-Projekte ausführen, die eine XAML-Datei mit dem Namen Init.xaml enthalten.
      • Eine XAML-Datei im Stammordner eines Projekts darf nicht den gleichen Namen wie ein Unterordner haben, der andere XAML-Dateien enthält.
    • project.json – Enthält Informationen über Ihr Automatisierungsprojekt.
  • Unterordner

    • .entities – Enthält Daten über Entitäten, die aus dem Data Service importiert wurden, falls diese im Projekt verwendet werden.
    • .local – Enthält lokal für das Projekt zwischengespeicherte Daten.
      Hinweis: Der Ordner .local ist ausgeblendet. Sie können die Anzeige ausgeblendeter Elemente in den Einstellungen von Windows-Explorer aktivieren.
    • .objects – Enthält Daten im Zusammenhang mit Elementen, die dem Object Repository hinzugefügt wurden, falls diese im Projekt verwendet werden.
    • .project – Enthält Tags, die zum Projekt hinzugefügt wurden.
    • .screenshots – Enthält informative Screenshots, die in UI-Automatisierungsaktivitäten generiert werden, falls welche im Projekt verwendet werden.
    • .settings – Enthält Aktivitätsprojekteinstellungen, die zur Laufzeit verwendet werden.
    • .templates – Enthält Dateivorlagen, die dem Projekt hinzugefügt wurden.
    • .tmh – Enthält Daten im Zusammenhang mit Testfällen, falls diese im Projekt verwendet werden.
      Hinweis: Projekte, die mit neueren Versionen von Studio erstellt wurden, funktionieren möglicherweise nicht mit älteren Robotern. Lesen Sie mehr über Ab- und Aufwärtskompatibilität.
      Die folgenden Zeichen dürfen in Dateinamen nicht verwendet werden: ", <, >, |, :, *, ?, \, /,;. Diese Zeichen stammen aus Microsoft Windows-Einschränkungen und anderen Sonderzeicheneinschränkungen.

Festlegen der Projektkompatibilität

Wenn Sie ein neues Projekt erstellen, wählen Sie die Kompatibilität basierend auf der Umgebung aus, in der das Projekt ausgeführt wird:

  • Windows – Verwendet .NET 6 mit Windows-Unterstützung. Dies ist die Standardoption.
  • Plattformübergreifend – Verwendet .NET 6 mit plattformübergreifender Unterstützung.
  • Windows – Legacy – Verwendet .NET Framework 4.6.1., die Kompatibilität, die in Versionen vor 2021.10 verwendet wurde.

    Wichtig:
    • Windows- und plattformübergreifende Prozesse erfordern Orchestrator 2021.10 und höher zur Ausführung.
    • The Windows - Legacy option will no longer be available for new projects in the near future. We recommend selecting Windows or Cross-platform when creating a new project. You can .

Weitere Informationen zu den Unterschieden zwischen Kompatibilitäten finden Sie in der folgenden Tabelle. Weitere Informationen zur Designumgebung bei jeder Kompatibilität finden Sie unter Entwerfen von Automatisierungen.

 

Windows – Legacy

Windows

Plattformübergreifend

Prozessausführung

32-Bit

64-Bit

64-Bit

Unterstützte Plattformen für die Ausführung

Windows (64-Bit)

Windows (64-Bit)

Windows, Linux und macOS (64 Bit)

Prozesse werden beim Veröffentlichen kompiliert

Nein. Veröffentlichte Pakete enthalten die Projektquelldateien.

Ja. Veröffentlichte Pakete enthalten kompilierte DLL-Dateien.

Ja. Veröffentlichte Pakete enthalten kompilierte DLL-Dateien.

Nur die Aktivitätspakete, welche die ausgewählte Kompatibilität unterstützen, können über den Paketmanager installiert werden.

Die Kompatibilität jedes Projekts wird rechts neben der Studio-Statusleiste und im Panel Projekt > Abhängigkeiten-Knoten angezeigt. Die Kompatibilität wird auch im Eintrag jedes Projekts in der Liste Zuletzt verwendete öffnen unter Start (Studio Backstage-Ansicht) > Registerkarte Starten angezeigt.

Hinweis: Das Kopieren und Einfügen von Aktivitäten zwischen Projekten mit unterschiedlichen Kompatibilitäten wird nicht unterstützt.

Entwerfen plattformübergreifender Projekte

Mit plattformübergreifenden Projekten können Sie Automatisierungen, die keine Benutzerinteraktion erfordern, und Webbrowser-Automatisierungen mit Chrome erstellen. Plattformübergreifende Automatisierungen können auf Windows und Unix-ähnlichen Betriebssystemen wie Linux und macOS ausgeführt werden.

So erstellen Sie Unattended-Projekte mit plattformübergreifender Unterstützung:

  1. Erstellen Sie ein neues Projekt in Studio und wählen Sie die Option für die plattformübergreifende Kompatibilität aus. Diese Option ist für alle Projekttypen verfügbar. Bei Prozessen, die die VB-Sprache für Ausdrücke verwenden, haben Sie die Möglichkeit, in Studio sowie in Studio Web zu arbeiten.
  2. Entwerfen Sie die Automatisierung. Bitte beachten Sie, dass nicht alle Aktivitätspakete mit plattformübergreifenden Projekten kompatibel sind, sodass im Paketmanager nur eine Auswahl der Pakete verfügbar ist. Hier erfahren Sie mehr über die Designerfahrung in plattformübergreifenden Projekten.

    Die Standardabhängigkeiten für ein plattformübergreifendes Projekt sind:

    • Im Studio-Profil: UiPath.System.Activities, UiPath.Testing.Activities, UiPath.WebApi.Activities und UiPath.UIAutomation.Activities.
    • Im StudioX-Profil: UiPath.System.Activities, Microsoft Office 365, Google Workspace und UiPath.UIAutomation.Activities.
  3. Testen Sie die Automatisierung. Es wird empfohlen, Automatisierungen auf den Maschinen zu testen, auf denen sie ausgeführt werden. Verwenden Sie dazu Remote-Debugging, das mit Windows-Robotern, Linux-Robotern und macOS-Robotern funktioniert.
  4. Veröffentlichen Sie das Projekt nach dem Testen der Automatisierung im Orchestrator. Das Verfahren zum Ausführen von Unattended-Aufträgen ist für Windows, macOS und Linux identisch.

    Wichtig: Diese Version von Studio ist nicht kompatibel mit älteren Versionen von plattformübergreifenden Aktivitätspaketen, die in Studio 2022.4 oder früher verfügbar waren. Wenn Sie plattformübergreifende Projekte in Studio-Versionen vor 2022.10 erstellt haben, aktualisieren Sie die installierten Pakete auf die neuesten Versionen, bevor Sie sie in Studio 2022.10 oder höher bearbeiten. Einige Eigenschaften können möglicherweise nicht mehr bearbeitet werden.

Öffnen eines Projekts in Studio Web

Wenn Sie Ihre plattformübergreifenden Projekte unterwegs von einem beliebigen Gerät aus direkt über den Browser entwickeln möchten, können Sie Projekte zur Cloud hinzufügen und sie in Studio Web, dem Automatisierungsdesigner in der UiPath Automation Cloud, bearbeiten. Wenn Sie ein Projekt zur Cloud hinzufügen, werden Änderungen immer synchronisiert, sodass Sie nahtlos zwischen Desktop und Web wechseln und dort weitermachen können, wo Sie aufgehört haben.

Wenn ein Studio-Projekt mit Studio Web kompatibel ist, wird die Beschriftung Mit Cloud kompatibel auf der rechten Seite der Studio-Statusleiste angezeigt. Um das Projekt in Studio Web verfügbar zu machen, wählen Sie Cloud-kompatibel > In Cloud speichern aus.

Hinweis: Projekte, welche die Sprache C# für Ausdrücke verwenden, werden in Studio Web nicht unterstützt. Sie können ein C#-Projekt in der Cloud speichern, aber Sie können es nicht in Studio Web bearbeiten.
Verwalten eines Cloudprojekts in Studio

Um mit Studio Web kompatibel zu sein, muss ein plattformübergreifendes Projekt die folgenden Anforderungen erfüllen:

  • Der Projekttyp ist „Prozess“.
  • Die Sprache für Ausdrücke ist „VB“.
  • Das Projekt enthält eine einzelne Workflowdatei.

Nachdem ein Projekt in Studio Web gespeichert wurde, ändert sich die Beschriftung in der Statusleiste zu Cloud-Projekt. Klicken Sie auf die Beschriftung, um ein Dropdownmenü mit Optionen zum Verwalten des Projekts zu öffnen:

  • InCloud speichern – Speichern Sie die neuesten Änderungen, die Sie in Studio Desktop am Projekt in Studio Web vorgenommen haben. Wenn das Remote-Projekt Änderungen enthält, müssen Sie zuerst bestätigen, dass Sie diese überschreiben möchten. Sie können das Projekt nicht in der Cloud speichern, wenn es durch Studio Web gesperrt ist.
  • In Studio Web öffnen – Öffnen Sie das Projekt in Studio Web. Wenn das Projekt von Studio Web gesperrt ist, wird ein Fehler angezeigt und das Projekt auf einer neuen Registerkarte im schreibgeschützten Modus geöffnet.
  • Eine Kopie speichern – Speichern Sie das aktuelle Projekt lokal als neues Projekt. Sie können den Namen bearbeiten, einen Speicherort auswählen und eine Projektbeschreibung eingeben.
  • Aktuelle Version abrufen – Rufen Sie die neuesten Änderungen ab, die Sie in Studio Web vorgenommen haben. Wenn Unterschiede zwischen dem Remote-Projekt und dem lokalen Projekt bestehen, müssen Sie zuerst bestätigen, dass Sie die lokale Version überschreiben möchten.



Wenn Sie ein Projekt in Studio Web erstellen, haben Sie ebenfalls die Möglichkeit, die Arbeit in Studio fortzusetzen. Öffnen Sie auf der Seite Projekte in Studio Web das Menü auf der rechten Seite eines Projekts und wählen Sie dann In Studio Desktop öffnen aus.

So werden Änderungen zwischen Studio und Studio Web synchronisiert

Wenn Sie ein Cloudprojekt in Studio speichern und schließen, werden die Änderungen auch im Remoteprojekt gespeichert, wenn das Projekt nicht von Studio Web gesperrt ist. Wenn Sie das Projekt dann in Studio Web öffnen, wird das Projekt mit allen Änderungen aktualisiert, die Sie in Studio in der Cloud gespeichert haben.

Wenn Sie ein Cloud-Projekt in Studio öffnen, wird das Projekt mit allen Änderungen aktualisiert, die Sie in Studio Web vorgenommen haben. Um ein Projekt, das bereits in Studio geöffnet ist, mit den neuesten Änderungen aus Studio Web zu aktualisieren, wählen Sie Cloud-Projekt > Aktuelle Version abrufen in der Studio-Statusleiste aus.

In beiden Fällen werden Sie, wenn Unterschiede zwischen dem lokalen Projekt und dem Remoteprojekt vorliegen, zur Bestätigung aufgefordert, bevor Sie fortfahren.

Einstellung der Projektsprache

Wenn Sie ein neues Projekt im Studio-Profil erstellen, können Sie auswählen, welche Sprache für Ausdrücke verwendet werden soll – entweder VB oder C#. VB ist die standardmäßig ausgewählte Sprache, aber Sie können C# als Standardsprache für neue Projekte festlegen, indem Sie zu Start (Studio-Backstage-Ansicht) > Einstellungen > Design gehen. Bei Projekten, die im StudioX-Profil erstellt werden, wird die VB.NET-Sprache für Ausdrücke verwendet.

Die Verwendung von VB- und C#-Ausdrücken im selben Projekt wird nicht unterstützt. Ebenso wenig wird die Verwendung von VB-Ausdrücken in C#-Workflows unterstützt und umgekehrt. Stellen Sie beim Kopieren und Einfügen der Aktivitäten von anderen Projekten und Aufrufen oder Importieren von Workflows sicher, dass sie dieselbe Sprache wie Ihr Projekt verwenden.

Sie können C#-Bibliotheken als Abhängigkeiten in VB-Projekten installieren und umgekehrt. Auf Standardwerte, die für Argumente im Bibliotheksprojekt unter Verwendung sprachspezifischer Ausdrücke definiert sind, kann jedoch nicht vom Projekt aus zugegriffen werden, in dem die Bibliothek installiert ist.

Einschränkungen von C#

  • Die aktuelle C#-Implementierung basiert auf dem C#-Compiler, der die C#-Version 5 verwendet, daher ist der Zugriff auf neuere Funktionen wie Coalescing-Zuweisung, Null-Bedingungsoperator, Null-Coalescing-Operator, String-Interpolation und andere nur eingeschränkt möglich.
  • Projekte, die Ausdrücke mit Inkrementen enthalten, sind ungültig.
  • Ausdrücke, die den Operator nameof() enthalten, werden als ungültig markiert und sind mit der aktuellen Implementierung von C# nicht erlaubt.
  • Ausdrücke, die Aufrufe von Methoden mit optionalen Argumenten enthalten, müssen Werte für die optionalen Argumente enthalten.
  • Die Entwurfszeit- und Laufzeitleistung von C#-Projekten ist im Vergleich zu VB.NET niedriger. Wenn Laufzeitleistung ausschlaggebend ist, empfehlen wir die Verwendung VB.NET anstelle von C#.

Einstellen der Projektversion

Semantikversionen

Das Schema der Semantikversionen hat das Format Major.Minor.Patch[-Suffix], wobei:

  • Haupt (Major) die Hauptversion ist.
  • Neben (Minor) die Nebenversion ist.
  • Patch (Patch) die Patch-Version ist.
  • Suffix (Suffix) (optional) ein Bindestrich gefolgt von einer Reihe durch Punkt getrennter Identifier unmittelbar hinter der Patch-Version ist. Damit wird eine frühere Version bezeichnet.

Identifier dürfen nur aus alphanumerischen ASCII-Zeichen und Bindestrich bestehen und nicht leer sein. Numerische Identifier dürfen nicht mit Nullen beginnen. Außerdem kann das Aufbauen von Metadaten durch Anhängen eines Plus-Zeichens und einer Reihe von durch Punkte getrennten Identifiern gekennzeichnet sein, die unmittelbar auf den Patch oder die frühere Version folgen, zum Beispiel 1.0.0-alpha+1.

Beim Erstellen eines neuen Prozesses oder einer Bibliothek ist das Standardversionsschema Semantik. Es kann im Fenster Veröffentlichen (Publish) geändert werden. Dazu hängt man einfach eine weitere Ziffer an die Versionsnummer an. Die Semantikversion des Projekts kann ebenfalls über die project.json-Datei geändert werden. Die Patch-Nummer 0 wird automatisch an Projekte mit der Versionsnummer major.minor angehängt.

Veraltete Versionen

Die für das Projekt generierte veraltete Versionsnummer hat das Format M.m.bbbb.rrrrr, wobei:

  • M ist die Hauptversion.
  • m ist die Nebenversion.
  • bbbb ist die Buildversion.
  • rrrrr die Revisionversion ist.
Die Haupt- und Nebenversionen in der Datei project.json bearbeitet werden können, während die Build- und Revisionsversionen gemäß einem Algorithmus generiert werden. Der Build-Wert ist die Anzahl der seit dem 01.01.2000 vergangenen Tage. Der Revisionswert die Anzahl der Sekunden ist, die am aktuellen Tag bis zum Moment der Freigabe vergangen sind. Das Ergebnis wird durch 2 dividiert, sodass die maximale Revisionsanzahl nicht höher als 65535 ist.

Die vorgeschlagene Versionsnummer im Fenster Veröffentlichen (Publish) basierend auf dem vorherigen Versionsschema des Projekts generiert wird, während das aktuelle Datum und der Zeitstempel für Projekte berücksichtigt werden, die das 4-stellige Versionsschema verwenden.

Verwalten von Projekten



Im Panel Projekt (Project)können Sie den Inhalt des aktuellen Projekts anzeigen, Ordner hinzufügen, den Speicherort der Datei öffnen, Abhängigkeiten verwalten und Prozesseinstellungen anpassen.



Fügen Sie aus dem Datei-Explorer kopierte Dateien direkt in das Projekt-Panel ein. Dieselbe Aktion kann per Drag & Drop für eine oder mehrere Dateien durchgeführt werden, einschließlich .xaml-Workflows. Sie können auch die Tastenkombinationen Strg + C und Strg + V oder die Optionen Kopieren und Einfügen im Kontextmenü verwenden, um Dateien oder Ordner innerhalb des Panels zu kopieren und zu duplizieren.

Mit einem Doppelklick auf TXT-, CS-, VB-, JSON- (außer „project.json“) und XML-Dateien, die kleiner als 10 MB sind, können Sie diese in Studio in einem Texteditor mit Syntaxhervorhebung bearbeiten.

Option

Beschreibung

Alle erweitern (Expand All)

Erweitert alle Knoten in den Automationsprojekten.

Alle reduzieren (Collapse All)

Reduziert alle Knoten in den Automationsprojekten.

Aktualisieren

Aktualisiert das Projekt.

Alle Dateien anzeigen

Zeigt alle Dateien an, die zum Automationsprojekt gehören, einschließlich der Datei project.json.

Datei-Explorer

Öffnet den Speicherort des Projekts auf dem Computer.

Projekteinstellungen

Öffnet das Fenster Projekteinstellungen (Project Settings) für Prozesse und Bibliotheken.

Kontextmenü für Projekte

Klicken Sie mit der rechten Maustaste im Projektfenster auf eine beliebige Stelle, um das Kontextmenü mit den in der folgenden Tabelle beschriebenen Optionen zu öffnen. Die verfügbare Gruppe von Optionen hängt von der mit der rechten Maustaste angeklickten Stelle im Fenster, vom Projekttyp sowie davon ab, ob das Projekt zu Source Control hinzugefügt wird.

Option

Beschreibung

Projektordner öffnen (Open Project Folder)

Öffnet den lokalen Ordner mit dem Projekt.

Projekteinstellungen

Öffnet das Fenster Projekteinstellungen (Project Settings) zum Anpassen der Projekteinstellungen.

Hinzufügen

Öffnet eine Liste von Elementen, die dem Projekt hinzugefügt werden können: Ordner, Sequence, Flowchart, State Machine, globaler Handler, Workflow oder, in Testautomatisierungsprojekten, Testfall.

Verwenden Sie den Workflow, um eine Workflow-Datei basierend auf integrierten Vorlagen (Sequence, Flowchart, State Machine) oder lokalen Dateivorlagen zu erstellen.

Dateien importieren

Öffnet das Datei-Explorer-Fenster zum Importieren von Dateien in Ihr Projekt. Standardmäßig wird der *.xaml-Filter angewendet, damit nur Workflow-Dateien aufgelistet werden, aber Sie können zu allen Dateien wechseln, um andere Dateitypen zu importieren. Importiert wird zum importierten Dateinamen hinzugefügt, wenn er mit dem Namen eines Workflows aus dem aktuellen Projekt übereinstimmt.

Sie können nur Workflow-Dateien importieren, welche die gleiche Sprache für Ausdrücke wie das aktuelle Projekt verwenden. Wenn Sie eine Workflow-Datei importieren, werden die Abhängigkeiten des aktuellen Projekts mit denen in der Quellprojektdatei verglichen, sofern eine verfügbar ist. Bei Diskrepanzen wird das Fenster Workflow importieren mit Informationen zu Änderungen angezeigt, die zur Vermeidung ungelöster Aktivitäten erforderlich sind. Verfügbare Aktualisierungen der Abhängigkeiten sind standardmäßig ausgewählt und werden installiert, wenn Sie Importieren auswählen.

  • Das Symbol docs image weist auf eine fehlende Abhängigkeit hin, die installiert werden sollte.
  • Das Symbol docs image weist auf eine neuere Version hin, die im Quellprojekt verwendet wird, auf die Sie aktualisieren sollten.
  • Das Symbol docs image wird angezeigt, wenn eine fehlende Abhängigkeit für das aktuelle Projekt nicht verfügbar ist oder wenn sich die verfügbare Version von der im Quellprojekt unterscheidet.

Optional können Sie eine project.json-Datei angeben, die als Referenz verwendet werden soll, und auswählen, ob in Vorabversionen von Paketen gesucht werden soll.

In Windows konvertieren

Öffnet in einem „Windows – Legacy“-Projekt das Fenster In Windows konvertieren, in dem Sie das Projekt zur Kompatibilität mit Windows konvertieren können.

Als Bibliothek extrahieren

Extrahiert ein Prozess- oder Testautomatisierungsprojekt als Bibliothek.

Zu Source Control hinzufügen

Fügt das aktuelle Projekt anhand der Option GIT-Initialisierung, In GIT kopieren, Zu TFS hinzufügen oder Zu SVN hinzufügen der Source Control hinzu. Diese Option ist nur sichtbar, wenn mit der rechten Maustaste auf den Projektknoten geklickt wird.

Wenn ein Projekt zur Quellcodeverwaltung hinzugefügt wird, stehen zusätzliche Optionen im Kontextmenü zur Verfügung. Sehen Sie sich die Optionen für GIT und die Optionen für SVN und TFS an.

Offen

Öffnet die ausgewählten Dateien mit dem Standardprogramm.

Dateispeicherort öffnen

Öffnet den lokalen Ordner mit der Datei.

Umbenennen

Ermöglicht das Umbenennen der ausgewählten Datei oder des ausgewählten Ordners und öffnet das Fenster Element umbenennen. Das Element wird in allen Vorkommen umbenannt. Hinweis: Der vollständige Pfad der neuen Datei darf höchstens 258 Zeichen lang sein.

Kopieren

Kopiert die ausgewählten Dateien oder Ordner in die Zwischenablage. Sie können sie dann im Projektfenster oder im Windows Datei-Explorer einfügen.

Einfügen

Fügt Dateien oder Ordner ein, die in die Zwischenablage kopiert wurden.

Löschen

Löscht nur das ausgewählte Element von Ihrem lokalen Computer.

Zum Vergleichen auswählen (Select for Compare)

Wählt die aktuelle Datei zum Vergleichen aus.

Mit ausgewählten vergleichen (Compare with Selected)

Vergleicht die aktuelle Datei mit der zuvor ausgewählten Datei anhand von Dateien vergleichen (Compare Files).

Verweise suchen

Sucht alle Verweise auf die Datei im Projekt. Die Ergebnisse werden im Bereich Verweise suchen angezeigt.

Im Text-Editor öffnen

Öffnet die ausgewählte Textdatei in einem Texteditor in Studio im schreibgeschützten Modus.

Um eine Textdatei im Bearbeitungsmodus zu öffnen, doppelklicken Sie darauf. Mit einem Doppelklick auf TXT-, CS-, VB-, JSON- (außer „project.json“) und XML-Dateien, die kleiner als 10 MB sind, können Sie diese in Studio in einem Texteditor mit Syntaxhervorhebung bearbeiten.

Datei debuggen

Debuggt die ausgewählte .xaml-Datei.

Als Haupt festlegen (Set as Main)

Legt die ausgewählte .xaml-Datei in der Projektdefinition als Hauptinstanz fest, d. h., die Projektausführung beginnt mit dieser Datei. Es kann nur eine Hauptprojektdatei geben. Der Name des als Hauptinstanz festgelegten Dateisatzes wird im Projektfenster fett angezeigt.

Aktivitätslayout

Öffnen Sie das Eigenschaften-Fenster für Dateien in Bibliotheksprojekten, in dem Sie das Design der generierten Aktivität anpassen können.

Als globale Bearbeitung festlegen

Legt die .xaml-Datei im Projekt als (Global Exception Handler für das Projekt fest. Dies gilt für einen Workflow bei jedem Projekt/Prozess.

Bearbeitung entfernen

Entfernt das Tag Global Exception Handler aus der .xaml-Datei.

Einstiegspunkt aktivieren

Markiert die ausgewählte Workflowdatei als einen Einstiegspunkt für den Prozess, sodass sie als der Workflow ausgewählt werden kann, der zuerst ausgeführt werden soll, wenn die Aktivitäten Invoke Process und Run Parallel Process in anderen Prozessen ausgeführt werden, oder wenn ein Auftrag vom Orchestrator aus ausgeführt wird.

Hinweis:
  • Wenn eine Datei als Einstiegspunkt markiert ist, wird auf dem Symbol neben dem Dateinamen docs image ein Pfeil angezeigt.
  • Wird eine beim Veröffentlichen ignorierte Datei als Einstiegspunkt aktiviert, wird sie veröffentlichbar.
  • Diese Option ist für Testfalldateien nicht verfügbar.
  • Diese Option ist in Bibliotheksprojekten nicht verfügbar.

Einstiegspunkt deaktivieren

Markiert die ausgewählte Workflowdatei nicht mehr als Einstiegspunkt für den Prozess. Diese Option ist für die Workflowdatei, die als Hauptdatei festgelegt ist, nicht verfügbar.

Als Vorlage extrahieren

Speichert den ausgewählten Workflow oder Testfall als Vorlage, auf der Sie dann andere Dateien im Projekt aufbauen können. Mithilfe einer Dateivorlage können Sie Zeit sparen, wenn Sie mehrere Dateien mit derselben Struktur erstellen müssen. Wenn Sie einen neuen Workflow oder Testfall hinzufügen, haben Sie die Möglichkeit, ihn auf einer beliebigen Vorlage desselben Typs aufzubauen, die im Projektordner Vorlagen vorhanden ist.

Bei Veröffentlichung ignorieren/Als veröffentlichbar festlegen

Markiert eine oder mehrere ausgewählte Dateien als von der Veröffentlichung ausgeschlossen oder veröffentlichbar.

Hinweis:
  • Wenn eine Datei bei der Veröffentlichung ignoriert wird, wird das Symbol neben dem Dateinamen ausgegraut docs image.
  • Das Ignorieren einer als Einstiegspunkt markierten Datei bei der Veröffentlichung deaktiviert den Einstiegspunkt.
  • Diese Optionen sind nicht für Workflowdateien in Bibliotheksprojekten verfügbar.
  • In Projekten, in denen XAML-Dateien bei der Veröffentlichung kompiliert werden, werden Workflow- und Testfalldateien, die von der Veröffentlichung ausgeschlossen sind, nicht kompiliert.

Als privat festlegen/Als öffentlich festlegen

Markiert eine oder mehrere ausgewählte Dateien in einem Bibliotheksprojekt als privat oder öffentlich. Eine private Workflowdatei ist im veröffentlichten Paket enthalten, aber es wird keine wiederverwendbare Komponente erstellt und im Panel Aktivitäten in Projekten zur Verfügung gestellt, in denen die Bibliothek als Abhängigkeit installiert wird.

Hinweis:
  • Wenn eine Datei als privat markiert wird, dann wird das Symbol neben dem Dateinamen ausgegraut docs image.
  • Diese Optionen stehen nicht für Testfalldateien zur Verfügung.

Testfall erstellen

Erstellt einen Testfall, der die ausgewählte Workflowdatei aufruft.

In Testfall konvertieren/In Workflow konvertieren

Konvertiert die ausgewählten Workflows in Testfälle oder die ausgewählten Testfälle in Workflows.

Testfälle importieren

Importiert Testfälle als Entwurfstestfälle in das Projekt.

Testdaten hinzufügen

Öffnet das Fenster Datenvariantenquelle importieren, in dem Sie dem Projekt Testdaten hinzufügen können. Diese Option steht nur für Testfälle zur Verfügung.

Mit Test Manager verknüpfen

Öffnet das Fenster Mit Test Manager verknüpfen, in dem Sie die ausgewählten Testfälle mit dem Test Manager verknüpfen können.

Testfälle ausführen/Testfälle debuggen

Führt mehrere ausgewählte Testfälle aus oder debuggt sie.

Kontextmenüoptionen für GIT

In Projekten, die GIT-Repositorys hinzugefügt werden, wird neben jeder Datei im Projektfenster ein Symbol angezeigt, das den Dateistatus angibt:

Die Datei ist mit dem Repository synchronisiert.

Die Datei wurde geändert.

Die Datei wurde hinzugefügt.

Die Datei wurde entfernt.

Klicken Sie mit der rechten Maustaste auf eine Datei oder einen Projektknoten im Panel Projekt, um das GIT-spezifische Kontextmenü für Verwalten von Projekten mit GIT zu öffnen.



Option

Beschreibung

Commit

Übergibt aktuelle Änderungen an das lokale GIT-Repository.

Verschieben (Push)

Verschiebt die aktuelle Version auf das Remote-Repository.

Ziehen (Pull (rebase))

Zieht Remote-Dateien und stellt eine neue Basis für die aktuelle Verzweigung her.

Verzweigungen verwalten (Manage Branches)

Öffnet das Fenster GIT mit den Optionen zum Verwalten aktuell hinzugefügter Verzweigungen.

Änderungen anzeigen (Show Changes)

Öffnet das Fenster Datei-Diff (File Diff) zum Vergleichen der Änderungen zwischen der lokalen Version und der Remote-Version der Datei.

Verlauf anzeigen (Show History)

Öffnet das Fenster Verlauf anzeigen (Show History) zum Vergleichen von zwei Versionen derselben Datei.

Rückgängig machen

Öffnet das Fenster Anstehende Änderungen rückgängig machen (Undo Pending Changes), wenn die Datei nicht übergeben oder in das Remote-Repository verschoben wurde.

Repository-URL kopieren

Kopiert die Repository-URL des Projekts in die Zwischenablage.

Kontextmenüoptionen für SVN und TFS

In Projekten, die GIT-Repositorys hinzugefügt werden, wird neben jeder Datei im Panel Projekt ein Symbol angezeigt, das den Dateistatus angibt:

Die Datei ist nicht zur Bearbeitung ausgecheckt.

Die Datei wurde zur Bearbeitung ausgecheckt.

Die Datei wurde bearbeitet.

Die Datei wurde hinzugefügt.

Klicken Sie im Projektfenster mit der rechten Maustaste auf eine Datei oder einen Projektknoten, um das Kontextmenü mit Optionen zu öffnen, die für die Verwaltung von Projekten mit TFS oder SVN spezifisch sind.



Option

Beschreibung

Offen

Öffnet die ausgewählte .xaml-Datei im Designer-Panel im schreibgeschützten Modus, wenn sie nicht zum Bearbeiten aus dem TFS/SVN-Repository ausgecheckt wurde.

Umbenennen

Ermöglicht das Umbenennen der ausgewählten Datei oder des ausgewählten Ordners und öffnet das Fenster Element umbenennen. Beim Einchecken der umbenannten Datei .xaml muss auch die zuvor geänderte Version eingecheckt werden.

Löschen

Löscht nur das ausgewählte Element von Ihrem lokalen Computer. Die neueste Check-In Version der Datei ist weiterhin im TFS/SVN-Repository verfügbar.

Für die Eingabe auschecken

Markiert die ausgewählte Datei oder den ausgewählten Ordner als für die Bearbeitung gesperrt. Wenn Sie eine Datei auschecken, wird sie auf dem Server gesperrt, sodass sie niemand anders sie bearbeiten kann.

Bearbeitung abschließen

Checkt die project.json-Datei zusammen mit Änderungen und einer Commit-Nachricht in das Repository ein.

Hinzufügen

Lädt das ausgewählte Element auf den TFS/SVN-Server hoch. Diese Option ist nicht verfügbar, wenn das Objekt zuvor auf den Server hochgeladen wurde.

Neueste Version abrufen

Lädt die neueste Version des ausgewählten Elements vom TFS/SVN-Repository herunter.

Änderungen anzeigen (Show Changes)

Öffnet die Datei-Diff (File Diff) zum Vergleichen der Änderungen zwischen der versionierten und der lokal zugeordneten Datei.

Check-In

Zeigt das Fenster Check In Changes und ermöglicht Ihnen einen Upload des ausgewählten Objekts als neueste Version auf den Server. Die Datei .xaml muss vor dem Hochladen gespeichert werden. Nach dem Einchecken wird die Datei in Studio schreibgeschützt.

Rückgängig machen

Zeigt das Fenster Anstehende Änderungen rückgängig machen (Undo Pending Changes) an und ermöglicht es Ihnen, entweder die geänderten Dateien in den früheren bzw. versionslosen Status zurückzuführen oder Dateien abzurufen, die aus dem lokalen Computer gelöscht wurden.

Änderungen können nach dem Einchecken der Datei nicht mehr rückgängig gemacht werden.

Ausführen (Run)

Führt den ausgewählten Workflow aus, auch wenn dieser nicht ausgecheckt oder zum Repository hinzugefügt wurde.

Als Haupt festlegen (Set as Main)

Legt die ausgewählte .xaml-Datei im Projekt als Haupt (Main) fest. Die erste erstellte .xaml wird standardmäßig als Haupt (Main) definiert.

Repository-URL kopieren

Kopiert die Repository-URL des Projekts in die Zwischenablage.

Anpassen der Projekteinstellungen

Für jedes Automationsprojekt, an dem Sie arbeiten, kann ein individueller Einstellungssatz festgelegt werden. Diese Einstellungen stehen im Fenster Projekteinstellungen (Project Settings) zur Verfügung, das durch Anklicken von im Panel Projekt (Project) geöffnet werden kann.



Feldbeschreibung für das Fenster „Einstellungen“

In der folgenden Tabelle werden die Projekteinstellungen für Prozess-, Testautomatisierungs- und Vorlagenprojekte beschrieben. Informationen zu den für Bibliotheken verfügbaren Einstellungen finden Sie unter Über Bibliotheken.

Feld

Beschreibung

Name

Ändern Sie den Namen des Projekts. Solche Namen können Leerzeichen enthalten. Beachten Sie beim Benennen von Projekten, dass Leerzeichen zum Zeitpunkt der Veröffentlichung entfernt werden. Dieses Feld akzeptiert bis zu 128 Zeichen.

Beschreibung

Ändern Sie die Projektbeschreibung. Dieses Feld akzeptiert bis zu 500 Zeichen.

Projekt-Tags

Sie können ein oder mehrere Tags zum Projekt hinzufügen, indem Sie entweder neue erstellen oder bereits im Orchestrator definierte Tags wiederverwenden. Es gibt zwei Arten von Tags: Beschriftungen und Eigenschaften (Schlüssel-Wert-Paare). Tags sind im veröffentlichten Paket enthalten und helfen bei der Beschreibung und Kategorisierung von Projekten. Sie können beispielsweise auf die automatisierte Anwendung (eine Excel-Beschriftung) oder die Abteilung (eine department:accounting-Schlüssel-Wert-Eigenschaft) verweisen.
Wenn Sie mit der Eingabe beginnen, werden mögliche Übereinstimmungen aus bereits definierten Tags vorgeschlagen, und Sie können eines wiederverwenden, indem Sie es aus der Liste der Übereinstimmungen auswählen. Bei einer Eigenschaftsübereinstimmung wird zuerst der Schlüssel gefolgt vom Doppelpunkt : angezeigt. Die zugehörigen Werte werden angezeigt, nachdem Sie den Schlüssel ausgewählt haben.
Um ein neues Tag hinzuzufügen, klicken Sie nach der Eingabe des Namens auf den Eintrag mit dem Pluszeichen neben dem Namen. Trennen Sie Strings mit einem Doppelpunkt :, um Eigenschaften hinzuzufügen. Verwenden Sie keinen Doppelpunkt : bei den Einträgen, um Beschriftungen hinzuzufügen.
Beschriftungen und Schlüssel-Wert-Eigenschaften sind auf 256 Zeichen begrenzt. Tag-Namen dürfen diese Zeichen nicht enthalten: <, >, %, &, \, ?, /, :.

Projekt-Tags können automatisch auf Prozesse im Orchestrator angewendet werden. Weitere Informationen zur Verwendung von Tags finden Sie unter Organisieren von Ressourcen mit Tags im Orchestrator-Handbuch.

Automation Hub-URL

URL einer Automation Hub-Idee, die mit dem Projekt verknüpft ist. Weitere Informationen finden Sie unter Verknüpfen eines Projekts mit einer Idee im Automation Hub.

Paketsymbol

Definieren Sie optional ein benutzerdefiniertes Symbol für das Projekt. Sie können nach einer Datei suchen und diese auswählen, oder Sie geben einen Pfad oder eine öffentliche URL zu einer jpeg-, jpg- oder png-Datei mit einer Größe von maximal 1 MB ein.

Nachdem das Projekt veröffentlicht wurde, wird das Symbol wie folgt angezeigt:

  • Bei Prozessen im Assistant neben dem Prozessnamen, sodass sie in der Liste der Prozesse leichter identifiziert werden können.
  • Für Vorlagen neben der Vorlage in Start (Studio Backstage View) > Vorlagen.
  • Für Bibliotheken neben dem Paket im Fenster Pakete verwalten in Studio.
Hinweis: Das Symbol ist in „Pakete verwalten“ nicht sichtbar, wenn eine lokale Datei für eine Bibliothek verwendet wird, die im Orchestrator oder in einem Feed veröffentlicht wurde, der keine eingebetteten Symbole unterstützt. In diesem Fall geben Sie das Symbol mithilfe einer URL an.

Pause deaktivieren

Aktivieren oder verhindern Sie, dass Benutzer die Ausführung über den UiPath Assistant anhalten. Legen Sie Ja fest, wenn das Anhalten des Prozesses während der Ausführung zu einem Absturz führen würde. Wenn z. B. eine Aktivität in Ihrem Workflow die Timeout-Eigenschaft verwendet, kann das Anhalten der Ausführung dazu führen, dass das Timeout abläuft, wodurch die Ausführung abgebrochen wird.

Beaufsichtigte Automatisierung

Legen Sie Ja fest, um anzugeben, dass das Projekt nur in einem Attended-Kontext ausgeführt werden soll. Verwenden Sie diese Einstellung für Projekte, die UI-Automatisierungsaktivitäten oder andere Aktivitäten enthalten, die eine Benutzerinteraktion erfordern.

Wird im Hintergrund gestartet

Auf Ja festlegen, um das Projekt in einen Hintergrundprozess zu verwandeln und zuzulassen, dass es gleichzeitig mit anderen Prozessen im Hintergrund ausgeführt wird, solange es keine UI-Interaktion verwendet.

Unterstützt Persistenz

Auf Ja festlegen, um das Projekt in einen Orchestrierungsprozess zu verwandeln.

BiB-Optionen

Geben Sie an, ob das Projekt mit Bild in Bild (BiB) getestet wurde und ob es standardmäßig im BiB-Modus starten soll.

  • Für BiB-Verwendung getestet; in BiB starten – Die Automatisierung wurde für die Ausführung im BiB-Modus genehmigt. Wenn sie ausgeführt wird, startet sie standardmäßig im BiB-Modus.
  • Für BiB-Verwendung getestet; standardmäßig nicht in BiB starten – Die Automatisierung wurde für die Ausführung im BiB-Modus genehmigt. Sie wird standardmäßig in der Hauptsitzung oder auf dem Desktop gestartet.
  • Nicht für die BiB-Verwendung getestet – Die Automatisierung wurde nicht für die Ausführung im BiB-Modus genehmigt. Sie wird standardmäßig in der Hauptsitzung oder auf dem Desktop gestartet. Wenn der Benutzer sie im BiB-Modus ausführt, wird er in einem Dialogfeld darüber informiert, dass diese Funktion nicht getestet wurde, und muss dies bestätigen, bevor er fortfahren kann.

BiB-Typ

Wählen Sie aus, wie die Automatisierung von der Benutzersitzung isoliert werden soll, wenn das Projekt im BiB-Modus ausgeführt wird: Neue Sitzung (untergeordnete Sitzung auf der Maschine) oder Neuer Desktop (virtueller Desktop in der Benutzersitzung).

Klicken Sie auf OK und die Änderungen werden im Panel Projekt (Project) und in der Datei project.json sichtbar gemacht.

Lesen Sie auf der Seite Konfigurieren von Aktivitätsprojekteinstellungen, wie Aktivitätseigenschaften auf Projektebene angepasst werden.

Hinweis: Bitte berücksichtigen Sie, dass es sich empfiehlt, im Designer-Panel im Voraus nach unten zu scrollen, wenn Sie eine Vielzahl von Aktivitäten von einer Sequence in eine andere kopieren möchten. Dies ist durch die Begrenzung der Windows Workflow Foundation bedingt.

Entfernen nicht verwendeter Projektressourcen

Unnötige Ressourcen können die Verständlichkeit von Projekten erschweren und die Leistung beeinträchtigen. Um dieses Problem zu vermeiden, entfernen Sie nicht-verwendete Ressourcen aus Ihren Projekten, indem Sie im Studio-Menüband auf Nicht-verwendete entfernen klicken und dann auswählen, was entfernt werden soll:

  • Workflows – Entfernen Sie Workflow-Dateien, auf die im Projekt nicht verwiesen wird.
  • Variablen – Entfernen der Variablen, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Argumente – Entfernen Sie Argumente, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Abhängigkeiten – Entfernen Sie installierte Aktivitätspakete, aus denen keine Aktivitäten im Projekt verwendet werden.
  • Importe – Entfernen Sie importierte Namespaces, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Screenshots – Entfernen Sie informative Screenshots, die in keiner Aktivität im Projekt verwendet werden.

War diese Seite hilfreich?

Hilfe erhalten
RPA lernen – Automatisierungskurse
UiPath Community-Forum
UiPath Logo weiß
Vertrauen und Sicherheit
© 2005-2024 UiPath. All rights reserved.