Studio
2021.10
False
Bannerhintergrundbild
Studio-Benutzerhandbuch
Letzte Aktualisierung 1. März 2024

Über Automatisierungsprojekte

UiPath Studio ermöglicht die Erstellung folgender Projekttypen:

  • Prozess – Entwerfen Sie einen Automatisierungsprozess und veröffentlichen Sie ihn, damit er von Robotern ausgeführt werden kann.
  • Bibliothek – Entwerfen Sie Workflows als wiederverwendbare Komponenten und veröffentlichen Sie das Projekt als Bibliothek, die als Abhängigkeit zu mehreren Prozessen hinzugefügt werden kann. Weitere Informationen finden Sie im Abschnitt Über Bibliotheken.
  • Testautomatisierung – Entwerfen Sie ein Testautomatisierungsprojekt. Weitere Informationen zur Testautomatisierung finden Sie im Abschnitt Test Suite.
  • Vorlage - Entwerfen Sie einen Prozess und veröffentlichen Sie ihn als Vorlage, auf der dann andere Prozesse mit gemeinsamen Eigenschaften basieren können. Weitere Informationen finden Sie unter Projektvorlagen.

Um ein neues leeres Projekt zu erstellen, wechseln Sie zu Start (Studio Backstage-Ansicht) > Starten und wählen Sie den Projekttyp aus, der unter Neues Projekt erstellt werden soll. Alternativ können Sie mit einer der Standardvorlagen beginnen, die unter Neu aus Vorlage verfügbar sind, oder zur Registerkarte Vorlagen wechseln, um nach weiteren Vorlagen aus verschiedenen Quellen zu suchen.



Konfigurieren Sie im neuen Projektfenster für jedes Projekt Folgendes:

  • Geben Sie einen Namen für das neue Projekt (bis zu 128 Zeichen) und eine Beschreibung ein, die zusammenfasst, was Sie mit diesem Automatisierungsprojekt erreichen möchten (bis zu 500 Zeichen).
  • Wählen Sie den Speicherort aus, an dem das Projekt erstellt werden soll. Der Standardspeicherort, an dem Projekte erstellt werden, lautet %USERPROFILE%\Documents\UiPath.
  • Wählen Sie Kompatibilität und Sprache aus.

    Hinweis: Die Kompatibilität und Sprache kann nach dem Erstellen eines Projekts nicht geändert werden.

Standardmäßig enthält der Projektordner die folgenden Dateien und Unterordner:

  • Dateien

    • Main.xaml – Wird standardmäßig erstellt, um Ihren Hauptworkflow zu speichern. Darüber hinaus werden alle anderen Automatisierungs-XAML-Dateien, die Sie dem Projekt hinzufügen, im Projektordner gespeichert. Optional können Sie eine andere Datei als Hauptdatei festlegen. Alle Dateien müssen über die Aktivität Invoke Workflow File mit der Datei verknüpft werden, die als Hauptdatei festgelegt ist, oder mit einer Datei, die als Einstiegspunkt für das Projekt markiert ist. Für Testautomatisierungsprojekte wird standardmäßig eine TestCase.xaml-Datei anstelle von Main.xaml erstellt.
    • project.json – Enthält Informationen über Ihr Automatisierungsprojekt.
  • Unterordner

    • .entities – Enthält Daten über Entitäten, die aus dem Data Service importiert wurden, falls diese im Projekt verwendet werden.
    • .local – Enthält lokal für das Projekt zwischengespeicherte Daten.
      Hinweis: Der Ordner .local ist ausgeblendet. Sie können die Anzeige ausgeblendeter Elemente in den Einstellungen von Windows-Explorer aktivieren.
    • .objects – Enthält Daten im Zusammenhang mit Elementen, die dem Object Repository hinzugefügt wurden, falls diese im Projekt verwendet werden.
    • .screenshots – Enthält informative Screenshots, die in UI-Automatisierungsaktivitäten generiert werden, falls welche im Projekt verwendet werden.
    • .settings – Enthält Aktivitätsprojekteinstellungen, die zur Laufzeit verwendet werden.
    • .templates – Enthält Dateivorlagen, die dem Projekt hinzugefügt wurden.
    • .tmh – Enthält Daten im Zusammenhang mit Testfällen, falls diese im Projekt verwendet werden.
      Hinweis: Projekte, die mit neueren Versionen von Studio erstellt wurden, funktionieren möglicherweise nicht mit älteren Robotern. Lesen Sie mehr über Ab- und Aufwärtskompatibilität.
      Die folgenden Zeichen dürfen in Dateinamen nicht verwendet werden: ", <, >, |, :, *, ?, \, /,;. Diese Zeichen stammen aus Microsoft Windows-Einschränkungen und anderen Sonderzeicheneinschränkungen.

Festlegen der Projektkompatibilität

Wenn Sie ein neues Projekt im Studio-Profil erstellen, wählen Sie die Kompatibilität basierend auf der Umgebung aus, auf der das Projekt ausgeführt wird:

  • Windows – Legacy – Verwendet .NET Framework 4.6.1., die Kompatibilität, die in Versionen vor 2021.10 verwendet wurde. Dies ist die Standardoption.
  • Windows – Verwendet .NET 6 (in Studio 2021.10.6 und höheren Versionen) oder .NET 5 (in Studio 2021.10-Versionen vor 2021.10.6) mit Windows-Unterstützung.
  • Plattformübergreifend – Verwendet .NET 6 (in Studio 2021.10.6 und höheren Versionen) oder .NET 5 (in Studio 2021.10-Versionen vor 2021.10.6) mit plattformübergreifender Unterstützung.

    Wichtig: Windows- und plattformübergreifende Prozesse erfordern Orchestrator 2021.10 und höher zur Ausführung.

Informationen zu den Unterschieden zwischen Kompatibilitäten finden Sie in der folgenden Tabelle.

 

Windows – Legacy

Windows

Plattformübergreifend

Prozessausführung

32-Bit

64-Bit

64-Bit

Unterstützte Plattformen für die Ausführung

Windows (32-Bit und 64-Bit)

Windows (64-Bit)

Windows und Linux (64-Bit)

Prozesse werden beim Veröffentlichen kompiliert

Nein. Veröffentlichte Pakete enthalten die Projektquelldateien.

Ja. Veröffentlichte Pakete enthalten kompilierte DLL-Dateien.

Ja. Veröffentlichte Pakete enthalten kompilierte DLL-Dateien.

Die Designumgebung ist für alle Kompatibilitäten gleich, aber nur die Aktivitätspakete, die die ausgewählte Kompatibilität unterstützen, können über den Paketmanager installiert werden.

Die Kompatibilität jedes Projekts wird rechts neben der Studio-Statusleiste und im Panel Projekt > Abhängigkeiten-Knoten angezeigt. Die Kompatibilität wird auch im Eintrag jedes Projekts in der Liste Zuletzt verwendete öffnen unter Start (Studio Backstage-Ansicht) > Registerkarte Starten angezeigt.

Hinweis: Das Kopieren und Einfügen von Aktivitäten zwischen Projekten mit unterschiedlichen Kompatibilitäten wird nicht unterstützt.

Entwerfen plattformübergreifender Projekte

Plattformübergreifende Projekte ermöglichen es Ihnen, API-basierte Automatisierungen zu erstellen, die unter Windows sowie Unix-ähnlichen Betriebssystemen ausgeführt werden können.

Hinweis: In Version 2021.10 unterstützen plattformübergreifende Projekte die Ausführung nur unter Windows und Linux.

So erstellen Sie Unattended-Projekte mit plattformübergreifender Unterstützung:

  1. Erstellen Sie in Studio ein neues Projekt und wählen Sie die Option plattformübergreifende Kompatibilität aus. Diese Option ist für alle Projekttypen verfügbar.
  2. Entwerfen Sie die Automatisierung. Bitte beachten Sie, dass nicht alle Aktivitätspakete mit plattformübergreifenden Projekten kompatibel sind, sodass im Paketmanager nur eine begrenzte Auswahl an Paketen verfügbar ist. Die Standardabhängigkeiten für ein plattformübergreifendes Projekt sind UiPath.System.Activities und UiPath.WebApi.Activities.
  3. Testen Sie die Automatisierung. Es wird empfohlen, Automatisierungen auf den Maschinen zu testen, auf denen sie mit Remote-Debugging ausgeführt werden, das sowohl mit Windows- als auch mit Linux-Robotern funktioniert.
  4. Veröffentlichen Sie das Projekt nach dem Testen der Automatisierung im Orchestrator. Das Verfahren zum Ausführen von Unattended-Aufträgen ist für Windows und Linux identisch.

Einstellung der Projektsprache

Wenn Sie ein neues Projekt im Studio-Profil erstellen, können Sie auswählen, welche Sprache für Ausdrücke verwendet werden soll – entweder VB oder C#. VB ist die standardmäßig ausgewählte Sprache, aber Sie können C# als Standardsprache für neue Projekte festlegen, indem Sie zu Start (Studio-Backstage-Ansicht) > Einstellungen > Design gehen. Bei Projekten, die im StudioX-Profil erstellt werden, wird die VB.NET-Sprache für Ausdrücke verwendet.

Die Verwendung von VB- und C#-Ausdrücken im selben Projekt wird nicht unterstützt. Ebenso wenig wird die Verwendung von VB-Ausdrücken in C#-Workflows unterstützt und umgekehrt. Stellen Sie beim Kopieren und Einfügen der Aktivitäten von anderen Projekten und Aufrufen oder Importieren von Workflows sicher, dass sie dieselbe Sprache wie Ihr Projekt verwenden.

Sie können C#-Bibliotheken als Abhängigkeiten in VB-Projekten installieren und umgekehrt. Auf Standardwerte, die für Argumente im Bibliotheksprojekt unter Verwendung sprachspezifischer Ausdrücke definiert sind, kann jedoch nicht vom Projekt aus zugegriffen werden, in dem die Bibliothek installiert ist.

Einschränkungen von C#

  • Die aktuelle C#-Implementierung basiert auf dem C#-Compiler, der die C#-Version 5 verwendet, daher ist der Zugriff auf neuere Funktionen wie Coalescing-Zuweisung, Null-Bedingungsoperator, Null-Coalescing-Operator, String-Interpolation und andere nur eingeschränkt möglich.
  • Projekte, die Ausdrücke mit Inkrementen enthalten, sind ungültig.
  • Ausdrücke, die den Operator nameof() enthalten, werden als ungültig markiert und sind mit der aktuellen Implementierung von C# nicht erlaubt.
  • Ausdrücke, die Aufrufe von Methoden mit optionalen Argumenten enthalten, müssen Werte für die optionalen Argumente enthalten.
  • Die Entwurfszeit- und Laufzeitleistung von C#-Projekten ist im Vergleich zu VB.NET niedriger. Wenn Laufzeitleistung ausschlaggebend ist, empfehlen wir die Verwendung VB.NET anstelle von C#.

Einstellen der Projektversion

Semantikversionen

Das Schema der Semantikversionen hat das Format Major.Minor.Patch[-Suffix], wobei:

  • Haupt (Major) die Hauptversion ist.
  • Neben (Minor) die Nebenversion ist.
  • Patch (Patch) die Patch-Version ist.
  • Suffix (Suffix) (optional) ein Bindestrich gefolgt von einer Reihe durch Punkt getrennter Identifier unmittelbar hinter der Patch-Version ist. Damit wird eine frühere Version bezeichnet.

Identifier dürfen nur aus alphanumerischen ASCII-Zeichen und Bindestrich bestehen und nicht leer sein. Numerische Identifier dürfen nicht mit Nullen beginnen. Außerdem kann das Aufbauen von Metadaten durch Anhängen eines Plus-Zeichens und einer Reihe von durch Punkte getrennten Identifiern gekennzeichnet sein, die unmittelbar auf den Patch oder die frühere Version folgen, zum Beispiel 1.0.0-alpha+1.

Beim Erstellen eines neuen Prozesses oder einer Bibliothek ist das Standardversionsschema Semantik. Es kann im Fenster Veröffentlichen (Publish) geändert werden. Dazu hängt man einfach eine weitere Ziffer an die Versionsnummer an. Die Semantikversion des Projekts kann ebenfalls über die project.json-Datei geändert werden. Die Patch-Nummer 0 wird automatisch an Projekte mit der Versionsnummer major.minor angehängt.

Veraltete Versionen

Die für das Projekt generierte veraltete Versionsnummer hat das Format M.m.bbbb.rrrrr, wobei:

  • M ist die Hauptversion.
  • m ist die Nebenversion.
  • bbbb ist die Buildversion.
  • rrrrr die Revisionversion ist.
Die Haupt- und Nebenversionen in der Datei project.json bearbeitet werden können, während die Build- und Revisionsversionen gemäß einem Algorithmus generiert werden. Der Build-Wert ist die Anzahl der seit dem 01.01.2000 vergangenen Tage. Der Revisionswert die Anzahl der Sekunden ist, die am aktuellen Tag bis zum Moment der Freigabe vergangen sind. Das Ergebnis wird durch 2 dividiert, sodass die maximale Revisionsanzahl nicht höher als 65535 ist.

Die vorgeschlagene Versionsnummer im Fenster Veröffentlichen (Publish) basierend auf dem vorherigen Versionsschema des Projekts generiert wird, während das aktuelle Datum und der Zeitstempel für Projekte berücksichtigt werden, die das 4-stellige Versionsschema verwenden.

Verwalten von Projekten



Im Panel Projekt (Project)können Sie den Inhalt des aktuellen Projekts anzeigen, Ordner hinzufügen, den Speicherort der Datei öffnen, Abhängigkeiten verwalten und Prozesseinstellungen anpassen.



Fügen Sie aus dem Datei-Explorer kopierte Dateien direkt in das Projekt-Panel ein. Dieselbe Aktion kann per Drag & Drop für eine oder mehrere Dateien durchgeführt werden, einschließlich .xaml-Workflows. Sie können auch die Tastenkombinationen Strg + C und Strg + V oder die Optionen Kopieren und Einfügen im Kontextmenü verwenden, um Dateien oder Ordner innerhalb des Panels zu kopieren und zu duplizieren.

Option

Beschreibung

Alle erweitern (Expand All)

Erweitert alle Knoten in den Automationsprojekten.

Alle reduzieren (Collapse All)

Reduziert alle Knoten in den Automationsprojekten.

Aktualisieren

Aktualisiert das Projekt.

Alle Dateien anzeigen

Zeigt alle Dateien an, die zum Automationsprojekt gehören, einschließlich der Datei project.json.

Datei-Explorer

Öffnet den Speicherort des Projekts auf dem Computer.

Projekteinstellungen

Öffnet das Fenster Projekteinstellungen (Project Settings) für Prozesse und Bibliotheken.

Kontextmenü für Projekte

Klicken Sie mit der rechten Maustaste im Projektfenster auf eine beliebige Stelle, um das Kontextmenü mit den in der folgenden Tabelle beschriebenen Optionen zu öffnen. Die verfügbare Gruppe von Optionen hängt von der mit der rechten Maustaste angeklickten Stelle im Fenster, vom Projekttyp sowie davon ab, ob das Projekt zu Source Control hinzugefügt wird.

Option

Beschreibung

Projektordner öffnen (Open Project Folder)

Öffnet den lokalen Ordner mit dem Projekt.

Projekteinstellungen

Öffnet das Fenster Projekteinstellungen (Project Settings) zum Anpassen der Projekteinstellungen.

Hinzufügen

Öffnet eine Liste von Elementen, die dem Projekt hinzugefügt werden können: Ordner, Sequence, Flowchart, State Machine, globaler Handler, Workflow oder, in Testautomatisierungsprojekten, Testfall.

Workflows importieren

Importiert .xaml Dateien in das Projekt und fügt zum Dateinamen Importiert (Imported) hinzu, wenn dieser mit dem Namen der Hauptdatei übereinstimmt.

Dateien importieren

Öffnet das Fenster „Datei-Explorer“, um verschiedene Dateien in Ihr Projekt zu importieren.

Zu Source Control hinzufügen

Fügt das aktuelle Projekt anhand der Option GIT-Initialisierung, In GIT kopieren, Zu TFS hinzufügen oder Zu SVN hinzufügen der Source Control hinzu. Diese Option ist nur sichtbar, wenn mit der rechten Maustaste auf den Projektknoten geklickt wird.

Wenn ein Projekt zur Quellcodeverwaltung hinzugefügt wird, stehen zusätzliche Optionen im Kontextmenü zur Verfügung. Sehen Sie sich die Optionen für GIT und die Optionen für SVN und TFS an.

Offen

Öffnet die ausgewählten Dateien mit dem Standardprogramm.

Dateispeicherort öffnen

Öffnet den lokalen Ordner mit der Datei.

Umbenennen

Ermöglicht das Umbenennen der ausgewählten Datei oder des ausgewählten Ordners und öffnet das Fenster Element umbenennen. Das Element wird in allen Vorkommen umbenannt.

Kopieren

Kopiert die ausgewählten Dateien oder Ordner in die Zwischenablage. Sie können sie dann im Projektfenster oder im Windows Datei-Explorer einfügen.

Einfügen

Fügt Dateien oder Ordner ein, die in die Zwischenablage kopiert wurden.

Löschen

Löscht nur das ausgewählte Element von Ihrem lokalen Computer.

Zum Vergleichen auswählen (Select for Compare)

Wählt die aktuelle Datei zum Vergleichen aus.

Mit ausgewählten vergleichen (Compare with Selected)

Vergleicht die aktuelle Datei mit der zuvor ausgewählten Datei anhand von Dateien vergleichen (Compare Files).

Verweise suchen

Sucht alle Verweise auf die Datei im Projekt. Die Ergebnisse werden im Bereich Verweise suchen angezeigt.

Datei debuggen

Debuggt die ausgewählte .xaml-Datei.

Als Haupt festlegen (Set as Main)

Legt die ausgewählte .xaml-Datei in der Projektdefinition als Hauptinstanz fest, d. h., die Projektausführung beginnt mit dieser Datei. Es kann nur eine Hauptprojektdatei geben. Der Name des als Hauptinstanz festgelegten Dateisatzes wird im Projektfenster fett angezeigt.

Eigenschaften

Öffnet das Bibliotheksfenster Eigenschaften (Properties), um einen Tooltipp und einen Link zur Hilfe hinzuzufügen.

Als globale Bearbeitung festlegen

Legt die .xaml-Datei im Projekt als (Global Exception Handler für das Projekt fest. Dies gilt für einen Workflow bei jedem Projekt/Prozess.

Bearbeitung entfernen

Entfernt das Tag Global Exception Handler aus der .xaml-Datei.

Einstiegspunkt aktivieren

Markiert die ausgewählte Workflowdatei als einen Einstiegspunkt für den Prozess, sodass sie als der Workflow ausgewählt werden kann, der zuerst ausgeführt werden soll, wenn die Aktivitäten Invoke Process und Run Parallel Process in anderen Prozessen ausgeführt werden, oder wenn ein Auftrag vom Orchestrator aus ausgeführt wird.

Hinweis:
  • Wenn eine Datei als Einstiegspunkt markiert ist, wird auf dem Symbol neben dem Dateinamen docs image ein Pfeil angezeigt.
  • Wird eine beim Veröffentlichen ignorierte Datei als Einstiegspunkt aktiviert, wird sie veröffentlichbar.
  • Diese Option ist für Testfalldateien nicht verfügbar.
  • Diese Option ist in Bibliotheksprojekten nicht verfügbar.

Einstiegspunkt deaktivieren

Markiert die ausgewählte Workflowdatei nicht mehr als Einstiegspunkt für den Prozess. Diese Option ist für die Workflowdatei, die als Hauptdatei festgelegt ist, nicht verfügbar.

Als Vorlage extrahieren

Speichert den ausgewählten Workflow oder Testfall als Vorlage, auf der Sie dann andere Dateien im Projekt aufbauen können. Mithilfe einer Dateivorlage können Sie Zeit sparen, wenn Sie mehrere Dateien mit derselben Struktur erstellen müssen. Wenn Sie einen neuen Workflow oder Testfall hinzufügen, haben Sie die Möglichkeit, ihn auf einer beliebigen Vorlage desselben Typs aufzubauen, die im Projektordner Vorlagen vorhanden ist.

Bei Veröffentlichung ignorieren/Als veröffentlichbar festlegen

Markiert eine oder mehrere ausgewählte Dateien als von der Veröffentlichung ausgeschlossen oder veröffentlichbar.

Hinweis:
  • Wenn eine Datei bei der Veröffentlichung ignoriert wird, wird das Symbol neben dem Dateinamen ausgegraut docs image.
  • Das Ignorieren einer als Einstiegspunkt markierten Datei bei der Veröffentlichung deaktiviert den Einstiegspunkt.
  • Diese Optionen sind nicht für Workflowdateien in Bibliotheksprojekten verfügbar.
  • In Projekten, in denen XAML-Dateien bei der Veröffentlichung kompiliert werden, werden Workflow- und Testfalldateien, die von der Veröffentlichung ausgeschlossen sind, nicht kompiliert.

Als privat festlegen/Als öffentlich festlegen

Markiert eine oder mehrere ausgewählte Dateien in einem Bibliotheksprojekt als privat oder öffentlich. Eine private Workflowdatei ist im veröffentlichten Paket enthalten, aber es wird keine wiederverwendbare Komponente erstellt und im Panel Aktivitäten in Projekten zur Verfügung gestellt, in denen die Bibliothek als Abhängigkeit installiert wird.

Hinweis:
  • Wenn eine Datei als privat markiert wird, dann wird das Symbol neben dem Dateinamen ausgegraut docs image.
  • Diese Optionen stehen nicht für Testfalldateien zur Verfügung.

Testfall erstellen

Erstellt einen Testfall, der die ausgewählte Workflowdatei aufruft.

In Testfall konvertieren/In Workflow konvertieren

Konvertiert die ausgewählten Workflows in Testfälle oder die ausgewählten Testfälle in Workflows.

Testfälle importieren

Importiert Testfälle als Entwurfstestfälle in das Projekt.

Testdaten hinzufügen

Öffnet das Fenster Datenvariantenquelle importieren, in dem Sie dem Projekt Testdaten hinzufügen können. Diese Option steht nur für Testfälle zur Verfügung.

Mit Test Manager verknüpfen

Öffnet das Fenster Mit Test Manager verknüpfen, in dem Sie die ausgewählten Testfälle mit dem Test Manager verknüpfen können.

Testfälle ausführen/Testfälle debuggen

Führt mehrere ausgewählte Testfälle aus oder debuggt sie.

Kontextmenüoptionen für GIT

In Projekten, die GIT-Repositorys hinzugefügt werden, wird neben jeder Datei im Projektfenster ein Symbol angezeigt, das den Dateistatus angibt:

Die Datei ist mit dem Repository synchronisiert.

Die Datei wurde geändert.

Die Datei wurde hinzugefügt.

Die Datei wurde entfernt.

Klicken Sie mit der rechten Maustaste auf eine Datei oder einen Projektknoten im Panel Projekt, um das GIT-spezifische Kontextmenü für Verwalten von Projekten mit GIT zu öffnen.



Option

Beschreibung

Commit

Übergibt aktuelle Änderungen an das lokale GIT-Repository.

Verschieben (Push)

Verschiebt die aktuelle Version auf das Remote-Repository.

Ziehen (Pull (rebase))

Zieht Remote-Dateien und stellt eine neue Basis für die aktuelle Verzweigung her.

Verzweigungen verwalten (Manage Branches)

Öffnet das Fenster GIT mit den Optionen zum Verwalten aktuell hinzugefügter Verzweigungen.

Änderungen anzeigen (Show Changes)

Öffnet das Fenster Datei-Diff (File Diff) zum Vergleichen der Änderungen zwischen der lokalen Version und der Remote-Version der Datei.

Verlauf anzeigen (Show History)

Öffnet das Fenster Verlauf anzeigen (Show History) zum Vergleichen von zwei Versionen derselben Datei.

Rückgängig machen

Öffnet das Fenster Anstehende Änderungen rückgängig machen (Undo Pending Changes), wenn die Datei nicht übergeben oder in das Remote-Repository verschoben wurde.

Repository-URL kopieren

Kopiert die Repository-URL des Projekts in die Zwischenablage.

Kontextmenüoptionen für SVN und TFS

In Projekten, die GIT-Repositorys hinzugefügt werden, wird neben jeder Datei im Panel Projekt ein Symbol angezeigt, das den Dateistatus angibt:

Die Datei ist nicht zur Bearbeitung ausgecheckt.

Die Datei wurde zur Bearbeitung ausgecheckt.

Die Datei wurde bearbeitet.

Die Datei wurde hinzugefügt.

Klicken Sie im Projektfenster mit der rechten Maustaste auf eine Datei oder einen Projektknoten, um das Kontextmenü mit Optionen zu öffnen, die für die Verwaltung von Projekten mit TFS oder SVN spezifisch sind.



Option

Beschreibung

Offen

Öffnet die ausgewählte .xaml-Datei im Designer-Panel im schreibgeschützten Modus, wenn sie nicht zum Bearbeiten aus dem TFS/SVN-Repository ausgecheckt wurde.

Umbenennen

Ermöglicht das Umbenennen der ausgewählten Datei oder des ausgewählten Ordners und öffnet das Fenster Element umbenennen. Beim Einchecken der umbenannten Datei .xaml muss auch die zuvor geänderte Version eingecheckt werden.

Löschen

Löscht nur das ausgewählte Element von Ihrem lokalen Computer. Die neueste Check-In Version der Datei ist weiterhin im TFS/SVN-Repository verfügbar.

Für die Eingabe auschecken

Markiert die ausgewählte Datei oder den ausgewählten Ordner als für die Bearbeitung gesperrt. Wenn Sie eine Datei auschecken, wird sie auf dem Server gesperrt, sodass sie niemand anders sie bearbeiten kann.

Bearbeitung abschließen

Checkt die project.json-Datei zusammen mit Änderungen und einer Commit-Nachricht in das Repository ein.

Hinzufügen

Lädt das ausgewählte Element auf den TFS/SVN-Server hoch. Diese Option ist nicht verfügbar, wenn das Objekt zuvor auf den Server hochgeladen wurde.

Neueste Version abrufen

Lädt die neueste Version des ausgewählten Elements vom TFS/SVN-Repository herunter.

Änderungen anzeigen (Show Changes)

Öffnet die Datei-Diff (File Diff) zum Vergleichen der Änderungen zwischen der versionierten und der lokal zugeordneten Datei.

Check-In

Zeigt das Fenster Check In Changes und ermöglicht Ihnen einen Upload des ausgewählten Objekts als neueste Version auf den Server. Die Datei .xaml muss vor dem Hochladen gespeichert werden. Nach dem Einchecken wird die Datei in Studio schreibgeschützt.

Rückgängig machen

Zeigt das Fenster Anstehende Änderungen rückgängig machen (Undo Pending Changes) an und ermöglicht es Ihnen, entweder die geänderten Dateien in den früheren bzw. versionslosen Status zurückzuführen oder Dateien abzurufen, die aus dem lokalen Computer gelöscht wurden.

Änderungen können nach dem Einchecken der Datei nicht mehr rückgängig gemacht werden.

Ausführen (Run)

Führt den ausgewählten Workflow aus, auch wenn dieser nicht ausgecheckt oder zum Repository hinzugefügt wurde.

Als Haupt festlegen (Set as Main)

Legt die ausgewählte .xaml-Datei im Projekt als Haupt (Main) fest. Die erste erstellte .xaml wird standardmäßig als Haupt (Main) definiert.

Repository-URL kopieren

Kopiert die Repository-URL des Projekts in die Zwischenablage.

Anpassen der Projekteinstellungen

Für jedes Automationsprojekt, an dem Sie arbeiten, kann ein individueller Einstellungssatz festgelegt werden. Diese Einstellungen stehen im Fenster Projekteinstellungen (Project Settings) zur Verfügung, das durch Anklicken von im Panel Projekt (Project) geöffnet werden kann.



Feldbeschreibung für das Fenster „Einstellungen“

In der folgenden Tabelle werden die Projekteinstellungen für Prozess-, Testautomatisierungs- und Vorlagenprojekte beschrieben. Informationen zu den für Bibliotheken verfügbaren Einstellungen finden Sie unter Über Bibliotheken.

Feld

Beschreibung

Name

Ändern Sie den Namen des Projekts. Solche Namen können Leerzeichen enthalten. Beachten Sie beim Benennen von Projekten, dass Leerzeichen zum Zeitpunkt der Veröffentlichung entfernt werden. Dieses Feld akzeptiert bis zu 128 Zeichen.

Beschreibung

Ändern Sie die Projektbeschreibung. Dieses Feld akzeptiert bis zu 500 Zeichen.

Automation Hub-URL

URL einer Automation Hub-Idee, die mit dem Projekt verknüpft ist. Weitere Informationen finden Sie unter Verknüpfen eines Projekts mit einer Idee im Automation Hub.

Paketsymbol

Definieren Sie optional ein benutzerdefiniertes Symbol für das Projekt. Sie können nach einer Datei suchen und diese auswählen, oder Sie geben einen Pfad oder eine öffentliche URL zu einer ico-, jpeg-, jpg-, oder png-Datei mit einer Größe von maximal 1 MB ein.

Nachdem das Projekt veröffentlicht wurde, wird das Symbol wie folgt angezeigt:

  • Bei Prozessen im Assistant neben dem Prozessnamen, sodass sie in der Liste der Prozesse leichter identifiziert werden können.
  • Für Vorlagen neben der Vorlage in Start (Studio Backstage View) > Vorlagen.
  • Für Bibliotheken neben dem Paket im Fenster Pakete verwalten in Studio.
Hinweis: Das Symbol ist in „Pakete verwalten“ nicht sichtbar, wenn eine lokale Datei für eine Bibliothek verwendet wird, die im Orchestrator oder in einem Feed veröffentlicht wurde, der keine eingebetteten Symbole unterstützt. In diesem Fall geben Sie das Symbol mithilfe einer URL an.

Pause deaktivieren

Aktivieren oder verhindern Sie, dass Benutzer die Ausführung über den UiPath Assistant anhalten. Legen Sie Ja fest, wenn das Anhalten des Prozesses während der Ausführung zu einem Absturz führen würde. Wenn z. B. eine Aktivität in Ihrem Workflow die Timeout-Eigenschaft verwendet, kann das Anhalten der Ausführung dazu führen, dass das Timeout abläuft, wodurch die Ausführung abgebrochen wird.

Beaufsichtigte Automatisierung

Legen Sie Ja fest, um anzugeben, dass das Projekt nur in einem Attended-Kontext ausgeführt werden soll. Verwenden Sie diese Einstellung für Projekte, die UI-Automatisierungsaktivitäten oder andere Aktivitäten enthalten, die eine Benutzerinteraktion erfordern.

Wird im Hintergrund gestartet

Auf Ja festlegen, um das Projekt in einen Hintergrundprozess zu verwandeln und zuzulassen, dass es gleichzeitig mit anderen Prozessen im Hintergrund ausgeführt wird, solange es keine UI-Interaktion verwendet.

Unterstützt Persistenz

Auf Ja festlegen, um das Projekt in einen Orchestrierungsprozess zu verwandeln.

BiB-fähig

Auf Ja setzen, um anzugeben, dass das Projekt für Bild in Bild getestet wurde. Wenn auf Nein festgelegt wurde, während der Prozess in BiB vom Assistant durchgeführt wird, informiert ein Dialogfeld den Benutzer, dass nicht mit dieser Funktion getestet wurde, und fordert Sie zur Bestätigung auf, bevor fortgefahren wird.

In BiB starten

Legen Sie Ja fest, um anzugeben, dass der Prozess standardmäßig mit der Funktion „Bild in Bild“ ausgeführt werden soll.

Moderne Designumgebung

Legen Sie Ja fest , um eine moderne Arbeitsumgebung für UI-Automatisierung zu aktivieren, einschließlich neuer und verbesserter Aktivitäten, Recorder und Assistenten sowie des Objekt-Repositorys.

Diese Einstellung aktiviert/deaktiviert auch eine moderne Designumgebung für Excel, wenn die Option Excel-Designumgebung auf UseGlobalSetting in den Projekteinstellungen der Excel-Aktivitäten festgelegt ist.

Klicken Sie auf OK und die Änderungen werden im Panel Projekt (Project) und in der Datei project.json sichtbar gemacht.

Lesen Sie auf der Seite Konfigurieren von Aktivitätsprojekteinstellungen, wie Aktivitätseigenschaften auf Projektebene angepasst werden.

Hinweis: Bitte berücksichtigen Sie, dass es sich empfiehlt, im Designer-Panel im Voraus nach unten zu scrollen, wenn Sie eine Vielzahl von Aktivitäten von einer Sequence in eine andere kopieren möchten. Dies ist durch die Begrenzung der Windows Workflow Foundation bedingt.

Entfernen nicht verwendeter Projektressourcen

Unnötige Ressourcen können die Verständlichkeit von Projekten erschweren und die Leistung beeinträchtigen. Um dieses Problem zu vermeiden, entfernen Sie nicht-verwendete Ressourcen aus Ihren Projekten, indem Sie im Studio-Menüband auf Nicht-verwendete entfernen klicken und dann auswählen, was entfernt werden soll:

  • Workflows – Entfernen Sie Workflow-Dateien, auf die im Projekt nicht verwiesen wird.
  • Variablen – Entfernen der Variablen, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Argumente – Entfernen Sie Argumente, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Abhängigkeiten – Entfernen Sie installierte Aktivitätspakete, aus denen keine Aktivitäten im Projekt verwendet werden.
  • Importe – Entfernen Sie importierte Namespaces, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Screenshots – Entfernen Sie informative Screenshots, die in keiner Aktivität im Projekt verwendet werden.

Über die Project.Json-Datei

Project.json ist eine automatisch generierte Datei, die für jede .xaml-Datei erstellt wird, die im Projektordner als Main markiert ist.

Die Datei enthält verschiedene Informationen, einschließlich Projektabhängigkeiten oder in Bibliotheken geladene Webdienste. Um weitere Informationen über Webdienste in Bibliotheken zu erhalten, gehen Sie auf die Seite Webdienste in Bibliotheken laden.

Hinweis:

Manuelles Bearbeiten der project.json-Datei sollte nur für Fehlersuchszenarien versucht werden, da es schwerwiegende Konsequenzen haben und zum Verlust der Unterstützung führen kann.

Ab Version 2018.2 sollten Sie beim Ausführen Ihres Projekts vom Client UiRobot.exe (Befehlszeile) eine project.json-Datei angeben.
Die Parameter, die in der Datei Project.json enthalten sind, werden in der folgenden Tabelle beschrieben.

Parameter

Beschreibung

name

Der Titel des Automatisierungsprojekts. Er wird in Studio bei der Erstellung eines neuen Projekts bzw. einer neuen Bibliothek angegeben.

description

Die Beschreibung des Projekts. Es wird in Studio im Feld „Description“ bereitgestellt, wenn ein neues Projekt erstellt wird.

main

Der Einstiegspunkt des Automatisierungsprojekts. Er besteht aus einer .xaml-Datei. Der Standardname ist „Main.xaml“. Er wird sowohl als Titel des Panels Designer als auch im Panel Eigenschaften in Studio angezeigt. Wenn Sie zuerst ein anderes Projekt ausführen möchten, ändern Sie den Wert dieses Parameters in den Namen der zu verarbeitenden .xaml-Datei.
Hinweis: Wenn Ihr Automatisierungsprojekt mehrere Dateien enthält, sollte jede von ihnen über Workflow-Datei aufrufenmit Main.xaml verknüpft werden. Dies ist besonders nützlich, wenn das Projekt an Orchestrator veröffentlicht und an einen Roboter gesendet wird, da der Roboter nur die in diesem Parameter angegebene Datei ausführt.

dependencies

Die Aktivitätspakete, die zum Erstellen des Automatisierungsprojekts und ihrer Versionen verwendet werden. Die Liste wird jedes Mal aktualisiert, wenn eine Abhängigkeit hinzugefügt oder aus dem Projekt entfernt wird oder wenn sich eine Paketversion ändert.

Hinweis:Versionsnummern bestehen aus den folgenden Teilen (in dieser Reihenfolge): major, minor, build und revision. Der Build-Wert ist die Anzahl der seit dem 01.01.2000 verstrichenen Tage. Der Revisionswert ist die Anzahl der Sekunden, die am Tag der Veröffentlichung verstrichen sind, beginnend mit 5:00 Uhr GMT.

webServices

  • namespace - Der Name des Dienstes, der im Fenster Neuen Dienst hinzufügen (Add new service) für Bibliotheken angegeben wird.
  • serviceDocument: Der Pfad zur .xml- oder .json-Datei, die Metadaten für den SOAP- oder Swagger-Dienst enthält. Die Datei wird beim Reparieren des Dienstes verwendet und sollte dieselbe Version wie das Projekt haben.
  • webDocumentUri - Der Dateipfad oder der Link zur Swagger- oder SOAP-Ressource (die beim Erstellen des Dienstes im Fenster Neuen Service hinzufügen (Add new service) zur Verfügung gestellt wurde).
  • uniqueReference - eine Referenz, die für die Dienstversion benötigt wird.

entitiesStores

  • serviceDocument – Der Pfad zur Datei der lokalen Entitäten.
  • tenantName – Der Mandant, in dem sich der Data Service befindet.
  • namespace – Der Namespace, unter dem die Entitäten importiert werden (der Projekt-Namespace).
  • uniqueReference - eine Referenz, die für die Dienstversion benötigt wird.

schemaVersion

Die Version der Datei project.json.

studioVersion

Die Version von Studio, mit der das Automatisierungsprojekt erstellt wurde.

projectVersion

Die Version, die beim Veröffentlichen dieses Projekts in einem Feed verwendet wird. Stellt diejenige dar, die im Fenster Veröffentlichen (Publish) angegeben ist.

runtimeOptions

  • isPausable – Gibt an, ob die Pause für den Prozess aktiviert ist.
  • requiresUserInteraction – Gibt an, ob es sich um einen Hintergrundsprozess handelt.
  • supportsPersistence – Gibt an, ob es sich um einen Prozess mit langer Ausführungszeit handelt
  • excludedLoggedData – Enthält Schlüsselwörter, die zum Namen einer Aktivität hinzugefügt werden können, um zu verhindern, dass Variablen- und Argumentwerte auf Verbose-Ebene protokolliert werden. Dies kann auch erreicht werden, indem Sie das Kontrollkästchen „Privat“ einer beliebigen Aktivität aktivieren. Hier erfahren Sie mehr über den Schutz sensibler Informationen.
  • readyForPiP – Gibt an, ob der Prozess als BiB-fähig markiert ist.
  • startsInPiP – Gibt an, ob der Prozess so konfiguriert ist, dass er in BiB gestartet wird.

designOptions

  • projectProfile – Das Studio-Profil, das beim Erstellen des Projekts verwendet wurde, entweder Business (StudioX) oder Development.
  • outputType Zeigt den Projekttyp an, entweder Prozess, Bibliothek oder Tests.
  • libraryOptions

    • includeOriginalXaml – Auswahl, ob die ursprünglichen Workflow-Dateien in die resultierende .nupkg-Datei aufgenommen werden sollen.
    • privateWorkflows – Der vollständige Name privater .xaml-Dateien in der Bibliothek.
  • processOptions

    • ignoredFiles – Liste der RPA-Workflowdateien, die beim Veröffentlichen ignoriert werden.
  • fileInfoCollection – Enthält die folgenden Informationen für jede Testfalldatei im Prozess: editingStatus (Publishable oder InProgress), testCaseId und fileName.
  • modernBehavior – Gibt an, ob der Prozess für die Verwendung der modernen Designumgebung konfiguriert ist.

arguments

Enthält die folgenden Informationen für jedes input- und output-Argument, das in der Workflowdatei definiert ist, die als Hauptdatei festgelegt ist: name, type, ob sie required ist und ob es sich um einen Standardwert (hasDefault) handelt.
Hinweis: Argumentinformationen werden der Datei im .nupkg-Paket nur nach der Veröffentlichung hinzugefügt.

expressionLanguage

Die für den Prozess festgelegte Programmiersprache (VisualBasic oder CSharp).

entryPoints

Enthält die folgenden Informationen für jede Datei, die als Einstiegspunkt für den Prozess filePath markiert ist,
uniqueId. und die folgenden Informationen für jedes input- und output-Argument in der Datei: name, type, ob sie required ist und ob sie einen Standardwert (hasDefault) hat.
Hinweis: Argumentinformationen werden der Datei im .nupkg-Paket nur nach der Veröffentlichung hinzugefügt.

isTemplate

Gibt an, ob es sich bei dem Projekt um eine Vorlage handelt.

templateProjectData

Enthält die folgenden Informationen für Vorlagenprojekte:

  • defaultProjectDescription – Die Standardprojektbeschreibung für Prozesse, die auf der Vorlage basieren.
  • defaultProjectName – Der Standardprojektname für Prozesse, die auf der Vorlage basieren.

targetFramework

Das für das Projekt festgelegte Zielframework (Legacy, Windows oder Portabel).

Im Folgenden finden Sie ein Beispiel für den Inhalt einer project.json-Datei, die in einem in Studio veröffentlichten Paket enthalten ist.
{
  "name": "UI-40028",
  "description": "Blank Process",
  "main": "Flowchart.xaml",
  "dependencies": {
    "UiPath.Excel.Activities": "[2.9.3]",
    "UiPath.Mail.Activities": "[1.9.3]",
    "UiPath.System.Activities": "[20.10.1]",
    "UiPath.UIAutomation.Activities": "[20.10.6]"
  },
  "webServices": [],
  "entitiesStores": [],
  "schemaVersion": "4.0",
  "studioVersion": "20.10.2.0",
  "projectVersion": "1.0.1",
  "runtimeOptions": {
    "autoDispose": false,
    "isPausable": true,
    "requiresUserInteraction": true,
    "supportsPersistence": false,
    "excludedLoggedData": [
      "Private:*",
      "<em>password</em>"
    ],
    "executionType": "Workflow",
    "readyForPiP": false,
    "startsInPiP": false
  },
  "designOptions": {
    "projectProfile": "Developement",
    "outputType": "Process",
    "libraryOptions": {
      "includeOriginalXaml": false,
      "privateWorkflows": []
    },
    "processOptions": {
      "ignoredFiles": []
    },
    "fileInfoCollection": [],
    "modernBehavior": false
  },
  "arguments": {
    "input": [
      {
        "name": "argument1",
        "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
        "required": false,
        "hasDefault": false
      },
      {
        "name": "argument2",
        "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
        "required": false,
        "hasDefault": false
      }
    ],
    "output": []
  },
  "expressionLanguage": "VisualBasic",
  "entryPoints": [
    {
      "filePath": "Main.xaml",
      "uniqueId": "5289efb0-f8bc-42f3-8cf4-0caa3a7d1915",
      "input": [
        {
          "name": "argument1",
          "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
          "required": false,
          "hasDefault": false
        },
        {
          "name": "argument2",
          "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
          "required": false,
          "hasDefault": false
        }
      ],
      "output": []
    },
    {
      "filePath": "Flowchart.xaml",
      "uniqueId": "d0904ba0-506e-437d-979c-b9da4325faad",
      "input": [
        {
          "name": "argument1",
          "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
          "required": false,
          "hasDefault": false
        },
        {
          "name": "argument2",
          "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
          "required": false,
          "hasDefault": false
        }
      ],
      "output": []
    }
  ],
  "isTemplate": false,
  "templateProjectData": {},
  "publishData": {}
}{
  "name": "UI-40028",
  "description": "Blank Process",
  "main": "Flowchart.xaml",
  "dependencies": {
    "UiPath.Excel.Activities": "[2.9.3]",
    "UiPath.Mail.Activities": "[1.9.3]",
    "UiPath.System.Activities": "[20.10.1]",
    "UiPath.UIAutomation.Activities": "[20.10.6]"
  },
  "webServices": [],
  "entitiesStores": [],
  "schemaVersion": "4.0",
  "studioVersion": "20.10.2.0",
  "projectVersion": "1.0.1",
  "runtimeOptions": {
    "autoDispose": false,
    "isPausable": true,
    "requiresUserInteraction": true,
    "supportsPersistence": false,
    "excludedLoggedData": [
      "Private:*",
      "<em>password</em>"
    ],
    "executionType": "Workflow",
    "readyForPiP": false,
    "startsInPiP": false
  },
  "designOptions": {
    "projectProfile": "Developement",
    "outputType": "Process",
    "libraryOptions": {
      "includeOriginalXaml": false,
      "privateWorkflows": []
    },
    "processOptions": {
      "ignoredFiles": []
    },
    "fileInfoCollection": [],
    "modernBehavior": false
  },
  "arguments": {
    "input": [
      {
        "name": "argument1",
        "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
        "required": false,
        "hasDefault": false
      },
      {
        "name": "argument2",
        "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
        "required": false,
        "hasDefault": false
      }
    ],
    "output": []
  },
  "expressionLanguage": "VisualBasic",
  "entryPoints": [
    {
      "filePath": "Main.xaml",
      "uniqueId": "5289efb0-f8bc-42f3-8cf4-0caa3a7d1915",
      "input": [
        {
          "name": "argument1",
          "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
          "required": false,
          "hasDefault": false
        },
        {
          "name": "argument2",
          "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
          "required": false,
          "hasDefault": false
        }
      ],
      "output": []
    },
    {
      "filePath": "Flowchart.xaml",
      "uniqueId": "d0904ba0-506e-437d-979c-b9da4325faad",
      "input": [
        {
          "name": "argument1",
          "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
          "required": false,
          "hasDefault": false
        },
        {
          "name": "argument2",
          "type": "System.String, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089",
          "required": false,
          "hasDefault": false
        }
      ],
      "output": []
    }
  ],
  "isTemplate": false,
  "templateProjectData": {},
  "publishData": {}
}

War diese Seite hilfreich?

Hilfe erhalten
RPA lernen – Automatisierungskurse
UiPath Community-Forum
UiPath Logo weiß
Vertrauen und Sicherheit
© 2005-2024 UiPath. All rights reserved.