Studio
2023.10
false
Studio-Benutzerhandbuch
Last updated 15. Juli 2024

ST-USG-027 – Erforderliche Pakete

Regel-ID: ST-USG-027

Scope: Projekt

Beschreibung

Die Regel ermöglicht das Erzwingen der Verwendung von Aktivitätspaketen und -versionen in einem bestimmten Projekt. Nachdem die Liste der erforderlichen Pakete definiert wurde, überprüft die Regel das Projekt, um festzustellen, ob alle als Abhängigkeiten hinzugefügt wurden. Wenn ein erforderliches Paket nicht im Projekt installiert wurde, protokolliert die Regel standardmäßig einen Fehler im Fehlerlistenbereich.

Empfehlung

Stellen Sie sicher, dass alle von Ihrer Organisation benötigten Pakete in Ihrem Projekt installiert sind.

Ändern der Regel

Wählen Sie im Fenster Projekteinstellungen die Registerkarte Workflow-Analyse aus. Suchen Sie die Regel, und wählen Sie sie aus wie in der folgenden Abbildung gezeigt:



Standardmäßig erfordert diese Regel keine Aktivitätspakete. Fügen Sie ein Paket hinzu, indem Sie den vollständigen Namen zusammen mit der durch das Gleichheitszeichen (=) getrennten Version schreiben, z. B. UiPath.Excel.Activities=2.5.3.
Fügen Sie das Größer-als-Symbol (>) hinzu, um eine Version zu erfordern, die höher als eine angegebene Version ist. UiPath.Excel.Activities>=2.5.3 würde zum Beispiel ein UiPath.Excel.Activities-Paket mit einer Version ab 2.5.3 erfordern. Das Größer-als-Symbol (>) kann nur zusammen mit dem Gleichheitszeichen (=) verwendet werden, Eingaben wie UiPath.Excel.Activities>2.5.3 sind ungültig.
Die Zeichen für kleiner als (<) und kleiner gleich (<=) werden nicht unterstützt. Daher werden Eingaben wie UiPath.Excel.Activities<2.5.3 oder UiPath.Excel.Activities<=2.5.3 als ungültig betrachtet.
Verwenden Sie ein Platzhalterzeichen *, um eine von mehreren Versionen desselben Pakets zu erfordern. Der Wert UiPath.Excel.Activities=2.7.2-beta* erfordert z. B. eine 2.7.2-beta-Version des Pakets UiPath.Excel.Activities=2.7.2 und die Regel generiert einen Fehler, wenn andere Versionen desselben Pakets installiert sind, einschließlich:
  • UiPath.Excel.Activities=2.7.2
  • Andere Vorabversionen des Pakets UiPath.Excel.Activities=2.7.2 (z. B. Alpha-Versionen)
  • Andere stabile und Vorabversionen des Pakets UiPath.Excel.Activities
Das Platzhalterzeichen * kann nur am Ende der Version verwendet werden. Wenn Sie außerdem das Symbol größer gleich (>=) zusammen mit einem Platzhalterzeichen * verwenden, wird das Symbol größer als (>=) als Gleichheitszeichen (=) interpretiert. Beispielsweise ist UiPath.Excel.Activities>=2.7.2-beta* eine gültige Eingabe, wird aber als UiPath.Excel.Activities=2.7.2-beta* interpretiert.

Beispiele:

  • UiPath.Excel.Activities=2.8.4-*
  • UiPath.Excel.Activities>=2.7.2
  • UiPath.Excel.Activities=2.7.2
Um mehrere Pakete zu erfordern, trennen Sie sie einfach durch ein Komma. UiPath.Excel.Activities, UiPath.UIAutomation.Activities erfordert zum Beispiel, dass eine beliebige Version von UiPath.Excel.Activities und UiPath.UIAutomation.Activities zum Projekt hinzugefügt werden muss.
Hinweis: Um zu überprüfen, zu welchem Paket eine Aktivität gehört, verwenden Sie die Option Nach Paketen gruppieren im Panel Aktivitäten, wie hier erläutert. Eine weitere einfache Möglichkeit, den Mauszeiger über eine Aktivität im Panel zu bewegen und die QuickInfo zu lesen.

Nachdem Sie der Regel Pakete hinzugefügt haben, verwenden Sie die Schaltfläche Projekt analysieren, um die Regel auszuprobieren.

Auf Standardwert zurücksetzen

Standardmäßig erfordert die Regel keine Pakete. Wenn Sie jedoch die hinzugefügten Pakete schnell entfernen möchten, klicken Sie im Fenster Projekteinstellungen mit der rechten Maustaste auf die Regel, und klicken Sie dann auf Auf Standardwerte zurücksetzen. Die Standardaktion wird auch auf ihren Standardwert Fehler zurückgesetzt.



  • Beschreibung
  • Empfehlung
  • Ändern der Regel
  • Auf Standardwert zurücksetzen

War diese Seite hilfreich?

Hilfe erhalten
RPA lernen - Automatisierungskurse
UiPath Community-Forum
Uipath Logo White
Vertrauen und Sicherheit
© 2005-2024 UiPath. Alle Rechte vorbehalten.