- リリース ノート
- 基本情報
- セットアップと構成
- オートメーション プロジェクト
- 依存関係
- ワークフローの種類
- ファイルの比較
- オートメーションのベスト プラクティス
- ソース管理との連携
- デバッグ
- 診断ツール
- ワークフロー アナライザー
- 変数
- 引数
- インポートされた名前空間
- レコーディング
- UI 要素
- 制御フロー
- セレクター
- オブジェクト リポジトリ
- データ スクレイピング
- 画像とテキストの自動化
- Citrix テクノロジの自動化
- RDP の自動化
- Salesforce の操作の自動化
- SAP のオートメーション
- VMware Horizon の自動化
- ログ
- ScreenScrapeJavaSupport ツール
- Webdriver プロトコル
- Studio でのテスト
- 拡張機能
- トラブルシューティング

Studio ガイド
Citrix 拡張機能をインストールすると、Citrix Apps をネイティブに自動化できるようになります。Studio またはコマンド プロンプトからインストールできます。
-
v2409 以降の Citrix Workspace を自動化するには、
UiPath.UiAutomation.Activities
v24.10.11 以降が必要です。 -
UiPath Citrix 拡張機能をインストールするには、マシンごとに Citrix のクライアント (Citrix Receiver または Citrix Workspace) をインストールする必要があります。
- Studio を開きます。
- [ホーム] > [ツール] > [UiPath 拡張機能] に移動します。
- [Citrix] > [インストール] を選択します。確認のダイアログ ボックスが表示されます。
- 変更を反映するために、すべての Citrix アプリケーションを再起動します。
これで UiPath Citrix 拡張機能が Citrix のインストール ディレクトリにインストールされます。
- Windows のスタートボタンをクリックし、検索フィールドに「
cmd
」と入力します。 - [コマンド プロンプト] を右クリックし、管理者として実行します。
- ディレクトリを UiPath のインストール フォルダー (マシン単位のインストールの場合は
cd C:\Program Files\UiPath\Studio\UiPath
、ユーザー単位のインストールの場合はcd %localappdata%\Programs\UiPath\Studio\UiPath
) に変更します。 SetupExtensions /CitrixClient
コマンドで拡張機能をインストールします。確認ダイアログ ボックスが表示されます。- 変更を反映するために、すべての Citrix アプリケーションを再起動します。これで UiPath Citrix 拡張機能がインストールされます。
Studio から
- Studio を開きます。
- [ホーム] > [ツール] > [UiPath 拡張機能] に移動します。
- [Citrix] > [アンインストール] を選択して、選択を確定します。
UiPath Citrix 拡張機能がアンインストールされました。
コマンド ラインから
- 実行中のすべての Citrix アプリを閉じます。
- Windows のスタートボタンをクリックし、検索フィールドに「
cmd
」と入力します。 - [コマンド プロンプト] を右クリックし、管理者として実行します。
- ディレクトリを UiPath のインストール フォルダー (マシン単位のインストールの場合は
cd C:\Program Files\UiPath\Studio\UiPath
、ユーザー単位のインストールの場合はcd %localappdata%\Programs\UiPath\Studio\UiPath
) に変更します。 - 拡張機能をアンインストールするには、
SetupExtensions /CitrixClient /uninstall
コマンドを使用します。確認ダイアログ ボックスが表示されます。
UiPath Citrix 拡張機能がアンインストールされました。
このページでは、Citrix 環境でオートメーションを実行するときに発生する可能性のある問題の修正方法について説明します。
Citrix App で対話型の選択がフリーズし、何も選択されない
現象
UiPath Citrix 拡張機能のインストール後に Citrix App から UI 要素を選択しようとすると、対話型の選択が 1 分間フリーズし、何も選択されません。
原因
この現象は、UiPath リモート ランタイムが Citrix App セッションで実行されていない場合に発生します。
解決策
- UiPathRemoteRuntime.msi が Citrix App を開く Citrix アプリケーション サーバーにインストールされているかどうかを確認します。
-
Citrix アプリケーション サーバーで、UiPathRemoteRuntime.exe プロセスが実行中であるかどうかを確認します。UiPathRemoteRuntime.msi がインストールされ、Citrix App セッションのログインでプロセスが自動的に開始されます。
注: Citrix アプリケーション サーバーに UiPathRemoteRuntime.msi をインストールできない場合は、ここで説明しているように、クライアント マシンから UiPath Citrix 拡張機能をアンインストールすることをお勧めします。
「C:\Program Files (x86)\Citrix\ICA Client\UIPathPluginCitrix.dll"」ファイルにコピーできない。このファイルは別のプロセスで使用されている。
原因
これは、UiPath Citrix 拡張機能がインストールされていて、開いている Citrix App がこれを使用している場合に発生します。
解決策
すべてのアクティブな Citrix App セッションを閉じ (手順についてはこちらを参照)、UiPath Citrix 拡張機能を再インストールします。
次の Citrix レジストリ キーを読み取れない: 'SOFTWARECitrixInstallICA Client' Value: 'InstallFolder'
現象
UiPath Citrix 拡張機能をインストールしようとすると、次のエラーが表示されます。
原因
このエラー メッセージは、Citrix Receiver がインストールされていない場合に表示されます。また、Citrix Receiver for Universal Windows Platform がインストールされている場合にも表示されます。
解決策
Citrix Receiver または Citrix Workspace をダウンロードしてインストールします。
wfica32.exe での処理されない例外 0xC0000094: ゼロによる整数の除算
現象
ターゲットの Citrix アプリが起動に失敗し、Citrix ICA クライアントがクラッシュしました。
原因
Citrix アプリが読み込まれる前に、GetWindowText 関数を使用するアクティビティ ([要素の存在を確認]など) が実行されました。
解決策
このアクティビティの前に遅延を追加して、Citrix アプリを読み込む時間を確保します。
- UiPath Studio から
- コマンド プロンプトから
- UiPath Citrix 拡張機能をアンインストールする
- トラブルシューティング
- Citrix App で対話型の選択がフリーズし、何も選択されない
- 「C:\Program Files (x86)\Citrix\ICA Client\UIPathPluginCitrix.dll"」ファイルにコピーできない。このファイルは別のプロセスで使用されている。
- 次の Citrix レジストリ キーを読み取れない: 'SOFTWARECitrixInstallICA Client' Value: 'InstallFolder'
- wfica32.exe での処理されない例外 0xC0000094: ゼロによる整数の除算