Studio
2022.10
False
Bannerhintergrundbild
Studio-Benutzerhandbuch
Letzte Aktualisierung 1. März 2024

Aktivieren von Studio

Online-Aktivierung

Wenn Sie Studio nach der Installation zum ersten Mal ausführen, hilft Ihnen ein Assistent beim Aktivieren und den ersten Schritten mit Ihrem Produkt. Die Aktivierungsmethode, mit der Sie aufgefordert werden, wird durch den Typ der durchgeführten Installation bestimmt, Sie können jedoch zu einem anderen Aktivierungstyp wechseln, indem Sie im Assistenten auf Weitere Optionen klicken:

Aktivieren durch Anmelden bei UiPath

Wenn Sie Studio zum ersten Mal nach der Installation von Studio mit einem aus UiPath Automation Cloud heruntergeladenen Installationsprogramm ausführen, werden Sie aufgefordert, sich bei Ihrem UiPath-Konto anzumelden.

Hinweis: Die Anmeldeoption ist nur verfügbar, wenn Sie den Roboter im Benutzermodus installiert haben.


  1. Klicken Sie auf Anmelden, um sich bei Ihrem UiPath-Konto anzumelden. Klicken Sie auf Weitere Informationen, um mehr über die Anmeldung zu erfahren.

  2. Ein neues Browserfenster wird geöffnet. Wenn Sie noch nicht eingeloggt sind, melden Sie sich mit Ihrer E-Mail oder mit einem der verfügbaren Anbieter an.



  3. Nach der Anmeldung werden Sie von Ihrem Webbrowser aufgefordert, UiPath zu öffnen. Klicken Sie auf UiPath öffnen, um zu Studio zurückzukehren und fortzufahren.



  4. Wenn Ihr Benutzer Zugriff auf mehrere Mandanten hat, wählen Sie aus, mit welchem Mandanten eine Verbindung hergestellt werden soll, und klicken Sie dann auf Fortfahren. Wenn Sie Zugriff auf einen einzelnen Mandanten haben, sind Sie mit ihm verbunden, ohne dass weitere Eingaben erforderlich sind.



  5. Sie sind bei Ihrem UiPath-Konto angemeldet und in Studio und Assistant mit Orchestrator verbunden sind, ist Ihr Produkt aktiviert, und es wird ein schnelles Schritt-für-Schritt-Tutorial angezeigt, mit dem Sie mit dem Erstellen von Automatisierungen beginnen können.

    Hinweis: Bei Problemen bei der Anmeldung finden Sie unter Häufige Fehler bei der Anmeldung in der Anleitung zu Studio Lösungsvorschläge.

Aktivieren durch Verbinden mit Orchestrator

Wenn Sie Studio zum ersten Mal nach der Installation von Studio mit einem Installationsprogramm ausführen, das Sie beim Kauf der lokalen UiPath Platform erhalten haben, werden Sie aufgefordert, mit Ihren Client-Anmeldeinformationen oder Ihrem Maschinenschlüssel die Verbindung mit Orchestrator herzustellen.

Hinweis: Wenn Sie den Roboter im Dienstmodus installiert haben, sind Administratorrechte erforderlich, um eine Verbindung mit dem Orchestrator mit dem Maschinenschlüssel herzustellen.


  1. Wählen Sie einen Verbindungstyp aus – Client-ID oder Maschinenschlüssel.
  2. Geben Sie die Orchestrator-URL und entweder die Client-ID und den Geheimen Clientschlüssel oder den im Orchestrator generierten Maschinenschlüssel ein und klicken Sie dann auf Weiter.

    • Wenn Sie keine Verbindung mit Orchestrator herstellen möchten, wählen Sie Weitere Optionen aus und dann Optionen für eigenständige Lizenzen, um durch Hinzufügen eines Lizenzschlüssels zu aktivieren.
  3. Sie sind sowohl in Studio als auch Assistant mit Orchestrator verbunden, ein Lizenzschlüssel wird von Orchestrator bezogen, und es wird ein schnelles Schritt-für-Schritt-Tutorial angezeigt, mit dem Sie mit dem Erstellen von Automatisierungen beginnen können.

    Hinweis: Wenn Sie sich mit Ihrem Maschinenschlüssel mit dem Orchestrator verbinden, können Sie Studio nur mit einer Non-Production- oder Unattended-Lizenz verwenden, um Fehler in Workflows zu beheben, wenn die Option Benutzerauthentifizierung erzwingen, Roboterschlüssel-Authentifizierung deaktivieren im Orchestrator deaktiviert ist. Wenn jedoch die Benutzerauthentifizierung erzwungen wird und Ihrem Benutzer auch eine Entwicklungslizenz zugewiesen ist, können Sie sich nach der Verbindung mit Ihrem Maschinenschlüssel bei Ihrem Konto anmelden.

Wenn Studio über den Orchestrator lizenziert wird (entweder durch Anmelden oder Herstellen einer Verbindung mit dem Orchestrator), wird auf der Registerkarte Hilfe der Lizenzanbieter: Orchestrator erwähnt. Ansonsten heißt es im selben Text Intern.



Beachten Sie, dass Lizenzänderungen erst nach einem Neustart von Studio wirksam werden.

Aktivieren mit einem Lizenzschlüssel

Wenn Sie Studio zum ersten Mal nach der Installation von Studio mit einem Installationsprogramm ausführen, das Im Rahmen einer Testversion der lokalen UiPath Platform-Instanz abgerufen wurde, können Sie die Aktivierung lokal mit einem Lizenzschlüssel vornehmen. Eine lokale Lizenz kann auch mit dem LicenseTool-Befehlszeilenprogramm aktiviert werden.



So aktivieren Sie einen Lizenzschlüssel:

  1. Wählen Sie für die Onlinelizenzierung die Option Automatisch aus.
  2. Geben Sie den Lizenzschlüssel, den Sie erhalten haben, in das Feld Lizenzschlüssel hinzufügen ein.
  3. Klicken Sie auf die Schaltfläche Fortfahren. Ihre UiPath-Lizenz ist nun aktiviert, und Sie können mit der Erstellung von Automatisierungs-Workflows beginnen.

    Hinweis:

    Ein Aktivierungsfehler wird möglicherweise während des Lizenzierungsprozesses angezeigt, wenn auf dem Computer ein Antivirenprogramm installiert ist. Um die Fehlermeldung zu vermeiden, muss Studio sowohl im Antivirenprogramm als auch in der Firewall auf die weiße Liste gesetzt werden.

    Wenn die Studio-Installation lokal lizenziert ist, Sie sie aber dennoch mit dem Orchestrator verbinden möchten, achten Sie darauf, beim Erstellen des zugehörigen Roboters im Orchestrator das Kontrollkästchen Eigenständig zu aktivieren. Dadurch wird sichergestellt, dass der Orchestrator keine Lizenz aus seinem Lizenzpool zuweist, da Studio standardmäßig die lokale Lizenz verwendet.

Aktivieren Ihrer Lizenz während der Installation

Sie können einen Lizenzschlüssel während der Installation aktivieren, indem Sie das UiPathStudio.msi -Installationsprogramm über die Befehlszeile mit dem Argument CODE gefolgt vom Lizenzschlüssel ausführen. Zum Beispiel: UiPathStudio.msi CODE=1234567890.

Für eine unbeaufsichtigte Installation können Sie ebenfalls einige Parameter im Hintergrund verwenden:

  • /quiet – Stiller Modus, keine Benutzerinteraktion
  • /passive- unbeaufsichtigter Modus – nur Statusanzeige
  • /q[n|b|r] - Legt das Benutzeroberflächen-Level fest
    • n - Keine UI
    • b - Grundlegende UI
    • r - Reduzierte UI

Zum Beispiel:

C:\UiPathStudio.msi CODE=1234567890 /passive – Installiert alle Standardfunktionen und aktiviert Ihre Lizenz mit einer Statusanzeige.

Offline-Aktivierung

Hinweis:
  • Stellen Sie sicher, dass der CNG Key Isolation-Dienst ausgeführt wird. Dies wird von UiPath gefordert, um Ihre Lizenz offline zu validieren.
  • Wenn Sie Ihre Lizenz verlängern, löschen Sie den Ordner LicenseInternal, der sich entweder in %AppData%/UiPath (für Lizenzen pro Benutzer) oder %ProgramData%/UiPath (für Lizenzen pro Maschine) befindet, bevor Sie die unten beschriebenen Schritte ausführen.

Wenn UiPath Studio auf einer Maschine installiert ist, die nicht mit dem Internet verbunden ist, oder wenn Ihre Netzwerksicherheitssoftware bzw. die Firewall den Zugang zu unserem Lizenzvalidierungsserver verhindert, können Sie mithilfe des LicenseTool-Befehlszeilenprogramms eine manuelle Aktivierung durchführen.

Alternativ können Sie den Aktivierungs-Assistenten verwenden, indem Sie die folgenden Schritte ausführen:

  1. Wählen Sie Weitere Optionen > Optionen für eigenständige Lizenzen aus, wenn Sie sich noch nicht im Bildschirm Lizenzschlüssel hinzufügen befinden.
  2. Geben Sie den Lizenzschlüssel, den Sie erhalten haben, in das Feld Lizenzschlüssel hinzufügen ein.
  3. Klicken Sie auf die Aktivierungsoption Manuell.
  4. Klicken Sie auf die Schaltfläche Fortfahren. Der erste Schritt der manuellen Aktivierung wird angezeigt, und ein Aktivierungsanforderungscode wird generiert und in die Zwischenablage kopiert.



  5. Kopieren Sie den Aktivierungsanforderungscode in eine E-Mail-Nachricht oder Textdatei und drücken Sie die Schaltfläche Fortfahren.

    Hinweis: Lassen Sie den Aktivierungsassistenten(Activation wizard) geöffnet, bis der Prozess abgeschlossen ist.
  6. Senden Sie den Aktivierungsanforderungscode an einen Computer mit Internetzugang.
  7. Navigieren Sie auf dem Computer mit Internetzugang zu https://activate.uipath.com/.



  8. Achten Sie darauf, dass auf der Webseite die Registerkarte Aktivieren Ihrer Lizenz ausgewählt ist, und fügen Sie den Aktivierungsanforderungscode in das Feld Zertifikat der Aktivierungsanforderung ein, und klicken Sie auf Lizenzdatei generieren. Der Lizenzcode wird generiert.



  9. Wählen Sie zwischen Lizenzdatei herunterladen, um den Lizenzcode in einer .txt Datei auf Ihrer Maschine zu speichern, oder kopieren Sie den Lizenzcode in die Zwischenablage.
  10. Hängen Sie die heruntergeladene .txt-Datei an eine E-Mail an, oder fügen Sie die Lizenz ein, und senden Sie sie an den Computer ohne Internetzugang oder mit Firewall-Einschränkungen.


  11. Drücken Sie auf der Maschine, auf der Sie Ihre Lizenz aktivieren möchten, im zweiten Schritt des Assistenten Manuelle Aktivierung die Schaltfläche Fortfahren. Der dritte und letzte Schritt des Assistenten Manuelle Aktivierung wird angezeigt.



  12. Geben Sie in das Feld Aktivierung(Activation) den in Schritt 10 erhaltenen Lizenzcode ein.
  13. Drücken Sie die Schaltfläche Fortfahren. Ihre Lizenz ist nun aktiviert.

    Hinweis: Wenn der Windows-Benutzername Nicht-ASCII-Zeichen enthält, tritt der Ausnahmefehler „Nicht kompatible Lizenzmodelldaten“ auf, wenn Sie auf Weiter klicken und die Offline-Aktivierung nicht erfolgreich abgeschlossen wurde.

Auswählen des Studio-Profils

Wenn Sie eine Neuinstallation im Rahmen einer Testversion der lokalen UiPath Platform durchführen oder die der Community Edition von Studio nutzen, werden Sie nach der Aktivierung aufgefordert, das zu verwendende Profil auszuwählen (Studio oder StudioX).



Wenn Sie über eine Enterprise-Lizenz verfügen, wird das Studio-Profil nach der Aktivierung basierend auf der Lizenzzuweisung in Orchestrator automatisch ausgewählt.

Sie können in Studio jederzeit zu einem anderen Benutzerprofil wechseln, indem Sie zu Start (Backstage-Ansicht) > Einstellungen > Lizenz und Profil > Profil ändern gehen.

Hinweis: Wenn Sie eine Citizen-Developer-Lizenz haben, können Sie nur das StudioX-Profil verwenden.

Das Wechseln zwischen Profilen kann auch mit den folgenden Befehlszeilenparametern erfolgen:

  • -p Development: um zum Studio-Profil zu wechseln.
  • -p Business: um zum StudioX-Profil zu wechseln.
Öffnen Sie dazu cmd in dem Verzeichnis, in dem Studio installiert ist, und geben Sie den folgenden Befehl ein: UiPath\Studio\UiPath.Studio.exe -p Business. Drücken Sie dann die Eingabetaste. Studio wird im StudioX-Profil geöffnet.

Bei den Befehlen wird die Groß-/Kleinschreibung beachtet. Wenn ein falsches Argument eingegeben wird, wird das Standardprofil „Studio“ geöffnet. Die Liste der letzten Projekte wird pro Profil beibehalten.

Aktualisieren des Lizenzschlüssels

Sie können einen lokalen Lizenzschlüssel in Studio ändern, indem Sie zu Startseite (Backstage-Ansicht) > Einstellungen > Lizenz und Profil gehen.



Klicken Sie auf Lokale Lizenz ändern, geben Sie den neuen Lizenzschlüssel ein, und klicken Sie auf Weiter.

War diese Seite hilfreich?

Hilfe erhalten
RPA lernen – Automatisierungskurse
UiPath Community-Forum
UiPath Logo weiß
Vertrauen und Sicherheit
© 2005-2024 UiPath. All rights reserved.