- リリース ノート
- 基本情報
- チュートリアル
- オートメーション プロジェクト
- オートメーションの作成
UiPath StudioX インターフェイスには、特定の機能に簡単にアクセスできるように複数のパネルが用意されています。パネルはドッキングしたり、どこにでも移動できるようにフローティングに設定したり、自動的に隠すように設定したりできます。
ホーム (Backstage ビュー)
StudioX を最初に開いたときに表示されるビューです。このビューは、デザイン ビューの左上隅の [ホーム] をクリックして開くこともできます。ここでは、プロジェクトへのアクセス、StudioX の設定の構成、ヘルプやライセンス情報へのアクセスなどができます。このビューでは、次のボタンやタブを利用できます。
-
開く - オートメーション プロジェクトを参照して開きます。
-
閉じる - 現在開いているオートメーション プロジェクトを閉じます。
-
Save as - Save the automation project and create a copy of it in a different location. You can use this option to copy local automation projects to source control by selecting a repository as the location or convert a project into a template.
-
開始 - 新しいタスクオートメーション プロジェクトを作成するか、最近アクセスしたプロジェクトを開きます。
-
Templates - Create a new project based on a template. In this tab, you can view all available project templates, search and filter them by source. For more information, see Project Templates.
-
Team - Manage source control integration for the automation project.
-
Tools - Install the Excel Add-in, extensions for web browsers and other applications that allow StudioX to capture actions you perform in them, and the Repair Tool for Microsoft Office. For more information on extensions, see Extensions in the Installation and Upgrade Guide.
-
Settings - Change the look and feel of StudioX, set global preferences, and manage activities packages sources. For more information, see Configuring StudioX Settings.
-
Help - Directs you to product documentation, release notes, online resources, the Community Forum and the RPA Academy.
また [ヘルプ] タブでは、製品のバージョン、インストール、ライセンスが使用可能かどうか、更新チャネル、デバイス ID に関する情報も得られます。[情報をコピー] ボタンを使用すれば、情報の詳細をすばやくクリップボードにコピーできます。
デザイン ビュー
オートメーション プロジェクトを作成、実行、パブリッシュするビューです。
リボン
The ribbon at the top of the window can be minimized or expanded by clicking the Minimize / Expand button
. It contains the following buttons:
-
保存 - オートメーション プロジェクトを保存します。
-
切り取り/コピー/貼り付け - これらのボタンを使用して、デザイナー パネルでアクティビティの切り取り、コピー、貼り付けができます。
-
プロジェクト - [プロジェクト設定] を選択して、プロジェクトの名前や説明、ワークフロー アナライザーのルール、またはアクティビティのグローバルな設定を編集します。[プロジェクト フォルダーを開く] を選択して、Windows のファイル エクスプローラーでプロジェクト フォルダーを開きます。
-
プロジェクト ノートブック - オートメーション プロジェクトのプロジェクト ノートブックとして定義した Excel ファイルを開きます。設定を編集するには、このボタンの横の矢印をクリックして、[プロジェクト ノートブックを構成] を選択します。
-
パッケージを管理 - [パッケージを管理] ウィンドウを開き、プロジェクトのアクティビティ パッケージとソースを構成できます。
-
App/Web Recorder - UiPath Recorder を開きます。このレコーダーは、画面上の操作をキャプチャし、それらに基づいて一連のアクティビティを自動的に生成します。詳細については、「 アプリ/Web レコーダー」をご覧ください。
-
表抽出 - 抽出ウィザードが開き、アプリケーションまたは Web ページから構造化データを抽出できます。詳細については、「 表データを抽出する」をご覧ください。
-
分析 - プロジェクトに検証エラーとワークフロー アナライザーのルール違反があるかチェックします。結果は [エラー リスト] パネルに表示されます。ワークフロー アナライザーの設定を編集するには、このボタンの横の矢印をクリックして、[ワークフロー アナライザーの設定] を選択します。
-
Excel にエクスポート - オートメーション プロジェクトを Excel ファイルにエクスポートします。
-
パブリッシュ - プロジェクトとプロジェクト フォルダーにあるすべての他のファイルをアーカイブし、ロボットに送信して実行できるようにします。
-
実行 - オートメーション プロジェクトを実行します。
プロジェクトの実行中に作業を中断せずに続行するには、このボタンの下にある矢印をクリックし、[PiP で実行] を選択します。プロジェクトは、フローティング ウィンドウで起動される新しいセッションで実行されます。
注:オートメーション プロジェクトの実行中に作成されたものではないファイルは、Orchestrator へのパブリッシュ時に読み取り専用になります。業務プロセスにおいて将来的に特定のファイルへの書き込みが必要となる場合は、プロジェクトの実行中にファイルを作成するようにしてください。
アクティビティを追加の検索バー
[アクティビティを追加] 検索バーでは、アクティビティをすばやく検索し、オートメーション プロジェクトに追加できます。
[アクティビティを追加] 検索バーを開くには、プロジェクトに追加したいずれかのアクティビティの上部または下部にある [アクティビティを追加]
アイコンをクリックするか、Ctrl + Shift + T のキーボード ショートカットを使用します。
このバーは次の 3 つのセクションに分かれています。
-
次に追加しなければならない可能性が最も高いと AI によって予測され提案されたアクティビティのグループです。この機能を無効化するには、[設定] メニュー > [デザイン] タブの [AI によるアクティビティの提案を有効化] オプションの選択を解除します。
-
Common Scenarios lists different common activities and preconfigured pieces of automation based on where in the project workflow you clicked Add activity
. This gives you quick access to the most relevant results in every context. -
[アクティビティ] には、インストールしたパッケージにあるすべてのアクティビティが表示されます。
アカウントにサインインする
Studio をユーザー モードの Robot とともにインストールした場合、または Studio Community Edition を使用している場合は、UiPath アカウントにサインインすれば、Studio と Assistant を Orchestrator に接続できます。これにより、Orchestrator リソースへのアクセス、製品のアクティベーション、Orchestrator へのプロジェクトのパブリッシュが可能になります。
- Studio ウィンドウの右上隅にある
をクリックし、続けて [サインイン] をクリックします。サインインに関する詳細は、こちらをご覧ください。
-
既定の
https://cloud.uipath.comの代わりにカスタム URL を使用するには、[サービス URL] フィールドに URL を入力します。 -
To connect to Orchestrator with your machine key, click Use Machine Key.
-
- Web ブラウザーに新しいページが開きます。サインインの手順を実行し、Web ブラウザーの指示に従い、[UiPath を開く] をクリックして Studio に戻ります。
サインインすると、自分のイニシャルの付いたアイコンが Studio ウィンドウの右上隅に表示されます。Studio と Assistant の両方からサインアウトし Orchestrator への接続を切断するには、そのアイコンをクリックして [サインアウト] を選択します。
マシン キーを使用して Orchestrator に接続する
Windows サービスとして登録された Robot とともに Studio をインストールした場合は、マシン キーによってのみ Orchestrator に接続できます。
- Click
, and then click Connect. - Orchestrator URL とマシン キーを入力して、[続行] をクリックします。
- ローカル ライセンス キーを使用してアクティベーションする場合は、[ライセンス コードを使用] をクリックします。
マシン キーを使用して Studio を Orchestrator に接続した後に、アカウントにサインインできます。
-
Click
on the upper-right side of the Studio window, and then click *Sign in. -
Web ブラウザーに新しいページが開きます。サインインの手順を実行し、Web ブラウザーの指示に従い、[UiPath を開く] をクリックして Studio に戻ります。
注:If you close the tab before the authentication is complete, it may take up to 10 seconds for the Sign in button in Studio to be enabled again.
フィードバックを送る
StudioX から直接送信できるフィードバックとして、[製品に関する提案を提出] と [バグを報告] の 2 種類があります。タイトルバーの
をクリックすると、どちらにもアクセスできます。
[品質向上にご協力ください] ウィンドウで、次の情報を入力して [送信] をクリックします。
- [目的] ドロップダウン メニューから、[製品に関する提案を提出] または [バグを報告] を選択します。
- [対象] ドロップダウン メニューから、フィードバックの送信対象の製品を選択します。StudioX は既定で選択されています。
- [内容の重要度] フィールドで [低]、[高]、[重大] のいずれかを選択します。
- [件名] フィールドに、メッセージの件名を入力します。
- [再現ステップ] または [説明] フィールドに詳細な説明を入力します。
- [追加] をクリックするとファイルを添付できます。最大 6 個の画像、ビデオ、またはテキスト ファイルを添付できます。それぞれのサイズは 10 MB 未満とします。
送信できる投稿は 5 分間で最大 3 件です。
[アクティビティ] パネルと [アクティビティを追加] 検索バーは、あいまい検索をサポートしているので、検索用語と正確に一致していなくても結果が返されます。検索用語がやや不完全な場合、スペルに誤りがある場合、各単語の先頭文字のみを指定している場合でも結果が返されます。
デザイナー パネル
デザイナー パネルは、オートメーションを作成するときのキャンバスとなります。ここでは、自動化するアクティビティの追加、そのプロパティの表示と編集、アクティビティの順序指定によるワークフローの定義などを実行します。オートメーション プロジェクトはダイアグラムで示されるので、プロセスを構成するアクティビティのシーケンスを視覚的に確認できます。
アクティビティは、ダブルクリックするかドラッグ アンド ドロップすることによって[アクティビティ] パネルから追加できます。または、既に追加されているアクティビティの上下にある [アクティビティを追加]
ボタンをクリックし、[アクティビティを追加] 検索バーから選択することもできます。パネルに追加したすべてのアクティビティについて、名前、主要なアクティビティのプロパティ、そのアクティビティの構成に役立つボタンやリンク、参考スクリーンショットなどの詳細情報を表示できます。さまざまな種類のアクティビティの識別に役立つように、各アクティビティの左側境界線は、適用先のアプリケーションごとに色分けされています。たとえば、Excel アクティビティの左側境界線は緑色で、メール アクティビティの左側境界線は青色です。
スペース キーまたはマウスの中ボタンを押しながら
アイコンをクリックすると、パン モードを有効にできます。ズーム ドロップダウンを使用してズーム レベルを変更し、
アイコンをクリックして 100% にリセットします。
[画面に合わせる]
アイコンを使用して、ワークフロー全体がデザイナー パネルに収まるようにズームを変更できます。プロジェクト全体の概要を把握し、フォーカスを調整してセクション間を移動するには、
アイコンをクリックします。
コンテキスト メニュー
コンテキスト メニューを使用すると、プロジェクト内のアクティビティに対していくつかの操作を実行できます。プロジェクト内のアクティビティを右クリックすると、コンテキスト メニューを表示できます。
コンテキスト メニューのフィールドの説明
| オプション | 説明 |
|---|---|
|
名前を変更する |
アクティビティの名前を編集します。 |
|
開く |
デザイナー パネルで選択したアクティビティを開きます。 |
|
折りたたみ |
アクティビティを折りたたむことで、表示される詳細を「ダブルクリックして表示」に変更します。折りたたみボタン |
|
埋め込み先で展開 |
アクティビティのコンテンツを展開し、その詳細を表示します。展開ボタン |
|
切り取り |
選択されたアクティビティを切り取り、クリップボード上に配置します。 |
|
コピー |
選択されたアクティビティをコピーし、クリップボード上に配置します。 |
|
貼り付け |
クリップボードのコンテンツを現在の位置に挿入します。 |
|
削除する |
対象となるアクティビティを削除します。 |
|
注釈 |
ワークフロー内のアクティビティについて、注釈の追加、編集、削除を行えます。また、注釈を表示 / 非表示にすることもできます。 |
|
画像としてコピー |
デザイナー パネル内で表示されたコンテンツのスクリーンショットを作成します。 |
|
画像として保存 |
デザイナー パネル内で表示されたコンテンツのスクリーンショットを作成し、保存の際に必要な情報(ファイル名、ファイルの種類、保存先)を設定するようユーザーに指示します。サポートされるファイル形式は、JPG、PNG、GIF、XPSです。 |
|
アクティビティを有効化 |
それまで無効化されていたアクティビティを有効化します。 |
|
アクティビティを無効化 |
アクティビティを無効化します。アクティビティは灰色表示され、[コメント アウト] アクティビティ内に配置されます。 |
|
ここにズーム |
特定のアクティビティのみを表示するようにダイアグラム内をナビゲートします。デザイナー パネルの見出しにパスが階層リンクとして表示されます。 |
|
Zoom out (縮小) |
プロジェクトのダイアグラム全体をデザイナー パネルに表示します。 |
|
このアクティビティまで実行 |
プロジェクトを始めから実行し、このアクティビティが実行された後に停止します。 |
|
このアクティビティから実行 |
このアクティビティからプロジェクトを実行します。 |
|
ヘルプ |
Activities ガイドでアクティビティの種類に関するヘルプ ページを開きます。 |
アクティビティ パネル
[アクティビティ] パネルには、現在のプロジェクトに追加できる、利用可能なアクティビティが表示されます。パネル上部の検索ボックスにアクティビティの名前や説明を入力して検索できます。アクティビティをオートメーションに追加するには、そのアクティビティをダブルクリックするか、デザイナー パネルの目的の場所にドラッグ アンド ドロップします。
パネル内のアクティビティ上でホバーすると、そのアクティビティが属するパッケージとその説明が表示されます。アクティビティをお気に入りのリストに追加するには、そのアクティビティを右クリックして、[お気に入りに追加] を選択します。
アクティビティ パネルをカスタマイズする
Click the View Options
button at the top of the panel to open a menu that allows you to customize the panel. See the following table for a list of available options.
| オプション | 説明 |
|---|---|
| お気に入りのアクティビティを表示 | お気に入りのアクティビティがあるセクションを表示します。既定では、このオプションは選択されています。 |
| 最近使用したアクティビティを表示 | 最近使用した 10 個のアクティビティを含むセクションを表示します。既定では、このオプションは選択されていません。 |
| カテゴリを表示 | 属するカテゴリ別にアクティビティをグループ化します。既定では、このオプションは選択されています。 |
| パッケージ別にグループ化 | 属するパッケージ別にアクティビティをグループ化します。既定では、このオプションは選択されていません。 |
| お気に入りをピン留め | パネル内を検索するときに、お気に入りのアクティビティが常に表示されるようにします。[お気に入りのアクティビティを表示] が選択されている場合に利用できます。既定では、このオプションは選択されていません。 |
| 開発者向けアクティビティを表示 | Studio プロファイル用に設計されたアクティビティを表示します。既定では、このオプションは選択されていません。 ただし、これらのアクティビティは、StudioX プロファイルでは期待どおりに動作しない場合があります。 |
たとえば、すべての Excel アクティビティを表示する場合、[パッケージ別にグループ化] を選択して [カテゴリを表示] を選択解除できます。
データ マネージャー パネル
[データ マネージャー] パネルには、オートメーション プロジェクトに現在追加されているデータが表示されます。このデータとして次のものがあります。
-
プロジェクトに追加したリソース: Excel ファイル (プロジェクト ノートブックを含む)、メール アカウント、Word 文書、PowerPoint プレゼンテーション、アプリケーション、およびブラウザー。
- リソースが定義されたアクティビティに移動するには、データ マネージャーのエントリをダブルクリックします。
- オートメーションに追加されたファイル、または、そのファイルが含まれるフォルダーを開くには、Excel または Word のファイル リソースを右クリックして、[開く] または [ファイルの場所を開く] を選択します。リモート ファイル (例: SharePoint) を使用している場合、このオプションは使用できません。
- For information about managing Excel resources from the Data Manager, see Excel Automation.
-
後でプロジェクトで使用するために保存した出力値。
- 保存済みの値の名前を変更するには、値を右クリックして、[保存された値の名前を変更] を選択します。
- 値が保存されたアクティビティに移動するには、保存された値をダブルクリックします。
-
アプリ/Web アクティビティのセレクターで使用するために作成された値のマッピング。
- 変数を編集するには、その変数を右クリックし [値マッピングを開く] を選択します。
- 変数が作成されたアクティビティに移動するには、変数をダブルクリックします。
-
File arguments used in the automation. To create and manage arguments, click the Arguments
button. Read more about Arguments in the Automation Basics guide.
プロパティ パネル
[プロパティ] パネルには状況に応じた内容が表示されます。選択したアクティビティの詳細なプロパティの表示と編集が可能です。複数のアクティビティを選択した場合、[プロパティ] パネルでは、これらのアクティビティに共通のプロパティのみを変更できます。
既定では、[プロパティ] パネルは非表示になっています。ほとんどの場合、デザイナー パネルで使用できるオプションでアクティビティを設定できます。
出力パネル
[出力] パネルでは、[1 行を書き込み] アクティビティの出力、プロジェクトの実行に関するステータス情報、アクティビティ パッケージで生成されたエラーなどを表示できます。
[出力] パネルでは、パネルの見出しにあるボタンをクリックすることで、さまざまなログ レベル (エラー、警告) のメッセージを表示または非表示にする操作や、パネルのコンテンツをテキスト ファイルにエクスポートする操作などができます。メッセージをダブルクリックすると、メッセージの詳細が表示され、その情報をコピーすることもできます。
[出力] パネルに表示されるすべての情報は、[すべてクリア] ボタンで消去できます。ワークフローの実行時に、このパネルのログやその他のデータが消去されます。[出力] パネルには、一度に 2,000 行まで表示できます。
The Error List panel next to the Output panel displays errors found in the project during validation and workflow analysis. For more information, see About Workflow Analyzer.
リソース パネル
The Resources panel can load assets, queues and processes, provided that the Robot is connected to Orchestrator. Read the Connecting Robots to Orchestrator page to find the steps.
Orchestrator に接続されているロボットの種類が標準の場合、[リソース] パネルには、このロボットがプロビジョニングされたクラシック フォルダーのみを表示できます。
If the Robot is of type Floating, then the panel displays all Classic and Modern folders that this Robot has access to. Read more about creating Robots in Orchestrator here.
The panel displays resources such as assets, queues, and processes found in Classic or Modern Folders in Orchestrator. Read more about folders.
- When using a classic, manually provisioned robot, it must be granted
Viewpermissions for the corresponding resources (i.e. Assets, Queues, and Processes) to appear in the panel. Read more about setting up Roles and permissions in Orchestrator. - Orchestrator にクラシック フォルダーとモダン フォルダーの両方が存在し、モダン フォルダー内のロボットを使用して Orchestrator に接続している場合 (アカウントにサインインしているか、マシン テンプレート キーを使用して接続している)、[リソース] パネルでクラシック フォルダー内のプロセスは使用できません。クラシック フォルダー内のプロセスにアクセスするには、クラシック ロボットを使用して標準マシン キー接続で Orchestrator に接続します。
パネルにリソースを読み込むには、[リソース] パネルの上部にある [更新] ボタンをクリックします。[リソース] パネル内の任意の項目を右クリックしてその項目の名前をコピーし、そうしたリソースと対話するアクティビティで使用します。
ステータス バーのフォルダー名上でホバーすると Orchestrator URL が表示され、そのフォルダー名をクリックすると別のフォルダーに切り替わります。
ステータス バー
ステータス バーでは、Orchestrator に関連するステータス情報を確認したり、オプションにアクセスしたりできます。また、プロジェクト内の式に使用されている言語 (VB または C#) も確認できます。
- Orchestrator/Cloud の接続 -
をクリックして Orchestrator オプションにアクセスし、クラウド アカウントへのサインイン、Orchestrator からの接続解除 (マシン キーを使用して接続されている場合)、リソースの更新を行います。 - Orchestrator のステータス - Orchestrator の接続ステータスを表示します。Orchestrator に接続されている場合は、現在選択されているフォルダーが表示されます。現在のフォルダーの名前をクリックして、利用可能なフォルダーのリストを表示して、リソースを同期する別のフォルダーを選択できます。
キーボード ショートカット
UiPath StudioX のキーボード ショートカットのリストを次に示します。
ファイルの管理
Ctrl + Shift + N - 新しい空のタスクを作成します。
Ctrl + C - デザイナー パネルからクリップボードにアクティビティをコピーします。Ctrl + V を使用して、デザイナー パネルの任意の場所に貼り付けます。
Ctrl + O - 過去に作成したタスク (.xaml または project.json ファイル) を開くことができます。
Ctrl + L - ログ ファイルが格納されているフォルダーを開きます。
Ctrl + S - 現在開いているプロジェクトを保存します。
Ctrl + V - クリップボードから以前にコピーしたアクティビティをデザイナー パネルに貼り付けます。
Ctrl + Tab/Alt + F7 - ワークフロー ファイル/パネル間でフォーカスを移動します。修飾キー (Ctrl または Alt) を押したままにすると、次のウィンドウが表示され、アクティブなファイルやパネルを切り替えられます。
検索
F3 または Ctrl + Shift + P - コマンド パレットを開きます。
Ctrl + Shift + T - 共通シナリオとアクティビティ の検索バーを開きます。
Ctrl + J - [アクティビティに移動] 検索バーを開きます。
Ctrl + Alt + A - [プロパティ] パネルを開いてフォーカスします。
Alt + Ctrl + F - [アクティビティ] パネルの検索ボックスにフォーカスを設定します。
Tab - パネル内の次の項目またはアクティビティの次の要素に移動します。
コメント
Ctrl + D - 現在選択しているアクティビティを [コメント アウト] コンテナーに配置して無視します。
Ctrl + E - [コメント アウト] コンテナーに配置されているアクティビティをコンテナーから削除します。
デバッグ
Ctrl + Alt + E - [エラー リスト] パネルを開きます。
レコーディング
F2 - 記録操作中に遅延を追加します。
ワークフローの分析と実行
F5 - 現在のプロジェクトを実行します。
F6 - 現在のプロジェクトをピクチャ イン ピクチャ モードで実行します。
F7 - ファイルに検証エラーとワークフロー アナライザーの違反があるかチェックします。
Shift + F7 - プロジェクト全体に検証エラーとワークフロー アナライザーの違反があるかチェックします。
F8 - ファイルに検証エラーがあるかチェックします。
Shift + F8 - すべてのプロジェクト ファイルの検証エラーをチェックします。
F12 - 現在のワークフローの実行を停止します (標準モードとデバッグ モードの両方)。
選択したアクティビティ
Ctrl + C - 選択した 1 つ以上のアクティビティをクリップボードにコピーします。
Ctrl + V - コピーした 1 つ以上のアクティビティを選択した項目の中に貼り付けます。
Ctrl + Space - 式エディターで IntelliPrompt ウィンドウを開きます。
Ctrl + 1 ... Ctrl + 6 - IntelliPrompt ウィンドウが開いているときに、コード完了ウィンドウの各項目の種類の表示を有効化/無効化します。これは、ウィンドウ下部のボタンを使用するのと同じことです。Ctrl + 1 メソッド、Ctrl + 2 プロパティ、Ctrl + 3 クラス、Ctrl + 4 名前空間、Ctrl + 5 定数、Ctrl + 6 キーワード。
F2 - 選択されたアクティビティの名前の変更を可能にします。
Shift + F2 - 選択したアクティビティに注釈を追加します。
Shift + Tab - [アクティビティ] パネル内の前のアクティビティまたはノードに移動します。
ステータス バー
Alt + D - ステータス バーの [ソース管理]、Orchestrator のフォルダー、[Orchestrator/Cloud の接続] メニューにアクセスし、Shift + Tab キーを使用してメニューを切り替えます。メニューを選択したら、Enter キーを押して開きます。
その他
F1 - 選択した要素に関連したヘルプ トピックにアクセスできます。
Ctrl + P - [パッケージを管理] ウィンドウを開きます。
Esc - [パブリッシュ]、[パッケージを管理]、ファイル差分検出の各ウィンドウを閉じます。
Ctrl + F1 - リボンを最小化または展開します。
Ctrl + Alt + D - フォーカスを [デザイン] タブから [保存] ボタンに切り替えます。
Alt + - 現在選択しているパネルのタイトル バーで [オプション] コンテキスト メニューを開きます。この操作は、テンキー内のマイナス記号キーではなく、文字キー上のハイフン キーを使用することで可能になります。
リボンと [ホーム] タブのショートカット キー
Alt キーを押して離した後、1 つ以上のキーを押すことで、[ホーム] タブ (StudioX の Backstage ビュー) のほとんどのオプションと、[デザイン] タブのリボンにすばやくアクセスできます。
Alt キーを押して放すと、1 つ以上の文字または数字が現在のビューのオプションの上に表示されます。オプションを使用するには、該当するキー (複数可) を押します。最初のキーの組み合わせを押した後に、追加のキーを使用できるオプションもあります。
ショートカットのリストについては、以下のセクションをご覧ください。
[デザイン] タブのリボンのキー
[デザイン] タブを表示している場合は、Alt + D を押して、[デザイン] タブのリボンのショートカット キーにアクセスします。
| キー | 実行する操作 | 追加のキーとアクション |
|---|---|---|
| S | プロジェクトを保存します。 | – |
| R | [実行] ドロップダウンを開きます。 | F5 - 実行 F6 - PiP で実行 |
| C | 選択したアクティビティをコピー | – |
| X | 選択したアクティビティを切り取り | |
| V | コピーしたアクティビティを貼り付け | – |
| MP | [パッケージを管理] ウィンドウを開く | – |
| A | [ファイルを分析] ドロップダウンを開く | A - 分析 D - 検証 S - ワークフロー アナライザーの設定 |
| EX | [Excel にエクスポート] ウィンドウを開く | – |
| p | [パブリッシュ] ウィンドウを開く | – |
[ホーム] タブのキー
[デザイン] タブまたは [デバッグ] タブを表示している場合は、Alt + H を押して [ホーム] タブ (Studio の Backstage ビュー) を開き、[ホーム] タブのショートカット キーにアクセスします。[ホーム] タブを既に開いている場合は、Alt キーを押すだけです。
| キー | 実行する操作 | 追加のキーとアクション |
|---|---|---|
| Z | プロジェクトが開いている場合、前のタブに戻る | – |
| O | プロジェクトを開く | – |
| C | 現在開いているプロジェクトを閉じる | – |
| S | [開始] タブを開く | O - ローカル プロジェクトを開く B - 空のタスクを作成 T - テンプレートを作成 1...9 - 直近の 9 つのプロジェクトのいずれかを開く |
| T | [テンプレート] タブを開く | – |
| L | [ツール] タブを開く | U - UI Explorer を開く R - Microsoft Office 修復ツールを開く C - Chrome 拡張機能をインストール F - Firefox 拡張機能をインストール E - Edge 拡張機能をインストール J - Java 拡張機能をインストール S - Silverlight 拡張機能をインストール T - Citrix 拡張機能をインストール W - Windows リモート デスクトップ拡張機能をインストール V - VMware Horizon 拡張機能をインストール X - Excel アドイン拡張機能をインストール |
| E | [設定] タブを開く | G - [全般] タブを開く D - [デザイン] タブを開く L - [場所] タブを開く M - [パッケージ ソースを管理] タブを開く P - [ライセンスとプロファイル] タブを開く |
| H | [ヘルプ] タブを開く | D - 製品ドキュメントのリンクを開く F - コミュニティ フォーラムのリンクを開く H - ヘルプ センターのリンクを開く A - アカデミーのリンクを開く R - リリース ノートのリンクを開く S - 簡単なアンケートに回答するのリンクを開く C - ライセンス情報をコピー |
をクリックしても、同じ結果を得られます。
をクリックすることによっても、同じ結果を得ることができます。