Abonnieren

UiPath Studio

UiPath Studio-Anleitung

Über Automatisierungsprojekte

UiPath Studio ermöglicht die Erstellung folgender Projekttypen:

  • Prozess – Entwerfen Sie einen Automatisierungsprozess und veröffentlichen Sie ihn, damit er von Robotern ausgeführt werden kann.
  • Library - Design workflows as reusable components and publish the project as a library that can be added as a dependency to multiple processes. For more information, see About Libraries.
  • Test Automation - Design a test automation project. For more information about test automation, see the Test Suite section.
  • Template - Design a process and publish it as a template that other processes which share common characteristics can then be based on. For more information, see Project Templates.

Um ein neues leeres Projekt zu erstellen, wechseln Sie zu Start (Studio Backstage-Ansicht) > Starten und wählen Sie den Projekttyp aus, der unter Neues Projekt erstellt werden soll. Alternativ können Sie mit einer der Standardvorlagen beginnen, die unter Neu aus Vorlage verfügbar sind, oder zur Registerkarte Vorlagen wechseln, um nach weiteren Vorlagen aus verschiedenen Quellen zu suchen.

Konfigurieren Sie im neuen Projektfenster für jedes Projekt Folgendes:

  • Geben Sie einen Namen für das neue Projekt (bis zu 128 Zeichen) und eine Beschreibung ein, die zusammenfasst, was Sie mit diesem Automatisierungsprojekt erreichen möchten (bis zu 500 Zeichen).
  • Wählen Sie den Speicherort aus, an dem das Projekt erstellt werden soll. Der Standardspeicherort, an dem Projekte erstellt werden, lautet %USERPROFILE%\Documents\UiPath.
  • Select the compatibility and language.
    :information-source: Note: The compatibility and language cannot be changed after you create a project.

Standardmäßig enthält der Projektordner die folgenden Dateien und Unterordner:

  • Files
    • Main.xaml - Created by default to hold your main workflow. In addition, all the other automation XAML files you add to the project are stored in the project folder. Optionally, you can set a different file as main. All the files must be linked through the Invoke Workflow File activity to the file set as main or to a file marked as an entry point to the project. For test automation projects, a TestCase.xaml file is created by default instead of Main.xaml.
    • project.json – Enthält Informationen über Ihr Automatisierungsprojekt.
  • Subfolders
    • .entities – Enthält Daten über Entitäten, die aus dem Data Service importiert wurden, falls diese im Projekt verwendet werden.
    • .local – Enthält lokal für das Projekt zwischengespeicherte Daten.
      :information-source: Note: The .local folder is hidden. You can enable viewing hidden items from the Windows File Explorer settings.
    • .objects – Enthält Daten im Zusammenhang mit Elementen, die dem Object Repository hinzugefügt wurden, falls diese im Projekt verwendet werden.
    • .screenshots – Enthält informative Screenshots, die in UI-Automatisierungsaktivitäten generiert werden, falls welche im Projekt verwendet werden.
    • .settings – Enthält Aktivitätsprojekteinstellungen, die zur Laufzeit verwendet werden.
    • .templates – Enthält Dateivorlagen, die dem Projekt hinzugefügt wurden.
    • .tmh – Enthält Daten im Zusammenhang mit Testfällen, falls diese im Projekt verwendet werden.

📘

Wichtig:

Projekte, die mit neueren Versionen von Studio erstellt wurden, funktionieren möglicherweise nicht mit älteren Studio-Versionen. Lesen Sie mehr über Ab- und Aufwärtskompatibilität.

Festlegen der Projektkompatibilität

Wenn Sie ein neues Projekt im Studio-Profil erstellen, wählen Sie die Kompatibilität basierend auf der Umgebung aus, auf der das Projekt ausgeführt wird:

  • Windows – Legacy – Verwendet .NET Framework 4.6.1., die Kompatibilität, die in Versionen vor 2021.10 verwendet wurde. Dies ist die Standardoption.
  • Windows - Uses .NET 6 (in Studio 2021.10.6 and later versions) or .NET 5 (in Studio 2021.10 versions prior to 2021.10.6) with Windows support.
  • Cross-platform - Uses .NET 6 (in Studio 2021.10.6 and later versions) or .NET 5 (in Studio 2021.10 versions prior to 2021.10.6) with cross-platform support.

🚧

Wichtig

Windows and Cross-platform processes require Orchestrator 2021.10 and newer to run.

Informationen zu den Unterschieden zwischen Kompatibilitäten finden Sie in der folgenden Tabelle.

Windows - Legacy

Windows

Cross-platform

Process execution

32-bit

64-bit

64-bit

Supported platforms for execution

Windows (32-bit and 64-bit)

Windows (64-bit)

Windows and Linux (64-bit)

Processes are compiled when published

No. Published packages contain the project source files.

Yes. Published packages contain compiled DLL files.

Yes. Published packages contain compiled DLL files.

The design experience is the same for all compatibilities, but only the activities packages that support the selected compatibility can be installed from the package manager.

Die Kompatibilität jedes Projekts wird rechts neben der Studio-Statusleiste und im Panel Projekt > Abhängigkeiten-Knoten angezeigt. Die Kompatibilität wird auch im Eintrag jedes Projekts in der Liste Zuletzt verwendete öffnen unter Start (Studio Backstage-Ansicht) > Registerkarte Starten angezeigt.

Entwerfen plattformübergreifender Projekte

Plattformübergreifende Projekte ermöglichen es Ihnen, API-basierte Automatisierungen zu erstellen, die unter Windows sowie Unix-ähnlichen Betriebssystemen ausgeführt werden können.

📘

Hinweis:

In Version 2021.10 unterstützen plattformübergreifende Projekte die Ausführung nur unter Windows und Linux.

So erstellen Sie Unattended-Projekte mit plattformübergreifender Unterstützung:

  1. Erstellen Sie in Studio ein neues Projekt und wählen Sie die Option plattformübergreifende Kompatibilität aus. Diese Option ist für alle Projekttypen verfügbar.
  2. Entwerfen Sie die Automatisierung. Bitte beachten Sie, dass nicht alle Aktivitätspakete mit plattformübergreifenden Projekten kompatibel sind, sodass im Paketmanager nur eine begrenzte Auswahl an Paketen verfügbar ist. Die Standardabhängigkeiten für ein plattformübergreifendes Projekt sind UiPath.System.Activities und UiPath.WebApi.Activities.
  3. Testen Sie die Automatisierung. Es wird empfohlen, Automatisierungen auf den Maschinen zu testen, auf denen sie mit Remote-Debugging ausgeführt werden, das sowohl mit Windows- als auch mit Linux-Robotern funktioniert.
  4. Veröffentlichen Sie das Projekt nach dem Testen der Automatisierung im Orchestrator. Das Verfahren zum Ausführen von Unattended-Aufträgen ist für Windows und Linux identisch.

Einstellung der Projektsprache

Wenn Sie ein neues Projekt im Studio-Profil erstellen, können Sie auswählen, welche Sprache für Ausdrücke verwendet werden soll – entweder VB oder C#. VB ist die standardmäßig ausgewählte Sprache, aber Sie können C# als Standardsprache für neue Projekte festlegen, indem Sie zu Start (Studio-Backstage-Ansicht) > Einstellungen > Design gehen. Bei Projekten, die im StudioX-Profil erstellt werden, wird die VB.NET-Sprache für Ausdrücke verwendet.

Die Verwendung von VB- und C#-Ausdrücken im selben Projekt wird nicht unterstützt. Ebenso wenig wird die Verwendung von VB-Ausdrücken in C#-Workflows unterstützt und umgekehrt. Stellen Sie beim Kopieren und Einfügen der Aktivitäten von anderen Projekten und Aufrufen oder Importieren von Workflows sicher, dass sie dieselbe Sprache wie Ihr Projekt verwenden.

Sie können C#-Bibliotheken als Abhängigkeiten in VB-Projekten installieren und umgekehrt. Auf Standardwerte, die für Argumente im Bibliotheksprojekt unter Verwendung sprachspezifischer Ausdrücke definiert sind, kann jedoch nicht vom Projekt aus zugegriffen werden, in dem die Bibliothek installiert ist.

Einschränkungen von C#

  • Die aktuelle C#-Implementierung basiert auf dem C#-Compiler, der die C#-Version 5 verwendet, daher ist der Zugriff auf neuere Funktionen wie Coalescing-Zuweisung, Null-Bedingungsoperator, Null-Coalescing-Operator, String-Interpolation und andere nur eingeschränkt möglich.
  • Projekte, die Ausdrücke mit Inkrementen enthalten, sind ungültig.
  • Ausdrücke, die den Operator nameof() enthalten, werden als ungültig markiert und sind mit der aktuellen Implementierung von C# nicht erlaubt.
  • Ausdrücke, die Aufrufe von Methoden mit optionalen Argumenten enthalten, müssen Werte für die optionalen Argumente enthalten.
  • Die Entwurfszeit- und Laufzeitleistung von C#-Projekten ist im Vergleich zu VB.NET niedriger. Wenn Laufzeitleistung ausschlaggebend ist, empfehlen wir die Verwendung VB.NET anstelle von C#.

Einstellen der Projektversion

Semantikversionen

Das Schema der Semantikversionen hat das Format Major.Minor.Patch[-Suffix], wobei:

  • Haupt (Major) die Hauptversion ist.
  • Neben (Minor) die Nebenversion ist.
  • Patch (Patch) die Patch-Version ist.
  • Suffix (Suffix) (optional) ein Bindestrich gefolgt von einer Reihe durch Punkt getrennter Identifier unmittelbar hinter der Patch-Version ist. Damit wird eine frühere Version bezeichnet.

Identifier dürfen nur aus alphanumerischen ASCII-Zeichen und Bindestrich bestehen und nicht leer sein. Numerische Identifier dürfen nicht mit Nullen beginnen. Außerdem kann das Aufbauen von Metadaten durch Anhängen eines Plus-Zeichens und einer Reihe von durch Punkte getrennten Identifiern gekennzeichnet sein, die unmittelbar auf den Patch oder die frühere Version folgen, zum Beispiel 1.0.0-alpha+1.

Beim Erstellen eines neuen Prozesses oder einer Bibliothek ist das Standardversionsschema Semantik. Es kann im Fenster Veröffentlichen (Publish) geändert werden. Dazu hängt man einfach eine weitere Ziffer an die Versionsnummer an. Die Semantikversion des Projekts kann ebenfalls über die project.json-Datei geändert werden. Die Patch-Nummer 0 wird automatisch an Projekte mit der Versionsnummer major.minor angehängt.

Veraltete Versionen

Die für das Projekt generierte veraltete Versionsnummer hat das Format M.m.bbbb.rrrrr, wobei:

  • M ist die Hauptversion.
  • m ist die Nebenversion.
  • bbbb ist die Buildversion.
  • rrrrr ist die Revisionsversion.

Die Haupt- und Nebenversionen in der Datei project.json bearbeitet werden können, während die Build- und Revisionsversionen gemäß einem Algorithmus generiert werden. Der Build-Wert ist die Anzahl der seit dem 01.01.2000 vergangenen Tage. Der Revisionswert die Anzahl der Sekunden ist, die am aktuellen Tag bis zum Moment der Freigabe vergangen sind. Das Ergebnis wird durch 2 dividiert, sodass die maximale Revisionsanzahl nicht höher als 65535 ist.

Die vorgeschlagene Versionsnummer im Fenster Veröffentlichen (Publish) basierend auf dem vorherigen Versionsschema des Projekts generiert wird, während das aktuelle Datum und der Zeitstempel für Projekte berücksichtigt werden, die das 4-stellige Versionsschema verwenden.

Verwalten von Projekten

Im Panel Projekt (Project)können Sie den Inhalt des aktuellen Projekts anzeigen, Ordner hinzufügen, den Speicherort der Datei öffnen, Abhängigkeiten verwalten und Prozesseinstellungen anpassen.

Fügen Sie aus dem Datei-Explorer kopierte Dateien direkt in das Projekt-Panel ein. Dieselbe Aktion kann per Drag & Drop für eine oder mehrere Dateien durchgeführt werden, einschließlich .xaml-Workflows. Sie können auch die Tastenkombinationen Strg + C und Strg + V oder die Optionen Kopieren und Einfügen im Kontextmenü verwenden, um Dateien oder Ordner innerhalb des Panels zu kopieren und zu duplizieren.

Option

Description

Expand Allexpand_allexpand_all

Expands all nodes in the automation project.

Collapse Allcollapse_allcollapse_all

Collapses all nodes in the automation project.

Refreshrefreshrefresh

Refreshes the project.

Show All Filesshow_filesshow_files

Shows all files belonging to the automation project, including the project.json.

File Explorerfile_explorerfile_explorer

Opens the project's location on the machine.

Project Settingsproject_settingsproject_settings

Opens the Project Settings window for processes or libraries.

Kontextmenü für Projekte

Klicken Sie mit der rechten Maustaste im Projektfenster auf eine beliebige Stelle, um das Kontextmenü mit den in der folgenden Tabelle beschriebenen Optionen zu öffnen. Die verfügbare Gruppe von Optionen hängt von der mit der rechten Maustaste angeklickten Stelle im Fenster, vom Projekttyp sowie davon ab, ob das Projekt zu Source Control hinzugefügt wird.

Option

Description

Open Project Folder

Opens the local folder containing the project.

Project Settings

Opens the Project Settings window for adjusting project preferences.

Add

Opens a list of items that can be added to the project: folder, sequence, flowchart, state machine, global handler, workflow, or, in test automation projects, test case.

Import Workflows

Imports .xaml files to the project and adds Imported in the file name if it coincides with the name of the main file.

Import Files

Opens the File Explorer window for importing various files into your project.

Add to Source Control

Adds the current project to source control using Git Init, Copy to Git, Add to TFS, or Add to SVN options. Please note that this option is only visible when right-clicking the project node.
When a project is added to source control, additional options are available in the context menu. See the options for GIT and the options for SVN and TFS.

Open

Opens the selected files using the default program.

Open File Location

Opens the local folder containing the file.

Rename

Enables you to rename the selected file or folder, and opens the Rename Item window. The item is renamed in all occurrences.

Copy

Copies the selected files or folders to the clipboard. You can then paste them in the project panel or in the Windows file explorer.

Paste

Pastes files or folders that were copied to the clipboard.

Delete

Deletes the selected item only from your local machine.

Select for Compare

Selects the current file for comparison.

Compare with Selected

Compares the current file with the previously selected file using Compare Files.

Find References

Finds all references to the file in the project. The results are displayed in the Find References panel.

Debug File

Debugs the selected .xaml file.

Set as Main

Sets the selected .xaml file as Main in the project definition, meaning that the project execution starts with that file. There can only be one Main project file. The name of the file set as main appears in bold in the Project panel.

Properties

Open the library’s Properties window for adding a tooltip and Help Link.

Set as Global Handler

Sets the .xaml file as the Global Exception Handler for the project. This is applicable to one workflow per project/process.

Remove Handler

Removes the Global Exception Handler tag from the .xaml file.

Enable Entry Point

Marks the selected workflow file as an entry point for the process, making it possible to select it as the workflow to run first when using the Invoke Process and Run Parallel Process activities in other processes, or when starting a job from Orchestrator.
Notes:
When a file is marked as an entry point, an arrow is displayed on the icon next to the file name icon_enable_entry_pointicon_enable_entry_point.
Enabling a file that is ignored from publishing as an entry point sets the file as publishable.
This option is not available for test case files.
This option is not available in library projects.

Disable Entry Point

No longer marks the selected workflow file as an entry point for the process. This option is not available for the workflow file that is set as Main.

Extract as Template

Saves the selected workflow or test case as a template on which you can then base other files in the project. Using a file template allows you to save time when you need to create multiple files with the same structure. When you add a new workflow or test case, you have the option to base it on any template of the same type that exists in the Templates project folder.

Ignore from Publish / Set as Publishable

Marks one or more selected files as excluded from publishing or publishable.
Notes:
When a file is ignored from publishing, the icon next to the file name turns gray icon_ignore_publishicon_ignore_publish.
Ignoring a file marked as an entry point from publishing disables the entry point.
These options are not available for workflow files in library projects.
In projects where XAML files are compiled when published, workflow and test case files that are excluded from publishing are not compiled.

Make Private / Make Public

Marks one or more selected files in a library project as private or public, A private workflow file is included in the published package, but no reusable component is created and made available in the Activities panel in projects where the library is installed as a dependency.
Notes:
When a file is marked as private, the icon next to the file name turns gray icon_ignore_publishicon_ignore_publish.
These options are not available for test case files.

Create Test Case

Creates a test case that invokes the selected workflow file.

Convert to Test Case / Convert to Workflow

Converts the selected workflows to test cases or the selected test cases to workflows.

Import Test Cases

Imports test cases into the project as draft test cases.

Add Test Data

Opens the Import Data Variation Source window that enables you to add test data to the project. This option is only available for test cases.

Link to Test Manager

Opens the Link to Test Manager window that enables you to link the selected test cases to Test Manager.

Run Test Cases / Debug Test Cases

Runs or debugs multiple selected test cases.

Kontextmenüoptionen für GIT

In Projekten, die GIT-Repositorys hinzugefügt werden, wird neben jeder Datei im Projektfenster ein Symbol angezeigt, das den Dateistatus angibt:
git branchgit branch The file is synced with the repository.
git editedgit edited The file has been modified.
source control addedsource control added The file has been added.

Right-click a file or project node in the Project panel to open the GIT-specific context menu for Managing Projects with GIT.

Option

Description

Commit

Commits current changes to the local GIT repository.

Push

Pushes the current version onto the remote repository.

Pull (rebase)

Pulls remote files and rebases the current branch.

Manage Branches

Opens the GIT window with options for managing currently added branches.

Show Changes

Opens the File Diff window for comparing changes between the local version and the remote version of the file.

Show History

Opens the Show History window for comparing two versions of the same file.

Undo

Opens the Undo Pending Changes window if the file was not committed or pushed to the remote repository.

Copy Repository URL

Copies the repository URL of the project to the clipboard.

Kontextmenüoptionen für SVN und TFS

In Projekten, die GIT-Repositorys hinzugefügt werden, wird neben jeder Datei im Panel Projekt ein Symbol angezeigt, das den Dateistatus angibt:
svn lockedsvn locked The file is not checked out for editing.
svn checked outsvn checked out The file has been checked out for editing.
svn editedsvn edited The file has been edited.
source control addedsource control added The file has been added.

Right-click a file or project node in the Project panel to open the context menu with options specific to managing projects with TFS or SVN.

Option

Description

Open

Opens the selected .xaml file in the Designer panel, in read-only mode if it was not checked out for edit from the TFS/SVN repository.

Rename

Enables you to rename the selected file or folder, and opens the Rename Item window. When checking in the renamed .xaml file, the previously modified version must also be checked in.

Delete

Deletes the selected item only from your local machine. The latest checked in version of the file is still available in the TFS/SVN repository.

Check Out For Edit

Marks the selected file or folder as locked for editing. Checking out a file locks it on the server so that no one else can edit it.

Finish Editing

Checks in the project.json file in the respository, together with changes and a commit message.

Add

Uploads the selected item to the TFS/SVN server. This option is not available, if the item was previously uploaded to the server.

Get Latest Version

Downloads the latest version of the selected item from the TFS/SVN repository.

Show changes...

Opens the File Diff to compare changes between the versioned file and the one mapped locally.

Check In

Displays the Check In Changes window and enables you to upload the selected item to the server as the newest version. The .xaml file must be saved before uploading it. After it’s checked in, the file becomes read-only in Studio.

Undo

Displays the Undo Pending Changes window and enables you to Revert the changes done to the project, either revert modified files to previous or unversioned states, or retrieve files which were deleted from the local machine.

Changes cannot be reverted after the file was checked in.

Run

Runs the selected workflow, even if it's not checked out or added to the repository.

Set as Main

Sets the selected .xaml file as Main in the project. The first created .xaml is set as Main by default.

Copy Repository URL

Copies the repository URL of the project to the clipboard.

Anpassen der Projekteinstellungen

A set of individual settings can be established for each automation project that you’re working on. Such settings are available in the Project Settings window, which can be opened by clicking the settings_iconsettings_icon in the Project panel.

Feldbeschreibung für das Fenster „Einstellungen“

The following table describes the project settings for process, test automation, and template projects. For information about the settings available for libraries, see About Libraries.

Field

Description

Name

Change the name of the project. Such names may contain whitespace characters. When naming projects, keep in mind that whitespace characters are removed at publish time. This field accepts up to 128 characters.

Description

Change the project description. This field accepts up to 500 characters.

Automation Hub URL

URL of an Automation Hub idea linked to the project. For more information, see Linking a Project to an Idea in Automation Hub.

Package Icon

Optionally, define a custom icon for the project. You can browse to and select a file, or enter a path or public URL to an ico, jpeg, jpg, or png file up to 1MB in size.

After the project is published, the icon is displayed as follows:
For processes, in the Assistant next to the process name, making it easier to identify it in the list of processes.
For templates, next to the template in Home (Studio Backstage View) > Templates.
For libraries, next to the package in the Manage Packages window in Studio.
:information-source: The icon is not visible in Manage Packages if a local file is used for a library published to Orchestrator or a feed that does not support embedded icons, In this case, specify the icon using a URL.

Disable Pause

Enable or prevent users from pausing execution from the UiPath Assistant. Set to Yes if pausing the process during execution would result in crashing it. For example, if an activity in your workflow uses the Timeout property, pausing the execution might cause the timeout to expire, thus breaking the execution.

Attended Automation

Set to Yes to indicate that the project should only be executed in an attended context. Use this setting for projects that include UI Automation activities or other activities that require user interaction.

Starts in Background

Set to Yes to turn the project into a Background Process and allow it to run in the background concurrently with other processes, as long as it does not use UI interaction.

Supports Persistence

Set to Yes to turn the project into an Orchestration Process.

PiP Ready

Set to Yes to indicate that the project was tested using Picture in Picture. If set to No, when the process is run in PiP from the Assistant, a dialog informs the user it was not tested using this feature and prompts for confirmation before proceeding.

Starts in PiP

Set to Yes to indicate that the process should be run by default using the Picture in Picture feature.

Modern Design Experience

Set to Yes to enable a modern experience of working with UI Automation, including new and improved activities, recorders, and wizards, as well as the Object Repository.
This setting also enables / disables a modern design experience for Excel if the Excel Design Experience option is set to UseGlobalSetting in the Excel activities project settings.

Klicken Sie auf OK und die Änderungen werden im Panel Projekt (Project) und in der Datei project.json sichtbar gemacht.

Check out the Configuring Activity Project Settings page to read about how to adjust activity properties at project level.

📘

Hinweis:

Bitte berücksichtigen Sie, dass es sich empfiehlt, im Panel „Designer“ im Voraus nach unten zu scrollen, wenn Sie eine Vielzahl von Aktivitäten von einer Sequence in eine andere kopieren möchten. Dies ist durch die Begrenzung der Windows Workflow Foundation bedingt.

Entfernen nicht verwendeter Projektressourcen

Unnötige Ressourcen können die Verständlichkeit von Projekten erschweren und die Leistung beeinträchtigen. Um dieses Problem zu vermeiden, entfernen Sie nicht-verwendete Ressourcen aus Ihren Projekten, indem Sie im Studio-Menüband auf Nicht-verwendete entfernen klicken und dann auswählen, was entfernt werden soll:

  • Workflows – Entfernen Sie Workflow-Dateien, auf die im Projekt nicht verwiesen wird.
  • Variablen – Entfernen der Variablen, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Argumente – Entfernen Sie Argumente, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Abhängigkeiten – Entfernen Sie installierte Aktivitätspakete, aus denen keine Aktivitäten im Projekt verwendet werden.
  • Importe – Entfernen Sie importierte Namespaces, die in der aktuell geöffneten Datei nicht verwendet werden.
  • Screenshots – Entfernen Sie informative Screenshots, die in keiner Aktivität im Projekt verwendet werden.

Vor etwa einem Monat aktualisiert


Über Automatisierungsprojekte


Auf API-Referenzseiten sind Änderungsvorschläge beschränkt

Sie können nur Änderungen an dem Textkörperinhalt von Markdown, aber nicht an der API-Spezifikation vorschlagen.