- Versionshinweise
- Erste Schritte
- Einstellung und Konfiguration (Setup and Configuration)
- Automationsprojekte
- Abhängigkeiten
- Workflow-Typen
- Dateivergleich
- Beste Praktiken für die Automatisierung (Automation Best Practices)
- Integration der Quellenkontrolle
- Debugging
- Das Diagnose-Tool
- Workflow-Analyse
- Über die Workflow-Analyse
- ST-NMG-001 – Namenskonvention für Variablen
- ST-NMG-002 – Namenskonvention für Argumente
- ST-NMG-004 – Duplizierung des Anzeigenamens
- ST-NMG-005 – Variable überschreibt Variable
- ST-NMG-006 – Variable überschreibt Argument
- ST-NMG-008 – Variablenlänge überschritten
- ST-NMG-009: Datentabellenvariablen mit Präfix versehen
- ST-NMG-011 – Datentabellenargumente mit Präfix versehen
- ST-NMG-012 – Standardwerte für Argumente
- ST-NMG-016 – Argumentlänge überschritten
- ST-DBP-002 – Hohe Anzahl von Argumenten
- ST-DBP-003 – Leerer Catch-Block
- ST-DBP-007 – Mehrere Flussdiagrammebenen
- ST-DBP-020 – Nicht definierte Ausgabeeigenschaften
- ST-DBP-023 – Leerer Workflow
- ST-DBP-024 – Prüfung der Persistenzaktivität
- ST-DBP-025 – Voraussetzung für Variablenserialisierung
- ST-DBP-026 – Verwendung der Verzögerungsaktivität
- ST-DBP-027 – Bewährte Methode für Persistenz
- ST-DBP-028 – Voraussetzung für Argumentenserialisierung
- ST-USG-005 – Hartcodierte Aktivitätsargumente
- ST-USG-009 – Nicht verwendete Variablen
- ST-USG-010 – Nicht verwendete Abhängigkeiten
- ST-USG-014 – Paketbeschränkungen
- ST-USG-020 – Minimale Protokollmeldungen
- ST-USG-024 – Nicht verwendet, gespeichert für später
- ST-USG-025 – Missbrauch gespeicherter Werte
- ST-USG-026 – Aktivitätseinschränkungen
- ST-USG-027 – Erforderliche Pakete
- ST-USG-028 – Aufruf von Dateivorlagen einschränken
- Variablen
- Argumente
- Importierte Namespaces
- Kontrollfluss
- Objekt-Repository
- Protokollierung
- Das Tool ScreenScrapeJavaSupport
- Studio Testing
- Erweiterungen
- Fehlersuche und ‑behebung
- Informationen zur Fehlerbehebung
- Microsoft App-V – Unterstützung und Einschränkungen
- Fehlerbehebung bei Internet Explorer x64
- Probleme in Microsoft Office
- Erkennen von UI-Elementen in PDF mit Zugriffsoptionen.
- Reparieren der Active Accessibility-Unterstützung
- Fehlerbehebung bei JxBrowser-Anwendungen
- Überwachung der Benutzerereignisse (User Events Monitoring)
- Citrix-Fehlerbehebung
- Automatisieren von Anwendungen, die unter einem anderen Windows-Benutzer ausgeführt werden
Studio enthält mehrere Bereiche für den einfacheren Zugriff auf bestimmte Funktionalitäten. Diese können entweder angedockt oder als schwebende Fenster konfiguriert sein oder Sie aktivieren die Option Automatisch ausblenden in der Dropdownliste.
Überblick
| Nein. | Name | Beschreibung |
|---|---|---|
|
1 |
Greifen Sie auf die drei Hauptbereiche von Studio zu:
| |
|
2 | ||
|
3 |
Erstellen Sie Ihre Automatisierung, indem Sie die Aktivitäten verwalten, die der aktuellen Workflowdatei hinzugefügt wurden. | |
|
4 |
Suchen Sie innerhalb Ihres Projekts mit den verfügbaren Suchleisten: | |
|
5 |
Variablen verwalten. | |
|
6 |
Verwalten Sie Argumente. | |
|
7 |
Verwalten Sie importierte Namespaces. | |
|
8 |
Zeigen Sie den Inhalt Ihres aktuellen Projekts an, verwalten Sie Dateien, Ordner und Abhängigkeiten, und passen Sie die Projekteinstellungen an. | |
|
9 |
Zeigen Sie alle verfügbaren Aktivitäten an, und fügen Sie Aktivitäten zu Ihrer Automatisierung hinzu. | |
|
10 |
Verwenden Sie vorgefertigte Workflows, und fügen Sie Ihre eigenen wiederverwendbaren Automatisierungen hinzu. | |
|
11 |
Zeigen Sie die Eigenschaften einer ausgewählten Aktivität an, und konfigurieren Sie sie. | |
|
12 |
Zeigen Sie die Hierarchie des aktuellen Workflows und alle verfügbaren Knoten an. | |
|
13 |
Fügen Sie Ressourcen wie Assets, Warteschlangen, Prozesse und Entitäten aus Orchestrator hinzu. | |
|
14 |
Erstellen Sie UI-Taxonomien innerhalb und über Projekte hinweg, und verwenden Sie sie wieder. | |
|
15 |
Zeigen Sie die Ausgabe der Protokollnachricht und der Aktivitäten unter Zeile schreiben, Statusinformationen zur Ausführung Ihres Projekts, Fehler, die von Aktivitätspaketen generiert werden, und vieles mehr an. | |
|
16 |
Zeigen Sie alle Fehler an, die beim Ausführen der Workflow-Analyse generiert wurden. | |
|
17 |
Zeigen Sie alle Orte an, an denen in Ihrem Projekt auf ein Element verwiesen wird. | |
|
18 |
Verwalten Sie Haltepunkte, die dem Projekt hinzugefügt wurden. | |
|
19 |
Zeigen Sie Statusinformationen an, und verwalten Sie die Orchestrator-Verbindung und die Quellcodeverwaltungsintegration. |
Das Menüband
Registerkarten auf dem Menüband
The ribbon is straightforward and can be minimized or expanded by clicking the Minimize / Expand button
. It consists of the following three tabs:
-
Home - create and open projects, configure Studio, or access help and license information from the Studio Backstage View.
-
Design – Ergänzen Sie Ihr Projekt mit Sequences, Flowcharts und State Machines, installieren und verwalten Sie Aktivitätenpakete, erstellen Sie Interaktionen mit Elementen der grafischen Bedienoberfläche, exportieren Sie Workflows nach Excel, und veröffentlichen Sie Ihre Arbeit in Orchestrator oder benutzerdefinierten Feeds. Denken Sie daran, dass Assistenten und UI-Explorer im Menüband nur dann sichtbar sind, wenn Sie das Paket
UiPath.UIAutomation.Activitiesinstallieren. -
Debug - debug your workflow, while using debugging tools to set breakpoints, monitor the execution of activities step by step, and adjust the debugging speed. Open logs to view details regarding execution and any changes made to the project. For more information on debugging, check the About Debugging page.
Hinweis:Dateien, die nicht während der Ausführung des Automationsprojekts erstellt wurden, sind bei Veröffentlichung in Orchestrator schreibgeschützt. Wenn Ihr Geschäftsprozess es erfordert, dass Sie an einem bestimmten Punkt einer bestimmten Datei schreiben, achten Sie darauf, diese beim Projektdesign zu erstellen.
Die Titelleiste
Feedback senden
Es gibt zwei Arten von Feedback, das Sie direkt über Studio senden können: Eine Idee für das Produkt übermitteln oder Einen Fehler melden. Beide sind über das Menüband verfügbar, wenn Sie auf das Symbol
klicken.
Die Funktion Feedback senden dient ausschließlich zum Senden von anonymem Feedback an das Produktteam. Um mit unserem Support-Team Kontakt aufzunehmen, nutzen Sie bitte das Formular Technischen Support kontaktieren.
Geben Sie die folgenden Informationen an, und klicken Sie dann auf Übermitteln:
- Wählen Sie im Dropdown-Menü Ich möchte entweder Eine Idee für das Produkt einreichen oder Einen Fehler melden.
- Wählen Sie im Dropdown-Menü Für entweder UiPath-Aktivitäten, UiPath Studio, UiPath Robot, UiPath Orchestrator oder UiPath Assistant aus.
- Wählen Sie im Dropdownmenü Wie wichtig ist das für Sie entweder Wünschenswert, Wichtig oder Kritisch aus.
- Fügen Sie im Feld Betreff einen kurzen Titel hinzu.
- Fügen Sie eine detaillierte Beschreibung hinzu, und hängen Sie bis zu 6 Bild-, Video- oder Textdateien an, die jeweils kleiner als 10 MB sind. Die Schwellenwert für das Senden von Feedback liegt bei 3 Beiträgen in einem Zeitrahmen von 5 Minuten.
Hilfe
Click the Help icon to quickly access the resources that are also available in the Help tab in Backstage View, as illustrated below:
Backstage-Ansicht
Dies ist die Ansicht, die Sie sehen, wenn Sie Studio zum ersten Mal öffnen. Sie kommen auch hierher, indem Sie in der oberen linken Ecke des Fensters auf Startseite klicken. Hier können Sie Projekte erstellen und öffnen, Studio konfigurieren oder auf Hilfe- und Lizenzinformationen zugreifen.
Die folgenden Schaltflächen und Registerkarten sind in dieser Ansicht verfügbar:
-
Öffnen – Navigieren Sie zu einem lokalen Automatisierungsprojekt und öffnen Sie es. Standardmäßig werden Projekte in C:\Users<current_user>\Documents\UiPath erstellt.
Hinweis:Projects located on network folders where your user only has read permissions cannot be opened in Studio. We recommend using source control systems to collaborate on projects.
-
Close - Close the automation project that is currently open.
-
Start – Erstellen eines neuen Automatisierungsprojekts oder Öffnen eines kürzlich abgerufenen Projekts. Sie können ein neues Projekt aus vordefinierten Vorlagen erstellen oder ein Projekt öffnen, an dem Sie kürzlich gearbeitet haben. Projekte können der Liste „Zuletzt verwendete öffnen“ angeheftet oder aus ihr entfernt werden, in der die Beschreibung, das Zielframework, die für Ausdrücke verwendete Sprache und die Projektquelle (lokales oder GIT/SVN/TFS-Repository) für jedes Projekt angezeigt werden. Wenn Sie mit der Maus auf einen Eintrag in der Liste „Zuletzt verwendete öffnen“ zeigen, wird der Pfad zur
project.json-Datei angezeigt sowie wann das Projekt zuletzt geöffnet wurde. -
Templates - Create a new project based on a template. In this tab, you can view all available project templates, search and filter them by source. For more information, see Project Templates.
-
Team - Manage source control integration for the automation project.
-
Tools – Greifen Sie auf Tools zu, die Ihre Studio-Erfahrung verbessern.
- Select the Apps tab for the , Project Dependencies Mass Update Tool, and the Repair Tool for Microsoft Office.
- Select the UiPath Extensions tab to install or uninstall the following extensions: Chrome, Firefox, Edge, Java, Silverlight, Citrix, Windows Remote Desktop, VMware Horizon, Excel Add-in, and SAP Solution Manager.
- Select the Plugins tab to enable or disable source control and test automation plugins.
-
Settings - Change the look and feel of Studio, set global preferences, and manage activities package sources. For more information, see Configuring Studio Settings.
-
Help - Directs you to product documentation, release notes, online resources, the Community Forum and the RPA Academy.
Hier können Sie auch auf ein schnelles Tutorial zugreifen, mit dem Sie die Grundlagen des Erstellens, Veröffentlichens und Ausführens einer Automatisierung erlernen können.
Hinweis:Um sicherzustellen, dass das Tutorial erfolgreich abgeschlossen wird, empfehlen wir Ihnen, das Tutorial anzuhalten, bevor Sie Änderungen am Workflow vornehmen, die nicht in den Schritten des Tutorials hervorgehoben sind.
Überdies finden Sie auf der Registerkarte Hilfe Hinweise zur Produktversion und zur Installation, zur Lizenzverfügbarkeit, zum Aktualisieren der Kanal- und Geräte-ID zusammen mit einer Schaltfläche Info kopieren zum schnellen Kopieren von Details ins Clipboard.
Die Befehlspalette
Die Befehlspalette wird mit den Tastenkombinationen Strg + Umschalt + P, F3 oder durch Klicken auf die Suchschaltfläche geöffnet. Sie umfasst die Suchleisten Aktivität hinzufügen, Universalsuche, Zu Datei wechseln und Zu Aktivität wechseln.
Studio unterstützt die Priorisierung von Aktivitäten nach Scope. Klicken Sie innerhalb eines Aktivitäten-Scopes auf das Symbol
, und beachten Sie, dass die Befehlspalette Vorschläge für Aktivitäten anbietet, die zum aktuellen Scope passen. Die Unterstützung für diese Funktion wird schrittweise in offiziellen Aktivitätspaketen eingeführt, überprüfen Sie regelmäßig die Versionshinweise.
Aktivität hinzufügen
Die Suchleiste Aktivität hinzufügen wird mit der Tastenkombination Strg+Umschalt+T geöffnet. Sie können nach Aktivitäten in installierten Paketen suchen und diese nach der ausgewählten Aktivität in der Datei hinzufügen. Die Leiste weist den ersten fünf Ergebnissen automatisch Tastenkombinationen zu. Die vorherigen Ergebnisse bleiben erhalten.
Klicken Sie in einer Sequence oben oder unten in einer Aktivität auf das Symbol
, um die Suchleiste Aktivität hinzufügen zu öffnen.
If the Enable AI activity suggestions option in the Studio design settings is selected, a UiPath AI service analyzes the location in the workflow where you opened the Add activity search bar and suggests activities that you may want to add next based on the current context. If there is no context (for example, you press Ctrl + Shift + T when no activity is selected in the Designer panel) activity suggestions are not provided.
Die universelle Suche
In der Leiste Universelle Suche können Sie Snippets, Aktivitäten, Variablen, Argumente, Importe, Projektabhängigkeiten und Dateien in Ihrem aktuellen Projekt finden. Die Suche gibt Ergebnisse aus allen Workflowdateien zurück, einschließlich geschlossener Dateien.
| Option | Verknüpfung | Beschreibung |
|---|---|---|
| Aktuelle Datei | Strg + 1 | Listet Ergebnisse aus der aktuell geöffneten Datei auf, die der Suchanfrage entsprechen. |
| Alle Dateien | Strg + 2 | Listet die Ergebnisse auf, die in allen Dateien des aktuellen Projekts gefunden wurden und der Suchanfrage entsprechen. |
| Aktivitäten | Strg + 3 | Listet Ergebnisse von Aktivitäten auf, die der Suchabfrage entsprechen. |
| Variablen | Strg + 4 | Sucht alle Variablen des aktuellen Projekts, die der Suchanfrage entsprechen. |
| Argumente | Strg + 5 | Sucht im Projekt nach definierten Argumenten, die der Suchanfrage entsprechen. |
| Importe | Strg + 6 | Sucht im Projekt nach importierten Namespaces, die der Suchanfrage entsprechen. |
| Projektdateien | Strg + 7 | Sucht alle Dateien des aktuellen Projekts, die der Suchanfrage entsprechen. |
| Abhängigkeiten | Strg + 8 | Listet Ergebnisse auf, die in im Projekt installierten Abhängigkeiten zu finden sind. |
| Snippets | Strg + 9 | Findet Snippet-Dateien, die der Suchanfrage entsprechen. |
Die Suchergebnisse bleiben bis zum nächsten Öffnen der Suchleiste erhalten, falls Sie die universelle Suche oder Aktivität hinzufügen verwenden. Bei Zu Datei wechseln und Zu Aktivität wechseln bleibt die vorherige Suchanfrage nicht erhalten.
Doppelklicken Sie auf eine Aktivität, oder drücken Sie die Eingabetaste, um Sie der aktuell geöffneten Datei hinzuzufügen. Mit denselben Befehlen können Sie Dateien aus den Kategorien Alle Dateien und Projektdateien öffnen oder das gewünschte Suchergebnis fokussieren.
Standardwerte von Argumenten aus einem Prozess innerhalb der Aktivität Invoke Workflow können nicht mit der universellen Suche gefunden werden.
Zu Datei wechseln
Die Leiste Zu Datei wechseln sucht und öffnet Dateien aus dem aktuellen Projektordner. .xaml-Dateien werden in Studio im Panel Designer geöffnet. Andere Dateien, z. B. Screenshots oder Excel-Dateien werden in der jeweiligen Standardanwendung auf Ihrem Gerät geöffnet. Doppelklicken Sie, oder drücken Sie die Eingabetaste, um eine Datei zu öffnen.
Die Panels Aktivitäten und Projekt sowie die Befehlspalette unterstützen die Fuzzy-Suche. Das bedeutet, dass eine Liste von Ergebnissen zurückgegeben wird, auch wenn die Suchbegriffe nicht genau übereinstimmen. Die Suchbegriffe können leicht unvollständig oder falsch geschrieben sein oder nur den ersten Buchstaben eines jeden Wortes enthalten. Beispiel: Wenn Sie dci in die Leiste Aktivitäten eingeben, wird die Aktivität Double Click Image zurückgegeben.
Zu Aktivität wechseln
Die Suchleiste Zu Aktivität wechseln ist Teil der Befehlspalette und hilft Ihnen, bestimmte Aktivitäten in umfangreichen Workflows zu finden und zu fokussieren. Öffnen Sie sie entweder mit der Tastenkombination Strg + J, oder indem Sie die Tastenkombinationen F3 und Strg + Umschalt + P verwenden und dann Zu Aktivität wechseln auswählen.
Wenn sie geöffnet ist, zeigt die Leiste Zu Aktivität wechseln die Liste aller Aktivitäten in der .xaml-Datei, die im Panel Designer aktuell fokussiert ist.
Geben Sie den Anzeigenamen oder den Namespace einer Aktivität ein, z. B. Assign. Wählen Sie mithilfe der Pfeiltasten die Aktivität aus, und drücken Sie die Eingabetaste, um sie im Panel Designer zu fokussieren.
Aktivitäten in der Leiste Zu Aktivität wechseln werden in der folgenden Reihenfolge sortiert: Container, übergeordnete Aktivitäten und untergeordnete Aktivitäten.
Die Bereiche
Das Designer-Panel
The Designer panel displays your current automation project, enables you to make changes to it, and provides quick access to variables, arguments and imports.
Sie können innerhalb eines Diagramms navigieren, indem Sie auf die Aktivität doppelklicken, die Sie anzeigen möchten. Der Pfad wird als Breadcrumbs im Header des Bereichs Designer angezeigt. Beachten Sie, dass bei Verwendung mehrerer unterschiedlich skalierter Anzeigen der Text im Eingabefeld einiger Aktivitäten möglicherweise nicht korrekt angezeigt wird.
Aktivitäten können mit der Tastenkombination Strg + C oder dem Kontextmenü in einen Texteditor kopiert, geändert und dann wieder in das Designer-Panel kopiert werden. Sie können eine im Panel ausgeführte Aktion rückgängig machen oder wiederholen, indem Sie im Studio-Menüband die Schaltflächen anklicken oder Strg + Z/Strg + Y drücken.
If an activity has validation errors, an error icon
is displayed on the right side of the activity title bar in the Designer panel and a warning icon
is displayed for all its parent activities. Clicking the icons opens the Properties panel for the activity affected by the issue and the error message is displayed at the top of the Properties panel.
When you hover the mouse over an activity input field in the Designer panel or in the Properties panel, a Plus
button is displayed on the right side of the field. Clicking this button opens a menu with options that enable you to configure the activity:
-
Für die folgenden Aktivitätstypen können Sie die zugeordnete Ressource suchen und Daten, die dem Typ der Eigenschaft entsprechen, direkt in diesem Menü auswählen, ohne Ausdrücke manuell eingeben zu müssen:
- Excel-Automatisierung – Wenn die Moderne Excel-Designumgebung aktiviert ist, haben Sie in untergeordneten Aktivitäten der Use Excel File-Aktivität folgende Möglichkeiten:
- Wählen Sie Zellen, Bereiche, Tabellen, Blätter oder Diagramme vom Arbeitsblatt aus. Sie können auch die aktuelle Zeile oder das aktuelle Blatt in einer Iteration angeben.
- Erstellen Sie Eingaben basierend auf Zell- und Bereichsverweisen, Tabellen-, Diagramm- oder Blattnamen mit der Option Custom Input.
- Switch to Excel to indicate data directly from the file using the Indicate in Excel option. This functionality requires the Excel Add-in to be installed.
- PowerPoint-Automatisierung – Wählen Sie in untergeordneten Aktivitäten der Use PowerPoint Presentation-Aktivität Folien, Formen oder Layouts aus der PowerPoint-Datei aus.
- E-Mail-Automatisierung – Wählen Sie in untergeordneten Aktivitäten von Use Outlook 365-, Use Gmail- und Use Desktop Outlook App-Aktivitäten E-Mail-Daten wie Outlook-Ordner, Gmail-Labels, die aktuelle E-Mail in einer Iteration oder bestimmte Nachrichtenfelder vom E-Mail-Konto aus.
- Excel-Automatisierung – Wenn die Moderne Excel-Designumgebung aktiviert ist, haben Sie in untergeordneten Aktivitäten der Use Excel File-Aktivität folgende Möglichkeiten:
-
Open in Advanced Editor - Open the Expression Editor.
-
Variable erstellen – Erstellen Sie eine Variable.
-
Wert löschen – Löschen Sie einen vorhandenen Wert.
-
Datum/Uhrzeit wählen – Wählen Sie ein Datum aus dem Kalender oder eine Uhrzeit (Stunde, Minute) aus. Diese Option ist für Aktivitäten verfügbar, die TimeSpan-Werte als Eingabe akzeptieren.
Aktivieren Sie den Pan-Modus, indem Sie auf das Symbol
klicken, die Leertaste gedrückt halten oder die mittlere Maustaste drücken. Ändern Sie über die Auswahlliste „Zoom“ den Zoom und klicken Sie auf das Symbol
, um ihn auf 100 % zurückzusetzen.
Das Symbol An Bildschirm anpassen
ändert den Zoom so, dass der gesamte Workflow in den Bereich Designer passt. Klicken Sie auf das Symbol
, um einen Überblick über das gesamte Projekt zu erhalten und durch die Abschnitte zu navigieren, indem Sie den Fokus anpassen.
Das Kontextmenü
Über das Kontextmenü können Sie mehrere Vorgänge in Ihrem Workflow ausführen, sei es eine Sequence oder ein Flowchart. Um es anzuzeigen, klicken Sie mit der rechten Maustaste auf eine Aktivität in Ihrem Workflow.
Wenn Sie mehr Aktivitäten auswählen, wird das Menü überhaupt nicht angezeigt.
Feldbeschreibungen für das Kontextmenü
| Option | Beschreibung |
|---|---|
|
Übergeordnetes Element anzeigen |
Zeigt das übergeordnete Element der Zielaktivität im Bereich Designer an. |
|
Offen |
Öffnet die ausgewählte Aktivität im Panel Designer (Designer). Führt zu demselben Ergebnis wie ein Doppelklick. |
|
Reduzieren |
Reduziert die Aktivität und damit die angezeigten Details auf „Zum Anzeigen doppelklicken“. Dasselbe Ergebnis erzielen Sie durch Klicken auf die Schaltfläche Reduzieren |
|
Direkt erweitern |
Erweitert den Inhalt der Aktivität und zeigt ihren detaillierten Inhalt an. Dasselbe Ergebnis erzielen Sie durch Klicken auf die Schaltfläche Erweitern |
|
Ausschneiden |
Entfernt die ausgewählte Aktivität und legt Sie in der Zwischenablage ab. |
|
Kopieren |
Kopiert die ausgewählte Aktivität, und legt sie in der Zwischenablage ab. Aktivitäten aus schreibgeschützten Dateien können in einen anderen Workflow oder eine |
|
Einfügen |
Fügt den Inhalt der Zwischenablage an der aktuellen Stelle ein. |
|
Löschen |
Löscht die Zielaktivität. |
|
Anmerkungen |
Hinzufügen, Bearbeiten, Löschen, Anzeigen und Ausblenden von Anmerkungen zu Aktivitäten im Workflow. |
|
Als Bild kopieren |
Macht einen Screenshot vom Inhalt, der im Panel Designer (Designer) angezeigt wird. |
|
Als Bild speichern |
Macht einen Screenshot vom Inhalt, der im Panel Designer (Designer) angezeigt wird, und fordert den Benutzer auf, die Details für das Speichern (Name, Typ, Ziel) festzulegen. Unterstützte Formate: JPG, PNG, GIF, XPS. |
|
Variable erstellen |
Erstellt eine Variable im Panel Variable (Variable). |
|
Automatisch anordnen |
Ordnet Aktivitäten automatisch in einem Flowchart an. |
|
Umgebende Sequenz entfernen |
Entfernt die ausgewählte Sequence-Aktivität aus dem Panel Designer (Designer). Die darin enthaltenen Aktivitäten werden in die übergeordnete Sequence verschoben. |
|
Mit Try-Catch (Strg+T) umgeben |
Inserts the activity in a Try Catch statement. |
|
Als Workflow extrahieren |
Creates a new workflow containing the targeted activity with the purpose of breaking down a large project into smaller ones. In the place of the extracted activity an Invoke |
|
Workflow öffnen |
Öffnet einen Workflow, der mit der obigen Option erstellt wurde. |
|
Aktivität aktivieren |
Aktiviert eine zuvor deaktivierte Aktivität. |
|
Aktivität deaktivieren |
Deaktiviert eine Aktivität, die dann in eine Auskommentieren (Comment Out)-Aktivität platziert wird. |
|
Breakpoint umschalten (Toggle Breakpoint) |
Markiert die ausgewählte Aktivität als Haltepunkt für die Fehlersuche. Haltepunkte können auch umgeschaltet werden. Klicken Sie dazu auf die Schaltfläche Haltepunkt (Breakpoint) auf der Registerkarte Ausführen (Execute). Sie können immer nur einen Haltepunkt für eine Aktivität auslösen. |
|
Haltepunkteinstellungen bearbeiten |
Öffnet das Fenster Haltepunkteinstellungen. |
|
Bis zu dieser Aktivität ausführen |
Debuggt das Projekt und hält an, bevor diese bestimmte Aktivität ausgeführt wird. |
|
Ab dieser Aktivität ausführen |
Startet das Debugging von dieser Aktivität. |
|
Alle Bedingungen anzeigen |
Zeigt alle in Ihrem Projekt definierten Bedingungen an (Panel Eigenschaften (Properties) > Bedingungen (Conditions)). |
|
Alle Bedingungen ausblenden |
Blendet alle angezeigten Bedingungen aus. |
|
Als Startknoten festlegen |
Verbindet die ausgewählte Aktivität mit dem Knoten Start. |
|
Als Anfangsstatus festlegen |
Verbindet die spezifische Aktivität der State Machine mit dem Startknoten. |
Das Kontextmenü wird auch für Registerkarten im Panel Designer (Designer) angezeigt. Die folgenden Optionen sind verfügbar:
| Option | Beschreibung |
|---|---|
| Schließen | Schließt die aktive Registerkarte. |
| Andere schließen | Schließt alle Registerkarten, bis auf die aktive. |
| Alle Dokumente schließen | Schließt alle Registerkarten. |
| Frei anordnen | Dockt die Zielregisterkarte ab und ändert sie in einen schwebenden Zustand. |
| Registerkarte anheften | Heftet die Zielregisterkarte im Panel Designer (Designer) an. Die zuletzt angeheftete Registerkarte wird immer vor alle anderen vorhandenen Registerkarten verschoben (angeheftet oder nicht). Die Position einer angehefteten Registerkarte kann nur relativ zu anderen angehefteten Registerkarten geändert werden. |
| Neue horizontale Registerkartengruppe | Teilt den Bildschirm horizontal auf, sodass Sie zwei oder mehr Instanzen des Designer (Designer)-Panels auf demselben Bildschirm sehen können. Das Zielprojekt wird auf das Panel auf der rechten Seite verschoben. Nur angezeigt, wenn Ihr Projekt zwei oder mehr Registerkarten und implizit Workflows enthält. |
| Neue vertikale Registerkartengruppe | Teilt den Bildschirm vertikal auf, sodass Sie zwei oder mehr Instanzen des Designer (Designer)-Panels auf demselben Bildschirm sehen können. Das Zielprojekt wird auf das Panel auf der untere Seite verschoben. Nur angezeigt, wenn Ihr Projekt zwei oder mehr Registerkarten und implizit Workflows enthält. |
| In vorherige Registerkartengruppe verschieben | Verschiebt die Zielregisterkarte in den zuvor angezeigten Bereich Designer. Nur angezeigt, wenn Sie zuvor die Optionen Neue vertikale Registerkartengruppe oder Neue horizontale Registerkartengruppe verwendet haben. |
| In die nächste Registerkartengruppe verschieben | Verschiebt die Zielregisterkarte in den als nächstes angezeigten Bereich Designer. Nur angezeigt, wenn Sie zuvor die Optionen Neue vertikale Registerkartengruppe oder Neue horizontale Registerkartengruppe verwendet haben. |
Das Projekt-Panel
The Project panel enables you to manage project files, dependencies, and configure project settings. For more information, see Managing Projects.
Das Aktivitäten-Panel
The Activities panel shows available activities that can be added to the current workflow. You can search for activities by name and optionally by description using the search box at the top of the panel, navigate through them using navigation keys, and press Enter to add the selected activity to the currently opened file.
Im Suchfeld können Sie Aktivitäten nach Klassennamen suchen, ohne die in Studio eingestellte Bedienoberfläche zu berücksichtigen.
Wenn Sie den Mauszeiger über eine Aktivität im Bedienfeld bewegen, wird das Paket, zu dem sie gehört, und dessen Beschreibung angezeigt. Um der Favoritenliste eine Aktivität hinzuzufügen, klicken Sie mit der rechten Maustaste darauf und wählen Sie Zu Favoriten hinzufügen aus.
Right-click an activity in the panel and select Create Test Bench to test out one or more activities before adding them to a project. Read more about this here.
Anpassen des Aktivitätenbereichs
Click the View Options
button at the top of the panel to open a menu that allows you to customize the panel. See the following table for a list of available options.
| Option | Beschreibung |
|---|---|
| Favoriten anzeigen | Einen Abschnitt mit bevorzugten Aktivitäten anzeigen. Diese Option ist standardmäßig ausgewählt. |
| Aktuelle anzeigen | Einen Abschnitt mit den zehn zuletzt verwendeten Aktivitäten anzeigen. Diese Option ist standardmäßig ausgewählt. |
| Verfügbare anzeigen | Alle verfügbaren Aktivitäten anzeigen. Diese Option ist standardmäßig ausgewählt. |
| Kompatibilität anzeigen | Option wird derzeit nicht verwendet. Diese Option ist standardmäßig nicht ausgewählt. |
| Klassisch/modern anzeigen | Moderne UI-Automatisierungsaktivitäten in Projekten mit der klassischen Designumgebung oder klassische UI-Automatisierungsaktivitäten in Projekten mit der modernen Umgebung anzeigen. Diese Option ist standardmäßig nicht ausgewählt. |
| Kategorien anzeigen | Aktivitäten nach der Kategorie, zu denen sie gehören, gruppieren. Diese Option ist standardmäßig ausgewählt. |
| Nach Paketen gruppieren | Aktivitäten nach den Paketen, zu denen sie gehören, gruppieren. Diese Option ist standardmäßig nicht ausgewählt. |
| Anhand der Beschreibung suchen | Bei der Suche im Panel in Aktivitätsbeschreibungen suchen, nicht nur in Aktivitätsnamen. Diese Option ist standardmäßig nicht ausgewählt. |
| Favoriten anheften | Bei der Suche im Bereich die bevorzugten Aktivitäten immer sichtbar lassen. Verfügbar, wenn Favoriten anzeigen ausgewählt ist. Diese Option ist standardmäßig nicht ausgewählt. |
Das Snippets-Panel
Im Snippets-Panel können Sie Automationen einfach wiederverwenden. Es enthält per Standard mehrere Beispiele und Snippets.
Sie können auch Ihre eigenen hinzufügen, indem Sie auf die Schaltfläche Ordner hinzufügen (Add Folder) klicken und ein Verzeichnis auf Ihrer Festplatte auswählen. Leere Ordner werden nicht angezeigt.
Um einen Ordner zu entfernen, klicken Sie mit der rechten Maustaste darauf und wählen Sie Entfernen (Remove) aus.
Das Eigenschaften-Panel
Das Panel Eigenschaften (Properties) ist kontextabhängig und ermöglicht das Anzeigen und Ändern der Eigenschaften einer ausgewählten Aktivität. Wenn Sie zwei Aktivitäten in ein- und demselben Workflow auswählen, können gemeinsame Eigenschaften aus dem Panel Eigenschaften (Properties) geändert werden.
Der Ausdrucks-Editor
Auf den Ausdrucks-Editor kann mit der Tastenkombination Strg + Umschalt + E zugegriffen werden, wenn er in Aktivitätseingabefeldern verwendet wird. Er ist auch im Eigenschaftenbereich in Feldern, in denen Text eingegeben werden muss, sowie im Textkörper einer Aktivität verfügbar, indem Text direkt in den Pflichtfeldern hinzugefügt wird.
Expressions can be written on multiples lines. Keyboard shortcuts for creating variables and arguments directly in expressions are available.
Verwenden Sie Strg + F im Editor, um die Funktionen für Suchen und Ersetzen zu öffnen. Wählen Sie einen Teil eines Ausdrucks aus, und drücken Sie Strg + F3, um den Text zum Suchfeld hinzuzufügen. Halten Sie die Strg-Taste gedrückt, um den Suchbereich halbtransparent zu machen und den Text dahinter anzuzeigen.
Wenn Sie den Editor schließen, werden seine Position auf dem Display, die Fenstergröße und der Zoomfaktor des Textes gespeichert und beim nächsten Öffnen angewendet.
Das Gliederungspanel
Das Gliederungspaneel (Outline) zeigt die Projekthierarchie und alle verfügbaren Knoten an. Sie können Aktivitäten in diesem Panel markieren, indem Sie sie im Panel Designer (Designer) auswählen, oder zu einer bestimmten Aktivität wechseln, indem Sie sie im Panel Outline auswählen.
Das Ausgabe-Panel
Das Panel Ausgabe (Output) ermöglicht Ihnen unter anderem die Ausgabe der Aktivitäten Protokollnachricht (Log Message) oder Zeile schreiben (Write Line). Ausnahmen für Pakete werden in diesem Panel ebenfalls angezeigt.
Über das Panel Ausgabe (Output) können Sie Meldungen ein- oder ausblenden, die unterschiedliche Protokollierungsstufen (Fehler, Warnungen) aufweisen. Dazu müssen Sie auf die Schaltflächen im Panel-Kopf klicken. Durch Doppelklicken auf eine Nachricht werden weitere Details über diese angezeigt, mit der Option, Informationen zu kopieren.
Wenn Sie im Panel Ausgabe nach einem Protokoll suchen und ein Element der Suchergebnisliste auswählen, wird das Protokoll hervorgehoben.
Mit der Schaltfläche Protokolle exportieren exportieren Sie Protokolle in eine .txt-Datei. Zeitstempel und Fehlermeldungen werden ebenfalls exportiert. Es ist möglich, gefilterte Protokolle zu exportieren. Wenn Sie beispielsweise nur Protokolle der Verfolgungsebene exportieren möchten, filtern Sie die Liste, und benutzen Sie dann die Schaltfläche Protokolle exportieren.
Beim Debugging zeigt das Panel Ausgabe Protokolle für die Ausführungsstartzeit einer Aktivität bis zu deren Ende an. Dies können Sie mit der Option Aktivitäten protokollieren auf der Registerkarte Debuggen aktivieren.
The Error List panel displays errors found in the file or project during the validation process, together with errors generated by Workflow Analyzer rules.
Mit der Schaltfläche Alle löschen (Clear All) löschen Sie alle Informationen, die im Panel Ausgabe (Output) angezeigt werden. Protokolle und andere in diesem Panel gespeicherte Daten werden beim Ausführen des Workflows gelöscht. Im PanelAusgabe (Output) werden bis zu 2.000 Zeilen gleichzeitig angezeigt.
Das Ausgabe-Panel ist nicht für die Produktionsüberwachung vorgesehen und sollte nur beim Entwickeln von Automatisierungen verwendet werden. Ereignisse werden möglicherweise nicht wie erwartet angezeigt, wenn z. B. eine große Anzahl von Log Message-Aktivitäten verwendet wird. Zum Überwachen von Produktionsläufen verwenden Sie die Orchestrator Protokolle.
Der Bereich „Verweise suchen“
Im Bereich Verweise suchen werden Ergebnisse für Verweise angezeigt, nach denen Sie in Ihrem Projekt suchen. Um jede Stelle im Projekt zu finden, an der auf ein Element verwiesen wird, klicken Sie mit der rechten Maustaste darauf und wählen Sie Verweise suchen aus. Dies funktioniert für:
-
Dateien im Bereich Projekt
-
Aktivitäten im Bereich Aktivitäten
-
Variablen im Bereich Variablen
-
Argumente im Bereich Argumente
-
Deskriptoren im Bereich Object Repository
Der Bereich „Ressourcen“
The Resources panel in Studio can load assets, queues, processes, and entities, provided that the Robot is connected to Orchestrator. Read the Connecting Robots to Orchestrator page to find the steps.
Falls der mit dem Orchestrator verbundene Roboter den Typ Standard aufweist, dann kann im Bereich Ressourcen nur der klassische Ordner angezeigt werden, den der Roboter bereitgestellt hat.
If the Robot is of type Floating, the panel can display resources from all classic and modern folders that this Robot has access to. Find out more about robots and folders in the Orchestrator Guide.
- When using a classic, manually provisioned robot, it must be granted
Viewpermissions for the corresponding resources (i.e. Assets, Queues, and Processes) to appear in the panel. Read more about setting up Roles and permissions in Orchestrator. - Wenn es sowohl klassische als auch moderne Ordner im Orchestrator gibt und Sie mit dem Orchestrator über einen Roboter aus einem modernen Ordner verbunden sind (Sie haben sich mit Ihrem Konto angemeldet oder über einen Maschinenvorlagenschlüssel verbunden), dann sind die Prozesse in den klassischen Ordnern im Panel „Ressourcen“ nicht verfügbar. Um von einem klassischen Ordner aus auf die Prozesse zugreifen zu können, verbinden Sie sich mit dem Orchestrator über einen klassischen Roboter mit einer Standardmaschinenschlüssel-Verbindung.
Auswählen eines Orchestrator-Ordners
The folder from which resources are currently loaded in the panel is displayed in the Studio status bar. You can switch to a different folder that you have access to by clicking the current folder name, and then selecting another Orchestrator folder from the menu that appears. In addition to the resources that are available in Studio, the folder selection also determines the default targets available when publishing your processes.
Um Ressourcen in das Panel zu laden, klicken Sie oben im Ressourcen-Panel auf die Schaltfläche Aktualisieren. Zeigen Sie mit der Maus auf den Ordnernamen in der Statusleiste, um die Orchestrator-URL anzuzeigen.
Protokolle, die aus Prozessen in Unterordnern generiert werden, sind in Orchestrator nur sichtbar, wenn der Unterordner im Bereich Ressourcen ausgewählt ist.
Verwenden von Orchestrator-Ressourcen in Ihren Projekten
Ziehen Sie Assets, Warteschlangen oder Prozesse aus dem Bereich Ressourcen direkt in Ihr Automatisierungsprojekt. Auf diese Weise werden geeignete Aktivitäten in der Suchleiste Aktivität hinzufügen vorgeschlagen. Wählen Sie beispielsweise nach dem Ziehen einer Warteschlange in Ihr Projekt die Aktivität Add Queue Item in der Suchleiste Aktivität hinzufügen aus und beachten Sie, dass die Warteschlange automatisch der Eigenschaft Queue Name der Aktivität zugewiesen wurde.
Sie können auch mit der rechten Maustaste auf ein beliebiges Element im Ressourcen-Panel klicken und dann Kopieren auswählen, um seinen Namen zu kopieren und ihn in Aktivitäten zu verwenden, die mit diesen Ressourcen interagieren.
Debuggen von Panels
The following panels are available to help you debug your projects: Breakpoints, Call Stack, Locals, Watch, and Immediate.
Die Statusleiste
In der Statusleiste können Sie Statusinformationen und Zugriffsoptionen im Zusammenhang mit dem Orchestrator und der Source Control anzeigen:
-
Orchestrator-/Cloud-Verbindung – Klicken Sie auf
, um auf die Orchestrator-Optionen zuzugreifen: Melden Sie sich bei Ihrem Cloud-Konto an, trennen Sie die Verbindung zum Orchestrator (falls mit einem Maschinenschlüssel verbunden) und aktualisieren Sie Ressourcen. -
Orchestrator-Status – Zeigt den Verbindungsstatus des Orchestrators an. Wenn eine Verbindung mit dem Orchestrator besteht, wird der aktuell ausgewählte Ordner angezeigt. Sie können auf den Namen des aktuellen Ordners klicken, um eine Liste mit den verfügbaren Ordnern anzuzeigen und einen anderen Ordner auszuwählen, von dem aus die Ressourcen synchronisiert werden sollen.
-
Source Control - Depending on whether the project is connected to a source control repository, different options are available to help you manage source control integration. For more information, see About Version Control.
-
Projektsprache – Zeigt die Sprache an, die für Ausdrücke im Projekt verwendet wird: VB oder C#.
-
Projektkompatibilität – Zeigt die Kompatibilität des Projekts an: Windows – Legacy, Windows oder plattformübergreifend.
- Überblick
- Das Menüband
- Registerkarten auf dem Menüband
- Die Titelleiste
- Backstage-Ansicht
- Die Befehlspalette
- Aktivität hinzufügen
- Die universelle Suche
- Zu Datei wechseln
- Zu Aktivität wechseln
- Die Bereiche
- Das Designer-Panel
- Das Projekt-Panel
- Das Aktivitäten-Panel
- Das Snippets-Panel
- Das Eigenschaften-Panel
- Das Gliederungspanel
- Das Ausgabe-Panel
- Der Bereich „Verweise suchen“
- Der Bereich „Ressourcen“
- Debuggen von Panels
- Die Statusleiste
.
.