UiPath Documentation
studio
2024.10
false
Studio 用户指南
重要 :
新发布内容的本地化可能需要 1-2 周的时间才能完成。

用户界面

Studio 用户界面:用于高效访问 Studio 功能的面板、停靠选项、自动隐藏和布局功能。

Studio 包含多个面板,以便更轻松地访问特定功能。 它们可以对接,充当浮动窗口,或者可以从下拉列表中启用“自动隐藏”选项。

概述​

编号

名称

描述

1

  • 主页 - 转到 Studio 后台视图,您可以在其中打开和创建项目、配置 Studio 等。
  • 设计 - 使用“命令选项板”和 Studio 面板中提供的工具构建自动化
  • “调试”- 使用一组全面的工具来调试工作流。有关更多信息,请参阅关于调试。

2

3

通过管理添加到当前工作流文件中的活动来构建自动化。

4

5

管理变量。

6

管理参数。

7

管理导入的命名空间。

8

查看当前项目的内容,管理文件、文件夹和依赖项,以及调整项目设置。

9

查看所有可用活动并将活动添加到自动化中。

10

使用预先构建的工作流并添加您自己的可重复使用的自动化流程。

11

查看和配置所选活动的属性。

12

管理项目中的数据。

13

查看当前工作流和所有可用节点的层次结构。

14

在流程内部和跨流程创建和重用 UI 分类法。

15

查看与测试自动化相关的信息。

16

查看“日志消息”和“写入行”活动的输出、有关项目执行状态的信息、活动包生成的错误等。

17

查看项目中引用元素的所有位置。

18

查看运行工作流分析器时生成的所有错误。

19

管理添加到项目中的断点。

20

查看状态信息,并管理 Orchestrator 连接和源代码控件集成的状况。

功能区​

功能区显示选项​

您可以通过单击以下内容来配置功能区,以增加或减少“设计器”面板的可用空间:

  • 精简视图压缩视图,以获取功能区的简化视图。

  • 标准视图标准视图,以查看完整尺寸的功能区。

您还可以通过单击显示或隐藏功能区:

  • 固定功能区固定功能区,以始终显示功能区。

  • 取消固定功能区取消固定功能区,以仅显示功能区选项卡。您也可以右键单击已固定功能区,然后选择“折叠功能区” 。

功能区选项卡​

功能区包含以下三个选项卡:

  • 主页 - 创建和打开项目、配置 Studio 或从 Studio 的“后台视图”查看帮助和许可证信息。

  • 设计 - 向项目中添加序列、流程图和状态机,安装和管理活动包,与用户界面元素构建交互,将工作流导出到 Excel,然后将您的工作发布到 OrcheStrator 或自定义订阅源。请记住,除非您安装 UiPath.UIAutomation.Activities 包,否则“功能区”中将不会显示“向导”和“用户界面探测器”。

  • 调试 - 调试工作流,同时使用调试工具设置断点,逐步监视活动的执行,并调整调试速度。打开日志,查看有关项目执行以及对项目进行的任何更改的详细信息。如需有关调试的更多信息,请查看关于调试页面。

    备注:

    不是在执行自动化项目期间创建的文件在发布到 Orchestrator 之后将变为只读文件。如果您的业务流程要求您在某个时候写入特定的文件,请确保在设计项目时创建该文件。

标题栏​

发送反馈​

您可以直接从 Studio 中发送以下两类反馈:“提交产品建议”或“报告错误”。您可以单击功能区中的 docs image 图标访问这两类反馈。

“发送反馈”功能必须仅用于向产品团队发送匿名反馈。 要联系我们的技术支持团队,请使用“联系技术支持”表单。

提供以下信息,然后单击“提交”:

  • 从“我希望”下拉菜单中,选择“提交产品建议”或“报告错误”。
  • 从“对象”下拉菜单中,选择“UiPath 活动”、“UiPath Studio”、“UiPath 机器人”、“UiPath Orchestrator”或“UiPath 助理”。
  • 从“这对您的重要性”下拉菜单中,选择“值得拥有”、“重要”或“关键”。
  • 在“主题”字段中,添加简短的标题。
  • 添加详细说明并附加最多 6 个图片、视频或文本文件,每个文件均需小于 10MB。发送反馈的阈值为 5 分钟内发送 3 次。
帮助​

单击“帮助”图标可快速访问“后台视图”>“帮助”选项卡中的可用资源,如下所示:

后台视图​

这是您首次打开 Studio 时看到的视图。您也可以通过单击窗口左上角的“主页”进入此视图。您可以在此处创建和打开项目、配置 Studio 或访问帮助和许可证信息。

此视图中提供以下按钮和选项卡:

  • 打开 - 浏览到本地自动化项目并将其打开。 默认情况下,项目创建在 C:\Users<current_user>\Documents\UiPath 中。

    备注:

    无法在 Studio 中打开位于用户仅具有读取权限的网络文件夹中的项目。 我们建议使用来源控件系统来协作处理项目。

  • Close - Close the automation project that is currently open.

  • “开始”- 创建新的自动化项目或打开最近访问的项目。

    • 从预定义模板创建或打开最近的项目
    • 从“打开最近的项目”列表中固定或删除项目
    • 查看项目说明、目标框架、语言和来源(本地、Studio Web 或 Git/SVN/TFS)
    • 将鼠标悬停在条目上可查看 project.json 路径和上次打开的日期
  • 模板 - 基于模板创建新项目。在此选项卡中,您可以查看所有可用的项目模板,并可按来源搜索和筛选模板。有关详细信息,请参阅项目模板。

  • “团队”- 管理自动化项目的“源代码控件集成”。

  • 工具 - 访问可增强 Studio 体验的工具。

  • 设置 - 更改 StudioX 的外观、设置全局首选项以及管理活动包来源。有关详细信息,请参阅配置 Studio 设置。

  • 帮助 - 提供产品文档、发行说明、在线资源、社区论坛和 RPA 学院。 您还可以在这里访问快速教程,该教程可以帮助您学习创建、发布和运行自动化的基础知识。

    备注:

    为了确保教程成功完成,我们建议您在对教程步骤中突出显示的更改以外的工作流进行任何更改之前,先暂停教程。

    Information regarding product version and installation, license availability, and device ID is also found in the Help tab, together with a Copy Info button for quickly copying the details to the clipboard.

命令面板​

通过使用 Ctrl + Shift + P、F3 键盘快捷键或单击搜索按钮打开命令选项板。 它整合了“添加活动”、“通用搜索”、“转到文件”和“跳转到活动”搜索栏,以及“向前导航”和“向后导航”文件导航选项。

备注:

Studio 支持按照作用域划分活动的优先级。单击活动作用域内的 命令面板 图标,并要注意,“命令面板”提供了适合当前作用域的活动的相关建议。官方活动包中分阶段推出了对此功能的支持,您可定期查看发行说明。

添加活动​

使用 Ctrl + Shift + T 键盘快捷方式打开“添加活动”搜索栏。 您可以在已安装和可安装的包中搜索活动,并将其添加到文件中所选活动后。 栏会自动将键盘快捷方式分配给前五个结果,并记住您之前的搜索结果。

单击序列中某个活动顶部或底部的 docs image 图标即可打开“添加活动”搜索栏。

如果在 Studio 设计设置中选择了“启用 AI 活动建议”选项,UiPath AI 服务会分析您在工作流中打开“添加活动”搜索栏的位置,并根据当前上下文建议您接下来可能要添加的活动。如果没有上下文(例如,在“设计器”面板中未选择任何活动时按 Ctrl + Shift + T),则不会提供活动建议。

如果选择了 Studio 设计设置中的“显示可安装的活动”选项,您可以搜索未包含在已安装的包中的活动。 搜索可安装活动仅适用于官方订阅源和 Orchestrator 租户订阅源中的包。添加可用活动还会安装其相应的活动包。 选择安装docs image按钮会安装包,而不会将活动添加到工作流。

使用 Autopilot 生成工作流​

借助 Autopilot 生成功能,您可以使用自然语言来描述工作流的结构和结果。要自动生成工作流,只需在搜索栏中输入您的工作流应执行的操作,然后双击“使用 Autopilot 生成”选项。然后,Autopilot 将分析您的说明,识别相关活动,并按逻辑顺序添加这些活动。如果说明无效,系统会要求您尝试其他说明。

处理完您的说明后,系统将在新序列中创建建议工作流的预览。预览版包含将在自动化中使用的活动。将鼠标指针悬停在活动上会显示该活动所属的活动包。

正在优化和确认​

您的说明也将作为批注添加,用于编辑建议的工作流。 如果您对 Autopilot 创建的结构不满意,可以通过在注释内部单击,编辑说明,然后选择“生成”按钮来优化初始说明,该操作将创建新的工作流预览。

确保工作流按预期工作后,请选择“确认”按钮,让 Autopilot 构建工作流。 您还可以通过选择“保留围绕的序列”选项,来保留围绕生成的工作流的“序列”活动,从而进一步编辑生成的工作流。否则,请选择“取消”按钮,以放弃预览。

工作流生成后,您可以通过在序列批注中单击来修改说明。 这次选择“生成”按钮后,将出现一个消息窗口,通知您所有当前活动及其配置都将丢失,并要求您确认生成。 选择“确定”,根据更新的说明继续生成新的工作流,或选择“取消”,保留当前工作流。

备注:
  • 您可以从任何序列生成工作流,包括放置在另一个工作流中的序列。
  • 访问 Autopilot 功能需要 Automation Cloud™ 连接。

“通用搜索”栏使您可以查找当前项目中的代码片段、活动、变量、参数、导入、项目依赖项和文件。搜索从所有工作流文件(包括已关闭的文件)中返回结果。

选项快捷方式描述
当前文件Ctrl + 1列出当前打开的文件中与搜索查询相匹配的结果。
所有文件Ctrl + 2列出当前项目的所有文件中与搜索查询相匹配的结果。
Activities (活动)Ctrl + 3列出与搜索查询匹配的活动的结果。
变量Ctrl + 4查找当前项目中与搜索查询相匹配的变量。
参数Ctrl + 5查找项目中定义的与搜索查询相匹配的参数。
导入Ctrl + 6在项目中查找与搜索查询相匹配的已导入命名空间。
项目文件Ctrl + 7查找当前项目中与搜索查询相匹配的文件。
依赖项Ctrl + 8列出安装到项目的依赖项中的查询结果。
代码片段Ctrl + 9查找与搜索查询匹配的代码片段文件。

若使用“通用搜索”或“添加活动”,系统会在您下一次打开搜索栏之前一直保留搜索结果。若使用“转到文件”和“跳转到活动”,则不会保留之前的搜索查询。

双击活动或按 Enter 键,将活动添加至当前打开的文件。通过使用相同命令,您可以打开“所有文件”或“项目文件”类别下的文件,或聚焦所需的搜索结果。

调用工作流活动内的流程参数默认值不可使用“通用搜索”功能进行搜索。

转到文件​

“转到文件”栏用于搜索及打开当前项目文件夹中的文件。.xaml 文件将在 Studio 的“设计器”面板中打开,其他文件(例如屏幕截图或 Excel 文件)则由计算机上的对应默认应用程序打开。双击或按 Enter 键即可打开文件。

备注:

“活动”、“项目”面板和“命令面板”支持模糊搜索。这表示,即使搜索词并不完全匹配,系统也会返回结果列表。搜索词可能仅缺失一小部分、出现拼写错误或仅包含每个词的首字母。例如,如果在“活动”栏键入 dci,系统将返回“双击图像”活动。

跳转到活动​

“命令面板”中的“跳转到活动”搜索栏可帮助在大型工作流中查找及聚焦特定活动。它可通过以下方式访问:使用 Ctrl + J 键盘快捷键,或者使用 F3 或 Ctrl + Shift + P 快捷键打开,然后选择“跳转到活动”。

使用跳转到活动​

打开后,“跳转到活动”栏将显示“设计器”面板中目前聚焦的 .xaml 文件内的完整活动列表。

键入活动的显示名称或命名空间,例如“分配”。使用键盘箭头选择该活动,并按 Enter 键以在“设计器”面板中将它设为焦点。

在“跳转到活动”栏中,活动依以下顺序排列:容器、父活动和子活动。

面板​

设计器面板​

“设计器”面板显示当前的自动化项目,可用于对该项目进行更改,并可让您快速访问变量、参数和导入项。

通过双击要查看的活动,可以在图表中导航。路径在“设计器”面板的标题中显示为面包屑导航。请注意,当使用缩放比例不同的多个显示器时,某些活动的输入字段部分中的文本可能会显示不当。

您可以使用“Ctrl + C”快捷键或上下文菜单将活动复制到文本编辑器,接收更改,然后将其复制回“设计器”面板。您可以使用 Studio 功能区中的按钮或按“Ctrl + Z”/“Ctrl + Y”来撤消/重做在面板中执行的操作。

如果活动存在验证错误,则“设计器”面板中活动标题栏的右侧会显示一个错误图标 docs image,同时该活动的所有父级活动中也会显示一个警告图标 docs image。错误消息还会显示在受问题影响活动的“属性”面板顶部,您可以通过选择消息旁边的剪贴板图标来复制该消息。

通过单击docs image 图标、按住空格键或按鼠标中键来激活平移模式。 使用 Zoom 下拉列表更改缩放比例,然后单击docs image图标,将其重置为 100%。

适应屏幕docs image图标会更改缩放比例,以便“设计器”面板能够容纳整个工作流。单击“docs image图标概览整个项目,并通过调整焦点浏览各个部分。

使用 Autopilot 进行活动和序列摘要​

使用 Autopilot 摘要功能,您可以创建有意义的名称,以清楚描述活动或序列正在执行的操作。此功能对于提高难以审核或维护的大型工作流的可读性特别有用。

为了提高活动名称的清晰度和一致性,Autopilot 会考虑定义活动的元素,包括其说明、参数、属性、输入值及其相应的包名称和说明。对于序列,Autopilot 会根据序列中包含的活动的所有说明创建单句摘要。

要使用此功能,请双击标题栏中的活动名称或序列(或从活动或序列上下文菜单中选择重命名),然后单击“汇总活动”按钮。 Autopilot 然后将生成一个唯一名称,用于描述活动或序列的功能。

上下文菜单​

上下文菜单用于在工作流上执行多个操作,无论是序列还是流程图。可以通过右击工作流中的某个活动来显示上下文菜单。

备注:

如果选择更多个活动,那么不会显示任何菜单。

上下文菜单的字段描述​

选项

描述

查看父项

在“设计器”面板中显示目标活动的父项。

注意:仅当在“设计器”面板中打开子活动时,才会显示此选项。

打开

在“设计器”面板中打开选定的活动。结果与双击相同。

折叠

折叠活动,从而将显示的详细信息减少为“双击以查看”。您可以通过单击“折叠”按钮docs image获得相同的结果。

注意:仅对序列显示。

原地展开

展开活动的内容,显示其详细内容。您可通过单击“展开”按钮 docs image 获得相同结果。

注意:仅对序列显示。

剪切

删除选定的活动,并将其放在剪贴板上。

复制

复制选定的活动,并将其放在剪贴板上。只读文件中的活动现在可以复制到另一个工作流或 .txt 文件中。将多个活动复制到剪贴板时,其顺序会颠倒。

:warning: 将活动复制到具有不同兼容性的项目(例如,从 Windows - 旧版到跨平台)时,可能会导致执行目标工作流失败。

粘贴

在当前位置插入剪贴板的内容。

删除

删除目标活动。

注意:由于只有选择了单个活动时才会显示“上下文”菜单,因此您可以通过对应的键盘快捷方式 Delete 对更多个活动使用此命令。

批注

添加、编辑、删除、显示和隐藏添加到工作流中活动的批注。

导出为图像

  • 将图像复制到剪贴板:将图像复制到剪贴板。
  • 将图像保存到文件 - 对设计器面板中显示的内容进行屏幕截图,并提示用户设置保存详细信息(名称、类型、目标)。支持的格式:JPG、PNG、GIF、XPS。

注意:如要截取子活动的屏幕截图,请首先在“设计器”面板中将其打开。

创建变量

在“变量”面板中创建一个变量。

自动排列

在流程图中自动安排活动。

删除围绕的序列

从“设计器”面板中删除选定的“序列”活动。其包含的活动将移入父级序列。

用“Try Catch” (Ctrl+T)包围

在“Try Catch 异常处理”语句中插入活动。

Try Catch 语句用于处理由数据或编码错误引起的异常。 “Try”子句包括要检查异常的活动。“Catch”子句是异常处理程序。无论前两个子句的状态如何,“Finally”子句都用于执行活动。

提取为工作流

创建包含目标活动的新工作流,目的是将大型项目分解为较小的项目。在提取活动的位置上,将创建一个“调用 <new> 工作流”活动,用于编辑和导入新建工作流中的参数。系统会根据该活动中使用的变量自动创建参数。“调用 <new> 工作流”活动自动映射本地变量,以调用所提取工作流的参数。请注意,这仅适用于您创建的变量,参数并非根据父活动(如“遍历循环”)隐式创建的变量而创建。

启用活动

启用以前禁用的活动。

禁用活动

禁用一个活动,然后将该活动放置在“注释掉”活动中。

切换断点

将选定的活动标记为断点以进行调试。也可以通过单击“执行”选项卡中的“断点”按钮来切换断点。一次可以为一个活动触发一个断点。

切换书签 为选定的活动添加书签,或删除为活动添加的书签。

编辑断点设置

打开“断点设置”窗口。

调试
  • 运行至此活动:调试项目,并在执行此特定活动之前停止。
  • 从此活动运行:从此活动开始调试。
  • 测试活动:调试此活动。

显示所有条件

显示项目中定义的所有条件(“属性”面板 >“条件”)。

注意:仅当您在项目中右击空白空间时才会对流程图显示该选项;如果您在流程图中右击某个活动,那么不会显示该选项。

隐藏所有条件

隐藏显示的所有条件。

注意:仅当您在项目中右击空白空间时才会对流程图显示该选项;如果您在流程图中右击某个活动,那么不会显示该选项。

设置为开始节点

将所选活动与开始节点连接。

仅对流程图显示。

设置为初始状态

将“状态机”专属活动连接到“开始”节点。

仅对状态机显示。

还会对“设计器”面板中的选项卡显示上下文菜单。可用的选项如下:

选项

描述

关闭

关闭活动选项卡。

关闭其他

关闭除活动选项卡之外的所有选项卡。

关闭所有文档

关闭所有选项卡。

浮动

取消停靠目标选项卡并将其更改为浮动状态。

固定选项卡

在“设计器”面板中固定目标选项卡。

最后固定选项卡始终移动到所有其他现有选项卡的前面(无论是否固定)。 固定选项卡的位置只能相对于其他固定选项卡进行更改。

新建水平选项卡组

水平分割屏幕,使您能够在同一屏幕中查看“设计器”面板的两个或多个实例。目标项目将移动到右侧面板。

仅当您的项目包含两个或更多选项卡和隐式工作流时才显示。

新建垂直选项卡组

垂直分割屏幕,使您能够在同一屏幕中看到“设计器”面板的两个或多个实例。目标项目会移至底部面板上。

仅当您的项目包含两个或更多选项卡和隐式工作流时才显示。

移至上一个选项卡组

将目标选项卡移动到显示的前一个“设计器”面板上。

仅在您之前使用过“新垂直选项卡组”或“新水平选项卡组”选项时才显示。

移至下一个选项卡组

将目标选项卡移至显示的下一个“设计器”面板上。

仅在您之前使用过“新垂直选项卡组”或“新水平选项卡组”选项时才显示。

项目面板​

“项目”面板用于管理项目文件、依赖项并配置项目设置。 有关更多信息,请参阅“管理项目”。

Data Manager 面板​

“数据管理器”面板使您能够从一个集中位置管理变量、参数、常量、实体、Orchestrator 资源、连接和命名空间等数据。如需更多信息,请参阅“使用数据管理器”。

活动面板​

“活动”面板显示可以添加到当前工作流的活动。 在 Windows 和跨平台项目中,您可以查看已安装和可用活动,而在旧版 Windows 项目中,仅显示已安装的活动。 “已安装”是指已作为项目依赖项添加的包中的活动,而“可用”是指未安装,但可从官方和 Orchestrator 租户订阅源中安装的包中的活动。

您可以使用面板顶部的搜索框按名称或说明搜索活动,使用导航键浏览这些活动,然后按 Enter 将所选活动添加到当前打开的文件。

备注:

无论 Studio 中设置了哪种界面语言,搜索框都可以按类名称来查找活动。

将鼠标悬停在面板中的活动上会显示该活动所属的包及其描述。要将活动添加到收藏夹列表,请右键单击它,然后选择“添加至收藏夹”。

右键单击面板中的活动,并选择“创建测试台”以测试一个或多个活动,然后再将它们添加到项目中。单击此处了解详情。

添加可用活动​

在 Windows 和跨平台项目中,您可以使用“活动”面板和“添加活动”搜索栏中的“可用”类别从官方 UiPath 包中快速查找和添加项目中未安装的活动。

要将可用活动添加到项目,请双击该活动或将其拖放到工作流中。 当您将可用活动添加到项目时,包含该活动的包将作为项目依赖项安装。 您还可以将可用包添加到项目,方法是右键单击其名称,然后选择安装。

添加 Integration Service 活动​

大多数 Integration Service 活动只能从“可用”类别中添加。这些活动包含在单个包“UiPath Integration Service 活动”中,使您能够快速为不同连接器添加多个活动。此包中的活动不会显示在“活动”面板的已安装部分中。

如果更新可用于已添加到项目中的活动,则每当您添加新的 Integration Service 活动或重新打开项目时,更新都会自动更新。

要将 Integration Service 活动添加到项目,请执行以下操作:

  1. 添加可用的 Integration Service 活动,或在“可用”部分右键选择类别名称,然后选择“安装” ,以将 UiPath Integration Service 活动包添加为项目依赖项。
  2. 从“可用”类别中添加其他 Integration Service 活动,而无需安装其他包。Integration Service 包中包含的可用活动会立即添加到您的工作流中。

有关使用 Integration Service 活动的更多信息,请参阅 Integration Service 活动指南。

备注:

通过 Orchestrator 故障排除会话访问 Studio 时,Integration Service 活动在“可用”部分中不可用。要处理 Integration Service 活动,请在故障排除会话之外使用您的标准用户帐户打开 Studio。

自定义活动面板​

单击面板顶部的“按说明搜索”按钮,以在活动说明中搜索关键字。

单击“按分组”按钮,按可用活动所属类别或所属包对活动进行分组。 您还可以清除这两个选项,以查看按字母顺序排列的未分组活动列表。

单击“筛选依据”docs image按钮以根据以下选项筛选活动。

对于跨平台项目​
  • 按可用性筛选:
    • 已安装 - 显示已安装且属于项目中的包的活动(无法停用此筛选器)
    • 可用 - 显示属于已卸载包的一部分的活动,您可以将其添加到项目中
    • Windows - 显示仅在 Windows 项目中可用的活动
  • 按类型筛选:
    • 活动 - 显示活动
    • 触发器 - 显示触发器
对于 Windows 项目​
  • 按可用性筛选:
    • 已安装 - 显示已安装且属于项目中的包的活动(无法停用此筛选器)
    • 可用 - 显示属于已卸载包的一部分的活动,您可以将其添加到项目中
  • 按类型筛选:
    • 活动 - 显示活动
    • 触发器 - 显示触发器
  • 按类别筛选:
    • 传统 - 使用新式体验显示项目中的传统活动
适用于 Windows - 旧版项目​
  • 按类型筛选:
    • 活动 - 显示活动
    • 触发器 - 显示触发器
  • 按类别筛选:
    • 预览 - 显示预发行活动(此设置可被监管)
    • 传统 - 使用新式体验显示项目中的传统活动

组件面板​

“组件”面板是一个上下文面板,在 Studio 中创建或打开表单时会显示。该面板包含用户界面组件,您可以将其拖放到“设计器”面板中以构建自定义表单。有关详细信息,请参阅表单组件。

代码片段面板​

“代码片段”面板使您可以轻松地重复使用自动化。默认情况下,它包括多个示例和代码片段。

要添加自己的示例和代码段,可以单击“添加文件夹”按钮并从硬盘驱动器中选择一个目录。空文件夹不会显示。

要删除某个文件夹,请右击该文件夹并选择“删除”。

属性面板​

“属性”面板包含上下文,用于查看和更改所选活动的属性。在同一工作流中选择两个活动时,可以从“属性”面板中修改公共属性。

在具有跨平台兼容性的项目中,如果启用了“显示活动属性内联”设计设置,则所有活动属性都在“设计器”面板的活动卡中可用。这也适用于使用 Windows 兼容性的项目中的某些活动。

表达式编辑器​

当用于活动输入字段时,可以使用 Ctrl + Shift + E 键盘快捷方式打开表达式编辑器。您还可从“属性”面板、需要输入文本的字段和活动主体中打开表达式编辑器,直接在所需字段中添加文本即可。

表达式编辑器包含智能代码完成功能。表达式可以写在多行上。提供了用于直接在表达式中创建变量和参数的键盘快捷方式。

在编辑器中使用 Ctrl + F 打开搜索和替换功能。选择表达式的一部分,然后按 Ctrl + F3 将文本添加到搜索字段。按住 Ctrl 键使搜索窗格半透明,并查看其背后的文本。

当您关闭编辑器时,系统会保存该编辑器在显示器上的位置、窗口大小和文本缩放级别,并会在您下次打开编辑器时加以应用。

Autopilot 面板​

Autopilot 面板是一个由 AI 驱动的集中式界面,可简化自动化项目的开发和维护。

Autopilot 功能​

通过该面板,您可以使用顶层访问 Autopilot汇总和工作流生成功能docs image工作流摘要,并docs image生成序列按钮。

此外,该面板通过提供基于 AI 的建议来解决低代码工作流错误,同时显示原始错误消息,从而改进错误处理和故障排除。单击已识别错误下的“获取建议”按钮,Autopilot 将提供每个错误的详细解释,以及您随后可以应用到工作流中、与上下文相关的清晰建议。这些高级功能也可处理工作流分析器错误。

您还可以使用 Autopilot 面板搜索 UiPath 官方文档,而无需从 Studio 外部导航到文档门户。只需选择“搜索”按钮,输入您的问题,Autopilot 就会给出相关答案,并将您引导至文档来源和类型,以获取更多信息。

大纲面板​

“大纲”面板显示项目层次结构以及所有可用节点。您可以在“设计器”面板中选择活动来高亮显示该面板中的活动,也可在“大纲”面板中选择特定的活动来切换到该活动。

输出面板​

“输出”面板使您能够显示“日志消息”或“写入行”活动的输出等内容。此面板中也会显示包的例外情况。

筛选和导出日志​

在“输出”面板中,通过单击面板标题中的按钮,可以显示或隐藏具有不同日志级别(错误、警告)的消息。双击消息会显示关于此消息的更多详细信息,并包含用于复制信息的选项。

在“输出”面板中搜索日志并在搜索结果列表中选择项目时,相应日志将会高亮显示。

日志搜索和导出​

“导出日志”按钮用于将日志导出至 .txt 文件。该按钮还会导出时间戳和错误消息详情。此外还可导出筛选后的日志。例如,若想仅导出 Trace 级日志,您可筛选列表,然后使用“导出日志”按钮。

调试时,“输出”面板将显示日志,表示活动开始执行时间,直至结束的时间。您可通过“调试”选项卡中的“日志活动”选项启用此功能。

错误列表面板​

“错误列表”面板显示验证流程中在文件或项目中发现的错误,以及由“工作流分析器”规则生成的错误。

“全部清除”按钮会擦除“输出”面板中显示的所有信息。在运行工作流时,将擦除此面板中存储的日志和其他数据。“输出”面板一次最多显示 2,000 行。

“输出”面板不适用于生产监控,仅应在开发自动化时使用。 例如,如果使用了大量日志消息活动,则事件可能无法按预期显示。 要监控生产运行,请使用 Orchestrator 日志。

“查找引用”面板​

“查找引用”面板显示您在项目中搜索的引用的结果。要查找项目中引用元素的每个位置,请右键单击该元素,然后选择“查找引用”。这适用于以下情况:

  • “项目”面板中的文件

  • “活动”面板中的活动

  • “变量”和“Data manager”面板中的变量

  • “参数”和“Data manager”面板中的参数

  • “对象存储库”面板中的描述符

调试面板​

以下面板可用于帮助您调试项目:断点和书签、调用堆栈、本地、观察和即时。

状态栏​

在状态栏中,您可以查看与 Orchestrator 和来源控件相关的状态信息,并访问相关选项:

  • Orchestrator/云连接 - 单击 要访问 Orchestrator 选项,请执行以下操作:登录到您的 Cloud 帐户 以访问 Orchestrator 选项:登录到您的云帐户、断开与 Orchestrator 的连接(如果与计算机密钥连接),以及刷新资源。

  • Orchestrator 状态 - 显示 Orchestrator 连接状态。连接到 Orchestrator 后,系统将显示当前选择的文件夹。您可以单击当前文件夹名称以查看可用文件夹列表,并选择要从中同步资源的其他文件夹。

  • “源代码控件” - 根据项目是否连接到源代码控件存储库,您可以使用不同的选项来帮助管理源代码控件集成。有关详细信息,请参阅关于版本控制。

  • Cloud 项目 - 对于使用 VB 语言的跨平台项目,提供了一个菜单,其中包含与在 Studio Web 中编辑项目相关的选项。如果项目尚未与 Studio Web 同步,则会显示“兼容 Cloud”标签。如果项目已与 Studio Web 同步,则会显示“Cloud 项目”标签。有关更多信息,请参阅“设计跨平台项目”。

  • “项目语言”- 显示项目中的表达式所使用的语言(“VB”或“C#”)。

  • “项目兼容性”- 显示项目的兼容性、“Windows - 旧版”、“Windows”或“跨平台”。

此页面有帮助吗?

连接

需要帮助? 支持

想要了解详细内容? UiPath Academy

有问题? UiPath 论坛

保持更新