- 发行说明
- 入门指南
- 设置和配置
- 自动化项目
- 依赖项
- 工作流类型
- 文件比较
- 自动化最佳实践
- 源代码控件集成
- 调试
- 诊断工具
- 工作流分析器
- 变量
- 参数
- 导入的命名空间
- 控制流程
- 对象存储库
- 日志记录
- ScaleCoordinates 迁移工具
- ScreenScrapeJavaSupport 工具
- StudioPro
- 扩展程序
- 故障排除
UiPath Studio 包含多个面板,便于您更轻松地访问特定功能。这些面板可以停靠,充当浮动窗口,也可以下拉列表中启用“自动隐藏”选项。
概述
| 编号 | 名称 | 描述 |
|---|---|---|
|
1 |
访问 Studio 的三个主要区域:
| |
|
2 | ||
|
3 |
通过管理添加到当前工作流文件中的活动来构建自动化。 | |
|
4 |
使用可用的搜索栏在项目内执行搜索: | |
|
5 |
管理变量。 | |
|
6 |
管理参数。 | |
|
7 |
管理导入的命名空间。 | |
|
8 |
查看当前项目的内容,管理文件、文件夹和依赖项,以及调整项目设置。 | |
|
9 |
查看所有可用活动并将活动添加到自动化中。 | |
|
10 |
使用预先构建的工作流并添加您自己的可重复使用的自动化流程。 | |
|
11 |
查看和配置所选活动的属性。 | |
|
12 |
查看当前工作流和所有可用节点的层次结构。 | |
|
13 |
通过 Orchestrator 添加资源,例如资产、队列、流程和实体。 | |
|
14 |
在流程内部和跨流程创建和重用 UI 分类法。 | |
|
15 |
查看“日志消息”和“写入行”活动的输出、有关项目执行状态的信息、活动包生成的错误等。 | |
|
16 |
查看运行工作流分析器时生成的所有错误。 | |
|
17 |
查看项目中引用元素的所有位置。 | |
|
18 |
管理添加到项目中的断点。 | |
|
19 |
查看状态信息,并管理 Orchestrator 连接和源代码控件集成的状况。 |
功能区
功能区选项卡
The ribbon is straightforward and can be minimized or expanded by clicking the Minimize / Expand button
. It consists of the following three tabs:
-
Home - create and open projects, configure Studio, or access help and license information from the Studio Backstage View.
-
设计 - 向项目中添加序列、流程图和状态机,安装和管理活动包,与用户界面元素构建交互,将工作流导出到 Excel,然后将您的工作发布到 OrcheStrator 或自定义订阅源。请记住,除非您安装
UiPath.UIAutomation.Activities包,否则“功能区”中将不会显示“向导”和“用户界面探测器”。 -
Debug - debug your workflow, while using debugging tools to set breakpoints, monitor the execution of activities step by step, and adjust the debugging speed. Open logs to view details regarding execution and any changes made to the project. For more information on debugging, check the About Debugging page.
备注:不是在执行自动化项目期间创建的文件在发布到 Orchestrator 之后将变为只读文件。如果您的业务流程要求您在某个时候写入特定的文件,请确保在设计项目时创建该文件。
标题栏
发送反馈
您可以直接从 Studio 中发送以下两类反馈:“提交产品建议”或“报告错误”。您可以单击功能区中的
图标访问这两类反馈。
“发送反馈”功能必须仅用于向产品团队发送匿名反馈。 要联系我们的技术支持团队,请使用“联系技术支持”表单。
提供以下信息,然后单击“提交”:
- 从“我希望”下拉菜单中,选择“提交产品建议”或“报告错误”。
- 从“对象”下拉菜单中,选择“UiPath 活动”、“UiPath Studio”、“UiPath 机器人”、“UiPath Orchestrator”或“UiPath 助理”。
- 从“这对您的重要性”下拉菜单中,选择“值得拥有”、“重要”或“关键”。
- 在“主题”字段中,添加简短的标题。
- 添加详细说明并附加最多 6 个图片、视频或文本文件,每个文件均需小于 10MB。发送反馈的阈值为 5 分钟内发送 3 次。
帮助
Click the Help icon to quickly access the resources that are also available in the Help tab in Backstage View, as illustrated below:
登录到您的帐户
如果您是在用户模式下使用 UiPathStudio.msi 安装程序或者 Studio 社区版同时安装 Studio 和机器人,便可通过登录 UiPath 帐户将 Studio 和助理连接到 Orchestrator:
- 单击
单击 Studio 窗口右上角的,然后单击登录。如需了解有关登录的更多信息,请点击了解详情。
-
要使用自定义 URL 代替默认 URL
https://cloud.uipath.com,请在“服务 URL”字段中输入 URL。 -
To connect to Orchestrator with your machine key, click Use Machine Key.
-
- 网页浏览器中将打开一个新页面。完成登录过程,并在网页浏览器提示时,单击“打开 UiPath”以返回 Studio。
登录后,带有首字母缩写的图标将显示在 Studio 窗口的右上方。要从 Studio 和助理中退出并断开与 Orchestrator 的连接,请单击图标,然后选择“退出登录”。
使用计算机密钥连接到 Orchestrator
如果您是使用 UiPathStudio.msi 和注册为 Windows 服务的机器人安装 Studio,则只能使用计算机键连接到 Orchestrator:
- Click
, and then click Connect. - 输入 Orchestrator URL 和计算机密钥,然后单击“继续”。
-
如果要激活本地许可证密钥,请单击“使用许可证代码”。
备注:仅当您是计算机管理员时,才可以使用通过计算机密钥连接到 Orchestrator 的选项。
-
连接到 Orchestrator 时的常见错误
下表记录您尝试通过登录或使用计算机密钥连接到 Orchestrator 时可能遇到的错误,以及原因和解决方案。
| 错误 | 原因 | 解决方案 |
|---|---|---|
|
系统没有为此租户启用交互式登录功能。请在 Orchestrator 设置中启用该功能,或使用计算机密钥进行连接 |
您正在尝试从 Orchestrator 登录帐户,但未启用用户身份验证。 |
请执行以下任一操作:
|
|
未经授权 |
没有有人值守的机器人分配给您的用户。 |
在 Orchestrator 中,转到“租户”>“用户”,并编辑当前用户。在“有人值守的机器人”选项卡中,选择“自动为该用户创建有人值守的机器人”,然后选择“许可证类型”。 |
|
远程名称无法解析:Orchestrator_URL |
无法建立与 Orchestrator 的连接。 |
确保处于正常联网状态。 |
后台视图
这是您首次打开 Studio 时看到的视图。您也可以通过单击窗口左上角的“主页”进入此视图。您可以在此处创建和打开项目、配置 Studio 或访问帮助和许可证信息。
此视图中提供以下按钮和选项卡:
-
打开 - 浏览到本地自动化项目并将其打开。 默认情况下,项目创建在 C:\Users<current_user>\Documents\UiPath 中。
备注:Projects located on network folders where your user only has read permissions cannot be opened in Studio. We recommend using source control systems to collaborate on projects.
-
Close - Close the automation project that is currently open.
-
“开始”- 创建新的自动化项目或打开最近访问的项目。您可以从预定义的模板创建新项目,也可以打开您最近处理过的项目。可以从“打开最近的项目”列表中固定或删除项目,将鼠标悬停在项目上时会显示
project.json文件的路径和项目说明。 -
Templates - Create a new project based on a template. In this tab, you can view all available project templates, search and filter them by source. For more information, see Project Templates.
-
Team - Manage source control integration for the automation project.
-
Tools - Install extensions for Chrome, Firefox, Edge, Java, Silverlight, Citrix, Windows Remote Desktop, VMware Horizon, launch the , Project Dependencies Mass Update Tool, and the Repair Tool for Microsoft Office Interop. For more information about extensions, see About Extensions.
-
Settings - Change the look and feel of Studio, set global preferences, and manage activities package sources. For more information, see Configuring Studio Settings.
-
Help - Directs you to product documentation, release notes, online resources, the Community Forum and the RPA Academy.
您还可以在这里访问快速教程,该教程可以帮助您学习创建、发布和运行自动化的基础知识。
备注:为了确保教程成功完成,我们建议您在对教程步骤中突出显示的更改以外的工作流进行任何更改之前,先暂停教程。
有关产品版本和安装、许可可用性、更新通道和设备 ID 的信息也可以在“帮助”选项卡中找到,其中还有一个用于将详细信息快速复制到剪贴板的“复制信息”按钮。
命令面板
使用 Ctrl + Shift + P、F3 键盘快捷键,或单击搜索按钮,以打开“命令面板”。该面板中包含“添加活动”、“通用搜索”、“转到文件”和“跳转到活动”搜索栏。
Studio 支持按照作用域划分活动的优先级。单击活动作用域内的
图标,并要注意,“命令面板”提供了适合当前作用域的活动的相关建议。官方活动包中分阶段推出了对此功能的支持,您可定期查看发行说明。
添加活动
使用 Ctrl + Shift + T 键盘快捷键即可打开“添加活动”搜索栏。您可以在已安装的包中搜索活动,并将其添加到文件中选定的活动之后。该搜索栏会向前五个结果自动分配键盘快捷方式,并记住之前的搜索结果。
单击序列中某个活动顶部或底部的
图标即可打开“添加活动”搜索栏。
通用搜索
“通用搜索”栏使您可以查找当前项目中的代码片段、活动、变量、参数、导入、项目依赖项和文件。搜索从所有工作流文件(包括已关闭的文件)中返回结果。
| 选项 | 快捷方式 | 描述 |
|---|---|---|
| 当前文件 | Ctrl + 1 | 列出当前打开的文件中与搜索查询相匹配的结果。 |
| 所有文件 | Ctrl + 2 | 列出当前项目的所有文件中与搜索查询相匹配的结果。 |
| Activities (活动) | Ctrl + 3 | 列出与搜索查询匹配的活动的结果。 |
| 变量 | Ctrl + 4 | 查找当前项目中与搜索查询相匹配的变量。 |
| 参数 | Ctrl + 5 | 查找项目中定义的与搜索查询相匹配的参数。 |
| 导入 | Ctrl + 6 | 在项目中查找与搜索查询相匹配的已导入命名空间。 |
| 项目文件 | Ctrl + 7 | 查找当前项目中与搜索查询相匹配的文件。 |
| 依赖项 | Ctrl + 8 | 列出安装到项目的依赖项中的查询结果。 |
| 代码片段 | Ctrl + 9 | 查找与搜索查询匹配的代码片段文件。 |
若使用“通用搜索”或“添加活动”,系统会在您下一次打开搜索栏之前一直保留搜索结果。若使用“转到文件”和“跳转到活动”,则不会保留之前的搜索查询。
双击活动或按 Enter 键,将活动添加至当前打开的文件。通过使用相同命令,您可以打开“所有文件”或“项目文件”类别下的文件,或聚焦所需的搜索结果。
调用工作流活动内的流程参数默认值不可使用“通用搜索”功能进行搜索。
转到文件
“转到文件”栏用于搜索及打开当前项目文件夹中的文件。.xaml 文件将在 Studio 的“设计器”面板中打开,其他文件(例如屏幕截图或 Excel 文件)则由计算机上的对应默认应用程序打开。双击或按 Enter 键即可打开文件。
“活动”、“项目”面板和“命令面板”支持模糊搜索。这表示,即使搜索词并不完全匹配,系统也会返回结果列表。搜索词可能仅缺失一小部分、出现拼写错误或仅包含每个词的首字母。例如,如果在“活动”栏键入 dci,系统将返回“双击图像”活动。
跳转到活动
“命令面板”中的“跳转到活动”搜索栏可帮助在大型工作流中查找及聚焦特定活动。它可通过以下方式访问:使用 Ctrl + J 键盘快捷键,或者使用 F3 或 Ctrl + Shift + P 快捷键打开,然后选择“跳转到活动”。
打开后,“跳转到活动”栏将显示“设计器”面板中目前聚焦的 .xaml 文件内的完整活动列表。
键入活动的显示名称或命名空间,例如“分配”。使用键盘箭头选择该活动,并按 Enter 键以在“设计器”面板中将它设为焦点。
在“跳转到活动”栏中,活动依以下顺序排列:容器、父活动和子活动。
面板
设计器面板
The Designer panel displays your current automation project, enables you to make changes to it, and provides quick access to variables, arguments and imports.
通过双击要查看的活动,可以在图表中导航。路径在“设计器”面板的标题中显示为面包屑导航。请注意,当使用缩放比例不同的多个显示器时,某些活动的输入字段部分中的文本可能会显示不当。
您可使用 Ctrl + C 快捷键或上下文菜单将活动复制到文本编辑器、对其作出更改,然后复制回“设计器”面板中。
通过单击
图标、按住空格键或按鼠标中键来激活平移模式。 使用 Zoom 下拉列表更改缩放比例,然后单击
图标,将其重置为 100%。
适应屏幕
图标会更改缩放比例,以便“设计器”面板能够容纳整个工作流。单击“
图标概览整个项目,并通过调整焦点浏览各个部分。
上下文菜单
上下文菜单用于在工作流上执行多个操作,无论是序列还是流程图。可以通过右击工作流中的某个活动来显示上下文菜单。
如果选择更多个活动,那么不会显示任何菜单。
上下文菜单的字段描述
| 选项 | 描述 |
|---|---|
|
查看父项 |
在“设计器”面板中显示目标活动的父项。 |
|
打开 |
在“设计器”面板中打开选定的活动。结果与双击相同。 |
|
折叠 |
折叠活动,从而将显示的详细信息减少为“双击以查看”。您可以通过单击“折叠”按钮 |
|
原地展开 |
展开活动的内容,显示其详细内容。您可通过单击“展开”按钮 |
|
剪切 |
删除选定的活动,并将其放在剪贴板上。 |
|
复制 |
复制选定的活动,并将其放在剪贴板上。您可将只读文件中的活动复制到其他工作流或 |
|
粘贴 |
在当前位置插入剪贴板的内容。 |
|
删除 |
删除目标活动。 |
|
批注 |
添加、编辑、删除、显示和隐藏添加到工作流中的活动的批注。 |
|
复制为图像 |
生成“设计器”面板中所显示内容的屏幕截图。 |
|
保存为图像 |
生成“设计器”面板中所显示内容的屏幕截图,并提示用户设置详细信息以便保存(名称、类型和目标位置)。支持的格式:JPG、PNG、GIF 和 XPS。 |
|
创建变量 |
在“变量”面板中创建一个变量。 |
|
自动排列 |
在流程图中自动安排活动。 |
|
删除围绕的序列 |
从“设计器”面板中删除选定的“序列”活动。其包含的活动将移入父级序列。 |
|
用“Try Catch” (Ctrl+T)包围 |
Inserts the activity in a Try Catch statement. |
|
提取为工作流 |
Creates a new workflow containing the targeted activity with the purpose of breaking down a large project into smaller ones. In the place of the extracted activity an Invoke |
|
打开工作流 |
打开使用上述选项创建的工作流。 |
|
启用活动 |
启用以前禁用的活动。 |
|
禁用活动 |
禁用一个活动,然后将该活动放置在“注释掉”活动中。 |
|
切换断点 |
将选定的活动标记为断点以进行调试。也可以通过单击“执行”选项卡中的“断点”按钮来切换断点。一次可以为一个活动触发一个断点。 |
|
编辑断点设置 |
打开“断点设置”窗口。 |
|
运行至此活动 |
调试项目并在执行此特定活动之前停止调试。 |
|
从此活动运行 |
从此活动开始调试。 |
|
显示所有条件 |
显示项目中定义的所有条件(“属性”面板 >“条件”)。 |
|
隐藏所有条件 |
隐藏显示的所有条件。 |
|
设置为开始节点 |
将所选活动与开始节点连接。 |
|
设置为初始状态 |
将“状态机”特定活动连接到开始节点。 |
还会对“设计器”面板中的选项卡显示上下文菜单。可用的选项如下:
| 选项 | 描述 |
|---|---|
| 关闭 | 关闭活动选项卡。 |
| 关闭其他 | 关闭除活动选项卡之外的所有选项卡。 |
| 关闭所有文档 | 关闭所有选项卡。 |
| 浮动 | 取消停靠目标选项卡并将其更改为浮动状态。 |
| 固定选项卡 | 在“设计器”面板中固定目标选项卡。 最后固定选项卡始终移动到所有其他现有选项卡的前面(无论是否固定)。 固定选项卡的位置只能相对于其他固定选项卡进行更改。 |
| 新建水平选项卡组 | 水平分割屏幕,使您能够在同一屏幕中查看“设计器”面板的两个或多个实例。目标项目将移动到右侧面板。 仅当您的项目包含两个或更多选项卡和隐式工作流时才显示。 |
| 新建垂直选项卡组 | 垂直分割屏幕,使您能够在同一屏幕中看到“设计器”面板的两个或多个实例。目标项目会移至底部面板上。 仅当您的项目包含两个或更多选项卡和隐式工作流时才显示。 |
| 移至上一个选项卡组 | 将目标选项卡移动到显示的前一个“设计器”面板上。 仅在您之前使用过“新垂直选项卡组”或“新水平选项卡组”选项时才显示。 |
| 移至下一个选项卡组 | 将目标选项卡移至显示的下一个“设计器”面板上。 仅在您之前使用过“新垂直选项卡组”或“新水平选项卡组”选项时才显示。 |
活动面板
The Activities panel shows available activities that can be added to the current workflow. You can search for activities by name and optionally by description using the search box at the top of the panel, navigate through them using navigation keys, and press Enter to add the selected activity to the currently opened file.
无论 Studio 中设置了哪种界面语言,搜索框都可以按类名称来查找活动。
将鼠标悬停在面板中的活动上会显示该活动所属的包及其描述。要将活动添加到收藏夹列表,请右键单击它,然后选择“添加至收藏夹”。
Right-click an activity in the panel and select Create Test Bench to test out one or more activities before adding them to a project. Read more about this here.
自定义活动面板
Click the View Options
button at the top of the panel to open a menu that allows you to customize the panel. See the following table for a list of available options.
| 选项 | 描述 |
|---|---|
| 显示收藏夹 | 显示包含收藏活动的部分。默认情况下,此选项处于选中状态。 |
| 显示最近的项目 | 显示包含最近使用的十个活动的部分。默认情况下,此选项处于选中状态。 |
| 显示可用 | 显示所有可用活动。默认情况下,此选项处于选中状态。 |
| 显示兼容性 | 当前未使用的选项。默认情况下未选中此选项。 |
| 显示 StudioX | 显示针对 StudioX 配置文件设计的活动。 默认情况下未选中此选项。 |
| 显示传统/新式 | 显示使用传统设计体验的项目中的新式用户界面自动化活动,或显示使用新式体验的项目中的传统用户界面自动化活动。默认情况下未选中此选项。 |
| 显示目录 | 根据活动所属的类别对活动进行分组。默认情况下,此选项处于选中状态。 |
| 按程序包分组 | 根据活动所属的包对活动进行分组。默认情况下未选中此选项。 |
| 按描述搜索 | 在面板中搜索时,请搜索活动说明,而不仅仅是搜索活动名称。默认情况下未选中此选项。 |
| 固定收藏夹 | 在面板中搜索时,请始终保持收藏夹活动可见。如果选择了“显示收藏夹”,则可用。默认情况下未选中此选项。 |
代码片段面板
“代码片段”面板使您可以轻松地重复使用自动化。默认情况下,它包括多个示例和代码片段。
要添加自己的示例和代码段,可以单击“添加文件夹”按钮并从硬盘驱动器中选择一个目录。空文件夹不会显示。
要删除某个文件夹,请右击该文件夹并选择“删除”。
属性面板
“属性”面板包含上下文,用于查看和更改所选活动的属性。在同一工作流中选择两个活动时,可以从“属性”面板中修改公共属性。
表达式编辑器
当用于活动输入字段时,可以使用 Ctrl + Shift + E 键盘快捷方式打开表达式编辑器。您还可从“属性”面板、需要输入文本的字段和活动主体中打开表达式编辑器,直接在所需字段中添加文本即可。
Expressions can be written on multiples lines. Keyboard shortcuts for creating variables and arguments directly in expressions are available.
在编辑器中使用 Ctrl + F 打开搜索和替换功能。选择表达式的一部分,然后按 Ctrl + F3 将文本添加到搜索字段。按住 Ctrl 键使搜索窗格半透明,并查看其背后的文本。
大纲面板
“大纲”面板显示项目层次结构以及所有可用节点。您可以在“设计器”面板中选择活动来高亮显示该面板中的活动,也可在“大纲”面板中选择特定的活动来切换到该活动。
输出面板
“输出”面板使您能够显示“日志消息”或“写入行”活动的输出等内容。此面板中也会显示包的例外情况。
在“输出”面板中,通过单击面板标题中的按钮,可以显示或隐藏具有不同日志级别(错误、警告)的消息。双击消息会显示关于此消息的更多详细信息,并包含用于复制信息的选项。
在“输出”面板中搜索日志并在搜索结果列表中选择项目时,相应日志将会高亮显示。
“导出日志”按钮用于将日志导出至 .txt 文件。该按钮还会导出时间戳和错误消息详情。此外还可导出筛选后的日志。例如,若想仅导出 Trace 级日志,您可筛选列表,然后使用“导出日志”按钮。
调试时,“输出”面板将显示日志,表示活动开始执行时间,直至结束的时间。您可通过“调试”选项卡中的“日志活动”选项启用此功能。
The Error List panel displays errors found in the file or project during the validation process, together with errors generated by About Workflow Analyzer rules.
“全部清除”按钮会擦除“输出”面板中显示的所有信息。在运行工作流时,将擦除此面板中存储的日志和其他数据。“输出”面板一次最多显示 2,000 行。
“查找引用”面板
“查找引用”面板显示您在项目中搜索的引用的结果。要查找项目中引用元素的每个位置,请右键单击该元素,然后选择“查找引用”。这适用于以下情况:
-
“项目”面板中的文件
-
“活动”面板中的活动
-
“变量”面板中的变量
-
“参数”面板中的参数
-
“对象存储库”面板中的描述符
资源面板
The Resources panel in Studio can load assets, queues, processes, and entities, provided that the Robot is connected to Orchestrator. Read the Connecting Robots to Orchestrator page to find the steps.
如果连接到 Orchestrator 的机器人是“标准”类型,则“资源”面板仅能显示已配置此机器人的传统文件夹。
If the Robot is of type Floating, then the panel displays all Classic and Modern folders that this Robot has access to. Read more about creating Robots in Orchestrator here.
The panel displays assets, queues, and processes found in Classic or Modern Folders in Orchestrator. Read more about Folders.
When using a classic, manually provisioned robot, it must be granted View permissions for the corresponding resources (i.e. Assets, Queues, and Processes) to appear in the panel. Read more about setting up Roles and permissions in Orchestrator.
要将资源加载到面板中,请单击“资源”面板中的“刷新”按钮。右键单击“资源”面板中的任何项目以复制其名称,并将其用于与此类资源进行交互的活动中。
将鼠标悬停在状态栏中的文件夹名称上以查看 Orchestrator URL,然后单击状态栏中的文件夹名称以切换到另一个文件夹。
只有在“Orchestrator 资源”面板中选取了相应子文件夹时,Orchestrator 中才会显示该子文件夹中流程生成的日志。
将资源、队列或流程从“资源”面板直接拖放到自动化项目中。这样做后,会在“添加活动”搜索栏中建议合适的活动。例如,在项目中拖动队列后,从“添加活动”搜索栏中选择“添加队列项目”活动,然后就能看到到该队列已自动分配给活动的“队列名称”属性。
状态栏
在状态栏中,您可以查看与 Orchestrator 和源代码控件管理相关的状态信息和访问选项。您还可以在此查看项目中的表达式(VB 或 C#)使用的语言。
- Cloud Options - Click Cloud Options
to access Orchestrator options: sign in to your cloud account, connect to or disconnect from Orchestrator, and refresh resources. - “Orchestrator 状态”- 显示 Orchestrator 连接状态。连接到 Orchestrator 后,系统将显示当前选择的文件夹。您可以单击状态以查看可用文件夹列表,并选择要从中同步资源的其他文件夹。
- Source Control - Depending on whether the project is connected to a source control repository, different options are available to help you manage source control integration. For more information, see About Version Control.
获得相同的结果。
获得相同结果。