Subscribe

UiPath Apps

The UiPath Apps Guide

Apps Troubleshooting and FAQs

Message: Connection to Apps service is lost.

When saving Apps from App Studio, the following error message can occur:
"Connection to Apps service is lost."

Possible cause

  1. You've lost internet connection. Apps requires an active internet connection to save changes you make to your app.
    OR
  2. The reason for this error can be the fact that the App service uses WebSocket to save the App definition.

Solution

First, ensure that you have an active internet connection. If you are still facing issues then:

  1. Allow apps-socket.uipath.com to have long live connections by making sure you have the connection: Upgrade parameter in the header. This must be done with the help of your IT team.
  2. Work with your IT or network team to understand how WebSocket traffic policies are being handled and alter them as needed.
  3. Allow WebSocket connections by making sure that apps-socket.uipath.com is not added to your proxy policy. This must be done with the help of your IT team.

Message: Errors in App

When previewing an app, the following error can occur, even if there are no errors:
"Errors in App"

Possible cause

One or more browser extensions can cause this error to occur.

Solution

  1. Try previewing the app in a different browser.
    OR
  2. Deactivate all extensions from your current browser.

Message: Process(Process_Name) not found.

An error stating a process is not found can occur in runtime, even if the process is available in Orchestrator.

Possible cause

Check the name of the process and make sure that it does not contain an underscore (_) character.

Solution

Rename the process and remove all underscore (_) characters.


Issue: Event on page load not working

Setting the control value using the Set Values rule in the Page load event results in not setting the control value properly.

Solution

Instead of setting the control value in the Page load event, use the app variable in the Set Values rule and bind the app variables to the control. By doing so, the control value is being set correctly.


Issue: Default selected value not showing in runtime

When in Apps design time, the default selected value is correctly displayed for the dropdown control, but when switching to runtime it is no longer displayed

Solution

For this example we will use 10 as the value. To correctly display the value in runtime, insert the value in the following format: =10, instead of simply 10.


Issue: Custom arguments not displayed

When adding custom arguments in the process details page, the newly added arguments are not displayed in the resource panel for binding.

Solution

Make sure to first refresh the browser and then add the arguments by pressing the :heavy-plus-sign: sign. If you do not refresh the browser first, the newly added arguments will not be displayed in the resource panel for binding.


Issue: App preview does not work in the first attempt

In some situations, app preview might not work in the first attempt.

Solution

Make sure that any pop-up blockers are disabled in your browser. Once pop-ups are allowed, app preview works as expected.


Issue: Unable to preview an app or run an app from the home page

When previewing or running an app from home page, the app does not load and can result in a blank page.

Possible cause

The start page of the app is not set. Since there is no start page set, the app cannot decide which page to run or preview.

Solution

Set the start page explicitly from the tree view.

317317

Issue: Variable not saved in the Get File from Storage bucket rule

When you assign an app variable in the Assign file to app variable property in the Get File from Storage bucket rule, the app variable is not saved.

Solution

When you open the app designer, you have to add the app variable again. You can publish the app after adding the app variable and the published version will have the app variable. However, in design time, the app variable has to be added again each time you open the app in App Studio.

324324

Issue: Incorrect start page is displayed when previewing an app

When previewing an app, the displayed start page is not the correct one.

Possible cause

Two pages have the same order, leading to an incorrect start page in runtime.

Solution

To display the correct page in runtime, follow these steps:

  1. Clone the page that needs to be set as the start page.
  2. Set the newly-cloned page as the start page.
  3. Delete the original page.

You can now preview your app and the correct start page should be displayed.


Issue: Borders not displayed properly

In certain situations, when adding a tab, container, or page container the borders are not displayed properly if the content within has a larger width than the width of the parent control (tab, container or page container) and if a center or right alignment is applied on it. In this situation, the left portion of the content is cut off from the view and it will also be inaccessible using scroll.

Possible cause

This is a browser behavior issue that is seen when flex display and center alignment is used together.

Solution

To get around this issue, we suggest using left alignment (justify left) or configure a width for the parent control that is larger (or at least equal) to the content inside it.


Issue: AppInsightService.AppInsight warning message in console logs

In certain situations, the following warning message is continuously displayed in the console logs:
"AppInsightService.AppInsight not yet ready"

Possible cause

An ad blocker can cause this issue

Solution

Make sure that any pop-up blockers are disabled in your browser.


Issue: A page opened in different places at once is no longer updated

A page opened twice stops updating.
For example, you have a table inside a page container updating the value of a variable when a row is selected. Once this page is opened in a new pop-up page, the variable is no longer updated after closing the pop-up.

Solution

To avoid similar situations, we do not recommend opening a page more than once at a time as it is not yet supported.


Issue: Unable to start Orchestrator process

When passing an Array[string] variable from a process to UiPath Apps, the following error message can occur:
Unable to start orchestrator process - invalid response received from orchestrator:orchestrator-start-process with message: The field InputArguments must be a string or array type with a maximum length of '10000'. and errorCode 0

Possible cause

This issue is related to a payload size limit from Orchestrator. The limit only applies in unattended mode.

Solution

  • You can reduce the data being sent to Orchestrator or break the process into smaller ones.
  • You can run the process in attended mode.

Updated 29 days ago

Apps Troubleshooting and FAQs


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.