Studio
2022.10
false
Studio 用户指南
Last updated 2024年7月15日

键盘快捷方式

UiPath Studio 键盘快捷方式的完整列表:

文件管理

Ctrl+Shift+N - 创建一个新的空白流程

Ctrl + C - 将文件从“项目”面板复制到剪贴板。使用 Ctrl + V 将其粘贴到树中的任何位置。

Ctrl+O - 使您能够打开先前创建的工作流:.xamlproject.json 文件。

Ctrl+L - 打开存储日志文件的文件夹。

“Ctrl+S”- 保存当前打开的工作流。

“Ctrl + Shift + S”- 保存当前打开的所有工作流。

Ctrl + V - 将剪贴板中的文件粘贴到“项目”面板中。

Ctrl + Tab - 在“设计器”面板中打开的工作流之间移动焦点。

Ctrl + W - 关闭“设计器”面板中聚焦的工作流文件。

Alt + F7 - - 在 Studio 面板之间移动焦点。当您使用 Ctrl + Tab 或 Alt + F7 并按住修饰键(分别为 Ctrl 或 Alt)时,将显示以下窗口,允许您在 Studio 中的活动文件和面板之间进行切换。



注释

Ctrl+D - 忽略当前被选中的活动,方法是将其放置到“注释掉”容器中。

Ctrl + E - 从放置了活动的“注释掉”容器中删除活动。

调试

“F9”- 用断点标记选定的活动。

Ctrl + Shift + B - 打开断点面板。

Ctrl + Alt + E - 打开“错误列表”面板。

“F10”- 调试时,在当前选定的工作流中跳过一个活动块的执行。

“F11”- 调试时,可用于进入一个活动块并执行第一个活动。

Shift + F11 - 调试时,在执行完最后一个活动后退出当前容器。

录制

Ctrl + Alt + B - 打开基本录制工具栏。

Ctrl + Alt + C - 打开 Citrix 录制工具栏。

Ctrl + Alt + D - 打开桌面录制工具栏。

Ctrl + Alt + W - 打开网页录制工具栏。

F2 - 在录制活动期间添加延迟。

“F3”- 用于指定自定义录制区域。

F4 - 允许您选择要录制的用户界面框架,这可以是“默认”、“AA”“UIA”

工作流分析和执行

F5 - 以调试模式运行当前项目,从设置为“主要”的 .xaml 文件开始。

Ctrl + F5 - 运行当前项目。

F6 - 以调试模式运行当前打开的 .xaml 文件。
Ctrl + F6 - 运行当前打开的 .xaml 文件。

F7 - 检查文件中是否存在验证错误和“工作流分析器”违规情况。

Shift + F7 - 检查整个项目是否存在验证错误和“工作流分析器”违规情况。

“F8”- 检查当前打开的工作流是否存在验证错误。

Shift + F8 - 检查所有项目文件中是否存在验证错误。

“暂停”- 在正常模式和调试模式下暂停当前工作流的执行。

F12 - 在正常模式和调试模式下停止当前工作流的执行。

选定活动

Ctrl+T - 将该活动放置在“Try Catch”活动的“Try”部分中。

Ctrl+N - 在当前项目中创建一个新的序列图

Ctrl + C - 将选定的一个或多个活动复制到剪贴板。

Ctrl + V - 粘贴选定项目中复制的一个或多个活动。

Ctrl + K - 在输入字段或“表达式编辑器”中使用时,创建与所需活动相同类型的变量。如果该字段中已经存在表达式,则在按 CTRL + K 之前,可以选择该表达式或表达式的一部分,以将选定的文本用作新变量的名称。

Ctrl + M - 在输入字段或“表达式编辑器”中使用时,创建与所需活动相同类型的输入参数。如果该字段中已经存在表达式,则在按 CTRL + M 之前,可以选择该表达式或表达式的一部分,以将选定的文本用作新参数的名称。

Ctrl + Shift + K - 在输入字段或“表达式编辑器”中使用时,创建与所需活动相同类型的输出参数。如果该字段中已经存在表达式,则在按 CTRL + Shift + M 之前,可以选择该表达式或表达式的一部分,以将选定的文本用作新参数的名称。

Ctrl + Shift + E - 在活动输入字段中使用时将打开“表达式编辑器”

“Ctrl + 空格”- 打开智能提示窗口。

F2 - 允许为选中的活动重命名。

Shift + F2 - 为选中的活动添加注释。

Enter- 保存在活动输入字段中添加的数据。

Shift + Enter - 在活动输入字段中添加一个新行。

选项卡 - 在活动中的字段和按钮之间移动,包括将鼠标悬停在输入字段上时显示的 菜单。

测试自动化

Ctrl+Alt+T - 打开“测试资源管理器”面板。您可以在“设计器”面板中的任何位置使用它。

Alt+T - 在“测试资源管理器”中打开“测试结果”子面板。您只能在“测试资源管理器”面板中使用此选项。

Alt+A - 在“测试资源管理器”中打开“活动”子面板。您只能在“测试资源管理器”面板中使用此选项。

参数对话框

在“调用工作流文件”和“注入 .NET 代码”等活动的“参数”对话框中提供以下键盘快捷方式:

选项卡 - 在网格中的项目之间移动。

删除 - 删除网格中选定的项目。

F2 - 高亮显示当前单元格以进行编辑,将光标定位在行尾。

Ctrl+Tab - 在窗口中为网格中所选项目提供的可用选项之间移动(删除、上移、下移)。

状态栏

Alt + D - 访问状态栏中的“来源控件”、“Orchestrator”文件夹和“Orchestrator/云连接”菜单,然后使用 Shift + Tab 循环切换菜单。选择菜单后,按 Enter 键将其打开。

后台视图

CTRL + Tab - 在选项卡之间移动焦点。该操作也适用于“工具”和“设置”选项卡中的子选项卡。

Tab - 在选项卡内的内容之间移动焦点。

杂项

F1 - 用于访问与当前选定元素关联的帮助主题。

Alt+F4 - 关闭当前窗口。

Alt + - - 打开当前选定面板标题栏中的“选项”上下文菜单。请注意,这适用于字符键上方的连字符键,而不适用于数字键盘中的减号键。

Windows 键+向上箭头- 最大化当前窗口。

Windows 键+向下箭头- 还原当前窗口。

Ctrl+P - 打开“管理包”窗口。

Esc - 关闭“发布”、“管理包”和“文件区别”窗口。

Ctrl + F1 - 最小化或展开功能区。

Ctrl + Shift + R - 删除所有未使用的项目依赖项。

Shift + Tab - 导航至“活动”面板中的前一个活动或节点。

Ctrl + Z - 撤消上一个操作。

Ctrl + Y - 重做您撤消的上一个操作。

Shift + F10 - 打开所选项目的上下文菜单(右键单击)。

Ctrl+Tab - 将焦点移出多行文本框,在该文本框中按 Tab 键可插入选项卡。

Ctrl+Shift+F10 - 关闭所选项目的工具提示内容。

Ctrl + Shift + Q - 在文本编辑器中使用键盘进行导航时,显示包含其他信息的工具提示。

功能区和主页选项卡键

您可以通过按下和释放 Alt 键,然后按一个或多个键,快速进入“主页”选项卡(Studio 后台视图)中的大多数选项,以及“设计”和“调试”选项卡中的功能区。

按下和释放 Alt 键时,当前视图中的选项上方会出现一个或多个字母或数字。要使用选项,请按相应的一个或多个键。对于某些选项,在按初始键组合后,可以使用其他键。



有关快捷方式列表,请参阅以下部分。

设计选项卡功能区键

如果您在“设计”选项卡或“调试”选项卡中,请按 Alt + D 以访问“设计”选项卡功能区的快捷键。

操作已执行

其他按键和操作

N

打开“新建“下拉菜单

S

打开“保存“下拉菜单

S - 另存为

L - 全部保存

ET

打开“导出为模板”窗口

R

打开“调试文件”下拉菜单

C - 运行文件

B - 调试项目

D - 运行项目

X

“剪切”选定的活动

C

“复制”选定的活动

V

“粘贴”复制的活动

MP

打开“管理程序包”窗口

ME

打开“管理实体”窗口

EW

打开“服务编辑器”窗口

U

打开“UI Explorer”窗口

IU

打开“删除未使用项”下拉菜单

F - 删除未使用的工作流

A - 删除未使用的变量

B - 删除未使用的参数

C - 删除未使用的依赖项

D - 删除未使用的导入

E - 删除未使用的屏幕截图

A

打开“分析文件”下拉菜单

B - 分析项目

C - 验证文件

D - 验证项目

S - 工作流分析器设置

EX

打开“导出到 Excel”窗口

p

打开“发布”窗口

调试选项卡功能区键

如果您在“设计”选项卡或“调试”选项卡中,请按 Alt+E 以访问“调试”选项卡功能区的快捷键。

操作已执行

其他按键和操作

R

打开“调试文件”下拉菜单

C - 运行文件

B - 调试项目

D - 运行项目

B

中断执行

T

停止执行

S

进入

V

跳过

O

退出

ER

重试

EI

忽略

ES

重启

F

焦点

p

打开“断点”下拉菜单

T - 切换断点

P - 显示断点面板

LS

设置“慢步骤”速度

LE

启用/禁用“执行跟踪”

LH

启用/禁用“突出显示元素”

LA

启用/禁用“日志活动”

LC

启用/禁用“继续处理异常”

LP

启用/禁用“画中画”

LR

打开“远程调试”下拉列表

C - 配置远程调试

LO

打开“日志”文件夹

标题栏键

要访问 Studio 标题栏中的按钮键(窗口右上侧),请按 Alt 键。

操作已执行

其他按键和操作

F

打开“发送反馈”窗口,

 

L

打开“帮助“下拉菜单。

 

I

打开“登录”/“注销”菜单

 
主页选项卡键

如果您在“设计”选项卡或“调试”选项卡中,请按“Alt + H”打开“主页”选项卡(Studio 后台视图),并访问“主页”选项卡的快捷键。如果您已经在“主页”选项卡中,则只需按“Alt”键。

操作已执行

其他按键和操作

Z

如果项目已打开,则返回上一个选项卡

O

打开项目

C

关闭当前打开的项目

S

打开“开始”选项卡

O - 打开本地项目

C - 克隆或签出项目

P - 创建流程

L - 创建库

A - 创建测试自动化

T - 创建模板

1...9 - 打开最近九个项目之一

T

打开“模板”选项卡

M

打开“团队”选项卡

L

打开“工具”选项卡

U - 打开“UI Explorer”

M - 打开“项目依赖项批量更新工具”

R - 打开“Microsoft Office 修复工具”

C - 安装“Chrome 扩展程序”

F - 安装 Firefox 扩展程序

E - 安装 Edge 扩展程序

J - 安装 Java 扩展程序

S - 安装 Silverlight 扩展程序

T - 安装 Citrix 扩展程序

W - 安装 Windows 远程桌面扩展程序

V - 安装“VMware Horizon 扩展程序”

E

打开“设置”选项卡

G - 打开“常规”选项卡

D - 打开“设计”选项卡

L - 打开“位置”选项卡

M - 打开“管理源”选项卡

P - 打开“许可证和配置文件”选项卡

T - 打开“团队”选项卡

B - 打开“实验室”选项卡

H

打开“帮助”选项卡

D - 打开“产品文档”链接

F - 打开“社区论坛”链接

M - 打开“帮助中心”链接

A - 打开“学院”链接

R - 打开“发行说明”链接

S - 打开“进行简短调查”链接

T - 打开“快速教程”链接

C - 复制许可证信息

此页面有帮助吗?

获取您需要的帮助
了解 RPA - 自动化课程
UiPath Community 论坛
Uipath Logo White
信任与安全
© 2005-2024 UiPath。保留所有权利。