studio
latest
false
Studio 用户指南
- 入门指南
- 设置和配置
- 自动化项目
- 依赖项
- 工作流类型
- 控制流程
- 文件比较
- 自动化最佳实践
- 源代码控件集成
- 调试
- 日志记录
- 诊断工具
- 工作流分析器
- 变量
- 参数
- 导入的命名空间
- 编码自动化
- 基于触发器的 Attended 自动化
- 对象存储库
- ScreenScrapeJavaSupport 工具
- 扩展程序
- Studio 测试
- 故障排除
重要 :
新发布内容的本地化可能需要 1-2 周的时间才能完成。
UiPath Studio 中可用于项目管理、设计、调试和导航的键盘快捷方式的完整列表。
以下是 Studio 键盘快捷方式的完整列表:
文件管理
| 快捷方式 | 描述 |
|---|---|
Ctrl + Shift + N | 新建“空白流程” 。 |
Ctrl + C | 将文件从“资源管理器”面板复制到剪贴板。Ctrl + V用于将其粘贴到树中的任意位置。 |
Shift + Alt + C | 将文件或文件夹路径从“资源管理器”面板复制到剪贴板。 |
Ctrl + O | 用于打开先前创建的工作流 .xaml 或 project.json 文件。 |
Ctrl + L | 打开存储日志文件的文件夹。 |
Ctrl + S | 保存当前打开的工作流。 |
Ctrl + Shift + S | 保存当前打开的所有工作流。 |
Ctrl + V | 将剪贴板中的文件粘贴到“资源管理器”面板中。 |
Ctrl + Tab | 在“设计器”面板中打开的工作流之间移动焦点。 |
Ctrl + W | 关闭“设计器”面板中聚焦的工作流文件。 |
Alt + Left 或者 mouse backward button | 转到项目文件中的上一个元素或上一个项目文件。 |
Alt + Right 或者 mouse forward button | 转到项目文件中的下一个元素或下一个项目文件。 |
Alt + F7 | 在 Studio 面板之间移动焦点。当您使用 Ctrl + Tab 或 Alt + F7 并按住修饰键(分别为 Ctrl 或 Alt)时,将显示以下窗口,允许您在 Studio 中的活动文件和面板之间进行切换。 |
搜索
| 快捷方式 | 描述 |
|---|---|
F3 或者 Ctrl + Shift + P | 打开“命令选项板” 。 |
Ctrl + Shift + T | 打开“添加活动”搜索栏。 |
Ctrl + Shift + F | 打开转到文件搜索栏。 |
Ctrl + F | 打开“通用搜索”栏。 |
Ctrl + J | 打开“跳转到”活动搜索栏。 |
Ctrl + 1 | 切换至通用搜索栏中的当前文件选项卡。 |
Ctrl + 2 | 切换至“通用搜索”栏中的“所有文件”选项卡。 |
Ctrl + 3 | 切换至“通用搜索”栏中的“活动”选项卡。 |
Ctrl + 4 | 切换至“通用搜索”栏中的“变量”选项卡。 |
Ctrl + 5 | 切换至“通用搜索”栏中的“参数”选项卡。 |
Ctrl + 6 | 切换至“通用搜索”栏中的“导入”选项卡。 |
Ctrl + 7 | 切换到“通用搜索”栏中的“项目文件”选项卡。 |
Ctrl + 8 | 切换至“通用搜索”栏中的“依赖项”选项卡。 |
Ctrl + 9 | 切换至“通用搜索”栏中的“代码片段”选项卡。 |
Ctrl + Alt + A | 打开并聚焦“属性”面板。 |
Ctrl + Alt + F | 将焦点设置为“活动”面板中的搜索框。 |
Ctrl + Alt + I | 打开并聚焦“Autopilot”面板。 |
Ctrl + Alt + O | 将焦点设置为“用户界面对象浏览器”面板中的搜索框。 |
Ctrl + Alt + P | 在“资源管理器”面板中打开并聚焦搜索栏。 |
Ctrl + Alt + S | 在代码片段面板中打开搜索栏并聚焦其中。 |
Tab | 导航至面板中的下一项或活动中的下个元素。 |
当关闭所有项目文件时,“设计器”面板中会显示一个实用键盘快捷方式列表,如下图所示:
注释
| 快捷方式 | 描述 |
|---|---|
Ctrl + D | 通过将当前选中的活动放置到“注释掉”容器中来忽略该活动。 |
Ctrl + E | 从放置了活动的“注释掉”容器中删除活动。 |
调试
| 快捷方式 | 描述 |
|---|---|
F9 | 使用断点标记选定的活动。 |
Ctrl + Shift + B | 打开“标记”面板。 |
Ctrl + Alt + E | 打开“错误列表”面板。 |
F10 | 调试时,在当前选定的工作流中跳过一个活动块的执行。 |
F11 | 调试时,使您可以进入一个活动块并执行第一个活动。 |
Shift + F11 | 调试时,在执行完最后一个活动后退出当前容器。 |
录制
| 快捷方式 | 描述 |
|---|---|
Ctrl + Alt + B | 打开基本录制工具栏。 |
Ctrl + Alt + C | 打开Citrix 录制工具栏。 |
Ctrl + Alt + D | 打开桌面录制工具栏。 |
Ctrl + Alt + W | 打开“网页录制”工具栏。 |
F2 | 在录制活动期间添加延迟。 |
F3 | 用于指定自定义录制区域。 |
F4 | 让您选择要录制的用户界面框架,这可以是默认、AA和UIA 。 |
工作流分析和执行
| 快捷方式 | 描述 |
|---|---|
F5 | 在调试模式下运行当前项目,从设置为“主要”的 .xaml 文件开始。 |
Ctrl + F5 | 运行当前项目。 |
F6 | 以调试模式运行当前打开的 .xaml 文件。 |
Ctrl + F6 | 运行当前打开的 .xaml 文件。 |
F7 | 检查文件中是否存在验证错误和“工作流分析器”违规情况。 |
Shift + F7 | 检查整个项目是否存在验证错误和“工作流分析器”违规情况。 |
F8 | 检查当前打开的工作流是否存在验证错误。 |
Shift + F8 | 检查所有项目文件中是否存在验证错误。 |
Pause | 在正常模式和调试模式下暂停当前工作流的执行。 |
F12 | 在正常模式和调试模式下停止当前工作流的执行。 |
选定活动
| 快捷方式 | 描述 |
|---|---|
Ctrl + T | 将该活动放置在“Try Catch”活动的“Try”部分中。 |
Ctrl + N | 在当前项目中新建序列图。 |
Ctrl + C | 将选定的一个或多个活动复制到剪贴板。 |
Ctrl + V | 将复制的一个或多个活动粘贴到选定项目中。 |
Ctrl + K | 当在输入字段或“表达式编辑器”中使用时,创建与所需活动相同类型的变量。如果该字段中已经存在表达式,则在按 CTRL + K 之前,可以选择该表达式或表达式的一部分,以将选定的文本用作新变量的名称。 |
Ctrl + M | 在输入字段或“表达式编辑器”中使用时,创建与所需活动相同类型的输入参数。如果该字段中已经存在表达式,则在按 CTRL + M 之前,可以选择该表达式或表达式的一部分,以将选定的文本用作新参数的名称。 |
Ctrl + Shift + M | 在输入字段或“表达式编辑器”中使用时,创建与所需活动相同类型的输出参数。如果该字段中已经存在表达式,则在按 CTRL + Shift + M 之前,可以选择该表达式或表达式的一部分,以将选定的文本用作新参数的名称。 |
Ctrl + Shift + E | 在活动输入字段中使用时,将打开表达式编辑器。 |
智能提示
| 快捷方式 | 描述 |
|---|---|
Ctrl + Space | 打开智能提示窗口。 |
Ctrl + 1**... **Ctrl + 6 | 当智能提示窗口打开时,启用/禁用在代码补全窗口中显示每个项目类型,方法与使用窗口底部的按钮相同:Ctrl + 1 方法、Ctrl + 2 属性、Ctrl + 3 类、Ctrl + 4 命名空间、Ctrl + 5 常量、Ctrl + 6 关键字。 |
F2 | 允许重命名选定的活动。 |
Shift + F2 | 向选定的活动添加注释。 |
Enter | 保存在活动输入字段中添加的数据。 |
Shift + Enter | 在活动输入字段中添加一个新行。 |
Tab | 在活动中的字段和按钮之间移动,包括 |
Ctrl + Shift + M | 启用或禁用书签。 |
Ctrl + Period (.) | 转到下一个书签。 |
Ctrl + Comma (,) | 转到上一个书签。 |
代码编辑器
| 快捷方式 | 描述 |
|---|---|
Alt + Down | 在代码编辑器标头中打开用作导航面包屑导航的下拉列表。此快捷方式可用于导航到项目中的其他编码自动化,以及已打开的编码自动化中的所有方法和类。 |
测试自动化
| 快捷方式 | 描述 |
|---|---|
Ctrl + Alt + T | 打开“测试资源管理器”面板。您可以在“设计器”面板中的任何位置使用它。 |
Alt + Down Arrow | 从“测试资源管理器”菜单中打开“在视图中运行全部” 。 |
Alt + T | 在“测试资源管理器”中打开“测试结果”子面板。您只能在“测试资源管理器”面板中使用此选项。 |
Alt + A | 在“测试资源管理器”中打开“活动”子面板。您只能在“测试资源管理器”面板中使用此选项。 |
参数对话框
在“调用工作流文件”和“注入 .NET 代码”等活动的“参数”对话框中提供以下键盘快捷方式:
| 快捷方式 | 描述 |
|---|---|
Tab | 在网格中的项目之间移动。 |
Delete | 删除网格中选定的项目。 |
F2 | 高亮显示当前单元格以进行编辑,将光标定位在行尾。 |
Ctrl + Tab | 在窗口中网格中所选项目的可用选项之间移动(删除、上移、下移)。 |
状态栏
| 快捷方式 | 描述 |
|---|---|
Alt + D | 访问状态栏中的“来源控件”、“Orchestrator”文件夹和“Orchestrator/云连接”菜单,然后使用Shift + Tab循环切换菜单。选择菜单后,按Enter 键即可打开该菜单。 |
后台视图
| 快捷方式 | 描述 |
|---|---|
CTRL + Tab | 在选项卡之间移动焦点。该操作也适用于“工具”和“设置”选项卡中的子选项卡。 |
Tab | 在选项卡内的内容之间移动焦点。 |
杂项
| 快捷方式 | 描述 |
|---|---|
F1 | 用于访问与当前选定元素关联的帮助主题。 |
Alt + F4 | 关闭当前窗口。 |
Alt + - | 在当前选定面板的标题栏中打开“选项”上下文菜单。请注意,这适用于字符键上方的连字符键,而不适用于数字键盘中的减号键。 |
Windows key + Up Arrow | 最大化当前窗口。 |
Windows key + Down Arrow | 还原当前窗口。 |
Ctrl + P | 打开“管理包”窗口。 |
Esc | 关闭发布、管理包、文件区别窗口。 |
Ctrl + F1 | 固定或取消固定功能区。 |
Ctrl + Shift + R | 删除所有未使用的项目依赖项。 |
Shift + Tab | 导航至“活动”面板中的上一个活动或节点。 |
Ctrl + Z | 撤消上一个操作。 |
Ctrl + Y | 重做您已撤消的上一个操作。 |
Shift + F10 | 打开所选项目的上下文菜单(右键单击)。 |
Ctrl + Tab | 将焦点移出多行文本框,在该文本框中按Tab键可插入选项卡。 |
Ctrl + Shift + F10 | 关闭所选项目的工具提示内容。 |
Ctrl + B | 显示/隐藏左侧面板。 |
| `Ctrl+` | 显示/隐藏底部面板。 |
Ctrl + Alt + B | 显示/隐藏右侧面板。 |
Ctrl + Alt + Z | 显示/隐藏所有面板。 |
功能区和主页选项卡键
您可以通过按下和释放 Alt 键,然后按一个或多个键,快速进入“主页”选项卡(Studio 后台视图)中的大多数选项,以及“设计”和“调试”选项卡中的功能区。
按下和释放 Alt 键时,当前视图中的选项上方会出现一个或多个字母或数字。要使用选项,请按相应的一个或多个键。对于某些选项,在按初始键组合后,可以使用其他键。
有关快捷方式列表,请参阅以下部分。
设计选项卡功能区键
如果您在“设计”选项卡或“调试”选项卡中,请按 Alt + D 以访问“设计”选项卡功能区的快捷键。
| 键 | 操作已执行 | 其他按键和操作 |
|---|---|---|
| N | 打开“新建“下拉菜单 | – “ |
| S | 打开“保存“下拉菜单 | S - 另存为 L - 全部保存 |
| EA | 打开“导出为”下拉列表 | ET - 打开“导出为模板”窗口 EL - 打开“导出为库”窗口 |
| R1 | 打开“调试文件”下拉菜单 | C - 运行文件 B - 调试项目 D - 运行项目 |
| X | “剪切”选定的活动 | – “ |
| C | “复制”选定的活动 | – “ |
| V | “粘贴”复制的活动 | – “ |
| U | 撤消操作 | – “ |
| R2 | 重做撤消操作 | – “ |
| MP | 打开“管理程序包”窗口 | – “ |
| ME | 打开“管理实体”窗口 | – “ |
| T | 打开 "Test Manager" 下拉列表 | T - Test Manager 设置 |
| A1 | 打开“应用/网页录制器” | – “ |
| C2 | 打开“计算机视觉录制器” | – “ |
| U2 | 打开“用户事件”下拉列表 | C - 当单击元素时 K - 当键入元素时 A - 当发生应用程序事件时 |
| T2 | 打开“表格提取”窗口 | – “ |
| U3 | 打开“UI Explorer”窗口 | – “ |
| IU | 打开“删除未使用项”下拉菜单 | F - 删除未使用的工作流 A - 删除未使用的变量 B - 删除未使用的参数 C - 删除未使用的依赖项 D - 删除未使用的导入 E - 删除未使用的屏幕截图 G - 移除未使用的项目缓存 |
| A2 | 打开“分析文件”下拉菜单 | B - 分析项目 C - 验证文件 D - 验证项目 S - 工作流分析器设置 |
| EX | 打开“导出到 Excel”窗口 | – “ |
| p | 打开“发布”窗口 | – “ |
调试选项卡功能区键
如果您在“设计”选项卡或“调试”选项卡中,请按 Alt+E 以访问“调试”选项卡功能区的快捷键。
| 键 | 操作已执行 | 其他按键和操作 |
|---|---|---|
| R | 打开“调试文件”下拉菜单 | C - 运行文件 B - 调试项目 D - 运行项目 |
| B | 中断执行 | – “ |
| T | 停止执行 | – “ |
| S | 进入 | – “ |
| V | 跳过 | – “ |
| O | 退出 | – “ |
| ER | 重试 | – “ |
| EI | 忽略 | – “ |
| ES | 重启 | – “ |
| F | 焦点 | – “ |
| P1 | 打开“断点”下拉菜单 | T - 切换断点 P - 显示“标记”面板 |
| LS | 设置“慢步骤”速度 | – “ |
| LE | 启用/禁用“执行跟踪” | – “ |
| LH | 启用/禁用“突出显示元素” | – “ |
| LA | 启用/禁用“日志活动” | – “ |
| LC | 启用/禁用“继续处理异常” | – “ |
| LP | 启用/禁用“画中画” | – “ |
| LR | 打开“远程调试”下拉列表 | C - 配置远程调试 |
| P2 | 打开“配置文件执行”下拉列表 | O - 打开分析面板 I - 导入分析会话 |
| LO | 打开“日志”文件夹 | – “ |
标题栏键
要访问 Studio 标题栏中的按钮键,请按 Alt 键。
| 键 | 操作已执行 | 其他按键和操作 |
|---|---|---|
| L | 打开“新建“下拉菜单 | |
| F1 | 打开“保存“下拉菜单 | |
| D | 打开“导出为”下拉列表 | |
| E | 打开“调试文件”下拉菜单 | |
| F2 | 打开“发送反馈”窗口, | |
| I | 打开“登录”/“退出登录”菜单 |
主页选项卡键
如果您在“设计”选项卡或“调试”选项卡中,请按“Alt + H”打开“主页”选项卡(Studio 后台视图),并访问“主页”选项卡的快捷键。如果您已经在“主页”选项卡中,则只需按“Alt”键。
| 键 | 操作已执行 | 其他按键和操作 |
|---|---|---|
| Z | 如果项目已打开,则返回上一个选项卡 | – “ |
| O | 打开项目 | – “ |
| C | 关闭当前打开的项目 | – “ |
| S | 打开“开始”选项卡 | O - 打开本地项目 C - 克隆或签出项目 P - 创建流程 L - 创建库 A - 创建测试自动化 T - 创建模板 R1...R9 - 打开最近九个项目之一 |
| L | 打开“工具”选项卡 | A - 打开“应用”选项卡 E - 打开“UiPath 扩展”选项卡 T - 打开“插件”选项卡 U - 打开“UI Explorer” M - 打开“项目依赖项批量更新工具” R - 打开“Microsoft Office 修复工具” |
| T | 打开“模板”选项卡 | – “ |
| M | 打开“团队”选项卡 | – “ |
| E | 打开“设置”选项卡 | G - 打开“常规”选项卡 D - 打开“设计”选项卡 L1 - 打开“位置”选项卡 M - 打开“管理源”选项卡 C - 打开“代码编辑器”选项卡 L2 - 打开“语言”下拉列表 T - 打开“重置设置”窗口 |
| H | 打开“帮助”选项卡 | D - 打开“产品文档”链接 F - 打开“社区论坛”链接 H - 打开“帮助中心”链接 A - 打开“学院”链接 R - 打开“发行说明”链接 T - 打开“快速教程”链接 C - 复制许可证信息 |