Orchestrator
2022.4
ソフトウェア要件 - スタンドアロン 2022.4
バナーの背景画像
ロゴ
Orchestrator インストール ガイド
最終更新日 2024年2月15日

ソフトウェア要件

サーバー OS

ソフトウェア

対応バージョン

Windows Server

  • 2012 R2
  • 2016
  • 2019
  • 2022 年

データベース

ソフトウェア

対応バージョン

SQL Server

  • 2012 Standard または Enterprise Edition
  • 2014 Standard または Enterprise Edition
  • 2016 Standard または Enterprise Edition
  • 2017 Standard または Enterprise Edition
  • 2019 Standard または Enterprise Edition
  • Azure SQL Database
  • Amazon RDS for SQL Server
  • Google Cloud SQL for SQL Server
: Insights のインストールを検討している場合は、データベースで列ストア インデックスと JSON 関数の両方がサポートされていることを確認してください。

UiPath High Availability Add-on

  • すべてのバージョン
: サポートされている HA インストールにのみ必要です。
重要:

Orchestrator のマルチノード デプロイは、通信に REdis Serialization Protocol (RESP) を使用するため、このプロトコルを使用するあらゆるソリューションによる設定が可能です。

UiPath がサポートしているソリューションは HAA のみです。

ログ & ビジュアリゼーション

注: 以下のソフトウェアは明示的に必要ではありませんが、ログ & ビジュアリゼーションの目的で推奨されます。

ソフトウェア

対応バージョン

Elasticsearch

  • 7.16.3 - 8.x

Elasticsearch のサポート終了日およびサポート一覧表をご確認ください。

バージョン 7.16.2 から、Elasticsearch では Windows MSI インストーラー パッケージが提供されなくなりました

Kibana

  • 7.16.3 - 8.x

ブラウザー

ソフトウェア

対応バージョン

Google Chrome

  • 50 以上

Firefox

  • 69.0.1 以降

プライベート ブラウジング モードではサポートされません。

Microsoft Edge

  • 20 以上
注: Internet Explorer はサポートされていません。

デプロイ

ソフトウェア

対応バージョン

WebDeploy

  • 3.5 以降

64 ビット バージョン

Azure one などの PowerShell スクリプトのインストールでのみ必要です。

ソフトウェアフレームワーク

ソフトウェア

対応バージョン

.NET Framework

  • 4.7.2 以降

ASP.NET Core モジュール

  • 3.1.x
  • 6.0.x
注:
  • IIS の ASP.NET Core モジュール 3.1.x は、ホスティング バンドルの一部としてこちらからダウンロードできます。
  • IIS の ASP.NET Core モジュール 6.0.x は、ホスティング バンドルの一部としてこちらからダウンロードできます。
インストールが必要なのはコアのみで、ランタイムは必要ありません。コアのみをインストールするには、コマンドラインで OPT_NO_RUNTIME=1 を使用してインストーラーを実行します。

Web サーバー

ソフトウェア

対応バージョン

IIS

  • 8+
  • IIS モジュール - URL Rewrite
  • 2.1+

仮想化プラットフォーム

注: Windows 仮想マシンを作成できる任意のプラットフォームも使用できます。

ソフトウェア

対応バージョン

Citrix XenDesktop

  • 7.6 以降

Oracle VirtualBox

  • 5.0 以降

Microsoft Hyper-V

N/A

VMWare

N/A

資格情報ストア

注: 以下の項目は、Orchestrator を使用する上で必須のものではなく、オプションの連携機能です。

ソフトウェア

対応バージョン

依存関係

CyberArk®

  • Central Provider 11.1
  • Digital Vault 9.6 以降
  • Application Password SDK 9.7 以降

Azure Key Vault

  

HashiCorp Vault

  • オープン ソース 1.5.0 以降
  • Enterprise 1.5.0 以降
  • Cloud (HCP Vault)
 

BeyondTrust

  • 21.3+
 
注:

CyberArk® Credential Provider のシステム要件の詳細については、CyberArk® のドキュメントをご覧ください。

Orchestrator でプラグイン経由で別の資格情報ストアを使用している場合、すべての依存関係と、各プラグインの要件を満たしていることを確認する必要があります。

StudioRobot のソフトウェア要件を確認してください。

[サポートとサービス] アイコン
サポートを受ける
UiPath アカデミーのアイコン
RPA について学ぶ - オートメーション コース
UiPath フォーラムのアイコン
UiPath コミュニティ フォーラム
UiPath ロゴ (白)
信頼とセキュリティ
© 2005-2024 UiPath. All rights reserved.