studio
2020.10
false
UiPath logo, featuring letters U and I in white
OUT OF SUPPORT

Studio User Guide

Last updated Dec 20, 2023

Automating Citrix Technologies

Interactive Selection in Citrix Apps Freezes And Nothing Is Selected

Observed Behavior

After you install the UiPath Extension for Citrix and try to select UI elements from a Citrix App, interactive selection freezes for one minute, and then nothing is selected.

Cause

This happens if the UiPath Remote Runtime is not running in the Citrix App session.

Solution

  • Check if the UiPathRemoteRuntime.msi is installed on the Citrix application server from which the Citrix App is opened.
  • On the Citrix application server, check if the UiPathRemoteRuntime.exe process is running. If the UiPathRemoteRuntime.msi is installed, then the process is started automatically on the Citrix App session login.



    Note: If you can not install the UiPathRemoteRuntime.msi on the Citrix application servers, it is recommended to uninstall the UiPath Extension for Citrix from the client machine, as described here.

Could Not Copy Over File "C:\Program Files (x86)\Citrix\ICA Client\UIPathPluginCitrix.dll". It Is Being Used by Another Process.

Observed Behavior

When you try to install the UiPath Extension for Citrix, the following error is displayed:



Cause

This occurs when the UiPath Extension for Citrix is already installed and an open Citrix App is using it.

Solution

Close all your active Citrix App sessions, as described here and then try to install the UiPath Extension for Citrix again.

Could Not Read Citrix Registry Key: 'SOFTWARECitrixInstallICA Client' Value: 'InstallFolder'

Observed Behavior

When you try to install the UiPath Extension for Citrix, the following error is displayed:



Cause

This error message is displayed when the Citrix Receiver is not installed. It is also displayed if the Citrix Receiver for Universal Windows Platform is installed.

Solution

Download and install the Citrix Receiver or Citrix Workspace.

Unhandled Exception in Wfica32.exe 0xC0000094: Integer Division by Zero

Observed Behavior

Target Citrix App fails to launch and the Citrix ICA client crashes.

Cause

Activities which use the GetWindowText function (such as Element Exists) are executed before the Citrix App can load.

Solution

Allow time for the Citrix App to load by adding a delay before the activity.

Was this page helpful?

Get The Help You Need
Learning RPA - Automation Courses
UiPath Community Forum
Uipath Logo White
Trust and Security
© 2005-2024 UiPath. All rights reserved.