UiPath Studio Guide

The User Interface

UiPath Studio contains multiple panels for an easier access to specific functionalities. They can be docked, act as floating windows, or the Auto-hide option can be enabled from the drop-down list.

The Ribbon

The ribbon is straightforward and can be minimized or expanded by clicking the Minimize / Expand button minimize_expand. It consists of the following three tabs:

  1. Start - Start a new project from predefined templates or open a project you recently worked on. By default, projects are created in C:\Users\<current_user>\Documents\UiPath. The Open project dialog searches for project.json files.

Note:

Updating Studio to v2018.3 causes the Recent projects list to be reset.

  1. Design - add sequences, flowcharts and state machines to your project, install and manage activities packages, build interactions with UI elements, export workflows to Excel, and then publish your work to Orchestrator or custom feeds. Keep in mind, that Wizards and Selectors sections aren't visible in the Ribbon unless you install the UiPath.UIAutomation.Activities package.
  1. Execute - validate and run your workflow, while using debugging tools to set breakpoints, monitor the execution of activities step by step, and adjust the debugging speed. Open logs to view details regarding execution and any changes made to the project.

Note:

Files that are not created during the execution of the automation project become read-only when published to Orchestrator. If your business process requires you to write in a specific file at some point, be sure to create it while designing the project.

The Tools Tab

The Tools tab can be used for installing extensions for Chrome, Firefox, Edge, Java ,Silverlight, Citrix, and Windows Remote Desktop, and for launching the UI Explorer and Project Dependencies Mass Update Tool. For more information on extensions, check the About Extensions page.

The Project Dependencies Mass Update Tool is also located under the Tools tab, offering a user-interface tool for updating dependencies versions on multiple projects at once, located locally or in remote source control repositories.

The Settings Tab

The Settings tab has options for changing the interface language, theme, setting global preferences, and managing activity feeds.

General

The General subsection includes the option to change the interface language for Studio and Robot, by picking one of the available languages: English, Japanese, French, Russian, or Chinese (Simplified).

The Studio interface theme can be changed from the drop-down menu, by choosing either Light or Dark theme, and restarting Studio for the changes to apply.

Studio detects High Contrast on the machine and switches to this mode upon restart.

Note:

For the Dark theme to work, automation projects must have at least UiPath.UIAutomation.Activities v18.4.2 and UiPath.System.Activities v18.4.1 as dependencies.

The Reset Settings button reverts all General and Design settings in Studio to their default state. However, please note that it has no effect on feeds or favorite activities.

Aside from this, the following settings are reverted to their default state:

  • The list of Recent files;
  • Studio layout;
  • The Break on Exceptions option in the Execute tab > Options;
  • Show Activities options and pinned activities in the Activities panel;
  • User-added folders in the Snippets panel, the last directory where you opened a project from, and the Update Channel, which is switched to Stable.

Design

This subsection contains a set of global settings that apply to all projects opened in this version of Studio.

Save and Publish

The Auto backup interval allows you to set a regular interval at which projects are automatically backed up. This is useful for restoring the last saved copy of the workflow. The default value is set at 30,000 milliseconds. The minimum value is 10,000 milliseconds, while the maximum one is 9,999,999 ms.

The Publish project timeout sets the timeout value for publishing projects. The default value is 30 seconds. The maximum timeout is 999,999 seconds while the minimum one is 1 second.

Execution

The Output console size sets up to 9,999 lines in a single session to be displayed in the Output panel. The default value is 2,000 lines. The maximum value that can be added is 9,999 lines, while the minimum one is 1 line.

The Minimize on run toggle allows you to set Studio to maximize or minimize when running projects.

Default Locations

To change the default location where projects are created simply add the new path in the Project Path box.

The Publish Library URL box allows you to add a default location where all libraries are published when the custom feed option is selected.

The Publish Process URL works in the same way only for processes. It allows you to provide a default path where processes are published when the custom feed option is selected.

Manage Sources

Manage feeds for activities packages from Studio Backstage view without having to open a project. This section is similar to the one in the Manage Packages window, which lets you adjust feeds per project.

Note:

The Local activity feed is enabled by default. The Orchestrator feed is also enabled if the Robot is connected to Orchestrator.

The Help Tab

The Help tab directs you to product documentation, release notes, online resources, the Community Forum and the RPA Academy.

Information regarding product version and installation, license availability, update channel and device ID is also found in the Help page, together with a Copy Info button for quickly copying the details to the clipboard.

The Quick Access Toolbar

The Quick Access Toolbar is located by default on the title bar, above the ribbon, yet you can easily move it below. It provides shortcuts for the most used commands.

The Universal Search Bar

The Universal Search bar enables you to search for activities, snippets, files, variables and arguments used in the project.

The Designer Panel

The Designer panel displays your current automation project, enables you to make changes to it, and provides quick access to variables, arguments and imports.

It is possible to navigate within a diagram by double-clicking the activity you want to view. The path is displayed as breadcrumbs in the header of the Designer panel. Please note that when using multiple displays scaled differently the text in the input field part of some activities might be improperly shown.

Activate Pan Mode by clicking the pan_mode icon, holding the Space key or pressing the middle mouse button. Use the zoom drop-down to change the zoom level and click the reset_zoom icon to reset it back to 100%.

The Fit to Screen fit_screen icon changes the zoom in such a way that the whole workflow fits in the Designer panel. Click the overview icon to get an overview of the whole project and navigate through sections by adjusting the focus.

The Context Menu

The context menu enables you to perform several operations on your workflow, be it a sequence or a flowchart. You can display it by right-clicking an activity inside your workflow.

Note

If you select more activities, the menu is not displayed at all.

Field Descriptions for the Context Menu

Option
Description

View Parent

Displays the parent of the target activity in the Designer panel.
Note: This option is only displayed for child-activities, if they are opened in the Designer panel.

Open

Opens the selected activity in the Designer panel. Has the same result as double-click.

Collapse

Collapses the activity thus reducing the displayed details to "Double-click to view". You can achieve the same result by clicking the Collapse button **Collapse**.
Note: Only displayed for sequences.

Expand in Place

Expands the content of the activity, displaying its detailed content. You can achieve the same result by clicking the Expand button **Expand**.
Note: Only displayed for sequences.

Cut

Removes the selected activity and places it onto the Clipboard.

Copy

Copies the selected activity and places it onto the Clipboard.

Paste

Inserts the content of the Clipboard at the current location.

Delete

Deletes the target activity.

Note: Since the Context menu is only displayed for a one-activity selection, you can use this command for more activities with the corresponding keyboard shortcut, Delete.

Annotations

Add, edit, delete, show and hide annotations added to activities in the workflow.

Copy as Image

Makes a screenshot of the content displayed in the Designer panel.

Note: If you want to make a screenshot of a child activity, make sure to firstly open it in the Designer panel.

Save as Image

Makes a screenshot of the content displayed in the Designer panel and prompts the user to set the details for saving it (Name, Type, Destination). Supported formats: JPG, PNG, GIF, XPS.

Create Variable

Creates a variable in the Variable panel.

Remove Surrounding Sequence

Removes the selected Sequence activity from the Designer panel. The activities that it contains are moved to the parent sequence.

Surround with Try Catch (Ctrl + T)

Inserts the activity in a Try Catch statement.

Note: A Try Catch statement is used for handling exceptions caused by data or coding errors. The Try clause encloses the activity to be checked for exceptions. The Catches clause is the exception handler. The Finally clause is used for executing an activity regardless of the status of the first two clauses.

Extract as Workflow

Creates a new workflow containing the targeted activity with the purpose of breaking down a large project into smaller ones. In the place of the extracted activity an Invoke <new> workflow activity is created which enables you to edit and import arguments from the newly created workflow. The arguments are created automatically from the variables used in that activity. The Invoke <new> workflow activity automatically maps the local variables to invoke arguments for the extracted workflow.

Open Workflow

Opens a workflow created using the above option.

Enable Activity

Enables a previously disabled activity.

Disable Activity

Disables an activity, which is then placed inside a Comment out activity.

Toggle Breakpoint

Marks the selected activity as a breakpoint for debugging. Breakpoints can also be toggled by clicking the Breakpoint button in the Execute tab. You can trigger a breakpoint for one activity at a time.

Show All Conditions

Displays all conditions defined in your project (Properties panel > Conditions).

Note: This option is only displayed for flowcharts when you right-click an empty space inside the project; it is not displayed if you right-click an activity in your flowchart.

Hide All Conditions

Hides all displayed conditions.

Note: This option is only displayed for flowcharts when you right-click an empty space inside the project; it is not displayed if you right-click an activity in your flowchart.

Set as Start Node

Connects the selected activity with the Start node.
Note: Only displayed for flowcharts.

Set as Initial State

Connects the State Machine specific activity to with the Start node.
Note: Only displayed for state machines.

The context menu is also displayed for tabs in the Designer panel. The following options are available:

Option
Description

Close

Closes the active tab.

Close Others

Closes all tabs but the active one.

Close All Documents

Closes all tabs.

Float

Undocks the target tab and changes it to a floating state.

Pin Tab

Pins the target tab in the Designer panel.
Note: The tab pinned last is always moved in front of all other existing tabs (pinned or not). The position of a pinned tab can only be changed relative to other pinned tabs.

New Horizontal Tab Group

Splits the screen horizontally, enabling you to see two or more instances of the Designer panel within the same screen. The target project is moved onto the panel on the right.
Note: Only displayed when your project contains two or more tabs and, implicitly, workflows.

New Vertical Tab Group

Splits the screen vertically, enabling you to see two or more instances of the Designer panel within the same screen. The target project is moved onto the panel at the bottom.
Note: Only displayed when your project contains two or more tabs and, implicitly, workflows.

Move to Previous Tab Group

Moves the target tab onto the previous Designer panel displayed.
Note: Only displayed if you had used the New Vertical Tab Group or New Horizontal Tab Group options before.

Move to Next Tab Group

Moves the target tab onto the next Designer panel displayed.
Note: Only displayed if you had used the New Vertical Tab Group or New Horizontal Tab Group options before.

The Activities Panel

The Activities panel shows available activities that can be added to the current project, and provides a search box for quick access.

The Show Activities button opens a list with options for showing favorite, recently used, available and compatible activities. The Pin Favorites option enables you to keep favorite activities always visible in the panel.

Note:

The search box can be used for finding activities by their class name, regardless of the interface language set in Studio.

The Snippets Panel

The Snippets panel enables you to easily reuse automations. It includes, by default, multiple samples and snippets.

You can add your own by clicking the Add Folder button and selecting a directory from your hard drive. Empty folders are not displayed.

To remove a folder, right-click it and select Remove.

The Project Panel

The Project panel enables you to view the contents of the current project, add folders, open the file location, manage dependencies, and adjust project settings.

Option
Description

Expand Allexpand_all

Expands all nodes in the automation project.

Collapse Allcollapse_all

Collapses all nodes in the automation project.

Refreshrefresh

Refreshes the project.

Show All Filesshow_files

Shows all files belonging to the automation project, including the project.json.

Project Settingsproject_settings

Opens the Project Settings window for processes or libraries.

File Explorerfile_explorer

Opens the project's location on the machine.

Show Team Pageshow_team

Opens the Team page in Studio Backstage view.

Remove Unused Screenshotsremove_screenshots

Removes screenshots that aren't used when running the automation project.

Context Menu for Projects

Right-click any file or folder in the Project panel to open a context menu that contains the following options:

Option
Description

Open Project Folder

Opens the local folder containing the project.

Project Settings

Opens the Project Settings window for adjusting project preferences.

Add New Folder

Adds a new folder to the project tree.

Import Workflows

Imports .xaml files to the project and adds Imported in the file name if it coincides with the name of the main file.

Open

Opens the selected .xaml file in the Designer panel.

Rename

Enables you to rename the selected file or folder, and opens the Rename Item window.

Delete

Deletes the selected item only from your local machine.

Select for Compare

Selects the current file for comparison.

Compare with Selected

Compares the current file with the previously selected file using Compare Files.

Run

Runs the selected .xaml file.

Set as Main

Sets the selected .xaml file as Main in the project definition, meaning that the project execution starts with that file. There can only be one Main project file.

Make private or public

Makes the workflow contained in the library, either public or private. After publishing, the public workflow is available in the Activities panel.

Properties

Open the library’s Properties window for adding a tooltip and Help Link.

Set as Global Handler

Sets the .xaml file as the Global Exception Handler for the project. This is applicable to one workflow per project/process.

Remove Handler

Removes the Global Exception Handler tag from the .xaml file.

The Properties Panel

The Properties panel is contextual and enables you to view and change the properties of a selected activity. When selecting two activities in the same workflow, common properties can be modified from the Properties panel.

The Outline Panel

The Outline panel displays the project hierarchy, all available variables and nodes. You can highlight activities in this panel by selecting them in the Designer panel, or you can go to a specific activity by selecting it in the Outline panel.

The Output Panel

The Output panel enables you to display the output of the Log Message or Write Line activities, among other things. Exceptions for packages are also displayed in this panel.

From the Output panel, you can show or hide messages that have different log levels (errors, warnings) by clicking the buttons in the panel’s header. Double-clicking a message displays further details about it, with the option to copy information.

When debugging, the Output panel shows logs for when an activity starts executing and until it ends. This can be enabled from the Log Activities option in the Execute tab.

The Clear All button erases all info displayed in the Output panel. Logs and other data stored in this panel are erased when a workflow is run. The Output panel displays up to 2,000 lines at a time.

The Locals Panel

The Locals panel displays all the variables that are in the scope of the activity that is currently running. This panel is only visible while debugging.

It can be used to track the usage of variables during execution, as well as viewing their values while they change. This can be done in the Property Value window, which can be accessed by hovering over the Value field of a variable and clicking the search button.


The User Interface


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.