- Notas de Versão
- Introdução
- Configuração e Instalação
- Projetos de automação
- Dependências
- Tipos de fluxos de trabalho
- Comparação de arquivos
- Melhores Práticas de Automação
- Integração de controle de origem
- Depuração
- A ferramenta de diagnóstico
- Analisador de Fluxo de Trabalho
- Sobre o Analisador de Fluxo de Trabalho
- STN MG-001 - Convenção de nomenclatura de variáveis
- STN MG-002 - Convenção de nomenclatura de argumentos
- STN MG-004 - Duplicação de Nome de Exibição
- STN MG-005 - Variável substitui variável
- STN MG-006 - Variável substitui argumento
- STN MG-008 - Comprimento de variável excedido
- STN MG-009 - Variáveis Catablema de prefixo
- STN MG-011 - Argumentos Catablema de prefixo
- STN MG-012 - Valores padrão de argumentos
- STN MG-016 - Comprimento do argumento excedido
- SR-DB-002 - Contagem alta de argumentos
- SR-DB-003 - Esvaziar bloco catechu
- SR-DB-007 - Múltiplas camadas Com fluxograma
- SR-DB-020 - Propriedades de saída indefinidas
- SR-DB-023 - Fluxo de trabalho vazio
- SR-DB-024 - Verificação da atividade Persistente
- SR-DB-025 - Pré-requisito de serialidade de variáveis
- SR-DB-026 - Uso da atividade Dela
- SR-DB-027 - Melhores práticas de persistência
- SR-DB-028 - Pré-requisito de serialidade de argumentos
- SR-US-005 - Argumentos de atividades embutidos em código
- SR-US-009 - Variáveis não utilizadas
- SR-US-010 - Dependências não utilizadas
- SR-US-014 - Restrições de pacotes
- SR-US-020 - Mensagens de logue mínimas
- SR-US-024 - Não utilizado e postergado
- SR-US-025 - Uso incorreto do valor salvo
- SR-US-026 - Restrições da atividade
- SR-US-027 - Pacotes necessários
- ST-USG-28 — restringir modelos de invocação de arquivos
- Variáveis
- Argumentos
- Namespaces Importados
- Fluxo de controle
- Repo. de Objetos
- Geração de logs
- A ferramenta ScreenScrapeJavaSupport
- Teste do Studio
- Extensões
- Solução de problemas
- Sobre a solução de problemas
- Suporte e limitações do Microsoft Apo-V
- Solução de problemas do Internet Explorer x64
- Problemas do Microsoft Office
- Como identificar elementos de EU em PDF com opções de acessibilidade
- Reparando o suporte da Active Accessibility
- Solução de problemas de aplicativos do JxBrowser
- Monitoração de eventos de usuário
- Solução de problemas da Citrix
- Automação de aplicativos em execução com um usuário diferente do Windows
O Studio contém vários painéis para acesso mais fácil a funcionalidades específicas. Elas podem ser encaixadas, atuar como janelas flutuantes ou a opção Ocultar automaticamente pode ser habilitada na lista suspensa.
Visão geral
| Não. | Name | Description |
|---|---|---|
|
1 |
Acesse as três principais áreas do Studio:
| |
|
2 | ||
|
3 |
Crie sua automação por meio do gerenciamento de atividades adicionadas ao arquivo de fluxo de trabalho atual. | |
|
4 |
Usando as barras de pesquisa disponíveis, pesquise dentro do seu projeto: | |
|
5 |
Gerencie as variáveis. | |
|
6 |
Gerencie os argumentos. | |
|
7 |
Gerencie os namespaces importados. | |
|
8 |
Visualize o conteudo do projeto atual, gerencie arquivos, pastas e dependências, ajustando as configurações do projeto. | |
|
9 |
Visualize todas as atividades e adicione atividades à automação. | |
|
10 |
Use os fluxos de trabalho previamente criados e adicione suas próprias automações reutilizáveis. | |
|
11 |
Visualize e configure as propriedades de uma atividade selecionada. | |
|
12 |
Visualize a hierarquia do fluxo de trabalho atual e todos os nós disponíveis. | |
|
13 |
Adicione recursos como ativos, filas, processos e entidades do Orchestrator. | |
|
14 |
Crie e reutilize as taxonomias da interface de usuário dentro e entre os projetos. | |
|
15 |
Visualize o resultado das atividades de Mensagem de Registro em Log e de WriteLine, informações de status sobre a execução do projeto, erros gerados por pacotes de atividades e muito mais. | |
|
16 |
Vizualize todos os erros gerados ao executar o Analisador de Fluxo de Trabalho. | |
|
17 |
Visualize todos os locais onde haja um elemento referenciado no projeto. | |
|
18 |
Gerencie os pontos de interrupção adicionados ao projeto. | |
|
19 |
Visualize as informações de status e gerencia a conexão com o Orchestrator e a integração do controle de origem. |
A Faixa de Opções
Guias da Faixa de Opções
The ribbon is straightforward and can be minimized or expanded by clicking the Minimize / Expand button
. It consists of the following three tabs:
-
Home - create and open projects, configure Studio, or access help and license information from the Studio Backstage View.
-
Design - Adicione sequências, fluxogramas e máquinas de estado para o seu projeto. Instale e gerencie os pacotes de atividades, crie interações com elementos de interface de usuário, exporte fluxos de trabalho para o Excel e depois publique seu trabalho no Orchestrator ou em feeds personalizados. Lembre-se que os assistentes e a ferramenta UI Explorer não ficam visíveis na Faixa de opções, a menos que você instale o pacote
UiPath.UIAutomation.Activities. -
Debug - debug your workflow, while using debugging tools to set breakpoints, monitor the execution of activities step by step, and adjust the debugging speed. Open logs to view details regarding execution and any changes made to the project. For more information on debugging, check the About Debugging page.
Observação:Os arquivos que não são criados durante a execução do projeto de automação, ficam como somente leitura ao serem publicados no Orchestrator. Se seu processo de negócios exige que, em algum momento, você escreva em um arquivo, assegure-se de criá-lo durante o design do projeto.
A Barra de Título
Enviar Feedback
Há dois tipos de feedback que você pode enviar diretamente do Studio: Enviar uma ideia para o produto ou Relatar um bug. As duas opções podem ser acessadas pela faixa de opções, clicando-se no ícone
.
O recurso Enviar Feedback deve ser usado apenas para o envio de feedback anônimo para a equipe de produto. Para entrar em contato com nossa equipe de suporte técnico, use o formulário Fale com o Suporte Técnico.
Forneça as informações a seguir e, depois, clique em Enviar:
- No menu suspenso Quero, escolha entre Enviar uma ideia para o produto ou Relatar um bug.
- No menu suspenso Para, escolha entre UiPath Activities, UiPath Studio, UiPath Robot, UiPath Orchestrator ou UiPath Assistant.
- No menu suspenso Qual a importância disso para você, escolha entre Legal ter, Importante ou Fundamental.
- No campo Assunto, adicione um título curto.
- Adicione uma descrição detalhada, anexando até 6 arquivos de imagens, vídeos ou texto, cada qual com menos de 10 MB. O limite para enviar feedback é de três posts em um período de cinco minutos.
Ajuda
Click the Help icon to quickly access the resources that are also available in the Help tab in Backstage View, as illustrated below:
Tela de início
Ao abrir o Studio pela primeira vez, esta é a visão que você tem. Também é possível chegar até aqui, clicando em Início, no canto superior esquerdo da janela. Aqui, é possível criar e abrir projetos, configurar o Studio ou acessar informações de ajuda e de licença.
Os botões e guias a seguir são disponibilizados nesta exibição:
-
Abrir: navegue até um projeto local de automação e abra-o. Por padrão, os projetos são criados em C:\Users<current_user>\Documents\UiPath.
Observação:Projects located on network folders where your user only has read permissions cannot be opened in Studio. We recommend using source control systems to collaborate on projects.
-
Close - Close the automation project that is currently open.
-
Iniciar — cria um novo projeto de automação ou abre projetos recentemente acessados. Você pode criar um novo projeto com base em modelos predefinidos ou abrir um projeto no qual tenha trabalhado recentemente. Os projetos podem ser fixados ou removidos da lista Abrir Recentes, que exibe a descrição, estrutura de destino, linguagem usada para expressões e origem do projeto (repositório local ou GIT/SVN/TFS) para cada projeto. Passar o mouse sobre uma entrada na lista Abrir Recentes exibe o caminho para o arquivo
project.jsone quando o projeto foi aberto pela última vez. -
Templates - Create a new project based on a template. In this tab, you can view all available project templates, search and filter them by source. For more information, see Project Templates.
-
Team - Manage source control integration for the automation project.
-
Ferramentas - Acesse ferramentas que aprimoram sua experiência com o Studio.
- Select the Apps tab for the , Project Dependencies Mass Update Tool, and the Repair Tool for Microsoft Office.
- Select the UiPath Extensions tab to install or uninstall the following extensions: Chrome, Firefox, Edge, Java, Silverlight, Citrix, Windows Remote Desktop, VMware Horizon, Excel Add-in, and SAP Solution Manager.
- Select the Plugins tab to enable or disable source control and test automation plugins.
-
Settings - Change the look and feel of Studio, set global preferences, and manage activities package sources. For more information, see Configuring Studio Settings.
-
Help - Directs you to product documentation, release notes, online resources, the Community Forum and the RPA Academy.
Aqui você tem acesso ao tutorial rápido que o ajudará a aprender os fundamentos básicos da criação, publicação e execução de uma automação.
Observação:Para garantir que o tutorial seja concluído com sucesso, recomendamos que você pause o tutorial antes de fazer quaisquer alterações no fluxo de trabalho fora daquelas destacadas nas etapas do tutorial.
Informações sobre a versão do produto e a instalação, disponibilidade de licença, o canal de atualização e a ID do dispositivo também podem ser encontradas na guia Ajuda, junto com o botão Copiar informações para copiar rapidamente os detalhes para a área de transferência.
A Paleta de Comandos
Para abrir a Paleta de Comandos, utilize os atalhos do teclado Ctrl + Shift + P, F3 ou clique no botão de pesquisa. Ela inclui as barras de pesquisa Adicionar atividade, Pesquisa Universal, Acessar o arquivo e Ir para a atividade.
O Studio é compatível com a priorização de atividades por escopo. Clique no ícone
dentro de um escopo de atividade e observe que a Paleta de Comandos faz sugestões de atividades adequadas ao escopo atual. O suporte para esse recurso está sendo lançado em fases nos pacotes oficiais de atividades. Verifique as Notas de versão periodicamente.
Adicionar atividade
A barra de pesquisa Adicionar atividade pode ser aberta com o atalho do teclado Ctrl + Shift + T. Você pode pesquisar por atividades nos pacotes instalados, adicionando-as ao arquivo, depois da atividade selecionada. A barra atribui automaticamente os atalhos do teclado aos cinco primeiros resultados e lembra você sobre seus resultados anteriores.
Clique no ícone
, na parte superior ou inferior de uma atividade de uma sequência para abrir a barra de pesquisa Adicionar atividade.
If the Enable AI activity suggestions option in the Studio design settings is selected, a UiPath AI service analyzes the location in the workflow where you opened the Add activity search bar and suggests activities that you may want to add next based on the current context. If there is no context (for example, you press Ctrl + Shift + T when no activity is selected in the Designer panel) activity suggestions are not provided.
A Pesquisa Universal
A barra Pesquisa Universal permite encontrar argumentos, atividades, variáveis, argumentos, importações, dependências do projeto e arquivos no projeto atual. As pesquisas retornam resultados de todos os arquivos de fluxo de trabalho, incluindo arquivos que estiverem fechados.
| Opção | Atalho | Description |
|---|---|---|
| Arquivo Atual | Ctrl + 1 | Lista os resultados do arquivo aberto no momento que corresponda à consulta de pesquisa. |
| Todos os arquivos | Ctrl + 2 | Lista os resultados encontrados todas as partes dos arquivos do projeto atual que correspondam à consulta de pesquisa. |
| Atividades | Ctrl + 3 | Lista os resultados das atividades que correspondam à consulta de pesquisa. |
| Variáveis | Ctrl + 4 | Encontra as variáveis, no projeto atual, que correspondam à consulta de pesquisa. |
| Argumentos | Ctrl + 5 | Encontra os argumentos definidos no projeto que correspondam à consulta de pesquisa. |
| Importações | Ctrl + 6 | Encontra os namespaces importados no projeto que correspondam à consulta de pesquisa. |
| Arquivos do Projeto | Ctrl + 7 | Encontra a parte dos arquivos do projeto atual que corresponde à consulta de pesquisa. |
| Dependências | Ctrl + 8 | Lista os resultados encontrados em dependências instaladas no projeto. |
| Fragmentos | Ctrl + 9 | Encontra os arquivos do fragmento que correspondem à consulta de pesquisa. |
Os resultados da pesquisa persistirão até a próxima vez que você abrir a barra de pesquisa se você usar a Pesquisa Universal ou a opção Adicionar atividade. Quanto às opções Acessar o arquivo e Ir para a atividade , a consulta de pesquisa anterior não persistirá.
Clique duas vezes sobre uma atividade ou pressione Enter para adicioná-la ao arquivo aberto no momento. Com os mesmos comandos você consegue abrir os arquivos sob as categorias Todos os Arquivos ou Arquivos do Projeto ou se concentrar no resultado de pesquisa desejado.
Os valores padrão dos argumentos de um processo dentro da atividade Invocar Fluxo de Trabalho não podem ser pesquisadas com a Pesquisa Universal.
Acessar Arquivo
A barra Acessar arquivo pesquisa e abre os arquivos que integram a pasta do projeto atual.Os arquivos .xaml são abertos no painel do Designer no Studio, ao passo que os demais arquivos como capturas de tela ou arquivos do Excel são abertos com seus respectivos aplicativos padrão em sua máquina. Para abrir um arquivo, clique duas vezes sobre ele ou pressione a tecla Enter.
As Atividades, os painéis de Projeto e a pesquisa difusa de suporte para a Paleta de Comando. Isso quer dizer que a lista de resultados será retornada, ainda que os termos da pesquisa não correspondam com exatidão. Os termos da pesquisa podem estar ligeiramente incompletos, com erros de ortografia ou incluir somente a primeira letra de cada palavra. Por exemplo, se você digitar dci na barra de Atividades, ela retornará a atividade Clicar duas vezes na imagem.
Pular para atividade
A barra de pesquisa Ir para atividade, que faz parte da Paleta de Comandos, ajuda a encontrar e se concentrar nas atividades específicas de fluxos de trabalho grandes. Ela pode ser acessada através do atalho de teclado Ctrl + J ou dos atalhos para abrir, F3 ou Ctrl + Shift + P e selecionando a opção Ir para atividade.
Uma vez aberta, a barra Ir para atividade exibe a lista de todas as atividades no .xaml arquivo em foco no painel Designer panel.
Digite o nome de exibição ou o namespace de uma atividade como, por exemplo, Atribuir. Utilize as setas do teclado para selecionar a atividade, pressionando Enter para colocá-la em foco no painel Designer.
As atividades na barra Ir para atividade estão organizadas da seguinte maneira: contêiner, atividades parent e child.
Os Painéis
O Painel do Designer
The Designer panel displays your current automation project, enables you to make changes to it, and provides quick access to variables, arguments and imports.
É possível navegar em um diagrama clicando duas vezes na atividade que você deseja ver. O caminho é exibido como trilhas de navegação no cabeçalho do painel Designer. Observe que, ao usar várias exibições dimensionadas de maneiras diferentes, o texto no campo de entrada, que é parte de algumas atividades, podem ser exibidas incorretamente.
As atividades podem ser copiadas com o atalho Ctrl + C ou o menu de contexto para um editor de texto, podendo ser editadas e então copiadas de volta para o painel Designer. É possível desfazer ou refazer uma ação realizada no painel com os botões na faixa de opções do Studio ou pressionando Ctrl + Z / Ctrl + Y.
If an activity has validation errors, an error icon
is displayed on the right side of the activity title bar in the Designer panel and a warning icon
is displayed for all its parent activities. Clicking the icons opens the Properties panel for the activity affected by the issue and the error message is displayed at the top of the Properties panel.
When you hover the mouse over an activity input field in the Designer panel or in the Properties panel, a Plus
button is displayed on the right side of the field. Clicking this button opens a menu with options that enable you to configure the activity:
-
Para os seguintes tipos de atividades, navegue no recurso associado e selecione dados que correspondam ao tipo da propriedade diretamente a partir desse menu sem ter que digitar expressões manualmente:
- Automação do Excel - Se a Modern Excel Design Experience estiver habilitada, nas atividades filhas da atividade Use Excel File, você pode:
- Selecione células, intervalos, tabelas, planilhas ou gráficos a partir da planilha de trabalho. Você também pode indicar a linha atual ou a planilha atual em uma iteração.
- Entrada baseada em referências de células e intervalos, tabela, gráfico ou nomes de planilhas usando a opção Entrada personalizada,
- Switch to Excel to indicate data directly from the file using the Indicate in Excel option. This functionality requires the Excel Add-in to be installed.
- Automação do PowerPoint - Em atividades filhas da atividade Use PowerPoint Presentation, selecione slides, formas ou layouts do arquivo do PowerPoint.
- Automação de e-mail - Nas atividades filhas das atividades Use Outlook 365, Use Gmail e Use Desktop Outlook App, selecione dados de e-mails como pastas do Outlook, rótulos do Gmail, o e-mail atual em uma iteração ou campos de mensagens específicos a partir da conta de e-mail.
- Automação do Excel - Se a Modern Excel Design Experience estiver habilitada, nas atividades filhas da atividade Use Excel File, você pode:
-
Open in Advanced Editor - Open the Expression Editor.
-
Criar variável - Crie uma variável.
-
Limpar valor - Limpe um valor existente.
-
Selecionar Data/Hora - Selecione uma data no calendário ou um horário (hora, minuto). Essa opção está disponível para atividades que aceitam valores do TimeSpan como entrada.
Ativar o Modo Panorâmico clicando no ícone
e segurando a tecla de espaço ou pressionando o botão do meio do mouse. Use o menu suspenso de zoom para alterar o nível de zoom e clique no ícone
para voltar a 100%.
O ícone Ajustar à Tela
altera o zoom de modo que o fluxo de trabalho inteiro caiba no painel Designer. Clique no ícone
para obter uma visão geral do projeto e navegar pelas seções ao ajustar o foco.
O Menu de Contexto
O menu de contexto permite a realização de várias operações em seu fluxo de trabalho, seja uma sequência ou um fluxograma. É possível exibí-lo ao clicar com o botão direito do mouse em ume atividade dentro de um fluxo de trabalho.
Caso selecionar mais atividades, o menu não será sequer exibido.
Descrições de Campos do Menu Contexto
| Opção | Description |
|---|---|
|
Visualizar Pai |
Exibe o pai da atividade de destino no painel Designer. |
|
Abrir |
Abre a atividade selecionada no painel Designer. Produz o mesmo efeito que um duplo clique. |
|
Recolher |
Recolhe a atividade, reduzindo assim os detalhes exibidos em "Clicar duas vezes para exibir". É possível atingir o mesmo resultado clicando no botão Recolher |
|
Expandir no Local |
Expande o conteúdo da atividade, exibindo seu conteúdo em detalhes. É possível obter o mesmo clicando no botão Expandir |
|
Recortar |
Remove a atividade selecionada e a coloca na Área de transferência. |
|
Copiar |
Copia a atividade selecionada e a coloca na Área de Transferência. As atividades de arquivos somente leitura podem ser copiadas para um outro fluxo de trabalho ou um arquivo |
|
Colar |
Insere o conteúdo da Área de Transferência no local atual. |
|
Excluir |
Exclui a atividade-alvo. |
|
Anotações |
Adicionar, editar, excluir, mostrar e ocultar anotações adicionadas às atividades no fluxo de trabalho. |
|
Copiar como Imagem |
Faz uma captura de tela do conteúdo exibido no painel Designer. |
|
Salvar como Imagem |
Faz uma captura de tela do conteúdo exibido no painel Designer, solicitando que o usuário defina os detalhes para salvá-lo (Nome, Tipo e Destino). Formatos de arquivo compatíveis: JPG, PNG, GIF e XPS. |
|
Criar variável |
Cria uma variável no painel Variável. |
|
Auto-organizar |
Organiza as atividades automaticamente em um fluxograma. |
|
Remover Sequência Delimitadora |
Remove a atividade de Sequência selecionada do painel Designer. As atividades contidas ali são movidas para a sequência parent. |
|
Delimitar com o Try Catch (Ctrl + T) |
Inserts the activity in a Try Catch statement. |
|
Extrair como Fluxo de Trabalho |
Creates a new workflow containing the targeted activity with the purpose of breaking down a large project into smaller ones. In the place of the extracted activity an Invoke |
|
Abrir Fluxo de Trabalho |
Abre um fluxo de trabalho criado com a opção acima. |
|
Habilitar Atividade |
Habilita uma atividade desabilitada anteriormente. |
|
Desabilitar Atividade |
Desabilita uma atividade que, em seguida, é colocada dentre de uma atividade Comentar. |
|
Ativar/Desativar Ponto de Interrupção |
Marca a atividade selecionada como ponto de interrupção para depuração. Também é possível alternar os pontos de interrupção, clicando-se sobre o botão Ponto de interrupção, na guia Executar. É possível disparar um ponto de interrupção em relação a uma atividade de cada vez. |
|
Editar Configurações do Ponto de Interrupção |
Abre a janela Configurações do Ponto de Interrupção. |
|
Executar até esta Atividade |
Depura o projeto e interrompe, antes de executar essa atividade específica. |
|
Executar a partir desta Atividade |
Inicia a depuração dessa atividade. |
|
Mostrar Todas as Condições |
Exibe todas as condições definidas no seu projeto (painel Propriedades > Condições). |
|
Ocultar todas as condições |
Oculta todas as condições exibidas. |
|
Definir como Nó Iniciar |
Conecta a atividade selecionada com o nó Iniciar. |
|
Definir como Estado Inicial |
Conecta a atividade específica da Máquina de Estado ao nó início. |
O menu de contexto também é exibido em relação às guias no painel Designer. As seguintes opções estão disponíveis:
| Opção | Description |
|---|---|
| Fechar | Fecha a guia ativa. |
| Fechar Outros | Fecha todas as guias, exceto a guia ativa. |
| Fechar Todos os Documentos | Fecha todas as guias. |
| Flutuar | Desencaixa a guia de destino, alterando-a para um estado flutuante. |
| Fixar Guia | Fixa a guia de destino no painel Designer. A guia fixada por último é sempre movida à frente de todas as outras guias existentes (fixadas ou não). A posição de uma guia fixada somente pode ser alterada em relação às demais guias fixadas. |
| Novo Grupo de Guias Horizontais | Divide a tela horizontalmente, o que possibilita que você veja duas ou mais instâncias do painel Designer na mesma tela. O projeto de destino é movido para o painel à direita. Exibido apenas quando seu projeto contém duas ou mais guias e, implicitamente, fluxos de trabalho. |
| Novo Grupo de Guias Verticais | Divide a tela verticalmente, permitindo que você veja duas ou mais instâncias do painel Designer na mesma tela. O projeto de destino é movido para o painel na parte inferior. Exibido apenas quando seu projeto contém duas ou mais guias e, implicitamente, fluxos de trabalho. |
| Mover para o Grupo de Guias Anterior | Move a guia de destino para o painel Designer exibido anteriormente. Exibido apenas se você tiver usado as opções Novo Grupo de Guias Verticais ou Novo Grupo de Guias Horizontais antes. |
| Mover para o Próximo Grupo de Guias | Move a guia de destino para o próximo painel Designer exibido. Exibido apenas se você tiver usado as opções Novo Grupo de Guias Verticais ou Novo Grupo de Guias Horizontais antes. |
O painel Projeto
The Project panel enables you to manage project files, dependencies, and configure project settings. For more information, see Managing Projects.
O Painel de Atividades
The Activities panel shows available activities that can be added to the current workflow. You can search for activities by name and optionally by description using the search box at the top of the panel, navigate through them using navigation keys, and press Enter to add the selected activity to the currently opened file.
A caixa de pesquisa pode ser usada para encontrar atividades pelo nome de sua classe, independentemente do idioma definido no Studio.
Passar o mouse sobre uma atividade no painel exibe o pacote ao qual ela pertence e sua descrição. Para adicionar uma atividade à lista de favoritos, clique com o botão direito do mouse e selecione Adicionar aos favoritos.
Right-click an activity in the panel and select Create Test Bench to test out one or more activities before adding them to a project. Read more about this here.
Personalização do Painel de Atividades
Click the View Options
button at the top of the panel to open a menu that allows you to customize the panel. See the following table for a list of available options.
| Opção | Description |
|---|---|
| Mostrar Favoritos | Mostrar uma seção com atividades. Esta opção é selecionada por padrão. |
| Mostrar Recente | Mostrar uma seção com as dez atividades mais usadas recentemente. Esta opção é selecionada por padrão. |
| Mostrar Disponível | Mostrar todas as atividades disponíveis. Esta opção é selecionada por padrão. |
| Mostrar Compatibilidade | Opção não utilizada no momento. Esta opção não está selecionada por padrão. |
| Mostrar Clássico / Moderno | Mostre atividades de Automação de Interface Gráfica moderna nos projetos, usando a experiência do design clássico ou mostre as atividades de Automação de Interface Gráfica clássica nos projetos, usando a experiência moderna. Esta opção não está selecionada por padrão. |
| Mostrar Categorias | Agrupe as atividades pela categoria à qual elas pertencem. Esta opção é selecionada por padrão. |
| Agrupar por Pacotes | Agrupar atividades de acordo com o pacote ao qual elas pertencem. Esta opção não está selecionada por padrão. |
| Pesquisar por Descrição | Ao pesquisar no painel, pesquise nas descrições da atividade e não apenas nos nomes das atividades. Esta opção não está selecionada por padrão. |
| Fixar Favoritos | Ao pesquisar no painel, mantenha as atividades favoritas sempre visíveis. Disponível se a opção Mostrar Favoritos estiver selecionada. Esta opção não está selecionada por padrão. |
O Painel Fragmentos
O painel Fragmentos permite a fácil reutilização das automações. Por padrão, ele inclui várias amostras e fragmentos.
É possível adicionar o seu próprio clicando no botão Adicionar pasta e selecionando um diretório do seu disco rígido. As pastas vazias não são exibidas.
Para remover uma pasta, clique nela com o botão direito do mouse nela e selecione Remover.
O Painel de Propriedades
O painel Propriedades é contextual e permite vizualizar e alterar as propriedades de uma atividade selecionada. Ao selecionar duas atividades no mesmo fluxo de trabalho, as propriedades comuns poderão ser modificadas no painel Propriedades.
O Editor Expressão
O Editor Expressão pode ser acessado com o atalho de teclado Ctrl + Shift + E quando usado dentro dos campos de entrada de atividade. Ele também fica disponível no painel Propriedades, a partir dos campos que exigem a inserção de texto e do corpo de uma atividade, adicionando texto diretamente nos campos necessários.
Expressions can be written on multiples lines. Keyboard shortcuts for creating variables and arguments directly in expressions are available.
Dentro do editor, use a combinação das teclas Ctrl + F para abrir a pesquisa e substituir recursos. Selecione parte de uma expressão e pressione Ctrl + F3 para adicionar texto ao campo de pesquisa. Mantendo a tecla Ctrl pressionada, torne o painel de pesquisa semitransparente para visualizar o texto por trás dele.
Ao fechar o editor, sua posição na tela, tamanho de janela e nível de zoom do texto são salvos e aplicados na próxima vez que você o abrir.
O Painel de Estrutura de Tópicos
O painel Estrutura de Tópicos exibe a hierarquia do projeto e todos os nós disponíveis. Neste painel é possível destacar atividades, selecionando-as no painel Designer ou acessando uma atividade específica, selecionando-a no painel Estrutura de Tópicos.
O Painel de Saída
O painel de Saída permite exibir a saída das atividades de Mensagem de Registro de Log ou de Escrever Linha, entre outras coisas. Neste painel também são exibidas as exceções dos pacotes.
No painel Saída, é possível exibir ou ocultar as mensagens que tenham diferentes níveis de log (erros, avisos), ao se clicar nos botões do cabeçalho do painel. Clicar duas vezes em uma mensagem exibe outros detalhes sobre ela, com a opção de copiar as informações.
Ao pesquisar por um log no painel Saída e selecionar um item da lista dos resultados da pesquisa, o log será realçado.
O botão Exportar Logs é usado para exportar logs para um arquivo .txt. Ele exporta carimbos de data e hora, bem como detalhes de mensagens de erro. Os logs de exportação filtrados estão disponíveis. Por exemplo, caso queira exportar somente os logs em nível de rastreamento, filtre a lista e depois use o botão Exportar Logs.
Na depuração, o painel Saída mostra registros do início e do fim da execução da atividade. Essa função pode ser habilitada na opção Log Activities, na guia Depurar.
The Error List panel displays errors found in the file or project during the validation process, together with errors generated by Workflow Analyzer rules.
O botão Limpar tudo apaga todas as informações exibidas no painel de Saída. Quando um fluxo de trabalho é executado, os logs e outros dados armazenados nesse painel são apagados. O painel Saída exibe até 2.000 linhas de cada vez.
O painel Saída não é destinado para o monitoramento da produção, e deve ser usado apenas ao desenvolver automações. Os eventos podem não ser exibidos como esperado se, por exemplo, um grande número de atividades Log Message forem usadas. Para monitorar as execuções, use os logs do Orchestrator.
O Painel Encontrar Referências
O painel Encontrar Referências exibe os resultados das referências que você pesquisar em seu projeto. Para encontrar todos os locais no projeto em que um elemento tiver sido referenciado, clique com o botão direito do mouse e selecione Encontrar Referências. Isso funciona nas seguintes situações:
-
Arquivos no painel Projeto
-
Atividades no painel Atividades
-
Variáveis no painel Variáveis
-
Argumentos no painel Argumentos
-
Descritores no painel Repositório de Objetos
O Painel de Recursos
The Resources panel in Studio can load assets, queues, processes, and entities, provided that the Robot is connected to Orchestrator. Read the Connecting Robots to Orchestrator page to find the steps.
Se o Robô conectado ao Orchestrator for do tipo Padrão, então o painel de Recursos somente poderá exibir a pasta Clássico que tiver esse Robô provisionado.
If the Robot is of type Floating, the panel can display resources from all classic and modern folders that this Robot has access to. Find out more about robots and folders in the Orchestrator Guide.
- When using a classic, manually provisioned robot, it must be granted
Viewpermissions for the corresponding resources (i.e. Assets, Queues, and Processes) to appear in the panel. Read more about setting up Roles and permissions in Orchestrator. - Se houver pastas clássicas e modernas no Orchestrator e você estiver conectado a ele usando um robô de uma pasta moderna (você fez login na sua conta ou conectou-se usando uma chave de modelo de máquina), o processo nas pastas antigas não ficarão disponíveis no painel Recursos. Para ter acesso aos processos de uma pasta clássica, conecte-se ao Orchestrator usando um robô clássico com uma conexão de chave de máquina padrão.
Selecionando uma pasta do Orchestrator
The folder from which resources are currently loaded in the panel is displayed in the Studio status bar. You can switch to a different folder that you have access to by clicking the current folder name, and then selecting another Orchestrator folder from the menu that appears. In addition to the resources that are available in Studio, the folder selection also determines the default targets available when publishing your processes.
Para carregar recursos no painel, clique no botão atualizar na parte superior do painel. Passe o mouse sobre o nome da pasta na barra de status para ver a URL do Orchestrator.
Os logs gerados de processos localizados em subpastas ficam visíveis somente se a subpasta for selecionada no painel Recursos.
Usando recursos do Orchestrator em seus projetos
Arraste e solte ativos, as filas ou os processos do painel Recursos diretamente em seu projeto de automação. Ao fazer isso, as atividades adequadas são sugeridas na barra de pesquisa Adicionar atividade. Por exemplo, após arrastar uma fila em seu projeto, escolha a atividade Adicionar Item da Fila na barra de pesquisa Adicionar atividade. Note que aquela fila foi automaticamente atribuída à propriedade Nome da Fila da atividade.
Você também pode clicar com o botão direito do mouse em qualquer item no painel Recursos e então selecionar Copiar para copiar seu nome e usá-lo em atividades que interagem com esses recursos.
Painéis de depuração
The following panels are available to help you debug your projects: Breakpoints, Call Stack, Locals, Watch, and Immediate.
A Barra de Status
Na barra de status, é possível visualizar informações de status e as opções de acesso ao Orchestrator e ao controle do código fonte:
-
Conexão do Orchestrator/Cloud - Clique em
para acessar opções do Orchestrator: faça login na sua conta da nuvem, desconecte-se do Orchestrator (se conectado a uma chave da máquina) e atualize os recursos. -
Status do Orchestrator - Exibe o status de conexão do Orchestrator. Quando conectado ao Orchestrator, a pasta atualmente selecionada é exibida. É possível clicar no nome da pasta atual para ver uma lista de pastas disponíveis e selecionar outra a partir da qual sincronizar recursos.
-
Source Control - Depending on whether the project is connected to a source control repository, different options are available to help you manage source control integration. For more information, see About Version Control.
-
Linguagem do projeto — exibe a linguagem usada para expressões no projeto, VB ou C#.
-
Compatibilidade do projeto - Exibe a compatibilidade do projeto, Windows - Legado, Windows ou Multiplataforma.
- Visão geral
- A Faixa de Opções
- Guias da Faixa de Opções
- A Barra de Título
- Tela de início
- A Paleta de Comandos
- Adicionar atividade
- A Pesquisa Universal
- Acessar Arquivo
- Pular para atividade
- Os Painéis
- O Painel do Designer
- O painel Projeto
- O Painel de Atividades
- O Painel Fragmentos
- O Painel de Propriedades
- O Painel de Estrutura de Tópicos
- O Painel de Saída
- O Painel Encontrar Referências
- O Painel de Recursos
- Painéis de depuração
- A Barra de Status
.
.