studio
2022.10
false
UiPath logo, featuring letters U and I in white

Guia do usuário do Studio

Última atualização 17 de dez de 2024

Solução de problemas

Esta página explica como corrigir problemas que você pode encontrar ao executar automação em ambientes Citrix.

Canais virtuais bloqueados por padrão

Description

A partir do Citrix Virtual Apps and Desktops 7 2109, todos os canais virtuais personalizados são bloqueados por padrão.

Se você atualizar para esta nova versão do Citrix, a automação existente no Citrix via UiPath Remote Runtime para de funcionar.

Solução

O canal virtual UiPath deve ser adicionado à política de lista de permissões. Isso pode ser feito seguindo as instruções aqui.

O valor abaixo deve ser adicionado à política permitir lista.

UIPCTX,<UiPathRemoteRuntime-Install_Path>\UiPathRemoteRuntime.exe

Por exemplo:

UIPCTX,C:\Program Files (x86)\UiPath\RemoteRuntime\UiPathRemoteRuntime.exe

Seleção Interativa em Aplicativos Citrix Congela e Nada é Selecionado

Comportamento Observado

Após instalar a Extensão da UiPath para Citrix e tentar selecionar elementos de interface gráfica a partir de um Aplicativo Citrix, a seleção interativa congela por um minuto e depois nada é selecionado.

Causa

Isso acontece se o UiPath Remote Runtime não estiver em execução na sessão do Aplicativo Citrix.

Solução

  • Verifique se o UiPathRemoteRuntime.msi está instalado no servidor do Aplicativo Citrix a partir do qual o Aplicativo Citrix é aberto.
  • No servidor do aplicativo Citrix, verifique se o processo da UiPathRemoteRuntime.exe está em execução. Se a UiPathRemoteRuntime.msi estiver instalada, o processo será iniciado automaticamente no logon de sessão do Aplicativo Citrix.



    Observação: se você não conseguir instalar o UiPathRemoteRuntime.msi nos servidores de aplicativos Citrix, é recomendável desinstalar a extensão UiPath para o Citrix da máquina cliente, conforme descrito aqui.

Não foi possível copiar o arquivo “C:\Arquivos de Programa (x86)\Citrix\ICA Client\UIPathPluginCitrix.dll". Ele está sendo usado por outro processo.

Comportamento Observado

Quando você tentar instalar a Extensão da UiPath para Citrix, o seguinte erro é exibido:



Causa

Isso ocorre quando a Extensão da UiPath para Citrix já está instalada e um Aplicativo Citrix aberto a está utilizando.

Solução

Feche todas as suas sessões ativas do Aplicativo Citrix conforme descrito aqui e tente instalar a Extensão da UiPath para Citrix novamente.

Não foi possível ler a chave de registro Citrix: 'SOFTWARECitrixInstallICA Client' Value: 'InstallFolder'

Comportamento Observado

Quando você tentar instalar a Extensão da UiPath para Citrix, o seguinte erro é exibido:



Causa

Esta mensagem de erro é exibida quando o Receptor Citrix não estiver instalado. Ela também é exibida se o Receptor Citrix para a Plataforma Universal do Windows estiver instalado.

Solução

Faça o download e instale o Citrix Receiver ou Citrix Workspace.

Exceção Não Técnica em wfica32.exe 0xC00094: Divisão de Inteiros por Zero

Comportamento Observado

Aplicativo Citrix de destino não pode ser iniciado e o cliente Citrix ICA falha.

Causa

Atividades que usam a função GetWindowText (como Element Exists) são executadas antes que o Aplicativo Citrix possa ser carregado.

Solução

Reserve um tempo para que o Aplicativo Citrix seja carregado adicionando um atraso antes da atividade.

A seleção interativa e a identificação de elementos não funcionam com DPI

Comportamento Observado

A partir do Citrix Workspace App (CWA) para Windows 2206, se nenhuma configuração de políticas de High DPI for aplicada, a seleção interativa e a identificação de elementos podem não funcionar para o Citrix Apps quando a escala de DPI da tela for superior a 100%.

Causa

Isso é causado pela seguinte alteração no Citrix: DPI suporta alterações com o Citrix Workspace App para Windows 2206.

Solução

Excluir o valor do registro Enable_DPI de Computer\HKEY_CURRENT_USER\SOFTWARE\Citrix\ICA Client\DPI:


Esta página foi útil?

Obtenha a ajuda que você precisa
Aprendendo RPA - Cursos de automação
Fórum da comunidade da Uipath
Uipath Logo White
Confiança e segurança
© 2005-2024 UiPath. Todos os direitos reservados.