studio
2023.4
false
UiPath logo, featuring letters U and I in white

Guía de usuario de Studio

Última actualización 17 de dic. de 2024

Errores de instalación comunes

Esta página documenta los errores que puedes encontrar al ejecutar el instalador MSI de Studio para realizar una instalación o una actualización.

Error 1603

Causa

El código de error 1603 indica un error genérico de instalación.

Solución

Para obtener más información sobre la causa del error, localiza el registro de instalación y comprueba si hay un mensaje más específico (por ejemplo, que el disco de instalación está lleno o que no se puede acceder a una ubicación concreta).

La ruta del archivo de registro es:

  • Para instalaciones y actualizaciones manuales: %TEMP%\MSI*.log (donde * representa un conjunto aleatorio de caracteres alfanuméricos)
  • Para las actualizaciones automática, instalación por usuario: %LOCALAPPDATA%\UiPath\UpdateService\Logs\
  • Para las actualizaciones automáticas, instalación por máquina: %PROGRAMDATA%\UiPath\UpdateService\Logs\
  • Para las actualizaciones automáticas de la Community Edition desde versiones anteriores a la 2021.10: %USERPROFILE%\AppData\Local\UiPath\Logs\install_error_log.txt

Error 1625

Causa

Una política establecida en la máquina no permite la instalación de aplicaciones mediante archivos MSI. Este error suele aplicarse a los equipos Windows Server que prohíben las instalaciones MSI mediante políticas.

Solución

Sigue los pasos siguientes para añadir una clave de registro que permita ejecutar instaladores MSI.

Nota: Se requieren derechos de administrador para realizar estos pasos. Si no gestionas esta configuración, ponte en contacto con el administrador del sistema o usa UiPath en una máquina en la que se permitan las instalaciones MSI.
  1. Abre el Editor del registro en la máquina.
  2. Navega hasta la clave del registro HKLM\Software\Policies\Microsoft\Windows\Installer.
  3. Crea o edita el valor denominado DisableMSI de tipo REG_DWORD y establece su Dato de valor a 0.
    Nota: es posible que tengas que reiniciar la máquina para que se apliquen los cambios en el registro.

Error 4000: disco completo

Causa

No hay suficiente espacio libre en el disco de tu máquina para realizar la instalación.

Solución

Libera el espacio de disco mínimo necesario para la instalación de Studio. Para más información, consulta los Requisitos de hardware.

Error 4001: No tienes autorización para crear una tarea programada

Causa

Tu usuario no tiene permisos para acceder a la carpeta C:\Windows\System32\Tasks a la que el instalador debe acceder para utilizar la función del Programador de tareas.

Solución

Asegúrate de que el usuario tenga permisos de acceso a la carpeta C:\Windows\System32\Tasks.
Nota: las tareas programadas de Studio existentes deben eliminarse del programador de tareas de Windows antes de realizar una instalación limpia.

Error 4003: se detectaron dos instalaciones por usuario y por máquina

Causa

Hay dos instalaciones simultáneas en la máquina, una para el usuario actual y otra para toda la máquina. Esto puede dar lugar a un comportamiento inesperado de los productos UiPath y requiere la desinstalación de uno de ellos.

Solución

Cierra todas las instancias de Studio y, a continuación, dirígete a Añadir o eliminar programas en la configuración de Windows para eliminar una de las instalaciones:

  • Para mantener la instalación por usuario: desinstala la versión anterior de UiPath Studio. Cuando vuelvas a abrir Studio, tu instalación por usuario se actualizará automáticamente a la última versión.
  • Para mantener la instalación por máquina: desinstala la versión más reciente de UiPath Studio. Puedes descargar manualmente la última versión desde el Centro de recursos de Automation Cloud e instalarla para actualizar a la última versión. Tras instalar la última versión, Studio recibirá actualizaciones automáticas cuando estén disponibles.

Error 4004: se han detectado dos instalaciones simultáneas de UiPath Studio

Causa

Hay dos instalaciones concurrentes para el usuario actual en la máquina. Esto puede dar lugar a un comportamiento inesperado de los productos UiPath y requiere una instalación limpia.

Solución

  1. Dirígete a Agregar o quitar programas en la configuración de Windows y desinstala las dos aplicaciones de UiPath Studio.
  2. Descarga la última versión de UiPath Studio desde el Centro de recursos de Automation Cloud e instálala. Tras instalar la última versión, Studio recibirá actualizaciones automáticas cuando estén disponibles.

Error 4012: se detectaron dos instalaciones simultáneas de UiPath Studio

Causa

Existen varias instalaciones (una por máquina y al menos una por usuario) al mismo tiempo e interfieren con una actualización o cambio de la instalación. Por lo general, buscarás una versión anterior (2019.10, 2020.10) instalada por máquina y una nueva instalada por usuario.

Solución

Ve a Añadir o eliminar programas en la configuración de Windows y desinstala todas las aplicaciones de UiPath Studio excepto una. En la mayoría de los casos se debería dejar la más antigua, ya que es probable que se haya instalado a través de la Política de la empresa y volvería a aparecer si se elimina. Si eres el único administrador de la máquina puedes dejar la versión más reciente y eliminar las anteriores.

Error 1921: UiPath.UpdateService no se pudo detener

Causa

El usuario no tiene suficientes privilegios para actualizar Studio.

Solución

Ejecuta el instalador de Studio con privilegios de administrador.

¿Te ha resultado útil esta página?

Obtén la ayuda que necesitas
RPA para el aprendizaje - Cursos de automatización
Foro de la comunidad UiPath
Uipath Logo White
Confianza y seguridad
© 2005-2024 UiPath. Todos los derechos reservados.