订阅

概述

兼容性矩阵

单机版


下面的矩阵根据 Robot、Studio、Test Manager、AI CenterTM、Insights 和 Action Center 的版本和 Orchestrator 的交付模型,提供了有关 Orchestrator 与这些软件之间的互操作性的信息。除非另有特别提及,否则此矩阵隐式支持修补程序。

如果不升级,您只能使用最小安装版本的机器人或 Orchestrator 的功能。

通常建议先升级 Orchestrator,然后再升级机器人。在这种情况下,必须在更新后将机器人重新连接至 Orchestrator。
Some versions are no longer supported. Please refer to the product lifecycle for more information. An out of support version of a product is only compatible with another product having a supported version until the next patch release. For example, Orchestrator 2021.4, which is currently out of support, is only compatible with AI Center 2021.10 until the next patch release after the out of support date of Orchestrator.
Note: Out of support versions are removed from the Compatibility matrix table six months after their support ends.

- Compatible   - Not compatible

                                            Product VersionOrchestrator 2022.10.xOrchestrator 2022.4.xOrchestrator 2021.10.xOrchestrator 2021.4.xOrchestrator 2020.10.xOrchestrator 2019.10.x
BuildStudio 1Studio 2022.10.x8, 98, 98, 9
Studio 2022.4.x8, 98, 98, 9
Studio 2021.10.x8, 98, 98, 9
Studio 2021.4.x
Studio 2020.10.x
Studio 2019.10.x2, 3, 42, 3, 42, 3, 42, 3, 42, 3, 4
RunRobot 1Robot 2022.10.x8, 98, 98, 9
Robot 2022.4.x8, 98, 98, 9
Robot 2021.10.x8, 98, 98, 9
Robot 2021.4.x
Robot 2020.10.x
Robot 2019.10.x2, 3, 42, 3, 42, 3, 42, 3, 42, 3, 4
ManageTest ManagerTest Manager 2022.10.x
Test Manager 2022.4.x
Test Manager 2021.10.x
Test Manager 2020.10.2+
AI   Center710AI Center 2022.10.x
AI Center 2022.4.x
AI Center 2021.10.x
AI Center 2020.10.x
InsightsInsights 2022.10.x
Insights 2022.4.x
Insights 2021.10.x
Insights 2020.10.x
EngageAction CenterAction Center 2022.10.xN/A
Action Center 2022.4.xN/A
Action Center 2021.10.xN/A
Action Center 2021.4.xN/A
Action Center 2020.10.xN/A

1 - Studio and Robot always need to have the same version when installed on the same machine. For example, if you have Studio 2022.4.x installed, Robot must be v2022.4.x as well. This also applies to Studio Pro. For more information on the compatibility between Robot and projects created in different versions of Studio, see the Automation Projects section.
2 - Robot 2018.4.4+ 和 2020.4-仅通过长轮询连接到 Orchestrator。
3 - 必须启用 TLS 1.1 / TLS 1.2。
4 - Robot 2019.10 和更旧版本不能在新式文件夹中执行无人值守的流程。
5 - Robot 2019.4 和更旧版本仅适用于传统文件夹。
6 - Robot SignalR 身份验证不可配置,并且默认启用,以确保 Orchestrator 与 Robot 之间的安全通信。因此,您只能使用 2018.4.4 或更高版本的 Robot。
7 - 此兼容性基于 AI Center 基础架构构建,因此也适用于 UiPath Document Understanding
8 - 您需要使用 Robot 和 Orchestrator 2021.10 及更新版本执行 .NET 5+ 流程。
9 - 您需要 Robot 2021.10+ 才能在没有凭据的情况下执行后台流程。
10 - 此兼容性适用于 AI Center 连接到外部 Orchestrator 的情况。

UiPath Process Mining and Task Capture work as standalone products and do not require a compatibility matrix. Even so, for the best experience, the following requirements must be met:

  • 对于 Process MiningAutomation Hub 集成,您需要在 Automation CloudTM 中拥有这两种产品的 2021.4 版本。
  • 要从 Automation CloudTM 中的 Automation Hub 运行 Task CaptureTask Capture 必须至少为 2020.10.4 及以上版本。
  • 要从 Test Manager 运行 Task CaptureTask Capture 版本的最低要求为 2020.4 或更高。
  • 要从 Task Mining 运行 Task CaptureTask Capture 版本的最低要求为 2021.10 或更高。
  • 如要在 UiPath Assistant 中运行 Task CaptureTask CaptureUiPath Assistant 均需至少为 2021.10 或更高版本。

Automation Suite


Products in Automation Suite are delivered as part of a single bundle and always have their versions in sync. See Automation Suite components in the Automation Suite guide for details on the products that are part of the suite.

Automation Suite 支持以下 Robot/Studio 版本。

- Compatible   - Not compatible

Robot and Studio 2022.10.xRobot and Studio 2022.4.xRobot and Studio 2021.10.xRobot and Studio 2021.4.xRobot and Studio 2020.10.xRobot and Studio 2019.10.x
Automation Suite 2022.101, 21, 21, 2
Automation Suite 2022.41, 21, 21, 2
Automation Suite 2021.101, 21, 21, 23, 4

1 - 您需要使用 Robot 2021.10+ 执行 .NET 5+ 流程。
2 - 您需要 Robot 2021.10+ 才能在没有凭据的情况下执行后台流程。
3 - Robot 2018.4.4+ 和 2020.4-仅通过长轮询连接到 Orchestrator。
4 - 必须启用 TLS 1.1 / TLS 1.2。
5 - Robot 2019.10 和更旧版本不能在新式文件夹中执行无人值守的流程。
6 - Robot 2019.4 和更旧版本仅适用于传统文件夹。

📘

UiPath 保证 UiPath 本地部署产品(单机版和 Automation Suite)的两个连续发布版本之间具有向后兼容性。此兼容性矩阵中将反映重大更改(如有)。如果不能保证两个连续的 LTS 版本之间的向后兼容性,UiPath 可能会帮助您完成迁移过程。

Automation Cloud


对于驻留在 Automation CloudTM 中的 Orchestrator 服务,我们确保与最新的三个企业版本 Robot 和 Studio 向后兼容。

Cloud Orchestrator Service
Latest Robot and Studio version
Mainstream Support
Second-latest Robot and Studio version
Mainstream Support
Third-latest Robot and Studio version
Extended Support

If you are currently using the third-latest Robot version, you should make arrangements to upgrade the Robot before we release the next Robot version to avoid compatibility issues.

Some versions are no longer supported. Please refer to the product lifecycle for more information. We don't support interoperability between two products if one of them is out of support.

活动包


活动包版本独立于 Studio、Robot 或 Orchestrator 版本,但 Orchestrator 活动除外。例如,2018.1 中引入的“启动作业”活动仅适用于 2018.1 或更高版本的 Robot。

自动化项目


Alpha 版或 Beta 版 Studio 创建的项目可能不兼容新版 Studio,并且新版机器人也无法执行这些项目。
We support backward compatibility, except for breaking changes announced in the official release notes, and following the product lifecycle.
新版 Robot 可以执行使用旧版 Studio 创建的项目。例如,使用 Studio 2018.4 创建的项目应可用于 2019.10 或更高版本的 Robot。
We do not support forward compatibility. Projects created with newer versions of Studio might not work with older Robots. For example, a project created in Studio 2019.10 might not work with a 2018.4 Robot.

Updated 17 days ago


兼容性矩阵


建议的编辑仅限用于 API 参考页面

您只能建议对 Markdown 正文内容进行编辑,而不能建议对 API 规范进行编辑。