studio
2022.4
false
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Studio User Guide
Last updated Nov 18, 2024

Common Installation Errors

This page documents errors you may encounter when running the Studio MSI installer to perform an installation or an update.

Error 1603

Cause

Error code 1603 indicates a generic installation error.

Solution

To get more information about the cause of the error, locate the installation log and check for a more specific message (for example, the installation disk is full, or a specific location cannot be accessed).

The path of the log file is:

  • For manual installations and updates: %TEMP%\MSI*.log (where * represents a random set of alphanumeric characters)
  • For Automatic updates, per-user installation: %LOCALAPPDATA%\UiPath\UpdateService\Logs\
  • For Automatic updates, per-machine installation: %PROGRAMDATA%\UiPath\UpdateService\Logs\
  • For Community Edition automatic updates from versions prior to 2021.10: %USERPROFILE%\AppData\Local\UiPath\Logs\install_error_log.txt

Error 1625

Cause

A policy set on the machine does not allow installing applications using MSI files. This error usually applies to Windows Server machines that forbid MSI installations through policies.

Solution

Follow the steps below to add a registry key that allows running MSI installers.

Note: Administrator rights are required to perform these steps. If you do not manage these settings, contact your system administrator or use UiPath on a machine on which MSI installations are allowed.
  1. Open the Registry Editor on the machine.
  2. Navigate to the registry key HKLM\Software\Policies\Microsoft\Windows\Installer.
  3. Create or edit the value named DisableMSI of type REG_DWORD and set its Value data to 0.
    Note: You may need to restart the machine for the registry changes to apply.

Error 4000 - Full Disk

Cause

There is not enough free disk space on your machine to perform the installation.

Solution

Free up the minimum disk space required for the Studio installation. For more information, see Hardware Requirements.

Error 4001 - Unauthorized to Create Scheduled Task

Cause

Your user does not have permissions to access the C:\Windows\System32\Tasks folder which the installer must access in order to use the Task Scheduler feature.

Solution

Make sure your user has permissions to access the folder C:\Windows\System32\Tasks.
Note: Existing Studio scheduled tasks should be deleted from Windows Task Scheduler prior to performing a clean installation.

Error 4003 - Two Per-user and Per-machine Installations Were Detected

Cause

There are two concurrent installations on the machine, one for the current user and the other for the entire machine. This might result in unexpected behavior of the UiPath products and requires uninstalling one of them.

Solution

Close all instances of Studio, and then go to Add or remove programs in the Windows settings to remove one of the installations:

  • To keep the per-user installation - Uninstall the older UiPath Studio version. After you open Studio again, your per-user installation will be automatically updated to the latest version.
  • To keep the per-machine installation - Uninstall the newer UiPath Studio version. You can then manually download the latest version from the Resource Center in Automation Cloud and install it to upgrade to the latest version. After installing the latest version, Studio will receive automatic updates when they are available.

Error 4004 - Two Concurrent UiPath Studio Installations Were Detected

Cause

There are two concurrent installations for the current user on the machine. This might result in unexpected behavior of the UiPath products and requires a clean installation.

Solution

  1. Go to Add or remove programs in the Windows settings and uninstall both UiPath Studio applications.
  2. Download the latest UiPath Studio version from the Resource Center in Automation Cloud and install it. After installing the latest version, Studio will receive automatic updates when they are available.

Error 4012 - Two Concurrent UiPath Studio Installations Were Detected

Cause

Multiple installations (one per-machine and at least one per-user) exist at the same time and interfere with an upgrade or change of the installation. Usually, you'll find an older version (2019.10, 2020.10) installed per machine and a newer one installed per user.

Solution

Go to Add or remove programs in the Windows settings and uninstall all the UiPath Studio applications except for one. In most cases, you should leave the oldest one, as it's probably installed via corporate policy and it would appear again if removed. If you are the sole administrator on the machine, you can stick to the latest version, removing the older ones.

Error 1921 - UiPath.UpdateService could not be stopped

Cause

The user does not have sufficient privileges to update Studio.

Solution

Run the Studio installer with administrator privileges.

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