Subscribe

UiPath Studio

The UiPath Studio Guide

Keyboard Shortcuts

The complete list of keyboard shortcuts for UiPath Studio:

File Management

Ctrl + Shift + N - Creates a new Blank Process.

Ctrl + C - Copies a file from the Project panel into clipboard. Use Ctrl + V to paste it anywhere in the tree.

Ctrl + O - Enables you to open a previously created workflow, either the .xaml or project.json file.

Ctrl + L - Opens the folder where the Log files are stored.

Ctrl + S - Saves the currently opened workflow.

Ctrl + Shift + S - Saves all the workflows that are currently open.

Ctrl + V - Pastes a file from clipboard into the Project panel.

Ctrl + Tab - Moves focus between workflows opened in the Designer panel.

Ctrl + W - Closes the workflow file that is in focus in the Designer panel.

Alt + F7 - Moves focus between Studio panels. When you use Ctrl + Tab or Alt + F7 and hold the modifier key (Ctrl or Alt respectively), the following window appears, allowing you to switch between active files and panels in Studio.

511

Search

F3 or Ctrl + Shift + P - Opens the Command Palette.

Ctrl + Shift + T - Opens the Add an Activity search bar.

Ctrl + Shift + F - Opens the Go to file search bar.

Ctrl + F - Opens the Universal Search bar.

Ctrl + J - Opens the Jump to activity search bar.

Ctrl + 1 - Switches to the Current File tab in the Universal Search bar.

Ctrl + 2 - Switches to the All Files tab in the Universal Search bar.

Ctrl + 3 - Switches to the Activities tab in the Universal Search bar.

Ctrl + 4 - Switches to the Variables tab in the Universal Search bar.

Ctrl + 5 - Switches to the Arguments tab in the Universal Search bar.

Ctrl + 6 - Switches to the Imports tab in the Universal Search bar.

Ctrl + 7 - Switches to the Project Files tab in the Universal Search bar.

Ctrl + 8 - Switches to the Dependencies tab in the Universal Search bar.

Ctrl + 9 - Switches to the Snippets tab in the Universal Search bar.

Ctrl + Alt + A - Opens and focuses the Properties panel.

Ctrl + Alt + F - Sets the focus to the search box in the Activities panel.

Ctrl + Alt + O - Sets the focus to the search box in the UI Objects Browser panel.

Ctrl + Alt + P - Opens and focuses the search bar in the Project panel.

Ctrl + Alt + S - Opens and focuses the search bar in Snippets panel.

Tab - Navigates to the next item in the panel or the next element in the activity.

A list of useful keyboard shortcuts is displayed in the Designer panel, when all project files are closed, as illustrated in the image below:

1125

Comment

Ctrl + D - Ignores the activity that is currently selected by placing it into a Comment Out container.

Ctrl + E - Removes the activity from the Comment Out container it was placed in.

Debugging

F9 - Marks the selected activity with a breakpoint.

Ctrl + Shift + B - Opens the Breakpoints panel.

Ctrl + Alt + E - Opens the Error List panel.

F10 - When debugging, steps over the execution of a block of activities in the currently selected workflow.

F11 - When debugging, enables you to step into a block of activities and executes the first one.

Shift + F11 - When debugging, steps out of the current container after its last activity is executed.

Recording

Ctrl + Alt + B - Opens the Basic Recording toolbar.

Ctrl + Alt + C - Opens the Citrix Recording toolbar.

Ctrl + Alt + D - Opens the Desktop Recording toolbar.

Ctrl + Alt + W - Opens the Web Recording toolbar.

F2 - Adds delay during a recording activity.

F3 - Lets you specify a custom recording region.

F4 - Lets you choose the UI Framework to record, which can be Default, AA, and UIA.

Workflow Analysis and Execution

F5 - Runs the current project in debugging mode, starting with the .xaml file set as Main.

Ctrl + F5 - Runs the current project.

F6 - Runs the currently opened .xaml file in debugging mode.

Ctrl + F6 - Runs the currently opened .xaml file.

F7 - Checks the file for validation errors and Workflow Analyzer violations.

Shift + F7 - Checks the whole project for validation errors and Workflow Analyzer violations.

F8 - Checks the currently opened workflow for validation errors.

Shift + F8 - Checks all project files for validation errors.

Pause - Pauses the execution of the current workflow, in both normal and debug mode.

F12 - Stops the execution of the current workflow, in both normal and debug mode.

Selected Activity

Ctrl + T - Places the activity inside the Try section of a Try Catch activity.

Ctrl + N - Creates a new Sequence Diagram in the current project.

Ctrl + C - Copies the selected activity or activities to the clipboard.

Ctrl + V - Pastes the copied activity or activities inside the selected item.

Ctrl + K - Creates a variable of the same type as the required type of the activity when used in an input field or the Expression Editor. If an expression already exists in the field, before pressing CTRL + K, you can select that expression or a part of it to use the selected text as the name of the new variable.

Ctrl + M - Creates an In argument of the same type as the required type of the activity when used in an input field or the Expression Editor. If an expression already exists in the field, before pressing CTRL + M, you can select that expression or a part of it to use the selected text as the name of the new argument.

Ctrl + Shift + M - Creates an Out argument of the same type as the required type of the activity when used in an input field or the Expression Editor. If an expression already exists in the field, before pressing CTRL + Shift + M, you can select that expression or a part of it to use the selected text as the name of the new argument.

Ctrl + Shift + E - Opens the Expression Editor when used inside activity input fields.

Ctrl + Space - Opens the IntelliPrompt window.

F2 - Allows for renaming the selected activity.

Shift + F2 - Adds an annotation to a selected activity.

Enter - Saves the data added in the activity input field.

Shift + Enter - Adds a new line in the activity input field.

Tab - Moves through the fields and buttons in the activity, including the plus_icon menu displayed when you hover the mouse over an input field.

Test Automation

Ctrl + Alt + T - Open Test Explorer panel. You can use this anywhere within the Designer panel.

Alt + T - Open Test Results sub-panel in Test Explorer. You can use this only in the Test Explorer panel.

Alt + A - Open Activity sub-panel in Test Explorer. You can use this only in the Test Explorer panel.

Arguments Dialogs

The following keyboard shortcuts are available in Arguments dialog boxes available in activities such as Invoke Workflow File and Inject .NET Code:

Tab - Moves through the items in the grid.

Delete - Deletes the item selected in the grid.

F2 - Highlights the current cell for editing, positioning the cursor at the end of the line.

Ctrl + Tab - Moves through the options available in the window for the selected item in the grid (Delete, Move up, Move Down).

Status Bar

Alt + D - Access the Source Control, Orchestrator folders, and Orchestrator/Cloud Connection menus in the status bar, and then use Shift + Tab to cycle through the menus. Once a menu is selected, press Enter to open it.

Miscellaneous

F1 - Enables you to access a help topic associated with the currently selected element.

Alt + F4 - Closes the current window.

Alt + - - Opens the Options context menu in the title bar of the currently selected panel. Please note that this works with the hyphen key above the character keys, not with the minus key in the numpad.

Windows key + Up Arrow - Maximizes the current window.

Windows key + Down Arrow - Restores down the current window.

Ctrl + P - Opens the Manage Packages window.

Esc - Closes the Publish, Manage Packages, File Diff windows.

Ctrl + F1 - Minimizes or expands the ribbon.

Ctrl + Shift + R - Removes all unused project dependencies.

Shift + Tab - Navigates to the previous activity or node in the Activities panel.

Ctrl + Z - Undo the last action.

Ctrl + Y - Redo the last action you've undone.

Shift + F10 - Open the context menu for the selected item (right-click).

Ctrl + Tab - Moves the focus out of multiline text boxes where pressing the Tab key inserts a tab.

Ctrl + Shift + F10 - Dismisses the tooltip content for the selected item.

Ribbon and Home Tab Shortcut Keys

You can quickly get to most of the options in the Home tab (Studio Backstage View) and the ribbons in the Design and Debug tabs by pressing and releasing the Alt key, and then pressing one or more keys.

When you press and release the Alt key, one or more letters or digits appear over the options in the current view. To use an option, press the corresponding key or keys. For some options, additional keys are available after you press the initial key combination.

1315

For a list of shortcuts, see the following sections.

Design Tab Ribbon Keys

If you are in the Design tab or Debug tab, press Alt+D to access the shortcut keys for the Design tab ribbon.

Key(s)Action PerformedAdditional Keys and Actions
NOpen the New drop-down
SOpen the Save drop-downS - Save as
L - Save all
ETOpen the Export as Template window
ROpen the Debug File drop-downC - Run file
B - Debug project
D - Run project
XCut the selected activities
CCopy the selected activities
VPaste the copied activities
MPOpen the Manage Packages window
MEOpen the Manage Entities window
EWOpen the Service Editor window
UOpen the UI Explorer window
IUOpen the Remove Unused drop-downF - Remove Unused Workflows
A - Remove Unused Variables
B - Remove Unused Arguments
C - Remove Unused Dependencies
D - Remove Unused Imports
E - Remove Unused Screenshots
AOpen the Analyze File drop-downB - Analyze Project
C - Validate File
D - Validate Project
S - Workflow Analyzer Settings
EXOpen the Export to Excel window
POpen the Publish window

Debug Tab Ribbon Keys

If you are in the Design tab or Debug tab, press Alt+E to access the shortcut keys for the Debug tab ribbon.

Key(s)Action PerformedAdditional Keys and Actions
ROpen the Debug File drop-downC - Run file
B - Debug project
D - Run project
BBreak execution
TStop execution
SStep Into
VStep Over
OStep Out
ERRetry
EIIgnore
ESRestart
FFocus
POpen the Breakpoints drop-downT - Toggle Breakpoints
P - Show Breakpoints Panel
LSSet Slow Step speed
LEEnable / disable Execution trail
LHEnable / disable Highlight Elements
LAEnable / disable Log Activities
LCEnable / disable Continue on Exception
LPEnable / disable Picture in Picture
LROpen the Remote Debugging drop-downC - Configure Remote Debugging
LOOpen the Logs folder

Title Bar Keys

To access keys for the buttons in the Studio title bar (top-right side of the window), press the Alt key.

Key(s)Action PerformedAdditional Keys and Actions
FOpen the Send feedback window,-
LOpen the Help drop-down.-
IOpen the Sign in / Sign out menu-

Home Tab Keys

If you are in the Design tab or Debug tab, press Alt+H to open the Home tab (Studio Backstage View) and access the shortcut keys for the Home tab. If you are already in the Home tab, all you need to do is press the Alt key.

Key(s)Action PerformedAdditional Keys and Actions
ZGo back to the previous tab, if a project is open
OOpen a project
CClose the currently open project
SOpen the Start tabO - Open a Local Project
C - Clone or Check Out a Project
P - Create a Process
L - Create a Library
A - Create a Test Automation
T - Create a Template
1...9 - Open one of the nine most recent projects
TOpen the Templates tab
MOpen the Team tab
LOpen the Tools tabU - Open the UI Explorer
M - Open the Project Dependencies Mass Update Tool
R - Open the Repair Tool for Microsoft Office
C - Install the Chrome extension
F - Install the Firefox extension
E - Install the Edge extension
J - Install the Java extension
S - Install the Silverlight extension
T - Install the Citrix extension
W - Install the Windows Remote Desktop extension
V - Install the VMware Horizon extension
EOpen the Settings tabG - Open the General tab
D - Open the Design tab
L - Open the Locations tab
M - Open the Manage Sources tab
P - Open the License and Profile tab
T - Open the Team tab
B - Open the Labs tab
HOpen the Help tabD - Open the Product Documentation link
F - Open the Community Forum link
M - Open the Help Center link
A - Open the Academy link
R - Open the Release Notes link
S - Open the Take a short survey link
T - Open the Quick Tutorial link
C - Copy the license information

Updated 2 months ago


Keyboard Shortcuts


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.