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Robot ガイド

最終更新日時 2024年12月18日

管理者として実行した場合のエラー

現象

v2020.4 のリリースより、UiPath® Assistant または Studio を管理者として実行すると、これらの製品が Robot サービスと通信できなくなり、以下に記載するエラーが発生する可能性があります。

Studio

ロボット ステータスに [Robot のエラー] というメッセージが表示され、プロセスを実行またはデバッグしようとすると「アクセスが拒否されました。」というエラーが表示されます。



UiPath® Assistant

Assistant 内の接続ステータスがオフラインであると誤って報告され、プロセス リストが表示されません。

原因

UiPath® Assistant と Studio (クライアント) は Robot サービスと通信する必要があります。これは個別の Windows プロセスであり、すでに実行されていない場合はクライアントによりクライアントと同じ昇格レベルで自動的に開始されます。

例:

  • Assistant が特権レベルで開始され (Robot サービスも同じ特権レベルで自動的に開始される)、その後 Studio が異なる特権レベルで開始されると、Robot サービスは同じ特権レベルを持つアプリケーション (Assistant) としか通信できません。
  • Assistant を通常の状態で開始した後に閉じて、その後管理者として開始すると、Robot サービスが最初に通常の権限で開始されているため、通信が切断されます。

Robot サービスが Assistant または Studio とは異なる権限レベルを持っているため、通信ができずに上記のエラーが発生します。

注: この挙動は、ユーザー モードサービス モードの Robot の両方で発生します。

解決策

この問題を回避するには、Assistant、Studio、Robot サービスが常に同じ特権レベルで実行されている必要があります。

注: UiPath® Assistant、Studio、および Robot をユーザー レベルの権限で実行することをお勧めします。昇格が必要な特殊な状況では、UiPath.Studio.exe と UiPath.Assistant.exe の両方が、既定で管理者権限で実行されるように設定されている必要があります。この設定では、コマンド ラインを管理者特権で使用する必要もあります。
重要: Robot JavaScript アドオンは、管理者モードで実行できません。
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