Studio
2022.10
False
Imagen de fondo del banner
Guía de usuario de Studio
Última actualización 26 de abr. de 2024

Solución de problemas de las extensiones de Citrix

En esta página se explica cómo solucionar los problemas que pueden surgir al ejecutar la automatización en entornos Citrix.

Canales virtuales bloqueados por defecto

Descripción

A partir de Citrix Virtual Apps and Desktops 7 2109, todos los canales virtuales personalizados se bloquean de forma predeterminada.

Si se actualiza a esta nueva versión de Citrix, la automatización existente en Citrix a través de UiPath Remote Runtime deja de funcionar.

Solución

El canal virtual UiPath debe añadirse a la política de la lista de permitidos. Para ello, sigue estas instrucciones.

El siguiente valor debe añadirse a la política de la lista de permitidos.

UIPCTX,<UiPathRemoteRuntime-Install_Path>\UiPathRemoteRuntime.exe

Por ejemplo:

UIPCTX,C:\Program Files (x86)\UiPath\RemoteRuntime\UiPathRemoteRuntime.exe

La selección interactiva en las Apps de Citrix se congela y no se selecciona nada

Comportamiento observado

Después de instalar la extensión de UiPath para Citrix e intentar seleccionar elementos de la IU de una App de Citrix, la selección interactiva se congela durante un minuto y luego no se selecciona nada.

Causa

Esto se produce si el tiempo de ejecución remoto de UiPath no se ejecuta en la sesión de la App de Citrix.

Solución

  • Compruebe si UiPathRemoteRuntime.msi está instalado en el servidor de aplicaciones Citrix desde el que se abre la aplicación Citrix.
  • En el servidor de la aplicación Citrix, comprueba si el proceso UiPathRemoteRuntime.exe se está ejecutando. Si el UiPathRemoteRuntime.msi está instalado, el proceso se inicia automáticamente en el inicio de sesión de la aplicación Citrix.



    Nota: Si no puede instalar UiPathRemoteRuntime.msi en los servidores de aplicaciones Citrix, se recomienda desinstalar la extensión de UiPath para Citrix de la máquina del cliente, como se describe aquí.

No ha podido copiar el archivo «C:\Program Files (x86)\Citrix\ICA Client\UIPathPluginCitrix.dll». Lo está utilizando otro proceso.

Comportamiento observado

Al intentar instalar la extensión de UiPath para Citrix, se mostrará el siguiente error:



Causa

Esto se produce cuando la extensión de UiPath para Citrix ya está instalada y una aplicación de Citrix abierta la está utilizando.

Solución

Cierra todas las sesiones activas de Citrix App, como se describe aquí, y luego intenta instalar la extensión UiPath para Citrix de nuevo.

No se puede leer la clave de registro de Citrix: 'SOFTWARECitrixInstallICA Client' Valor: 'InstallFolder'

Comportamiento observado

Al intentar instalar la extensión de UiPath para Citrix, se mostrará el siguiente error:



Causa

Este mensaje de error se mostrará cuando el receptor de Citrix no está instalado. También se muestra si el receptor de Citrix para la plataforma de Windows universal está instalado.

Solución

Descarga e instala Citrix Receiver o Citrix Workspace.

Excepción no gestionada en wfica32.exe 0xC0094: División Entera por Zero

Comportamiento observado

La aplicación Citrix no puede iniciarse y el cliente Citrix ICA se bloquea.

Causa

Las actividades que utilizan la función GetWindowText (como Element Exists) se ejecutan antes de que la aplicación Citrix se cargue.

Solución

Espera a que la aplicación Citrix se cargue y deja un margen antes de la actividad.

La selección e identificación interactiva de elementos no funciona con DPI altos

Comportamiento observado

A partir de la aplicación Citrix Workspace (CWA) para Windows 2206, si no se aplica ninguna configuración de políticas de DPI altos, es posible que la selección interactiva y la identificación de elementos no funcionen para apps Citrix cuando la escala de DPI de la pantalla sea superior al 100 %.

Solución

Elimina el valor de registro Enable_DPI de Computer\HKEY_CURRENT_USER\SOFTWARE\Citrix\ICA Client\DPI:


Was this page helpful?

Obtén la ayuda que necesitas
RPA para el aprendizaje - Cursos de automatización
Foro de la comunidad UiPath
Logotipo blanco de UiPath
Confianza y seguridad
© 2005-2024 UiPath. All rights reserved.