test-manager
2.2510
false
UiPath logo, featuring letters U and I in white

Test Manager-Benutzerhandbuch

Letzte Aktualisierung 11. Nov. 2025

Fehlerbehebung beim Test Manager

Der zu Test Manager migrierte Testsatz kann nicht verwendet werden

Fehlermeldung

Wenn Sie versuchen, einen Test Manager-Testsatz, der mit der Funktion Testsätze importieren aus dem Orchestrator importiert wurde, über eine CI/CD-Pipelineaufgabe auszuführen, erhalten Sie eine Fehlermeldung, die angibt, dass die CI/CD-Pipeline den Testsatz nicht verwenden kann zum Test Manager migriert.

Lösung
So umgehen Sie diese Einschränkung:
  1. Wechseln Sie im Orchestrator zur Registerkarte Tests .
  2. Klonen Sie den importierten Testsatz, den Sie ausführen möchten.
  3. Verwenden Sie den Klon, um den Testsatz über eine CI/CD-Pipelineaufgabe anstelle des ursprünglichen importierten Testsatzes auszuführen.
Hinweis: Beim Klonen eines Testsatzes wird dessen Ausführungsverlauf nicht kopiert. Um aktuelle Ausführungsdaten im Test Manager beizubehalten, empfehlen wir, die geklonten Testsätze in den Test Manager zu importieren, nachdem Sie ihn über CI/CD ausgeführt haben.

Die Automatisierung ist bereits mit einem anderen Testfall im Test Manager verknüpft.

Fehlermeldung

Wenn Sie versuchen, einen Studio-Testfall zu verknüpfen, der bereits mit einer anderen Test Manager-Instanz verknüpft ist als der, in der Sie gerade arbeiten, erhalten Sie den folgenden Fehler: „Die Automatisierung ist bereits mit einem anderen Testfall im Test Manager verknüpft.“

Lösung

Sie können die Verknüpfung des Testfalls nicht direkt aufheben. Sie können dies jedoch umgehen, indem Sie den Testfall in einen Workflow konvertieren und ihn dann wieder in einen Testfall umwandeln. Dieser Vorgang ändert die Testfall-ID, so dass er mit Ihrer aktuellen Test Manager-Instanz verknüpft werden kann, ohne jedoch die zugrunde liegende Logik des Testfalls zu ändern.

Weitere Informationen zum Konvertieren eines Workflows in einen Testfall finden Sie unter Workflow in Testfall konvertieren.

Die automatisierte Ausführung konnte nicht gestartet werden, da das Paket auf dem Orchestrator nicht gefunden wurde

Fehlermeldung

Die automatisierte Ausführung konnte nicht gestartet werden, da das Paket in Orchestrator nicht gefunden wurde. Nur Testfälle aus Paketen, die in Orchestrator veröffentlicht wurden, können ausgeführt werden.



Lösung

Um dieses Problem zu beheben, stellen Sie sicher, dass Sie das Paket im Orchestrator-Mandantenprozessfeed veröffentlicht haben.

Testfälle konnten nicht ausgeführt werden, da keine ausführbaren Versionen gefunden werden konnten

Fehlermeldung

Testfälle konnten nicht ausgeführt werden, da keine ausführbaren Versionen gefunden werden konnten. Nur Testfälle, die mit der neuesten Paketversion in Orchestrator veröffentlicht wurden, können ausgeführt werden.



Lösung

Um dieses Problem zu beheben, stellen Sie sicher, dass Sie das Paket mit den neuesten Testfalländerungen im Orchestrator-Mandantenprozessfeed veröffentlicht haben.

Dieses Problem kann auch durch einen Testfall in Ihrem Projekt ausgelöst werden, der mit einem anderen Test Manager- Projekt verknüpft ist. Um dieses Problem zu beheben, heben Sie die Verknüpfung der Automatisierung im Test Managerauf.

Testsatz enthält Testfälle aus mehreren Paketen

Fehlermeldung

Ausführung nicht möglich. Der Testsatz enthält Testfälle aus mehreren Paketen, die nicht unterstützt werden.

Lösungen

  1. Lokal dupliziertes Studio-Projekt: Wenn Sie ein Studio-Projekt lokal dupliziert haben, indem Sie den Projektordner kopiert haben, führen Sie die folgenden Schritte aus:
    1. Duplizieren Sie den fehlerhaften Testfall in Studio.
    2. Löschen Sie den ursprünglichen Testfall aus dem Projekt.
    3. Veröffentlichen Sie das Projekt erneut im Orchestrator,
  2. Kein lokales Studio-Projekt dupliziert: Wenn Sie ein Studio-Projekt nicht lokal dupliziert haben, verknüpfen Sie den fehlerhaften Testfall erneut mit dem Testsatz.

Keine Lizenz für Test Managergefunden

Fehlermeldung

Keine Lizenz für Test Manager gefunden. Es gelten funktionale Einschränkungen.

Ursache

Dieses Problem tritt auf, wenn Sie die Test Manager -Plattformlizenz aktiviert haben, aber keine Tester – Named User -Lizenz haben.

Lösung

Um dieses Problem zu beheben, stellen Sie sicher, dass Ihrem Benutzerkonto eine Tester – Named User -Lizenz zugewiesen ist. Weitere Informationen zur Lizenzierung für Test Manager finden Sie unter Einheitliche Preise: Lizenzierung Test Manager.

War diese Seite hilfreich?

Hilfe erhalten
RPA lernen – Automatisierungskurse
UiPath Community-Forum
Uipath Logo
Vertrauen und Sicherheit
© 2005–2025 UiPath. Alle Rechte vorbehalten