Subscribe

UiPath Studio

The UiPath Studio Guide

About Automation Projects

UiPath Studio enables you to create the following types of projects:

  • Process - Design an automation process and publish it so that it can be executed by robots.
  • Library - Design workflows as reusable components and publish the project as a library that can be added as a dependency to multiple processes. For more information, see About Libraries.
  • Test Automation - Design a test automation project. For more information about test automation, see the Test Suite section.
  • Template - Design a process and publish it as a template that other processes which share common characteristics can then be based on. For more information, see Project Templates.

To create a new blank project, go to Home (Studio Backstage View) > Start and select the type of project to create under New Project. Alternatively, you can start from one of the default templates available under New from Template or go to the Templates tab to browse for more templates from various sources.

In the new project window, configure the following for each project:

  • Enter a name for the new project and a description that summaries what you are aiming to do with this automation project.
    :information-source: Note: The project name cannot exceed 128 characters, and the description cannot exceed 500 characters.
  • Select the location where to create the project. The default location where projects are created is %USERPROFILE%\Documents\UiPath.
  • Select the compatibility and language.
    :information-source: Note: The compatibility and language cannot be changed after you create a project.

By default, the project folder includes the following files and subfolders:

  • Files
    • Main.xaml - Created by default to hold your main workflow. In addition, all the other automation XAML files you add to the project are stored in the project folder. Optionally, you can set a different file as main. All the files must be linked through the Invoke Workflow File activity to the file set as main or to a file marked as an entry point to the project. For test automation projects, a TestCase.xaml file is created by default instead of Main.xaml.
    • project.json - Contains information about your automation project.
  • Subfolders
    • .entities - Contains data about entities imported from the Data Service, if any are used in the project.
    • .local - Contains data cached locally for the project.
    • .objects - Contains data related to items added to the Object Repository, if any are used in the project.
    • .screenshots - Contains informative screenshots generated in UI automation activities, if any are used in the project.
    • .settings - Contains activity project settings used at runtime.
    • .tmh - Contains data related to test cases, if any are used in the project.

📘

Important:

Projects created with newer versions of Studio might not work with older Studio versions. Read more about Backward and Forward Compatibilty.

Setting the Project Compatibility

When you create a new project in the Studio profile, select the compatibility based on the environment on which the project will be executed:

  • Windows - Legacy - Uses .NET Framework 4.6.1. the compatibility used in releases prior to 2021.10. This is the default option.
  • Windows - Uses .NET 5 with Windows support.
  • Cross-platform - Uses .NET 5 with cross-platform support.

To learn about the differences between compatibilities, see the following table.

Windows - Legacy

Windows

Cross-platform

Process execution

32-bit

64-bit

64-bit

Supported platforms for execution

Windows (32-bit and 64-bit)

Windows (64-bit)

Windows and Linux (64-bit)

Processes are compiled when published

No. Published packages contain the project source files.

Yes. Published packages contain compiled DLL files.

Yes. Published packages contain compiled DLL files.

Compatible with Studio and Robot 2021.4 or older

Yes

No

No

The design experience is the same for all compatibilities, but only the activities packages that support the selected compatibility can be installed from the package manager.

The compatibility of each project is displayed on the right side of the Studio status bar and in the Project panel > Dependencies node. The compatibility is also displayed in the entry of each project in the Open Recent list in Home (Studio Backstage View) > Start tab.

Designing Cross-Platform Projects

Cross-platform projects enable you to create API-based automations that can be executed on Windows as well as Unix-like operating systems.

📘

Note:

In the 2021.10 release, cross-platform projects support execution only on Windows and Linux.

To create unattended projects with cross-platform support:

  1. In Studio, create a new project and select the Cross-platform compatibility option. This option is available for all project types.
  2. Design the automation. Please note that not all activities packages are compatible with cross-platform projects, so only a limited selection of packages is available in the package manager. The default dependencies for a cross-platform project are UiPath.System.Activities and UiPath.WebApi.Activities.
  3. Test the automation. We recommend testing automations on the machines where they will run using remote debugging which works with both Windows and Linux robots.
  4. After testing the automation, publish the project to Orchestrator. The procedure for running unattended jobs is the same for Windows and Linux.

Setting the Project Language

When you create a new project in the Studio profile, you can select which language to use for expressions, either VB or C#. VB is the language selected by default, but you can set C# as the default language for new projects by going to Home (Studio Backstage View) > Settings > Design. Projects created in the StudioX profile use the VB.NET language for expressions.

The use of both VB and C# expressions in the same project is not supported. Neither is the use of VB expressions in C# workflows and vice versa. When you copy and paste activities from other projects, invoke or import workflows, make sure they use the same language as your project.

You can install C# libraries as dependencies in VB projects and vice versa. However, default values defined for arguments in the library project using language-specific expressions cannot be accessed from the project where the library is installed.

C# Limitations

  • The current C# implementation is based on the C# compiler that uses C# version 5, therefore access to newer features like coalescing assignment, null-conditional operator, null-coalescing operator, string interpolation and others is limited.
  • Projects containing expressions with increments are invalid.
  • Expressions containing the nameof() operator are marked as invalid and are not allowed with the current implementation of C#.
  • Expressions containing calls to methods with optional arguments must include values for the optional arguments.
  • Design time and runtime performance of C# projects is lower when compared to VB.NET. When runtime performance is essential, we recommend using VB.NET instead of C#.

Setting the Project Version

Semantic Versioning

The semantic versioning scheme has the format Major.Minor.Patch[-Suffix], where:

  • Major is the major version.
  • Minor is the minor version.
  • Patch is the patch version.
  • -Suffix (optional) is a hyphen followed by a series of dot separated identifiers immediately following the patch version. This denotes a prerelease version.

Identifiers must comprise only of ASCII alphanumeric characters and hyphen, and they must not be empty. Numeric identifiers must not include leading zeroes. In addition, build metadata may be denoted by appending a plus sign and a series of dot separated identifiers immediately following the patch or pre-release version, for example 1.0.0-alpha+1.

When creating a new process or library, the default version scheme is semantic. It can be changed from the Publish window by simply adding an extra digit to the version number. The project’s semantic version can be modified from the project.json file too. The patch number 0 is automatically added to projects with version number major.minor.

Legacy Versioning

The legacy version number generated for the project has the format M.m.bbbb.rrrrr, where:

  • M is the major version.
  • m is the minor version.
  • bbbb is the build version.
  • rrrrr is the revision version.

The major and minor versions can be edited in the project.json file also, while the build and revision versions are generated according to an algorithm - the build value is the number of days that elapsed since 01.01.2000. The revision value is the number of seconds which elapsed since the current day, until the moment of the release. The result is divided by 2, so that the maximum revision number does not exceed 65535.

The suggested version number in the Publish window is generated based on the project’s previous versioning scheme, while the current date and timestamp are taken into account for projects using the 4-digit versioning scheme.

Managing Projects

The Project panel enables you to view the contents of the current project, add folders, open the file location, manage dependencies, and adjust project settings.

Copy and paste files from File Explorer directly into the Project panel. The same can be done using drag and drop on one or multiple files, including .xaml workflows. You can also use the Ctrl + C and Ctrl + V shortcuts or Copy and Paste options in the context menu to copy and duplicate files or folders inside the panel.

Option

Description

Expand Allexpand_allexpand_all

Expands all nodes in the automation project.

Collapse Allcollapse_allcollapse_all

Collapses all nodes in the automation project.

Refreshrefreshrefresh

Refreshes the project.

Show All Filesshow_filesshow_files

Shows all files belonging to the automation project, including the project.json.

File Explorerfile_explorerfile_explorer

Opens the project's location on the machine.

Project Settingsproject_settingsproject_settings

Opens the Project Settings window for processes or libraries.

Context Menu for Projects

Right-click anywhere in the Project panel to open the context menu with options described in the following table. A different subset of options is available depending on where in the panel you right-click, the type of project, and whether the project is added to source control.

Option

Description

Open Project Folder

Opens the local folder containing the project.

Project Settings

Opens the Project Settings window for adjusting project preferences.

Add

Opens a list of items that can be added to the project: folder, sequence, flowchart, state machine or global handler.

Import Workflows

Imports .xaml files to the project and adds Imported in the file name if it coincides with the name of the main file.

Import Files

Opens the File Explorer window for importing various files into your project.

Add to Source Control

Adds the current project to source control using Git Init, Copy to Git, Add to TFS, or Add to SVN options. Please note that this option is only visible when right-clicking the project node.
When a project is added to source control, additional options are available in the context menu. See the options for GIT and the options for SVN and TFS.

Open

Opens the selected files using the default program.

Open File Location

Opens the local folder containing the file.

Rename

Enables you to rename the selected file or folder, and opens the Rename Item window. The item is renamed in all occurrences.

Copy

Copies the selected files or folders to the clipboard. You can then paste them in the project panel or in the Windows file explorer.

Paste

Pastes files or folders that were copied to the clipboard.

Delete

Deletes the selected item only from your local machine.

Select for Compare

Selects the current file for comparison.

Compare with Selected

Compares the current file with the previously selected file using Compare Files.

Find References

Finds all references to the file in the project. The results are displayed in the Find References panel.

Debug File

Debugs the selected .xaml file.

Set as Main

Sets the selected .xaml file as Main in the project definition, meaning that the project execution starts with that file. There can only be one Main project file. The name of the file set as main appears in bold in the Project panel.

Properties

Open the library’s Properties window for adding a tooltip and Help Link.

Set as Global Handler

Sets the .xaml file as the Global Exception Handler for the project. This is applicable to one workflow per project/process.

Remove Handler

Removes the Global Exception Handler tag from the .xaml file.

Enable Entry Point

Marks the selected workflow file as an entry point for the process, making it possible to select it as the workflow to run first when using the Invoke Process and Run Parallel Process activities in other processes, or when starting a job from Orchestrator.
Notes:
When a file is marked as an entry point, an arrow is displayed on the icon next to the file name icon_enable_entry_pointicon_enable_entry_point.
Enabling a file that is ignored from publishing as an entry point sets the file as publishable.
This option is not available for test case files.
This option is not available in library projects.

Disable Entry Point

No longer marks the selected workflow file as an entry point for the process. This option is not available for the workflow file that is set as Main.

Ignore from Publish / Set as Publishable

Marks one or more selected files as excluded from publishing or publishable.
Notes:
When a file is ignored from publishing, the icon next to the file name turns gray icon_ignore_publishicon_ignore_publish.
Ignoring a file marked as an entry point from publishing disables the entry point.
These options are not available for workflow files in library projects.
In projects where XAML files are compiled when published, workflow and test case files that are excluded from publishing are not compiled.

Make Private / Make Public

Marks one or more selected files in a library project as private or public, A private workflow file is included in the published package, but no reusable component is created and made available in the Activities panel in projects where the library is installed as a dependency.
Notes:
When a file is marked as private, the icon next to the file name turns gray icon_ignore_publishicon_ignore_publish.
These options are not available for test case files.

Create Test Case

Creates a test case that invokes the selected workflow file.

Convert to Test Case / Convert to Workflow

Converts the selected workflows to test cases or the selected test cases to workflows.

Import Test Cases

Imports test cases into the project as draft test cases.

Add Test Data

Opens the Import Data Variation Source window that enables you to add test data to the project. This option is only available for test cases.

Link to Test Manager

Opens the Link to Test Manager window that enables you to link the selected test cases to Test Manager.

Run Test Cases / Debug Test Cases

Runs or debugs multiple selected test cases.

Context Menu Options for GIT

In projects added to GIT repositories, an icon is displayed next to each file in the Project panel to indicate the file status:
git branchgit branch The file is synced with the repository.
git editedgit edited The file has been modified.
source control addedsource control added The file has been added.

Right-click a file or project node in the Project panel to open the GIT-specific context menu for Managing Projects with GIT.

Option

Description

Commit

Commits current changes to the local GIT repository.

Push

Pushes the current version onto the remote repository.

Pull (rebase)

Pulls remote files and rebases the current branch.

Manage Branches

Opens the GIT window with options for managing currently added branches.

Show Changes

Opens the File Diff window for comparing changes between the local version and the remote version of the file.

Show History

Opens the Show History window for comparing two versions of the same file.

Undo

Opens the Undo Pending Changes window if the file was not committed or pushed to the remote repository.

Copy Repository URL

Copies the repository URL of the project to the clipboard.

Context Menu Options for SVN and TFS

In projects added to SVN or TFS repositories, an icon is displayed next to each file in the Project panel to indicate the file status:
svn lockedsvn locked The file is not checked out for editing.
svn checked outsvn checked out The file has been checked out for editing.
svn editedsvn edited The file has been edited.
source control addedsource control added The file has been added.

Right-click a file or project node in the Project panel to open the context menu with options specific to managing projects with TFS or SVN.

Option

Description

Open

Opens the selected .xaml file in the Designer panel, in read-only mode if it was not checked out for edit from the TFS/SVN repository.

Rename

Enables you to rename the selected file or folder, and opens the Rename Item window. When checking in the renamed .xaml file, the previously modified version must also be checked in.

Delete

Deletes the selected item only from your local machine. The latest checked in version of the file is still available in the TFS/SVN repository.

Check Out For Edit

Marks the selected file or folder as locked for editing. Checking out a file locks it on the server so that no one else can edit it.

Finish Editing

Checks in the project.json file in the respository, together with changes and a commit message.

Add

Uploads the selected item to the TFS/SVN server. This option is not available, if the item was previously uploaded to the server.

Get Latest Version

Downloads the latest version of the selected item from the TFS/SVN repository.

Show changes...

Opens the File Diff to compare changes between the versioned file and the one mapped locally.

Check In

Displays the Check In Changes window and enables you to upload the selected item to the server as the newest version. The .xaml file must be saved before uploading it. After it’s checked in, the file becomes read-only in Studio.

Undo

Displays the Undo Pending Changes window and enables you to Revert the changes done to the project, either revert modified files to previous or unversioned states, or retrieve files which were deleted from the local machine.

Changes cannot be reverted after the file was checked in.

Run

Runs the selected workflow, even if it's not checked out or added to the repository.

Set as Main

Sets the selected .xaml file as Main in the project. The first created .xaml is set as Main by default.

Copy Repository URL

Copies the repository URL of the project to the clipboard.

Adjusting Project Settings

A set of individual settings can be established for each automation project that you’re working on. Such settings are available in the Project Settings window, which can be opened by clicking the settings_iconsettings_icon in the Project panel.

Field Description for the Settings Window

The following table describes the project settings for process, test automation, and template projects. For information about the settings available for libraries, see About Libraries.

Field

Description

Name

Change the name of the project. Such names may contain whitespace characters. When naming projects, keep in mind that whitespace characters are removed at publish time. This field accepts up to 128 characters.

Description

Change the project description. This field accepts up to 500 characters.

Automation Hub URL

URL of an Automation Hub idea linked to the project. For more information, see Linking a Project to an Idea in Automation Hub
.

Package Icon

Optionally, define a custom icon for the project. You can browse to and select a file, or enter a path or public URL to an ico, jpeg, jpg, or png file up to 1MB in size.

After the project is published, the icon is displayed as follows:
For processes, in the Assistant next to the process name, making it easier to identify it in the list of processes.
For templates, next to the template in Home (Studio Backstage View) > Templates.
For libraries, next to the package in the Manage Packages window in Studio.
:information-source: The icon is not visible in Manage Packages if a local file is used for a library published to Orchestrator or a feed that does not support embedded icons, In this case, specify the icon using a URL.

Disable Pause

Enable or prevent users from pausing execution from the UiPath Assistant. Set to Yes if pausing the process during execution would result in crashing it. For example, if an activity in your workflow uses the Timeout property, pausing the execution might cause the timeout to expire, thus breaking the execution.

Attended Automation

Set to Yes to indicate that the project must only be executed in an attended context. Use this setting to prevent projects that include UI Automation activities or other activities that require user interaction from being executed in an unattended context.

Starts in Background

Set to Yes to turn the project into a Background Process and allow it to run in the background concurrently with other processes, as long as it does not use UI interaction.

Supports Persistence

Set to Yes to turn the project into an Orchestration Process.

PiP Ready

Set to Yes to indicate that the project was tested using Picture in Picture. If set to No, when the process is run in PiP from the Assistant, a dialog informs the user it was not tested using this feature and prompts for confirmation before proceeding.

Starts in PiP

Set to Yes to indicate that the process should be run by default using the Picture in Picture feature.

Modern Design Experience

Set to Yes to enable a modern experience of working with UI Automation, including new and improved activities, recorders, and wizards, as well as the Object Repository.
This setting also enables / disables a modern design experience for Excel if the Excel Design Experience option is set to UseGlobalSetting in the Excel activities project settings.

Click OK and the changes are made visible in the Project panel and project.json file.

Check out the Configuring Activity Project Settings page to read about how to adjust activity properties at project level.

📘

Note:

Please take into consideration that whenever you wish to copy a large number of activities from one sequence to another, it is recommended to scroll down to the bottom of the Designer panel beforehand. This is due to a Windows Workflow Foundation limitation.

Removing Unused Project Resources

Unnecessary resources can make projects more difficult to understand and can impact performance, To avoid this problem, remove unused resources from your projects by clicking Remove Unused in the Studio ribbon, and then selecting what to remove:

  • Workflows - Remove workflow files that are not referenced in the project.
  • Variables - Remove variables that are not used in the currently open file.
  • Arguments - Remove arguments that are not used in the currently open file.
  • Dependencies - Remove installed activities packages from which no activities are used in the project.
  • Imports - Remove imported namespaces that are not used in currently open file.
  • Screenshots - Remove informative screenshots that are not used in any activity in the project.

Updated 4 days ago


About Automation Projects


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.