Subscribe

UiPath Installation and Upgrade

The UiPath Installation and Upgrade Guide

Software Requirements

Server OS

Software

Compatible Versions

Windows Server

2012 R2
2016
2019

Databases

Software

Compatible Versions

SQL Server

2012 Standard or Enterprise Edition
2014 Standard or Enterprise Edition
2016 Standard or Enterprise Edition
2017 Standard or Enterprise Edition
2019 Standard or Enterprise Edition
Azure SQL Database
Amazon RDS for SQL Server
Google Cloud SQL for SQL Server

Note: If you are considering installing Insights, make sure that your database supports both columnstore indexes and JSON functions.

UiPath High Availability Add-on

All Versions

Note: Required only for supported HA installations.

🚧

Important!

Multi-node Orchestrator deployments use the RESP (Redis Serialization Protocol) for communication, and thus can be configured using any solution relying on this protocol.
HAA is the only such solution supported by UiPath.

Logging & Visualization

📘

Note:

The below software is not explicitly required, but is recommended for logging & visualization purposes.

Software

Compatible Versions

Elasticsearch

7.0 - 7.16.2

ECheck the official Elasticsearch End-of-Life dates and support matrix.

Kibana

7.0 - 7.16.2

Browsers

Software

Compatible Versions

Google Chrome

50+

Firefox

69.0.1+
Not supported in Private Browsing mode

Microsoft Edge

20+

🚧

Internet Explorer End of Support

Internet Explorer support is no longer offered for Orchestrator v2021.4 or newer. Previous Orchestrator versions are not impacted by this change. See this forum post for details.

Deployment

Software

Compatible Versions

WebDeploy

3.5+
64bit version

Please note that this is required only for PowerShell script installations, such as the Azure one.

Software Frameworks

Software

Compatible Versions

.NET Framework

4.7.2+

ASP.NET Core Module

3.1.x
6.0.x

📘

Note:

  • ASP.NET Core IIS Module 3.1.x is available for download here as part of the Hosting Bundle.
  • ASP.NET Core IIS Module 6.0.x is available for download here as part of the Hosting Bundle.

Only the core needs to be installed, no runtime(s), which is done by running the installer from the command-line using OPT_NO_RUNTIME=1.

Web Servers

Software

Compatible Versions

IIS

8+

IIS Modules - URL Rewrite

2.1+

Virtualization Platforms

📘

Note:

Any platform that can create a Windows Virtual Machine can be used as well.

Software

Compatible Versions

Citrix XenDesktop

7.6+

Oracle VirtualBox

5.0+

Microsoft Hyper-V

VMWare

Credential Stores

📘

Note:

The below items are not required for use of Orchestrator, but optional integrations.

Software

Compatible Versions

Dependencies

CyberArk®

Central Provider 11.1

Digital Vault 9.6 and later
Application Password SDK 9.7 and later.

Azure Key Vault

HashiCorp Vault

Open Source 1.5.0 and later
Enterprise 1.5.0 and later
Cloud (HCP Vault)

BeyondTrust

21.3+

📘

Note:

For additional details on the CyberArk® Credential Provider system requirements, refer to CyberArk® documentation.

If you are using another credential store via a plugin in Orchestrator you must verify that you meet all the dependencies and requirements of the respective plugin.

Check out software requirements for Studio and Robot.

Updated about a month ago


Software Requirements


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.