UiPath Documentation
data-service
2023.4
false
Data Service-Benutzerhandbuch
  • Erste Schritte
    • Einleitung
    • Die Benutzeroberfläche
    • Checkliste für die Data Service-Konfiguration
    • Installieren der Automation Suite
  • Einstellung und Konfiguration (Setup and Configuration)
  • Verwenden von Data Service
  • Referenz (Reference)
    • Data Service Studio-Aktivitäten
    • API-Zugang
  • Beispiele und Tutorials
Wichtig :
Bitte beachten Sie, dass dieser Inhalt teilweise mithilfe von maschineller Übersetzung lokalisiert wurde. Es kann 1–2 Wochen dauern, bis die Lokalisierung neu veröffentlichter Inhalte verfügbar ist.

Verwalten der Daten für eine Entität

Hinzufügen, Bearbeiten, Importieren und Löschen von Datensätzen für eine Entität im Data Service.

Sie können die Entität inUiPath® Studio importieren und in Ihrem Prozess zum Erstellen von Daten verwenden. Sie können auch Basisdaten für Entitäten direkt in Data Service hinzufügen, verwalten und löschen.

Hinzufügen von Daten​

So fügen Sie einer Entität neue Daten hinzu:

  1. Wählen Sie die Entität aus, zu der Sie weitere Daten hinzufügen möchten.
  2. Klicken Sie auf die Registerkarte Daten.
  3. Wählen Sie Neue Daten hinzufügen.
  4. In the Add Data panel, add a value for each field that you have defined for the entity.
  5. Wählen Sie Speichern.

Ein neuer Datensatz wird auf der Registerkarte Daten angezeigt.

Importieren von Daten mit einer CSV-Datei​

Importieren Sie Datensätze aus einer CSV-Datei, um einer vorhandenen Entität neue Daten hinzuzufügen.

Bevor Sie beginnen​

  • Sie verfügen über die Berechtigungen Lesen und Erstellen für die Entität, in die Sie Daten importieren möchten.
  • Sie verwenden einen anderen Webbrowser als Mozilla Firefox. Das Importieren wird in Firefox nicht unterstützt.
  • Beziehungsfelder, Auswahlsätze und Felder für die automatische Nummerierung in der Entität sind als nicht erforderlich konzipiert. Das Importieren wird für Daten in diesen Feldern nicht unterstützt.
  • Ihre CSV-Datei erfüllt die Voraussetzungen für die CSV-Datei.

Voraussetzungen für die CSV-Datei​

Um das erfolgreiche Ergebnis des Importvorgangs sicherzustellen, muss Ihre CSV-Datei die folgenden Voraussetzungen erfüllen.

Dateiformat:

  • Die CSV-Datei muss als einer der folgenden Typen gespeichert werden:
    • CSV (durch Trennzeichen getrennt) (*.csv)
    • CSV (MS-DOS) (*.csv)
    • CSV (UTF-8) (*.csv)
  • Das Spaltentrennzeichen in der CSV-Datei muss ein Komma sein.
  • The CSV file can be at most 10 MB.
  • The CSV file can contain at most 30,000 entries.

Column content:

  • Spalten in der CSV-Datei müssen mit dem Anzeigenamen der Entitätsfelder übereinstimmen.
  • Spalten in der CSV-Datei müssen mit dem Felddatentyp übereinstimmen. Beispiel: Für ein Texttypfeld muss die Spalte in der CSV-Datei Text enthalten.
  • Spalten in der CSV-Datei müssen Werte für Entitätsfelder enthalten, die als erforderlich markiert sind.
  • Spalten in der CSV-Datei, die Feldern entsprechen, die in Data Service als eindeutig markiert sind, dürfen keine doppelten Daten enthalten.

Importieren Sie die Datei​

  1. Navigieren Sie zu der Entität, in die Sie Daten importieren möchten.
  2. In the Fields or Data tab of the selected entity, select Import data. The File explorer window opens.
  3. Suchen Sie nach der CSV-Datei, die die Daten enthält, die Sie importieren möchten.
  4. Wenn eine Popup-Nachricht Sie zur Bestätigung auffordert, da Sie zuvor dieselbe Datei ausgewählt haben, bestätigen Sie den Import.

Import erfolgreich​

Die Meldung „Import erfolgreich!“ informiert Sie über das erfolgreiche Ergebnis des Imports.

Die neuen Datensätze werden fett formatiert angezeigt.

Das systemeigene Feld Erstellt von zeigt das Konto an, das den ersten Import durchgeführt hat, während das systemeigene Feld Erstellt das Datum des ersten Imports anzeigt. Die Felder Geändert von und Geändert enthalten Details zu den nachfolgenden Importen für dieselbe Entität.

Standardwerte werden für Felder bereitgestellt, in denen die Daten in der CSV-Datei fehlen.

Import fehlgeschlagen​

Das Meldungsfeld „Import fehlgeschlagen“ informiert über den Fehler, der dazu führt, dass der Import fehlschlägt.

Ein Import kann insgesamt erfolgreich sein, auch wenn einzelne Datensätze fehlschlagen. Sie können auf eine Ausgabedatei zugreifen, die die fehlgeschlagenen Datensätze zur Überprüfung enthält.

Durch Drosselung verursachte Fehler können auftreten, wenn mehr als 10 Benutzer gleichzeitig importieren. Versuchen Sie in diesem Fall den Import erneut.

Der gesamte Import schlägt fehl, wenn:

  • 80 der ersten 100 Datensätze schlagen beim Import fehl.
  • Network connectivity issues occur.
    Wichtig:

    Wenn Sie die Datei mit den fehlgeschlagenen Datensätzen nicht herunterladen können, fordern Sie eine Kopie an, indem Sie sich innerhalb von sieben Tagen an den Support wenden. Geben Sie die folgenden Daten an:

    • Datum und Uhrzeit des Imports
    • Organisations-ID
    • Entitäts-ID
    • BenutzerEMail

Updating data​

So ändern Sie einen Dateneintrag:

Hinweis:

Integrierte Systemfelder können nicht von Ihnen geändert werden.

  1. Aktivieren Sie auf der Registerkarte Daten das Kontrollkästchen vor der Datenzeile, die Sie bearbeiten möchten.
  2. Wählen Sie Bearbeiten aus, verfügbar auf der rechten Seite des Bildschirms.
  3. Übernehmen Sie die Aktualisierungen.
  4. Wählen Sie Speichern.
Hinweis:

Sie können einen Dateneintrag auch inline ändern, indem Sie das Feld für eine Datenzeile auswählen, die Sie bearbeiten möchten. Nehmen Sie Ihre Änderungen vor und wählen Sie dann außerhalb des Felds aus oder drücken Sie die Eingabetaste , um sie beizubehalten.

Daten löschen​

So löschen Sie einen Datensatz:

  1. In the Data tab, select the checkbox in front of the data row you want to delete.
  2. Wählen Sie das Symbol „Löschen“ aus, das auf der rechten Seite des Bildschirms verfügbar ist.
  3. Wählen Sie im Dialogfeld Daten löschen die Option Löschen aus , um die Aktion zu bestätigen.

Der Datensatz wird aus der Liste der Datensätze auf der Registerkarte Daten entfernt.

War diese Seite hilfreich?

Verbinden

Benötigen Sie Hilfe? Support

Möchten Sie lernen? UiPath Academy

Haben Sie Fragen? UiPath-Forum

Auf dem neuesten Stand bleiben