- Notes de publication
- Démarrage
- Didacticiels
- Projets d'automatisation
- Création d'automatisations
- Bases de l'automatisation
- Réf. d’objets
- À propos des cibles et des ancres
- Indication d'une cible
- Modification d’une cible
- Tutoriel : Travailler avec l’UI Automation
- Tutoriel : extraction de données de table d’une page Web et modification de ces données dans Excel
- Tutoriel : remplir des formulaires en format PDF avec des données Excel dans Acrobat Reader
- Tutoriel : Création d’un tableau croisé dynamique
- Tutoriel : parcourir les lignes d'une table
- Tutoriel : extraire des données d'e-mails automatisés et les déplacer vers une application de bureau
- Tutoriel : Filtrage des données dans Excel
- Tutoriel : Formatage des cellules
- Tutoriel : ajout d’informations sur les fichiers d'un dossier dans un fichier Excel
- Tutoriel : ajout de ses propres formules au Bloc-notes du projet
- Automatisation PowerPoint
- Automatisation des données
- Activités courantes
- Automatisation de l'espace de travail Google
- Automatisation OneDrive et SharePoint
L'interface UiPath StudioX contient plusieurs panneaux permettant d'accéder facilement à des fonctionnalités spécifiques. Les panneaux peuvent être définis comme étant fixes, flottants ou automatiquement masqués.
Accueil (mode Backstage)
This is the view you see when you first open StudioX. You can also get here by clicking Home in the upper-left corner of the Design View. You can access your projects, configure StudioX settings, or access help and license information. The following buttons and tabs are available in this view:
-
Open - Browse to an automation project and open it.
-
Close - Close the automation project that is currently open.
-
Save as - Save the automation project and create a copy of it in a different location. You can use this option to copy local automation projects to source control by selecting a repository as the location or convert a project into a template.
-
Start - Create a new task automation project or open recently accessed projects.
-
Templates - Create a new project based on a template. In this tab, you can view all available project templates, search and filter them by source. For more information, see Project Templates.
-
Team - Manage source control integration for the automation project.
-
Tools - Install the Excel Add-in, extensions for web browsers and other applications that allow StudioX to capture actions you perform in them, and the Repair Tool for Microsoft Office. For more information on extensions, see Extensions in the Installation and Upgrade Guide.
-
Settings - Change the look and feel of StudioX, set global preferences, and manage activities packages sources. For more information, see Configuring StudioX Settings.
-
Help - Directs you to product documentation, release notes, online resources, the Community Forum and the RPA Academy.
Les informations concernant la version et l'installation des produits, la disponibilité des licences, le canal de mise à jour et l'ID de périphérique sont également disponibles dans l'onglet Aide (Help), avec un bouton Copier les informations (Copy Info) pour copier rapidement les informations dans le Presse-papiers.
Mode de conception
C’est l'affichage où vous créez, exécutez et publiez votre projet d’automatisation.
Le Ruban
The ribbon at the top of the window can be minimized or expanded by clicking the Minimize / Expand button
. It contains the following buttons:
-
Save - Saves the automation project.
-
Couper/Copier/Coller - Utilisez ces boutons pour couper, copier ou coller les activités dans le panneau Concepteur.
-
Projet - Sélectionnez Paramètres du projet si vous souhaitez modifier le nom et la description du projet, les règles de l'analyseur de workflow ou les paramètres d’activités globales. Sélectionnez Ouvrir le dossier Projet pour ouvrir le dossier du projet dans l’explorateur de fichiers Windows.
-
Bloc-notes du projet - Ouvre le fichier Excel que vous avez défini comme Bloc-notes du projet pour le projet d’automatisation. Pour modifier ses paramètres, cliquez sur la flèche à côté de ce bouton et sélectionnez Configurer le Bloc-notes du projet.
-
Manage Packages - Opens the Manage Packages window where you can configure the activities packages and sources for the project.
-
Enregistreur d'application/Web - Ouvre l’enregistreur UiPath qui capture vos actions à l’écran et génère automatiquement une séquence d’activités basées sur ces actions. Pour plus d’informations, consultez Enregistreur d'application/Web.
-
Extraction de table - Ouvre l’assistant d'extraction qui vous permet d’extraire des données structurées à partir d’une application ou d’une page Web. Pour plus d’informations, voir Extraire des données de table.
-
Analyser - Recherche les erreurs de validation du projet et les violations des règles de l’analyseur de workflow. Les résultats sont affichés dans le panneau Liste d’erreurs. Pour modifier les paramètres de l’analyseur de workflow, cliquez sur la flèche à côté de ce bouton, puis sélectionnez Paramètres de l’analyseur de workflow.
-
Export to Excel - Exports the automation project to an Excel file.
-
Publish - Archives the project and all the other files in the project folder so that it can be sent to Robots and then executed.
-
Run - Executes the automation project.
Si vous souhaitez continuer votre travail sans être interrompu pendant l’exécution du projet, cliquez sur la flèche à côté de ce bouton, puis sélectionnez Exécuter en PiP. Le projet est exécuté dans une nouvelle session lancée dans une fenêtre flottante.
Remarque :Les fichiers non créés lors de l'exécution du projet d'automatisation passent en lecture seule lorsqu'ils sont publiés dans Orchestrator. Si votre processus métier requiert que vous écriviez dans un fichier spécifique à un certain moment, veillez à le créer tout en concevant le projet.
Ajouter une barre de recherche d'activité
Dans la barre de recherche Ajouter des activités (Add Activities), vous pouvez effectuer une recherche rapide dans les activités et les ajouter au projet d'automatisation.
Vous pouvez ouvrir la barre de recherche Ajouter une activité en cliquant sur l’icône Ajouter une activité
au-dessus/en dessous de toute activité ajoutée à votre projet ou en utilisant le raccourci clavier Ctrl + Shift + T.
La page est divisée en trois sections :
-
Un groupe d'activités suggérées qui sont prédites par une IA comme étant les plus susceptibles d'être ajoutées ensuite. Vous pouvez désactiver cette fonctionnalité en désélectionnant l'option Activer les suggestions d'activité AI (Enable AI activity suggestions) dans l'onglet Conception (Design) du menu Paramètres (Settings).
-
Common Scenarios lists different common activities and preconfigured pieces of automation based on where in the project workflow you clicked Add activity
. This gives you quick access to the most relevant results in every context. -
Activities lists all the activities in the installed packages.
Connectez-vous à votre compte
Si vous avez installé Studio avec le Robot en mode utilisateur ou si vous utilisez la Community Edition de Studio, vous pouvez connecter Studio et l’assistant avec Orchestrator en vous connectant à votre compte UiPath. Vous aurez ainsi accès aux ressources d'Orchestrator, vous pourrez activer votre produit et publier des projets vers Orchestrator.
- Cliquez sur
dans l'angle supérieur droit de la fenêtre Studio, puis sur Se connecter. Pour en savoir plus sur la connexion, cliquez sur En savoir plus.
-
Pour utiliser une URL personnalisée au lieu de l'URL par défaut
https://cloud.uipath.com, saisissez l'URL dans le champ URL du service. -
To connect to Orchestrator with your machine key, click Use Machine Key.
-
- Une nouvelle page s'ouvre dans votre navigateur Web. Terminez la procédure de connexion et, lorsque vous y êtes invité par votre navigateur Web, cliquez sur Ouvrir UiPath pour revenir à Studio.
Lorsque vous êtes connecté, une icône avec vos initiales s'affiche dans le coin supérieur droit de la fenêtre Studio. Pour vous déconnecter d'Orchestrator à la fois depuis Studio et l'Assistant, cliquez sur l'icône, puis sélectionnez Se déconnecter.
Connexion à Orchestrator avec votre clé de machine
Si vous avez installé Studio avec Robot enregistré en tant que service Windows, vous ne pouvez alors vous connecter à Orchestrator qu'avec votre clé de machine :
- Click
, and then click Connect. - Saisissez l'URL d'Orchestrator et la clé de machine, puis cliquez sur Continuer.
- Si vous souhaitez activer une clé de licence locale, cliquez sur Utiliser le code de licence.
Une fois Studio connecté à Orchestrator à l'aide de la clé de machine, vous pouvez vous connecter à votre compte :
-
Click
on the upper-right side of the Studio window, and then click *Sign in. -
Une nouvelle page s'ouvre dans votre navigateur Web. Terminez la procédure de connexion et, lorsque vous y êtes invité par votre navigateur Web, cliquez sur Ouvrir UiPath pour revenir à Studio.
Remarque :If you close the tab before the authentication is complete, it may take up to 10 seconds for the Sign in button in Studio to be enabled again.
Envoyer des commentaires
Il existe deux types de commentaires que vous pouvez envoyer directement depuis StudioX : Soumettre une idée ou Signaler un bogue. Les deux sont accessibles en cliquant sur
dans la barre de titre.
Dans la fenêtre Aidez-nous à nous améliorer, fournissez les informations suivantes, puis cliquez sur Envoyer :
- Dans le menu déroulant Je veux, choisissez soit Soumettre une idée pour le produit ou Signaler un bogue.
- Dans le menu déroulant Pour, sélectionnez le produit pour lequel envoyer un commentaire. StudioX est sélectionné par défaut.
- Dans le champ À quel point est-ce important pour vous, sélectionnez Bon à avoir, Important ou Critique.
- Dans le champ Objet, entrez l'objet du message.
- Dans le champ Étapes à reproduire/Description, entrez une description détaillée.
- Cliquez sur Ajouter pour joindre des fichiers. Vous pouvez joindre jusqu’à 6 images, vidéos ou fichiers texte d'une taille inférieure à 10 Mo.
Veuillez noter que vous ne pouvez pas envoyer plus de 3 messages dans un laps de temps de 5 minutes.
The Activities panel and the Add Activity search bar support fuzzy search, which means that a list of results is returned even if the search terms don't match exactly. The search terms could be slightly incomplete, misspelled or include only the first letter of each word.
Le module Designer
Le panneau Concepteur est la toile sur laquelle vous créez votre automatisation. C’est là que vous ajoutez les activités que vous souhaitez automatiser, visualiser et dont vous souhaitez modifier les propriétés. Vous définissez également le workflow en organisant les activités. Votre projet d’automatisation est représenté par un diagramme qui vous donne une représentation visuelle de la séquence d’activités qu’il contient.
Vous pouvez ajouter des activités du panneau Activités en double-cliquant dessus, en les faisant glisser et en les déposant ou en cliquant sur le bouton Ajouter une activité
au-dessus et en dessous d’une activité déjà ajoutée, puis en les sélectionnant à partir de la barre de recherche Ajouter une activité. Pour chaque activité ajoutée au panneau s’affichent des détails la concernant (nom, propriétés d’activité clés, boutons et liens) pour vous aider à la configurer, ou une capture d’écran informative. Pour vous aider à identifier différents types d’activités, la bordure gauche de chaque activité est de la couleur de l’application à laquelle elle s’applique. Par exemple, les activités Excel ont une bordure gauche verte, tandis que les activités E-mail ont une bordure gauche bleue.
Activez le Mode panoramique en cliquant sur l'icône
, en maintenant la touche Espace enfoncée ou en appuyant sur le bouton central de la souris. Utilisez la liste déroulante de Zoom pour modifier le niveau de Zoom et cliquez sur l'icône
pour le réinitialiser à 100 %.
L'icône Ajuster à l'écran
modifie le Zoom de manière à ce que le workflow entier s'intègre dans le panneau Concepteur. Cliquez sur l'
icône pour obtenir un aperçu de l'ensemble du projet et parcourir les sections en ajustant le focus.
Le menu contextuel
Le menu contextuel vous permet d'effectuer plusieurs opérations sur les activités de votre projet. Vous pouvez afficher ce menu en cliquant avec le bouton droit de la souris sur n'importe quelle activité dans votre projet.
Description des champs du menu contextuel
| Option | Description |
|---|---|
|
Renommer |
Modifie le nom de l'activité. |
|
Ouvrir |
Ouvre l’activité sélectionnée dans le panneau Concepteur. |
|
Réduire |
Permet de réduire l'activité en diminuant les détails affichés pour « Double-cliquer pour afficher ». Le même résultat est obtenu en cliquant sur le bouton Réduire (Collapse) |
|
Développer sur place |
Cette option permet de développer le contenu de l’activité en affichant son contenu détaillé. Le même résultat est obtenu en cliquant sur le bouton Développer (Expand) |
|
Couper |
Retire l'activité sélectionnée et la place dans le Presse-papiers. |
|
Copier |
Copie l'activité sélectionnée et la place dans le Presse-papiers. |
|
Coller |
Insère le contenu du Presse-papiers à l'emplacement actuel. |
|
Supprimer (Delete) |
Supprime l'activité cible. |
|
Annotations |
Ajoutez, modifiez, supprimez et masquez des annotations ajoutées aux activités dans le workflow. |
|
Copier en tant qu'image |
Cette option permet de faire une capture d'écran du contenu du module Concepteur (Designer). |
|
Enregistrer en tant qu'image |
Cette option permet de faire une capture d'écran du contenu du module Concepteur (Designer) et de l'enregistrer (en renseignant un Nom, un Type et une Destination). Les formats pris en charge sont : JPG, PNG, GIF et XPS. |
|
Activer l'activité |
Réactiver une activité qui a été désactivée. |
|
Désactiver l'activité |
Désactive une activité qui est alors grisée et placée à l’intérieur d’une activité Commenter. |
|
Effectuer un zoom ici |
Naviguez dans le diagramme pour afficher uniquement cette activité. Le chemin d'accès apparaît en fil d'Ariane dans l’en-tête du panneau Concepteur. |
|
Zoom arrière |
Permet de voir l’ensemble du diagramme du projet dans le panneau Concepteur. |
|
Accéder à cette activité |
Exécute le projet dès le démarrage et s’arrête après l’exécution de cette activité. |
|
Exécuter à partir de cette activité |
Exécute le projet en commençant par cette activité. |
|
Aide |
Ouvre la page d'aide sur le type d'activité dans le guide Activités (Activities). |
Le module Activités
Le panneau Activités (Activities) affiche les activités disponibles qui peuvent être ajoutées au projet actuel. Vous pouvez rechercher des activités par nom ou description à l'aide de la zone de recherche en haut du panneau. Pour ajouter une activité à votre automatisation, double-cliquez dessus ou faites-la glisser et déposez-la à l'endroit souhaité dans le panneau Concepteur (Designer).
Le survol d'une activité dans le panneau affiche le package auquel il appartient et sa description. Pour ajouter une activité à la liste des favoris, faites un clic droit et sélectionnez Ajouter aux favoris.
Personnalisation du panneau Activités
Click the View Options
button at the top of the panel to open a menu that allows you to customize the panel. See the following table for a list of available options.
| Option | Description |
|---|---|
| Afficher les favoris | Affiche une section contenant vos activités préférées. Cette option est activée par défaut. |
| Afficher les éléments récents | Affiche une section avec les dix activités les plus récemment utilisées. Cette option est désactivée par défaut. |
| Afficher les catégories | Regroupe les activités selon la catégorie à laquelle elles appartiennent. Cette option est activée par défaut. |
| Grouper par paquets | Regroupe les activités selon le package auquel elles appartiennent. Cette option est désactivée par défaut. |
| Épingler les favoris | Lorsqu'une recherche est effectuée dans le panneau, les activités favorites restent toujours visibles. Disponible si Afficher les favoris (Show Favorites) est sélectionné. Cette option est désactivée par défaut. |
| Afficher le développeur | Affiche les activités conçues pour le profil Studio. Cette option est désactivée par défaut. Ces activités peuvent ne pas fonctionner comme prévu dans le profil StudioX. |
Par exemple, si vous essayez d'afficher toutes les activités Excel, vous pouvez sélectionner Grouper par packages (Group by Packages) et désélectionner Afficher les catégories (Show Categories).
Le panneau du gestionnaire de données
The Data Manager panel displays data currently added to your automation project. This data includes:
-
Ressources ajoutées au projet : fichiers Excel (y compris le bloc-notes du projet), comptes e-mail, documents Word, présentations PowerPoint, applications et navigateurs.
- Pour aller à l’activité où une ressource est définie, double-cliquez sur l’entrée dans le Data Manager.
- Pour ouvrir un fichier ajouté à l’automatisation ou au dossier contenant le fichier, cliquez-droit sur une ressource de fichier Excel ou Word, puis sélectionnez Ouvrir ou Ouvrir l'emplacement du fichier. Cette option n'est pas disponible lorsque vous travaillez avec des fichiers distants (par exemple Sharepoint).
- For information about managing Excel resources from the Data Manager, see Excel Automation.
-
Valeurs de sortie que vous avez enregistrées pour une utilisation ultérieure dans le projet.
- Pour renommer une valeur enregistrée, cliquez-droit sur cette valeur et sélectionnez Renommer la valeur enregistrée.
- Pour aller à l’activité où une valeur a été enregistrée, double-cliquez sur la valeur enregistrée.
-
Mappings de valeur créés pour une utilisation dans les sélecteurs d’activités Application/Web.
- Pour modifier une variable, cliquez-droit et sélectionnez Ouvrir les mappings de valeurs.
- Pour aller à l’activité où une valeur a été enregistrée, double-cliquez sur la variable.
-
File arguments used in the automation. To create and manage arguments, click the Arguments
button. Read more about Arguments in the Automation Basics guide.
Le module Propriétés
Le panneau Propriétés est contextuel et vous permet d’afficher et de modifier les propriétés avancées de l’activité sélectionnée. Lorsque vous sélectionnez plusieurs activités vous pouvez modifier uniquement les propriétés communes dans le panneau Propriétés.
Le panneau Propriétés est masqué par défaut. Dans la plupart des situations, vous pouvez configurer des activités en utilisant les options disponibles dans le panneau Concepteur.
Le module Sortie
The Output panel enables you to display the output of the Write Line activity, displays status information regarding the execution of your projects, and errors generated by activities packages.
From the Output panel, you can show or hide messages that have different log levels (errors, warnings), or export the contents of the panel to a text file by clicking the buttons in the panel’s header. Double-clicking a message displays further details about it, with the option to copy information.
Le bouton Tout effacer (Clear All) efface toutes les informations s'affichant dans le panneau Sortie (Output). Les journaux et autres données stockées dans ce panneau sont effacés lors de l'exécution d'un workflow. Le panneau Sortie (Output) affiche un maximum de 2 000 lignes à la fois.
The Error List panel next to the Output panel displays errors found in the project during validation and workflow analysis. For more information, see About Workflow Analyzer.
Panneau Ressources (Resources)
The Resources panel can load assets, queues and processes, provided that the Robot is connected to Orchestrator. Read the Connecting Robots to Orchestrator page to find the steps.
Si le Robot connecté à Orchestrator est de type standard (Standard), le panneau Ressources (Resources) ne peut afficher que le dossier classique dans lequel ce Robot est enregistré.
If the Robot is of type Floating, then the panel displays all Classic and Modern folders that this Robot has access to. Read more about creating Robots in Orchestrator here.
The panel displays resources such as assets, queues, and processes found in Classic or Modern Folders in Orchestrator. Read more about folders.
- When using a classic, manually provisioned robot, it must be granted
Viewpermissions for the corresponding resources (i.e. Assets, Queues, and Processes) to appear in the panel. Read more about setting up Roles and permissions in Orchestrator. - S’il y a des dossiers classiques et modernes dans Orchestrator et que vous êtes connecté à Orchestrator à l’aide d’un Robot à partir d’un dossier moderne (vous vous êtes connecté à votre compte ou vous vous êtes connecté à l’aide d’une clé de modèle de machine), les processus dans les dossiers classiques ne sont pas disponibles dans le panneau Ressources (Resources). Pour avoir accès aux processus depuis un dossier classique, connectez-vous à Orchestrator en utilisant un Robot classique avec une connexion par clé de machine standard.
Pour charger des ressources dans le panneau, cliquez sur le bouton Actualiser en haut du panneau Ressources. Cliquez avec le bouton droit sur n'importe quel élément du panneau Ressources pour copier son nom et l'utiliser dans les activités qui interagissent avec ces ressources.
Survolez le nom du dossier dans la barre d'état pour voir l'URL d'Orchestrator, puis cliquez sur le nom du dossier dans la barre d'état pour basculer vers un autre dossier.
La barre d’état
Dans la barre de statut, vous pouvez afficher les informations de statut et les options d'accès liées à Orchestrator. C'est ici que vous pouvez également voir quelle langue est utilisée pour les expressions dans le projet (VB ou C#).
- Connexion à Orchestrator/au Cloud (Orchestrator/Cloud Connection) - Cliquez sur
pour accéder aux options Orchestrator : connectez-vous à votre compte cloud, déconnectez-vous d’Orchestrator (si vous êtes connecté à une clé machine) et actualisez les ressources. - Statut d'Orchestrator - Affiche le statut de connexion d'Orchestrator. Lorsqu’il est connecté à Orchestrator, le dossier actuellement sélectionné s’affiche. Vous pouvez cliquer sur le nom du dossier actuel pour afficher une liste de dossiers disponibles et sélectionner un autre dossier à partir duquel synchroniser les ressources.
Raccourcis clavier
Voici la liste complète des raccourcis clavier de l’UiPath StudioX :
Gestion de fichiers
Ctrl + Shift + N - Crée une nouvelle Tâche vierge.
Ctrl + C - Copie une activité du panneau Concepteur dans le presse-papiers. Utilisez Ctrl + V pour la coller n’importe où dans le panneau Concepteur.
Ctrl + O - Permet d’ouvrir une tâche créée précédemment, le fichier .xaml ou le fichier project.json.
Ctrl + L ouvre le dossier ou sont enregistrés les journaux d'événements.
Ctrl + S - Enregistre le projet ouvert.
Ctrl + V - Colle une activité précédemment copiée dans le presse-papiers dans le panneau Concepteur.
Ctrl + Tab/Alt + F7 – Déplace le focus entre les fichiers/panneaux de workflow. Lorsque vous maintenez la touche de modification enfoncée (Ctrl ou Alt respectivement), la fenêtre suivante apparaît, vous permettant ainsi de basculer entre les fichiers et les panneaux actifs.
Rechercher
F3 ou Ctrl + Maj + P : ouvre la Palette de commandes (Command Palette).
Ctrl + Shift + T - Ouvre la barre de recherche Scénarios et activités courants.
Ctrl + J (Ctrl + J) : ouvre la barre de recherche Accéder à l'activité (Jump to activity).
Ctrl + Alt + A : ouvre et active le panneau Propriétés (Properties).
Ctrl + Alt + F : définit le focus sur la zone de recherche dans le panneau Activités (Activities).
Tab : accède à l'élément suivant du panneau ou de l'activité.
Commentaire (Comment)
Ctrl + D insère l'activité sélectionnée dans un Commentaire (Comment Out) pour la rendre invisible.
Ctrl + E supprime le Commentaire (Comment Out) pour rendre l'activité visible.
Débogage
Ctrl + Alt + E - Ouvre le panneau Liste d’erreurs (Error List).
Enregistrement
F2 permet de stopper temporairement l'enregistrement en cours.
Analyse et exécution de workflows
F5 - Exécute le projet en cours.
F6 : permet d'exécuter le projet actuel en mode Incrustation d’image .
F7 : recherche les erreurs de validation dans le fichier et les violations de l'analyseur de workflow (Workflow Analyzer).
Maj + F7 : recherche les erreurs de validation dans l'ensemble du projet et les violations de l'analyseur de workflow (Workflow Analyzer).
F8 - Vérifie que le fichier ne contient pas d'erreur de validation.
Maj + F8 : recherche les erreurs de validation dans tous les fichiers projet.
F12 permet d'arrêter l'exécution du flux de travail (qu'elle soit en mode normal ou en mode débogage).
Activité sélectionnée
Ctrl + C permet de copier la ou les activité(s) sélectionnée(s) vers le presse-papiers.
Ctrl + V permet de coller la ou les activité(s) copiée(s) dans l'élément sélectionné.
Ctrl + Space - Ouvre la fenêtre IntelliPrompt dans l’éditeur d’expressions.
Ctrl + 1 ... Ctrl + 6 – Lorsque la fenêtre IntelliPrompt est ouverte, active/désactive l’affichage de chaque type d’élément dans la fenêtre de saisie de code, de la même manière qu’en utilisant les boutons en bas de la fenêtre : Ctrl + 1 Méthodes (Methods), Ctrl + 2 Propriétés (Properties), Ctrl + 3 Classes (Classes), Ctrl + 4 Espaces de noms (Namespaces), Ctrl + 5 Constantes (Constants), Ctrl + 6 Mots-clés (Keywords).
F2 : permet de renommer l'activité sélectionnée.
Maj + F2 : ajoute une annotation à une activité sélectionnée.
Maj + Tab : accède à l'activité ou au nœud précédent dans le panneau Activités (Activities).
Barre d’état
Alt + D - Accédez aux menus Contrôle de code source, Dossiers Orchestrator et Connexion Orchestrator/Cloud dans la barre d'état, puis utilisez Maj + Tab pour parcourir les menus. Une fois qu'un menu est sélectionné, appuyez sur Entrée pour l'ouvrir.
Divers
F1 permet d'ouvrir la rubrique d'aide correspondant à l'élément sélectionné.
Ctrl + P ouvre la fenêtre de Gestion des paquets (Manage Packages).
Échap : ferme les fenêtres Publier (Publish), Gérer les paquets (Manage Packages), Diff de fichiers (File Diff).
Ctrl + F1 : réduit et développe le ruban.
Ctrl + Alt + D - Passe de l’onglet Conception (Design) au bouton Enregistrer (Save).
Alt + - – Ouvre le menu contextuel Options dans la barre de titre du panneau actuellement sélectionné. Pour cela, utilisez la touche du trait d’union qui se trouve au-dessus des touches des caractères, pas la touche moins du pavé numérique.
Touches de raccourci du ruban et de l'onglet Accueil
Vous pouvez rapidement accéder à la plupart des options de l’onglet Accueil (Home) (mode Backstage de StudioX Backstage) et des rubans des onglets Conception (Design) et en appuyant sur la clé Alt et en la relâchant, puis en appuyant sur une ou plusieurs touches.
Lorsque vous appuyez sur la touche Alt et que vous la relâchez, une ou plusieurs lettres ou chiffres apparaissent au-dessus des options dans la vue actuelle. Pour utiliser une option, appuyez sur la clé ou les touches correspondantes. Pour certaines options, des touches supplémentaires sont disponibles après avoir appuyé sur la combinaison de touches initiale.
Pour consulter la liste de raccourcis, voir les sections suivantes.
Clés du ruban de l'onglet Design
Si vous êtes dans l’onglet Conception (Design), appuyez sur Alt + D pour accéder aux touches de raccourci du ruban de l’onglet Design.
| Clé(s) | Action effectuée | Clés et actions supplémentaires |
|---|---|---|
| S | Enregistre le projet. | – |
| R | Ouvre la liste déroulante Exécuter (Run) | F5 - Exécuter (Run) F6 - Exécuter en PiP (Run in PiP) |
| C | Copie les activités sélectionnées | – |
| X | Coupe les activités sélectionnées | |
| V | Colle les activités copiées | – |
| MP | Ouvre la fenêtre Gérer les packages (Manage Packages) | – |
| A | Ouvre la liste déroulante Analyser le fichier (Analyse File) | A - Analyser (Analyze) D - Valider (Validate) S - Paramètres de l'analyseur de workflows |
| EX | Ouvre la fenêtre Exporter vers Excel (Export to Excel) | – |
| p | Ouvre la fenêtre Publier (Publish) | – |
Clés de l'onglet Accueil
Si vous êtes dans l’onglet Conception (Design) ou l’onglet Débogage (Debug), appuyez sur Alt+H pour ouvrir l’onglet Accueil (mode Backstage de Studio) et accéder aux touches de raccourci de l’onglet Accueil. Si vous êtes déjà dans l’onglet Accueil, vous n'avez qu'à appuyer sur la clé Alt.
| Clé(s) | Action effectuée | Clés et actions supplémentaires |
|---|---|---|
| Z | Ramène à l’onglet précédent, si un projet est ouvert | – |
| O | Ouvre un projet | – |
| C | Ferme le projet actuellement ouvert | – |
| S | Ouvre l’onglet Démarrer (Start) | O - Ouvre un projet local B - Créer une tâche vierge (Create a Blank Task) T - Crée un modèle (Create a Template) 1...9 - Ouvre l’un des neuf projets les plus récents |
| T | Ouvrez l’onglet Modèles (Templates) | – |
| L | Ouvre l’onglet Outils (Tools) | U - Ouvre l’UI Explorer R - Ouvre l’Outil de réparation pour Microsoft Office (Repair Tool for Microsoft Office) C - Installe l’extension Chrome F - Installe l'extension Firefox E - Installe l'extension Edge J - Installe l'extension Java S - Installe l'extension Silverlight T - Installe l'extension Citrix W - Installe l'extension Bureau à distance Windows V - Installe l’extension VMware Horizon X - Installer l’extension du complément Excel. |
| E | Ouvre l’onglet Paramètres (Settings) | G - Ouvre l’onglet Général D - Ouvre l’onglet Design L - Ouvre l’onglet Emplacements (Locations) M - Ouvre l’onglet Gérer des sources (Manage Sources) P - Ouvre l’onglet Licence et Profil (License and Profile) |
| H | Ouvre l’onglet Aide (Help) | D - Ouvre le lien Documentation du produit (Product Documentation) F - Ouvre le lien du Forum de la communauté M - Ouvrir le lien du Centre d’aide A - Ouvre le lien de l'Académie R - Ouvre le lien des Notes de publication (Release Notes) S - Ouvre le lien vers Répondez à une courte enquête (Take a short survey) C - Copie les informations de licence |
- Accueil (mode Backstage)
- Mode de conception
- Le Ruban
- Ajouter une barre de recherche d'activité
- Connectez-vous à votre compte
- Envoyer des commentaires
- Le module Designer
- Le menu contextuel
- Le module Activités
- Le panneau du gestionnaire de données
- Le module Propriétés
- Le module Sortie
- Panneau Ressources (Resources)
- La barre d’état
- Raccourcis clavier
- Gestion de fichiers
- Rechercher
- Commentaire (Comment)
- Débogage
- Enregistrement
- Analyse et exécution de workflows
- Activité sélectionnée
- Barre d’état
- Divers
- Touches de raccourci du ruban et de l'onglet Accueil
.
.