通知を受け取る

UiPath 製品のインストールとアップグレード

UiPath 製品のインストールとアップグレード ガイド

ハードウェアおよびソフトウェアの要件

🚧

重要

Please note that this is a change from our HW/SW specs from Insights 2021.10. Insights 2021.10 requires a single Windows machine, while Insights 2022.4 requires a Windows machine and a Linux machine with RHEL 8.2-8.5.

Click to expand this section

In 2021.10, the Insights Windows machine ran Docker which hosted the Looker Linux container. Starting with 2022, the driver used to nest the Linux containers in Windows OS (called lcow) is not supported anymore by Microsoft for enterprise applications. As a result, we had to change our deployment architecture to require 2 machines - one Windows machine to run the UiPath Insights components, and a Linux machine to run the Looker container. With this change, enterprise support is available from OS vendors for the components needed to run UiPath products. The supported versions of Linux OS are the same that Automation Suite supports.

ハードウェア要件

These requirements are only applicable to the machine where Insights is installed.

Insights Windows Machine

🚧

重要

Insights must be installed on its own machine; it cannot be co-hosted with Orchestrator.

CPU (cores)

System Memory (GB)

Available Storage (GB)

Examples

Minimum Hardware

2

8

32

AWS t2.large or Azure D2s_v3

Recommended Hardware

4

16

32

AWS t2.xlarge or Azure D4s_v3

Insights Linux Machine

The following table lists the hardware requirements for hosting the Insights Linux Machine.

CPU (cores)

System Memory (GB)

Storage (GB)

Example

Minimum Hardware

4

16

32

AWS t2.xlarge or Azure D4s_v3

ポート

Make sure the following ports are externally accessible and no other service uses these ports:

Inbound Ports

Machine

543

Note: This is the default port, and you can change it to any available port

Insights Windows Machine

9999
Note: This is the Looker port.

Insights Linux Machine

19999
Note: This is the Looker API port.

Insights Linux Machine

29999
Note: This is the LookML update port.

Insights Linux Machine

📘

注:

Make sure that the hostnames for both the Insights Windows Machine and the Insights Linux Machine are resolvable within your DNS.

SQL Requirements

📘

注:

For best performance, consider hosting the Insights database on a dedicated machine. If you currently have a Small-Scale deployment or are evaluating Insights, you might have both Orchestrator and Insights databases on the same machine. If you start noticing performance issues, you can move the Insights database to a dedicated machine.

Small Scale Up to 1M Rows

Medium Scale Up to 20M Rows

Large Scale Up to 200M Rows

CPU

4 Cores

8 Cores

16 Cores

System Memory

16 GB

32 GB

64 GB

Data Disk

40 GB

100 GB

1 TB

ソフトウェア要件

🚧

重要

Your Orchestrator and Insights products must be of the same version (e.g., v2022.4.0).

オペレーティング システム

Software

Compatible Version

Windows Machine

2019

Red Hat Enterprise Linux

8.2 - 8.5

データベース

Software

Compatible Version

SQL Machine

2019

📘

注:

  • Insights では、SQL Server が列ストア インデックスと .json 機能をサポートしている必要があります。

  • Azure SQL の場合、データベースが S3 層以上であることを確認してください。

  • Make sure the compatibility level for Insights database is set to 150 or higher ("SELECT compatibility_level from sys.databases WHERE name = '{dbName}'). In most cases, the default settings meet this requirement. For more information, refer to View or Change the Compatibility level of a Database - SQL Server.

Web サーバー

Software

Compatible Version

IIS

10+

フレームワーク

📘

注:

IIS のインストール後にホスティング バンドルをインストールするようにしてください。

Software

Compatible Version

.NET Hosting Bundle 3.1

3.1.17+

Note: Available here as part of the Hosting Bundle. To download it, make sure you click Hosting Bundle.

セキュリティ プロトコル

Software

Compatible Version

TLS

1.1 or 1.2

Web ブラウザー

For users viewing Insights, the supported web browsers are captured below:

Software

Compatible Version

Chrome

50.0+

Firefox

69.0.1+
Note: Not supported in Private Browsing mode.

Edge (Chromium)

50.0+

1 日前に更新


ハードウェアおよびソフトウェアの要件


改善の提案は、API リファレンスのページでは制限されています

改善を提案できるのは Markdown の本文コンテンツのみであり、API 仕様に行うことはできません。