机器人
2022.10
False
横幅背景图像
机器人用户指南
上次更新日期 2024年2月8日

活动找不到 .NET Runtime

观察到的行为

在 2023.4.0 和更高版本的机器人上运行时,使用特定活动包的工作流将失败,并出现以下错误之一:
  • "To run this application, you must install missing frameworks for .NET."
  • "To run this application, you must install .NET."

以下活动包会受到影响:

  • UiPath.Form.Activities 版本 2.0.x
  • UiPath.Intelligent OCR.Activities
  • UiPath.MobileAutomation.Activities
  • UiPath.Vision
  • UiPath.DocumentUnderstanding.Activities
  • UiPath.UIAutomation.Activities 包中与 OCR 相关的活动
  • UiPath.OmniPage.Activities
  • UiPath.OCR.activities

解析 A

将受影响工作流的活动包升级到以下版本:

  • UiPath.Form.Activities 2.0.x -> 2.0.7
  • UiPath.IntelligentOCR.Activities -> 6.9.1
  • UiPath.MobileAutomation.Activities -> 23.4.0
  • UiPath.Vision -> 3.10.1
  • UiPath.DocumentUnderstanding.Activities ->2.2.2
  • OCR related usage from UiPath.UIAutomation.Activities fixed in ->23.4.5
  • UiPath.OmniPage.Activities -> 1.15.0
  • UiPath.OCR.activities -> 3.15.1

解析 B

使用以下语句在受影响的工作流的开头添加“调用代码”活动:“System.Environment.SetEnvironmentVariable("DOTNET_ROOT", System.AppContext.BaseDirectory)”。

解析 C

在计算机上安装 .NET Windows 运行时或缺少的 .NET 框架。
  • 观察到的行为
  • 解析 A
  • 解析 B
  • 解析 C

此页面是否有帮助?

获取您需要的帮助
了解 RPA - 自动化课程
UiPath Community 论坛
Uipath 白色徽标
信任与安全
© 2005-2024 UiPath. All rights reserved.