Subscribe

UiPath Orchestrator

The UiPath Orchestrator Guide

Software Requirements

Server OS

Software

Compatible Versions

Windows Server

2008 R2 SP1
2012 R2
2016
2019

Databases

Software

Compatible Versions

SQL Server

2008 R2 Standard or Enterprise Edition
2012 Standard or Enterprise Edition
2014 Standard or Enterprise Edition
2016 Standard or Enterprise Edition
2017 Standard or Enterprise Edition
2019 Standard or Enterprise Edition

UiPath High Availability Add-on

All Versions

Note: Required only for supported HA installations.

🚧

Important!

Multi-node Orchestrator deployments use the RESP (REdis Serialization Protocol) for communication, and thus can be configured using any solution relying on this protocol.
HAA is the only such solution supported by UiPath.
Full support is provided to users of Redis Enterprise with the purchase of a HAA module.

Logging & Visualization

📘

Note:

The below software is not explicitly required, but is recommended for logging & visualization purposes.

Software

Compatible Versions

Elasticsearch

6.x - 7.6.2

Before proceeding, please check the official Elasticsearch end of life dates, and support matrix.

Kibana

6.x - 7.6.2

Browsers

Software

Compatible Versions

Google Chrome

50+

Firefox

69.0.1+
Not supported in Private Browsing mode.

Internet Explorer

11
The Enterprise Mode needs to be turned off in Internet Explorer. Details on this page.

Microsoft Edge

20+

Deployment

Software

Compatible Versions

WebDeploy

3.5+
64bit version

Please note that this is required only for PowerShell script installations, such as the Azure one.

Software Frameworks

Software

Compatible Versions

.NET Framework

4.7.2+

Web Servers

Software

Compatible Versions

IIS

7.5+

IIS Modules - URL Rewrite

2.0+

Virtualization Platforms

📘

Note

Any platform that can create a Windows Virtual Machine can be used as well.

Software

Compatible Versions

Citrix XenDesktop

7.6+

Oracle VirtualBox

5.0+

Microsoft Hyper-V

VMWare

Credential Stores

📘

Note:

The below items are not required for use of Orchestrator, but optional integrations.

Software

Compatible Versions

Dependencies

CyberArk®

Credential Provider 10.5

Digital Vault version 7.x and later
Application Password SDK 5.5, 6.0, 7.0 - 7.2, 9.5, 10.5

Azure Key Vault

📘

Note:

For additional details on the CyberArk® Credential Provider system requirements, refer to CyberArk® documentation.

If you are using another credential store via a plugin in Orchestrator you must verify that you meet all the dependencies and requirements of the respective plugin.

Check out software requirements for Studio and Robot.

Updated 10 months ago


Software Requirements


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.