UiPath Orchestrator

Software Requirements

Server OS

Software
Compatible Versions

Windows Server

  • 2008 R2 SP1
  • 2012 R2
  • 2016
  • 2019

Databases

Software
Compatible Versions

SQL Server

  • 2008 R2 Standard or Enterprise Edition
  • 2012 Standard or Enterprise Edition
  • 2014 Standard or Enterprise Edition
  • 2016 Standard or Enterprise Edition
  • 2017 Standard or Enterprise Edition

Redis Enterprise

  • 5.2 - 5.4

Redis (on Linux)

  • 3.0.7 - 5.0.4

Redis (on Windows)

  • 3.0.504
    Redis on Windows is possible but not recommended. It has not been updated since July 2016, and it is not supported by either Redis or RedisLabs.

Logging & Visualization

Note

The below software is not explicitly required, but is recommended for logging & visualization purposes. Keep in mind that both products used must be the same version.

Software
Compatible Versions

Elasticsearch

  • 2.3 - 6.x
    Elasticsearch doesn't provide support for 2.x versions.
    Before proceeding, please check the official Elasticsearch end of life dates, and support matrix.

Kibana

  • 4.0 - 6.x

Browsers

Software
Compatible Versions

Google Chrome

  • 50+

Internet Explorer

  • 11
    The Enterprise Mode needs to be turned off in Internet Explorer. Details on this page.

Microsoft Edge

  • 20+

Deployment

Software
Compatible Versions

WebDeploy

  • 3.5+
    64bit version

Please note that this is required only for PowerShell script installations, such as the Azure one.

Software Frameworks

Software
Compatible Versions

.NET Framework

  • 4.6.1+

Web Servers

Software
Compatible Versions

IIS

  • 7.5+
  • IIS Modules - URL Rewrite
  • 2.0+

Virtualization Platforms

Note

Any platform that can create a Windows Virtual Machine can be used as well.

Software
Compatible Versions

Citrix XenDesktop

  • 7.6+

Oracle VirtualBox

  • 5.0+

Microsoft Hyper-V

VMWare

Credential Stores

Software
Compatible Versions
Dependencies

CyberArk®

  • Credential Provider 10.5
  • Digital Vault 7.x - 10.x
  • Application Password SDK 5.5, 6.0, 7.0 - 7.2, 9.5, 10.5

Check out software requirements for Studio and Robot.

Updated 2 months ago



Software Requirements


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.