- 基本情報
- インストールとアップグレード
- ロボットの種類
- Robot のコンポーネント
- ライセンス
- Robot を Orchestrator に接続する
- プロセスとアクティビティ
- ログ
- 特定のシナリオ
- ガバナンス
- トラブルシューティング

Robot 管理ガイド
現象
大量のデータを使用するプロセス (例:2500 行を超える Excel ファイルなど) を実行すると、以下のエラーで失敗することがあります。
Message: Could not retrieve the result of the job execution. This might be because a message was too large to process.
Exception Type: System.ExceptionMessage: Could not retrieve the result of the job execution. This might be because a message was too large to process.
Exception Type: System.Exception原因
uipath.config ファイルの maxMessageSizeInMegabytes パラメーターの最大設定値を超えています。
このパラメーターの既定値は 10 MB です。
uipath.config ファイルにアクセスするには、UiPath コンポーネントのインストール フォルダーに移動します。場所はデプロイの種類によって異なります。
- Robot が
.exeインストーラーを使用してユーザー モードでインストールされていれば、ユーザー プロファイル フォルダーC:\Users\{{user}}\AppData\Local\UiPath\uipath.configにuipath.configがあります。 - Robot がサービス モードでインストールされていれば、インストール フォルダーに
uipath.configがあります。既定のパスを使用して Robot がインストールされている場合は、C:\Program Files\UiPath\Studio\uipath.configにuipath.configファイルがあります。
解決策
uipath.config ファイル内の maxMessageSizeInMegabytes パラメーターの値を 50 MB などの大きな値に増やします。
現象
click、type into、take screenshot など) を使用した無人プロセスは機能しません。
原因
サーバー マネージャーなどの、スタートアップ時に起動するよう設定された、Windows ユーザー アカウント制御のプロンプトを表示するプログラムでは、Robot による UI の操作はすべてブロックされます。これは、ユーザー アカウント制御のプロンプトが、Robot がアクセスできない別の Windows デスクトップで開いているためです。
解決方法
UAC プロンプトを表示するプログラムを手動またはプログラムで検索し、UAC を回避するために、自動的に開始しないよう設定します。
現象
このシナリオでは、Robot はプロセスの実行を開始できず、次のエラーをスローします。
Executor start process failed, reason
System.Runtime.InteropServices.COMException: A specified logon session does not
exist. It may already have been terminated.
原因 A
ロボット端末に十分なリソース (CPU、RAM、ディスクスペースなど) がないため、Robot Executor がプロセスを開始できません。
解決策 A
次を確認または実行します。
- ロボット端末に十分なリソース (CPU、RAM、ディスク スペースなど) があることを確認します。
mstscコマンド ライン機能を使用して接続時間が 61 秒以上であることを確認します。60 秒以下の場合はエラーが表示されます。
原因 B
ログオン セッションを作成できません。これは、次の状況で発生する可能性があります。
- 高密度ロボットの [コンソールへログイン] が true に設定されています。この場合、Robot サービスは現在のコンソール セッションにアタッチします。一度にアクティブにできるコンソール セッションは 1 つのみであるため、高密度ロボットには推奨されません。
- スタンドアロンの Windows (サーバーではない) で複数の RDP セッションを使用しています。スタンドアロンの Windows は、マシンごとに一度に 1 つの RDP セッションしか処理できませんが、Windows Server は複数の RDP セッションを処理できます。
解決策 B
この場合、次のいずれかを実行する必要があります。
- [コンソールへログイン] が [false] に設定されています。これは、Robot サービスがロボット端末からそれ自体への RDP 接続を開始し、アタッチすることを意味します。これは、高密度ロボットに推奨される方法です。
- Windows のバージョンを確認してください。Windows Server である必要があります。詳しくは「高密度ロボット用の Windows Server を設定する」をご覧ください。
- 使用している Studio/Robot のバージョンが v2018.1.3 以降か確認します。このバージョンでは、KB4088876 (Windows 8.1 または Windows Server 2012 R2 Standard)、KB4088875 (Windows Server 2008 R2 SP1、Windows 7 SP1)、KB4088787 (Windows Server 2016、Windows 10 バージョン 1607)、および KB4088776 (Windows 10 バージョン 1709) Windows 更新プログラムによって発生した問題が修正されています。詳しくは、「ソフトウェア要件」をご覧ください。
- サーバーのシステム環境変数である
UIPATH_SESSION_TIMEOUTの値を増やします。既定値は 60 秒ですが、パフォーマンスが低い一部のマシンでは不十分な場合があります。環境変数は秒単位で設定されており、この変数を変更した後は Robot サービスを再起動する必要があります。 - サーバーでリモート デスクトップ ライセンスがアクティブになっているかどうかを確認します。詳細については、こちらのページをご覧ください。
- Robot が適切なグループに属しているかどうかを確認します。ローカル ユーザーは同じリモート デスクトップ グループに属している必要があります。
- ロボット端末への RDP 接続のユーザー名が、構成済みのユーザー名と一致しているかを確認します。このエラーを回避するには、ロボット端末上のすべての RDP 接続をサインオフします。
現象
パスワード フィールドに入力せずに Orchestrator でロボットを作成すると、プロセスの実行を開始できなくなります。また、ロボット端末の権限を変更した場合にもこの問題が発生する可能性があります。
Orchestrator または UiPath Assistant からプロセスを開始すると、次のエラー メッセージが表示されます。
Executor start process failed, reason System.UnauthorizedAccessException: Access is denied.
原因 A
ロボットがパスワードなしで作成されました。
解決策 A
こちらの記載に従ってロボットを編集し、次のフィールドが正しく設定されていることを確認してください。
- ドメイン\ユーザー名 - Robot がインストールされている端末への接続に使用しているユーザー名です。ユーザーがドメイン内の場合、
DOMAIN\UserName形式で指定する必要があります。コマンド プロンプトのWhoamiコマンドを使用すると簡単に見つけることができます。 - パスワード - マシンの Windows パスワードです。Attended ロボットの場合は不要です。
原因 B
SCM で管理された Robot サービスが実行されていません。詳しくは「Robot のデプロイの種類について」をご覧ください。
解決策 B
Robot サービスが実行されていることを確認します。
- Windows の [スタート] ボタンをクリックし、
Services.mscを検索して開きます。[サービス] ウィンドウが表示されます。 - UiPath Robot サービスを見つけ、ダブルクリックします。[UiPath Robot のプロパティ] パネルが表示されます。
- [ログオン] から [ローカル システム アカウント] オプションを選択します。
- [適用] ボタンをクリックしてウィンドウを閉じ、変更を確定します。これにより、Robot サービスが実行されており、プロセスの実行に必要な特権をすべて持っていることが確認されます。
原因 C
ロボット端末に管理者権限がありません。
解決策 C
Orchestrator でロボットを作成した際に使用した資格情報のセットを使用して、ロボット端末にログインします。プロセスが UiPath Assistant から開始できない場合は、ネットワーク管理者に連絡して、そのユーザー アカウントの管理者権限を許可する必要があります。
現象
[タスク完了まで待機して再開] アクティビティでデータ テーブルを使用すると、「Exception: Type 'System.Collections.IEnumerable' cannot be serialized. (例外: 種類 'System.Collections.IEnumerable' をシリアル化できません。)」というエラーが表示されます。
原因
DataRow はシリアル化できないため、ワークフローの永続化時に DataRow をシリアル化することができません。この現象は、DataRow 型変数を作成し、その後に待機 (永続化) しようとする場合にも発生します。
解決策
DataRows(System.Data.DataRow) に対してループ処理を行うときに、[フォーム タスクを作成] アクティビティを実行し、タスク オブジェクト (出力) のリストを作成します。
その後、[並列繰り返し (コレクションの各要素)] または [繰り返し (コレクションの各要素)] を使用してタスク オブジェクト (出力) のリストに対してループ処理を行い、[タスク完了まで待機して再開] アクティビティを実行します。
現象
UiPathStudioSetup.exe (Community Edition) からインストールした場合、UiPathStudio.msi (Enterprise Edition) と比較して、プロセスの実行にかかる時間はほぼ 2 倍になります。この問題は、v2021.10 以降の Studio で発生します。
原因
%localappdata%\UiPath にインストールされますが、これは Windows Defender が信頼できる場所ではありません。これは、ログ ファイルが作成されるたびに、Windows Defender がログ ファイルのスキャンを開始し、プロセスの実行が長くなることを意味します。
%ProgramFiles%\UiPath) は Windows Defender によって信頼されており、プロセスの実行中にログ ファイルが作成されるたびにスキャンされることはないため、シナリオは Studio Enterprise Edition には適用されません。
解決策
%localappdata%\UiPath) を追加すると、プロセスの実行中に作成されたログ ファイルがその場でスキャンされなくなります。Windows Defender 除外リストにフォルダーを追加するには、次の手順を実行する必要があります。
- Windows の [スタート] ボタンをクリックし、[ウイルスと脅威の防止] を検索して開きます。
- [ウイルスと脅威の防止] 設定ページにアクセスします。
- [除外] セクションから [除外の追加または削除] ページにアクセスします。
- その後、[除外を追加する] ボタンをクリックして、ドロップダウン メニューから [フォルダー] を選択します。
%localappdata%\UiPathフォルダーに移動し、[フォルダーの選択] ボタンをクリックします。除外リストにフォルダーを追加するには、管理者権限が必要です。
プロセスの実行中に作成されたログ ファイルは、Windows Defender によってその場でスキャンされなくなります。