通知を受け取る

UiPath Studio

UiPath Studio ガイド

キーボード ショートカット

UiPath Studio のキーボード ショートカットのリストを次に示します。

ファイルの管理

Ctrl + Shift + N - 新しい空のプロセスを作成します。

Ctrl + C - [プロジェクト] パネルからクリップボードにファイルをコピーします。Ctrl + V を使用して、ツリーの任意の場所に貼り付けます。

Ctrl + O - Enables you to open a previously created workflow, either the .xaml または project.json file.

Ctrl + L - ログ ファイルが格納されているフォルダーを開きます。

Ctrl + S - 現在開いているワークフローを保存します。

Ctrl + Shift + S - 現在開いているすべてのワークフローを保存します。

Ctrl + V - クリップボードから [プロジェクト] パネルにファイルを貼り付けます。

Ctrl + Tab - デザイナー パネルで開いているワークフロー間でフォーカスを移動します。

Alt + F7 - Studio パネル間のフォーカスを移動します。Ctrl + Tab または Alt + F7 を使用して修飾キー (Ctrl または Alt) を押したままにすると、次のウィンドウが表示され、Studio でアクティブなファイルやパネルを切り替えられます。

511511

検索

F3 または Ctrl + Shift + P - コマンド パレットを開きます。

Ctrl + Shift + T - [アクティビティを追加] 検索バーを開きます。

Ctrl + Shift + F - [ファイルに移動] 検索バーを開きます。

Ctrl + F - ユニバーサル検索バーを開きます。

Ctrl + J - [アクティビティに移動] 検索バーを開きます。

Ctrl + 1 - ユニバーサル検索バーの [現在のファイル] タブに切り替えます。

Ctrl + 2 - ユニバーサル検索バーで [すべてのファイル] タブに切り替えます。

Ctrl + 3 - ユニバーサル検索バーの [アクティビティ] タブに切り替えます。

Ctrl + 4 - ユニバーサル検索バーの [変数] タブに切り替えます。

Ctrl + 5 - ユニバーサル検索バーの [引数] タブに切り替えます。

Ctrl + 6 - ユニバーサル検索バーの [インポート] タブに切り替えます。

Ctrl + 7 - ユニバーサル検索バーで [プロジェクト ファイル] タブに切り替えます。

Ctrl + 8 - ユニバーサル検索バーの [依存関係] タブに切り替えます。

Ctrl + 9 - ユニバーサル検索バーの [スニペット] タブに切り替えます。

Ctrl + Alt + A - [プロパティ] パネルを開いてフォーカスします。

Alt + Ctrl + F - [アクティビティ] パネルの検索ボックスにフォーカスを設定します。

Ctrl + Alt + O - [UI オブジェクト ブラウザー] パネルの検索ボックスにフォーカスを設定します。

Ctrl + Alt + P - [プロジェクト] パネルの検索バーを開いてフォーカスします。

Ctrl + Alt + S - [スニペット] パネルの検索バーを開いてフォーカスします。

Tab - パネル内の次の項目またはアクティビティの次の要素に移動します。

以下の画像に示すように、すべてのプロジェクト ファイルが閉じられると、便利なキーボード ショートカットのリストがデザイナーパネルに表示されます。

11251125

コメント

Ctrl + D - 現在選択しているアクティビティを [コメント アウト] コンテナーに配置して無視します。

Ctrl + E - [コメント アウト] コンテナーに配置されているアクティビティをコンテナーから削除します。

デバッグ

F9 - 選択したアクティビティにブレークポイントのマークを付けます。

Ctrl + Shift + B - [ブレークポイント] パネルを開きます。

Ctrl + Alt + E - [エラー リスト] パネルを開きます。

F10 - デバッグ時に、現在選択しているワークフロー内のアクティビティのブロックをステップ オーバー実行します。

F11 - デバッグ時に、アクティビティのブロックにステップ インして 1 つ目のアクティビティを実行できます。

Shift + F11 - デバッグ時に、最後のアクティビティが実行された後に現在のコンテナーからステップ アウトします。

レコーディング

Ctrl + Alt + B - [ベーシック レコーディング] ツールバーを開きます。

Ctrl + Alt + C - [Citrix レコーディング] ツールバーを開きます。

Ctrl + Alt + D - [デスクトップ レコーディング] ツールバーを開きます。

Ctrl + Alt + W - [Web レコーディング] ツールバーを開きます。

F2 - 記録操作中に遅延を追加します。

F3 - 独自の記録領域を指定できます。

F4 - 記録する UI フレームワークを 既定値、AA、および UIA から選択できます。

ワークフローの分析と実行

F5 - Runs the current project in debugging mode, starting with the .xaml file set as Main.

Ctrl + F5 - 現在のプロジェクトを実行します。

F6 - Runs the currently opened .xaml file in debugging mode.

Ctrl + F6 - Runs the currently opened .xaml file.

F7 - ファイルに検証エラーとワークフロー アナライザーの違反があるかチェックします。

Shift + F7 - プロジェクト全体に検証エラーとワークフロー アナライザーの違反があるかチェックします。

F8 - 現在開いているワークフローに検証エラーがないかチェックします。

Shift + F8 - すべてのプロジェクト ファイルの検証エラーをチェックします。

Pause - 現在のワークフローの実行を一時停止します (標準モードとデバッグ モードの両方)。

F12 - 現在のワークフローの実行を停止します (標準モードとデバッグ モードの両方)。

選択したアクティビティ

Ctrl + T - アクティビティを [トライ キャッチ] アクティビティの [Try] セクション内に配置します。

Ctrl + N - 新しいシーケンス ダイアグラムを現在のプロジェクトに作成します。

Ctrl + C - 選択した 1 つ以上のアクティビティをクリップボードにコピーします。

Ctrl + V - コピーした 1 つ以上のアクティビティを選択した項目の中に貼り付けます。

Ctrl + K - 入力フィールドまたは式エディターで使用すると、アクティビティの必須の型と同じ型の変数を作成します。フィールドに式が既に存在する場合は、Ctrl + K を押す前にその式または式の一部を選択し、選択したテキストを新しい変数の名前として使用できます。

Ctrl + M - 入力フィールドまたは式エディターで使用すると、アクティビティの必須の型と同じ型の入力引数を作成します。フィールドに式が既に存在する場合は、Ctrl + M を押す前にその式または式の一部を選択し、選択したテキストを新しい引数の名前として使用できます。

Ctrl + Shift + M - 入力フィールドまたは式エディターで使用すると、アクティビティの必須の型と同じ型の出力引数を作成します。フィールドに式が既に存在する場合、Ctrl + Shift + M を押す前にその式または式の一部を選択し、選択したテキストを新しい引数の名前として使用できます。

Ctrl + Shift + E - アクティビティの入力フィールド内で使用すると、式エディターが開きます。

Ctrl + Space - IntelliPrompt ウィンドウを開きます。

F2 - 選択されたアクティビティの名前の変更を可能にします。

Shift + F2 - 選択したアクティビティに注釈を追加します。

Enter - アクティビティ入力フィールドに追加されたデータを保存します。

Shift + Enter - アクティビティの入力フィールドに新しい行を追加します。

その他

F1 - 選択した要素に関連したヘルプ トピックにアクセスできます。

Ctrl + P - [パッケージを管理] ウィンドウを開きます。

Esc - [パブリッシュ][パッケージを管理]ファイル差分検出の各ウィンドウを閉じます。

Ctrl + F1 - リボンを最小化または展開します。

Ctrl + Shift + R - 未使用のプロジェクト依存関係をすべて削除します。

Shift + Tab - [アクティビティ] パネル内の前のアクティビティまたはノードに移動します。

Ctrl + Z - 直前の操作を元に戻します。

Ctrl + Y - 直前に元に戻した操作をやり直します。

リボンと [ホーム] タブのショートカット キー

Alt キーを押して放した後、1 つ以上のキーを押すことで、[ホーム] タブ (Studio の Backstage ビュー) のほとんどのオプション、および [デザイン] タブと [デバッグ] タブのリボンにすばやくアクセスできます。

Alt キーを押して放すと、1 つ以上の文字または数字が現在のビューのオプションの上に表示されます。オプションを使用するには、該当するキー (複数可) を押します。最初のキーの組み合わせを押した後に、追加のキーを使用できるオプションもあります。

13151315

ショートカットのリストについては、以下のセクションをご覧ください。

[デザイン] タブのリボンのキー

[デザイン] タブまたは [デバッグ] タブを表示している場合は、Alt + D を押して、[デザイン] タブのリボンのショートカット キーにアクセスします。

Key(s)

Action Performed

Additional Keys and Actions

N

Open the New drop-down

S

Open the Save drop-down

S - Save as
L - Save all

ET

Open the Export as Template window

R

Open the Debug File drop-down

C - Run file
B - Debug project
D - Run project

X

Cut the selected activities

C

Copy the selected activities

V

Paste the copied activities

MP

Open the Manage Packages window

ME

Open the Manage Entities window

EW

Open the Service Editor window

U

Open the UI Explorer window

IU

Open the Remove Unused drop-down

F - Remove Unused Workflows
A - Remove Unused Variables
B - Remove Unused Arguments
C - Remove Unused Dependencies
D - Remove Unused Imports
E - Remove Unused Screenshots

A

Open the Analyze File drop-down

B - Analyze Project
C - Validate File
D - Validate Project
S - Workflow Analyzer Settings

EX

Open the Export to Excel window

P

Open the Publish window

[デバッグ] タブのリボンのキー

[デザイン] タブまたは [デバッグ] タブを表示している場合は、Alt + E を押して、[デバッグ] タブのリボンのショートカット キーにアクセスします。

Key(s)

Action Performed

Additional Keys and Actions

R

Open the Debug File drop-down

C - Run file
B - Debug project
D - Run project

B

Break execution

T

Stop execution

S

Step Into

V

Step Over

T

Step Out

ER

Retry

EI

Ignore

ES

Restart

F

Focus

P

Open the Breakpoints drop-down

T - Toggle Breakpoints
P - Show Breakpoints Panel

LS

Set Slow Step speed

LE

Enable / disable Execution trail

LH

Enable / disable Highlight Elements

LA

Enable / disable Log Activities

LC

Enable / disable Continue on Exception

LP

Enable / disable Picture in Picture

LO

Open the Logs folder

[ホーム] タブのキー

[デザイン] タブまたは [デバッグ] タブを表示している場合は、Alt + H を押して [ホーム] タブ (Studio の Backstage ビュー) を開き、[ホーム] タブのショートカット キーにアクセスします。[ホーム] タブを既に開いている場合は、Alt キーを押すだけです。

Key(s)

Action Performed

Additional Keys and Actions

Z

Go back to the previous tab, if a project is open

O

Open a project

C

Close the currently open project

S

Open the Start tab

O - Open a Local Project
C - Clone or Check Out a Project
P - Create a Process
L - Create a Library
A - Create a Test Automation
T - Create a Template
1...9 - Open one of the nine most recent projects

T

Open the Templates tab

M

Open the Team tab

L

Open the Tools tab

U - Open the UI Explorer
M - Open the Project Dependencies Mass Update Tool
R - Open the Repair Tool for Microsoft Office
C - Install the Chrome extension
F - Install the Firefox extension
E - Install the Edge extension
J - Install the Java extension
S - Install the Silverlight extension
T - Install the Citrix extension
W - Install the Windows Remote Desktop extension
V - Install the VMware Horizon extension

E

Open the Settings tab

G - Open the General tab
D - Open the Design tab
L - Open the Locations tab
M - Open the Manage Sources tab
P - Open the License and Profile tab
T - Open the Team tab
B - Open the Labs tab

H

Open the Help tab

D - Open the Product Documentation link
F - Open the Community Forum link
M - Open the Help Center link
A - Open the Academy link
R - Open the Release Notes link
S - Open the Take a short survey link
T - Open the Quick Tutorial link
C - Copy the license information

1 年前に更新


キーボード ショートカット


改善の提案は、API リファレンスのページでは制限されています

改善を提案できるのは Markdown の本文コンテンツのみであり、API 仕様に行うことはできません。