UiPath Orchestrator

About Backward and Forward Compatibilty

Definitions

  • Backward Compatibility - Refers to our platforms' ability to interact with older versions of the UiPath suite.
  • Forward Compatibility - Refers to our platforms' ability to interact with future versions of the UiPath suite.

UiPath Approach

Studio and Robot

Studio and Robot always need to have the same version. For the compatibility matrix between Orchestrator, Robot, and Studio, please see this table.

Projects created with alpha or beta Studio versions might not be compatible with newer Studio builds, nor can they be executed by newer Robots.

The versions of activity packages are not at all dependent on the versions of Studio, Robot, or Orchestrator. The only exceptions are Orchestrator-related activities. For example, the Start Job activity, which was introduced in the 2018.1 version, only works with Robots of that version or higher.

Important!

We do not support forward compatibility.
Projects created with newer versions of Studio might not work with older Robots or even older Studio versions. For example, a project created in Studio v2018.3 might not work with a v2017.1 Robot or v2017.1 Studio.

Orchestrator

The Folders functionality presents a paradigm shift in the structure and organization of your Orchestrator instance. Full backward compatibility is maintained through the use of Classic folders, which maintain the same functionality of previous Orchestrator versions ensuring that your existing resources and integrations function without interruption.

Taking advantage of the additional features and capabilities of Modern folders does, however, require the use of the latest Robot and Activities versions. For more information about using modern folders, see here.

Technical Compatibility Matrix

The following table lists what version of Robot and Studio works with what version of Orchestrator. Patches are implicitly supported in this matrix unless specifically mentioned here.

Please note that by not upgrading to the latest available version you are not taking advantage of the newest features or bug fixes added in our releases. You only have access to the features of the smallest installed version of either Robot or Orchestrator.

It is usually recommended to first upgrade your Orchestrator and then your Robots.

Orch 19.10.x
Orch 19.FT.x
Orch 18.4.x
Orch 18.3.x
Orch 18.2.x
Orch 18.1.x
Orch 17.1.x
Orch 16.2.x

Robot 2019.10.x

check_mark 1

check_mark 1

check_mark 1

no_right

no_right

no_right

no_right

no_right

Robot 2019FT.x

check_mark 1

check_mark 1

check_mark 1

check_mark

no_right

no_right

no_right

no_right

Robot 2018.4.x

check_mark 1

check_mark 1

check_mark 1

check_mark

check_mark

no_right

no_right

no_right

Robot 2018.3.x

no_right

check_mark

check_mark

check_mark

check_mark

no_right

no_right

no_right

Robot 2018.2.x

no_right

no_right

check_mark

check_mark

check_mark

no_right

no_right

no_right

Robot 2018.1.x

no_right

no_right

check_mark

check_mark

check_mark

check_mark

no_right

no_right

Robot 2017.1.x

no_right

no_right

check_mark

check_mark

check_mark

check_mark

check_mark

check_mark

Robot 2016.2.x

no_right

no_right

no_right

no_right

no_right

no_right

check_mark

check_mark

1 - Please note that if the Scalability.SignalR.AuthenticationEnabled parameter is set to true, you can only use v2018.4.3 Robots or above. For more information, see this page.

Important!

The 2017.1, 2018.1, 2018.2, and 2018.3 versions are no longer supported. Please refer to this page for other product lifecycle information.

Updated about a month ago


About Backward and Forward Compatibilty


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.