订阅

UiPath Studio

UiPath Studio 指南

键盘快捷方式

UiPath Studio 键盘快捷方式的完整列表:

文件管理

Ctrl+Shift+N - 创建一个新的空白流程。

Ctrl + C - 将文件从“项目”面板复制到剪贴板。使用 Ctrl + V 将其粘贴到树中的任何位置。

Ctrl+O - 使您能够打开先前创建的工作流:.xamlproject.json 文件。

“Ctrl+L”- 打开存储日志文件的文件夹。

“Ctrl+S”- 保存当前打开的工作流。

“Ctrl + Shift + S”- 保存当前打开的所有工作流。

Ctrl + V - 将剪贴板中的文件粘贴到“项目”面板中。

Ctrl + Tab - 在“设计器”面板中打开的工作流之间移动焦点。

Ctrl + W - 关闭“设计器”面板中聚焦的工作流文件。

Alt + F7 - - 在 Studio 面板之间移动焦点。当您使用 Ctrl + Tab 或 Alt + F7 并按住修饰键(分别为 Ctrl 或 Alt)时,将显示以下窗口,允许您在 Studio 中的活动文件和面板之间进行切换。

搜索

F3Ctrl + Shift + P - 打开“命令面板”

Ctrl + Shift + T - 打开“添加活动”搜索栏。

Ctrl + Shift + F - 打开“转到文件”搜索栏。

Ctrl + F - 打开“通用搜索”栏。

Ctrl + J - 打开“跳转到活动”搜索栏。

Ctrl + 1 - 切换至“通用搜索”栏中的“当前文件”选项卡。

Ctrl + 2 - 切换至“通用搜索”栏中的“所有文件”选项卡。

Ctrl + 3 - 切换至“通用搜索”栏中的“活动”选项卡。

Ctrl + 4 - 切换至“通用搜索”栏中的“变量”选项卡。

Ctrl + 5 - 切换至“通用搜索”栏中的“参数”选项卡。

Ctrl + 6 - 切换至“通用搜索”栏中的“导入”选项卡。

Ctrl + 7 - 切换至“通用搜索”栏中的“项目文件”选项卡。

Ctrl + 8 - 切换至“通用搜索”栏的“依赖项”选项卡。

Ctrl + 9 - 切换至“通用搜索”栏中的“代码片段”选项卡。

Ctrl + Alt + A - 在“属性”面板中打开并聚焦搜索栏。

Ctrl+Ctrl+F - 将焦点设置为“活动”面板中的搜索框。

Ctrl + Alt + O - Sets the focus to the search box in the UI Objects Browser panel.

Ctrl + Alt + P - 在“项目”面板中打开并聚焦搜索栏。

Ctrl + Alt + S - 在“代码片段”面板中打开并聚焦搜索栏。

“Tab”- 导航至面板中的下一项或活动中的下个元素。

当关闭所有项目文件时,“设计器”面板中会显示一个实用键盘快捷方式列表,如下图所示:

注释

“Ctrl+D”- 忽略当前被选中的活动,方法是将其放置到“注释掉”容器中。

“Ctrl + E” - 从放置了活动的“注释掉”容器中删除活动。

调试

“F9”- 用断点标记选定的活动。

Ctrl + Shift + B - 打开“断点”面板。

Ctrl + Alt + E - 打开“错误列表”面板。

“F10”- 调试时,在当前选定的工作流中跳过一个活动块的执行。

“F11”- 调试时,可用于进入一个活动块并执行第一个活动。

Shift + F11 - 调试时,在执行完最后一个活动后退出当前容器。

录制

Ctrl + Alt + B - 打开“基本录制”工具栏。

Ctrl + Alt + C - 打开“Citrix 录制”工具栏。

Ctrl + Alt + D - 打开“桌面录制”工具栏。

Ctrl + Alt + W - 打开“网页录制”工具栏。

“F2”- 在录制活动期间添加延迟。

“F3”- 用于指定自定义录制区域。

“F4”- 允许您选择要录制的用户界面框架,这可以是“默认”、“AA”和“UIA”。

工作流分析和执行

F5 - 以调试模式运行当前项目,从设置为“主要”的 .xaml 文件开始。

Ctrl + F5 - 运行当前项目。

F6 - 以调试模式运行当前打开的 .xaml 文件。

Ctrl + F6 - 运行当前打开的 .xaml 文件。

F7 - 检查文件中是否存在验证错误和“工作流分析器”违规情况。

Shift + F7 - 检查整个项目是否存在验证错误和“工作流分析器”违规情况。

“F8”- 检查当前打开的工作流是否存在验证错误。

Shift + F8 - 检查所有项目文件中是否存在验证错误。

“暂停”- 在正常模式和调试模式下暂停当前工作流的执行。

“F12”- 在正常模式和调试模式下停止当前工作流的执行。

选定活动

“Ctrl+T”- 将该活动放置在“Try Catch 异常处理”活动的“Try”部分中。

“Ctrl+N”- 在当前项目中创建一个新的“序列图”。

“Ctrl + C”- 将选定的一个或多个活动复制到剪贴板。

“Ctrl + V”- 粘贴选定项目中复制的一个或多个活动。

Ctrl + K - 在输入字段或“表达式编辑器”中使用时,创建与所需活动相同类型的变量。如果该字段中已经存在表达式,则在按 CTRL + K 之前,可以选择该表达式或表达式的一部分,以将选定的文本用作新变量的名称。

Ctrl + M - 在输入字段或“表达式编辑器”中使用时,创建与所需活动相同类型的输入参数。如果该字段中已经存在表达式,则在按 CTRL + M 之前,可以选择该表达式或表达式的一部分,以将选定的文本用作新参数的名称。

Ctrl + Shift + K - 在输入字段或“表达式编辑器”中使用时,创建与所需活动相同类型的输出参数。如果该字段中已经存在表达式,则在按 CTRL + Shift + M 之前,可以选择该表达式或表达式的一部分,以将选定的文本用作新参数的名称。

Ctrl + Shift + E - 在活动输入字段中使用时将打开“表达式编辑器”

“Ctrl + 空格”- 打开智能提示窗口。

F2 - 允许为选中的活动重命名。

Shift + F2 - 为选中的活动添加注释。

Enter- 保存在活动输入字段中添加的数据。

Shift + Enter - 在活动输入字段中添加一个新行。

Tab - Moves through the fields and buttons in the activity, including the plus_iconplus_icon menu displayed when you hover the mouse over an input field.

测试自动化

Ctrl + Alt + T - Open Test Explorer panel. You can use this anywhere within the Designer panel.

Alt + T - Open Test Results sub-panel in Test Explorer. You can use this only in the Test Explorer panel.

Alt + A - Open Activity sub-panel in Test Explorer. You can use this only in the Test Explorer panel.

Arguments Dialogs

The following keyboard shortcuts are available in Arguments dialog boxes available in activities such as Invoke Workflow File and Inject .NET Code:

Tab - Moves through the items in the grid.

Delete - Deletes the item selected in the grid.

F2 - Highlights the current cell for editing, positioning the cursor at the end of the line.

Ctrl + Tab - Moves through the options available in the window for the selected item in the grid (Delete, Move up, Move Down).

状态栏

Alt + D - 访问状态栏中的“来源控件”、“Orchestrator”文件夹和“Orchestrator/云连接”菜单,然后使用 Shift + Tab 循环切换菜单。选择菜单后,按 Enter 键将其打开。

杂项

“F1”- 用于访问与当前选定元素关联的帮助主题。

Alt + F4 - Closes the current window.

Alt + - - 打开当前选定面板标题栏中的“选项”上下文菜单。请注意,这适用于字符键上方的连字符键,而不适用于数字键盘中的减号键。

Windows key + Up Arrow - Maximizes the current window.

Windows key + Down Arrow - Restores down the current window.

“Ctrl+P”- 打开“管理包”窗口。

“Esc”- 关闭“发布”、“管理包”和“文件区别”窗口。

Ctrl + F1 - 最小化或展开功能区。

Ctrl + Shift + R - 删除所有未使用的项目依赖项。

Shift + Tab - 导航至“活动”面板中的前一个活动或节点。

Ctrl + Z - 撤消上一个操作。

Ctrl + Y - 重做您撤消的上一个操作。

Shift + F10 - 打开所选项目的上下文菜单(右键单击)。

功能区和主页选项卡键

您可以通过按下和释放 Alt 键,然后按一个或多个键,快速进入“主页”选项卡(Studio 后台视图)中的大多数选项,以及“设计”和“调试”选项卡中的功能区。

按下和释放 Alt 键时,当前视图中的选项上方会出现一个或多个字母或数字。要使用选项,请按相应的一个或多个键。对于某些选项,在按初始键组合后,可以使用其他键。

有关快捷方式列表,请参阅以下部分。

设计选项卡功能区键

如果您在“设计”选项卡或“调试”选项卡中,请按 Alt + D 以访问“设计”选项卡功能区的快捷键。

Key(s)

Action Performed

Additional Keys and Actions

N

Open the New drop-down

S

Open the Save drop-down

S - Save as
L - Save all

ET

Open the Export as Template window

R

Open the Debug File drop-down

C - Run file
B - Debug project
D - Run project

X

Cut the selected activities

C

Copy the selected activities

V

Paste the copied activities

MP

Open the Manage Packages window

ME

Open the Manage Entities window

EW

Open the Service Editor window

U

Open the UI Explorer window

IU

Open the Remove Unused drop-down

F - Remove Unused Workflows
A - Remove Unused Variables
B - Remove Unused Arguments
C - Remove Unused Dependencies
D - Remove Unused Imports
E - Remove Unused Screenshots

A

Open the Analyze File drop-down

B - Analyze Project
C - Validate File
D - Validate Project
S - Workflow Analyzer Settings

EX

Open the Export to Excel window

P

Open the Publish window

调试选项卡功能区键

如果您在“设计”选项卡或“调试”选项卡中,请按 Alt+E 以访问“调试”选项卡功能区的快捷键。

Key(s)

Action Performed

Additional Keys and Actions

R

Open the Debug File drop-down

C - Run file
B - Debug project
D - Run project

B

Break execution

T

Stop execution

S

Step Into

V

Step Over

O

Step Out

ER

Retry

EI

Ignore

ES

Restart

F

Focus

P

Open the Breakpoints drop-down

T - Toggle Breakpoints
P - Show Breakpoints Panel

LS

Set Slow Step speed

LE

Enable / disable Execution trail

LH

Enable / disable Highlight Elements

LA

Enable / disable Log Activities

LC

Enable / disable Continue on Exception

LP

Enable / disable Picture in Picture

LR

Open the Remote Debugging drop-down

C - Configure Remote Debugging

LO

Open the Logs folder

标题栏键

要访问 Studio 标题栏中的按钮键(窗口右上侧),请按 Alt 键。

Key(s)

Action Performed

Additional Keys and Actions

F

Open the Send feedback window,

L

Open the Help drop-down.

I

Open the Sign in / Sign out menu

主页选项卡键

如果您在“设计”选项卡或“调试”选项卡中,请按“Alt + H”打开“主页”选项卡(Studio 后台视图),并访问“主页”选项卡的快捷键。如果您已经在“主页”选项卡中,则只需按“Alt”键。

Key(s)

Action Performed

Additional Keys and Actions

Z

Go back to the previous tab, if a project is open

O

Open a project

C

Close the currently open project

S

Open the Start tab

O - Open a Local Project
C - Clone or Check Out a Project
P - Create a Process
L - Create a Library
A - Create a Test Automation
T - Create a Template
1...9 - Open one of the nine most recent projects

T

Open the Templates tab

M

Open the Team tab

L

Open the Tools tab

U - Open the UI Explorer
M - Open the Project Dependencies Mass Update Tool
R - Open the Repair Tool for Microsoft Office
C - Install the Chrome extension
F - Install the Firefox extension
E - Install the Edge extension
J - Install the Java extension
S - Install the Silverlight extension
T - Install the Citrix extension
W - Install the Windows Remote Desktop extension
V - Install the VMware Horizon extension

E

Open the Settings tab

G - Open the General tab
D - Open the Design tab
L - Open the Locations tab
M - Open the Manage Sources tab
P - Open the License and Profile tab
T - Open the Team tab
B - Open the Labs tab

H

Open the Help tab

D - Open the Product Documentation link
F - Open the Community Forum link
M - Open the Help Center link
A - Open the Academy link
R - Open the Release Notes link
S - Open the Take a short survey link
T - Open the Quick Tutorial link
C - Copy the license information

Updated 27 days ago


键盘快捷方式


建议的编辑仅限用于 API 参考页面

您只能建议对 Markdown 正文内容进行编辑,而不能建议对 API 规范进行编辑。