通知を受け取る

UiPath Studio

UiPath Studio ガイド

ユーザー インターフェイス

UiPath Studio には、特定の機能に簡単にアクセスするための複数のパネルがあります。これらはドッキングすることも、フローティング ウィンドウとして機能させることもできます。またドロップダウン リストから自動非表示オプションを有効化することもできます。

リボン

リボンは非常にシンプルな機能です。[最小化] / [展開] ボタン minimize_expandminimize_expand をクリックすることで、最小化や展開が可能です。次の 3 つのタブで構成されています。

  1. トップ - 定義済みのテンプレートから新しいプロジェクトを開始するか、最近作業したプロジェクトを開きます。プロジェクトは [最近使用したプロジェクトを開く] のリストにピン留めしたり、削除したりでき、プロジェクトにカーソルを合わせるとプロジェクト全体の説明が表示されます。既定では、プロジェクトは C:\Users\<current_user>\Documents\UiPath に作成されます。[ローカル プロジェクトを開く] ボタンをクリックすると、project.json ファイルを検索します。

📘

注:

Studio を v2018.3 以降のバージョンに更新すると、[最近使用したプロジェクトを開く] のプロジェクト リストがリセットされます。

  1. デザイン - プロジェクトへのシーケンス、フローチャート、ステート マシンの追加、アクティビティ パッケージのインストールと管理、UI 要素との対話の構築、ワークフローの Excel へのエクスポート、そして Orchestrator またはカスタム フィードへの作業内容のパブリッシュを行います。UiPath.UIAutomation.Activities パッケージをインストールしないと、ウィザードや UI Explorer はこのリボンには表示されない点にご注意ください。
  1. デバッグ - ワークフローをデバッグします。また、デバッグツールを使用してブレークポイントを設定し、アクティビティの実行をステップごとに監視し、デバッグの速度を調整します。ログを開くと、プロジェクトの実行や変更の詳細を確認できます。デバッグの詳細は、「デバッグについて」をご覧ください。

📘

注:

オートメーション プロジェクトの実行中に作成されたものではないファイルは、Orchestrator へのパブリッシュ時に読み取り専用になります。業務プロセスにおいて将来的に特定のファイルへの書き込みが必要となる場合は、プロジェクトの実行中にファイルを作成するようにしてください。

ツールタブ

[ツール] タブは、Chrome、Firefox、Edge、Java、Silverlight、Citrix、Windows Remote Desktop の拡張機能をインストールする場合や、UI Explorer およびプロジェクト依存関係一括更新ツール]を起動する場合に使用します。詳細は「拡張機能について」をご覧ください。

また、プロジェクト依存関係一括更新ツールは、[ツール] タブからもアクセスできます。ローカルはたはリモート ソース管理リポジトリに置かれ、複数のプロジェクトの依存関係のバージョンを一括で更新するユーザー インターフェイス ツールを提供します。

Settings タブ

[設定] タブには、インターフェイス言語やテーマの変更、グローバル設定の構成、アクティビティ フィード管理のオプションがあります。

全般

[一般] タブには、Studio と Robot のインターフェイス言語を変更するオプションがあります。言語は、英語日本語フランス語ロシア語中国語 (簡体字)ドイツ語スペイン語スペイン語 (中南米)ポルトガル語 (ポルトガル)ポルトガル語 (ブラジル)韓国語トルコ語のいずれかを選択できます。

Studio のインターフェイス テーマは、ドロップダウン メニューから変更できます。ライト または ダーク のテーマを選択してから、Studio を再起動すると変更が適用されます。

Studio は、マシン上でハイコントラストを検出すると、再起動時にこのモードに切り替えます。

📘

注:

ダークテーマを使用するには、オートメーション プロジェクトが少なくとも UiPath.UIAutomation.Activities v18.4.2 および UiPath.System.Activities v18.4.1 以降を依存関係として持つ必要があります。

[設定をリセット] ボタンは、Studio のすべての [一般] 設定と [デザイン] 設定を既定のステートに戻しリセットします。ただし、フィードやお気に入りのアクティビティには影響しません。

これとは別に、次の設定は既定のステートに戻ります。

  • 最近のファイルのリスト。
  • [お気に入り] アクティビティのリスト。
  • Studio のレイアウト調整。
  • [実行] タブ > [オプション][例外中に中断] オプション。
  • [アクティビティを表示] オプションと [アクティビティ] パネルでピン留めされたアクティビティ。
  • [スニペット] パネルのユーザーが追加したフォルダー、プロジェクトを最後に開いたディレクトリ、および安定版に切り替えられる更新チャネル

デザイン

このサブセクションに含まれる項目の設定は、このバージョンの Studio で開いたすべてのプロジェクトにグローバルに適用されます。

保存およびパブリッシュ

[自動バックアップの実行間隔] では、プロジェクトを定期的に自動バックアップする間隔を設定できます。これは、前回保存したワークフローのコピーを復元する際に役立ちます。既定値は、30,000 ミリ秒に設定されています。最小値は 10,000 ミリ秒、最大値は 9,999,999 ミリ秒です。

[プロジェクトのパブリッシュ時のタイムアウト] は、プロジェクトをパブリッシュする際のタイムアウト値を設定します。既定値は、30 秒です。タイムアウトの最大値は 999,999 秒、最小値は 1 秒です。

[プロジェクトを開く動作] ドロップダウン リストでは、プロジェクトの再開時に既定でどのファイルを開くかを選択できます。[最後に開いたタブを保持][メイン エントリ ポイントを開く] または [タブなし] から選べます。

[パブリッシュ時にアナライザーを強制実行] は、ワークフロー アナライザーのエラーでプロジェクトのパブリッシュを許可するか制限するかを切り替えます。

実行

[出力コンソールのサイズ] は、[出力] パネルに表示する 1 つのセッションに、最大 9,999 行を設定します。既定値は、2,000 行です。追加可能な行の最大値は 9,999 行、最小値は 1 行です。

[実行時に最小化] トグルでは、プロジェクトの実行時に Studio を最大化するか、最小化するかを設定できます。

アクティビティ デザインのスタイル

[注釈をドッキング] トグルを使用すると、プロジェクト内のアクティビティに対して作成する注釈の状態をドッキングまたはフローティングに切り替えられます。

場所

プロジェクトの作成先となる既定の場所を変更するには、[プロジェクト パス] ボックスに新しいパスを追加します。

[ライブラリのパブリッシュ先 URL] ボックスでは、カスタム フィードが選択されている場合に、すべてのライブラリのパブリッシュ先となる既定の場所を追加できます。

[プロセスのパブリッシュ先 URL] も、プロセスに対してのみ同様に機能します。これは、カスタム フィード オプションが選択されている場合に、すべてのプロセスのパブリッシュ先となる既定の場所を追加できます。

パッケージ ソースを管理

プロジェクトを開かずに、Studio の Backstage ビューからアクティビティ パッケージのフィードを管理します。このセクションは、[パッケージを管理] ウィンドウにある、プロジェクトごとのフィードを調整するためのセクションに類似しています。

📘

注:

ローカル アクティビティ フィードは、既定で有効化されています。ロボットが Orchestrator に接続されている場合には、Orchestrator フィードも有効化されています。

ライセンスとプロファイル

このタブを使用して、Community または Enterprise ライセンスをアクティベーションするか、Orchestrator を使用して Studio のライセンスを有効にします。

さらに、Studio プロファイルと StudioX プロファイルを切り替えることができます。

ヘルプタブ

[ヘルプ] タブから、ユーザー ガイド、リリース ノート、オンライン リソース、コミュニティ フォーラムUiPath アカデミーにアクセスできます。

また [ヘルプ] ページでは、製品のバージョン、インストール、ライセンスが使用可能かどうか、更新チャネル、デバイス ID に関する情報も得られます。[情報をコピー] ボタンを使用すれば、情報の詳細をすばやくクリップボードにコピーできます。

リボンにはヘルプ関連のリンクを含むショートカットがあり、下図のアイコンからアクセスできます。

フィードバックを送る

Studio 内から直接送信できるフィードバックには、[製品に関する提案を提出] または [バグを報告] の 2 種類があります。この機能にアクセスするには、リボンの send_feedbacksend_feedback アイコンをクリックします。

フィードバックを送る機能は、製品チームに匿名のフィードバックを送信するときだけに使用します。テクニカル サポート チームへの問い合わせには、テクニカル サポートへのお問い合わせフォームを使用してください。

[目的] ドロップダウン メニューから、[製品に関する提案を提出] または [バグを報告] を選択します。[対象] セクションの下のドロップダウン メニューから [UiPath Activities][UiPath Studio][UiPath Robot][UiPath Orchestrator] のいずれかを選択します。

要求の重要度を、ドロップダウン メニューの [低][高][重大] から選択します。[件名] フィールドに短いタイトルを入力します。

詳細な説明を追加し、最大 6 個の画像、ビデオ、またはテキスト ファイルを添付します。それぞれのサイズは 10MB 未満です。フィードバックを送信するためのしきい値は、5 分で 3 つの投稿です。

コマンドパレット

コマンドパレットは、Ctrl + Shift + PF3 キーショートカットを使用するか、検索ボタンをクリックして開きます。アクティビティの追加ユニバーサル検索ファイルに移動アクティビティにジャンプ検索バーが組み込まれています。

アクティビティを追加

アクティビティを追加するための検索バーは Ctrl + Shift + T キーボード ショートカットを使用して開きます。インストール済みパッケージでアクティビティを検索し、ファイル内の選択したアクティビティの後に追加できます。バーは、最初の 5 つの結果にキーボード ショートカットを自動的に割り当て、以前の検索結果を記憶します。

アクティビティを追加するための検索バーを開くには、シーケンスからアクティビティの上部または下部の plus_iconplus_icon アイコンをクリックします。

ユニバーサル検索

ユニバーサル検索バーを使用すると、現在のプロジェクトのスニペット、アクティビティ、プロジェクトの依存関係、およびファイル部分を見つけることができます。

Option

Shortcut

Description

Current File

Ctrl + 1

Lists results from the currently opened file that match the search query.

All Files

Ctrl + 2

Lists results found in all files part of the current project that match the search query.

Activities

Ctrl + 3

Lists results from activities that match the search query.

Variables

Ctrl + 4

Finds variables in the current project that match the search query.

Arguments

Ctrl + 5

Finds arguments defined in the project that match the search query.

Imports

Ctrl + 6

Finds imported namespaces in the project that match the search query.

Project Files

Ctrl + 7

Finds files part of the current project that match the search query.

Dependencies

Ctrl + 8

Lists results found in dependencies installed to the project.

Snippets

Ctrl + 9

Finds snippet files that match the search query.

検索結果は、 [ユニバーサル検索] または [アクティビティを追加] を使用する場合、次に検索バーを開くまで保持されます。 [ファイルに移動] および [アクティビティにジャンプ] の場合、前の検索クエリは保持されません。

アクティビティをダブルクリックするか、Enter を押して、現在開いているファイルに追加します。同じコマンドを使用して、すべてのファイルまたはプロジェクト ファイル カテゴリからファイルを開くか、目的の検索結果に焦点を合わせることができます。

以前にプロジェクトからパッケージをアンインストールしたことがある場合、検索結果に矛盾が生じる可能性があることに注意してください。また、ユニバーサル検索バーは、デザイナー パネルで開いている .xaml ファイルのみを対象として、注釈の検索結果を返します。

ファイルを開く

[ファイルへ移動] バーは、現在のプロジェクト フォルダーのファイル部分を検索して開きます。スクリーンショットや Excel ファイルなどの他のファイルがマシン上で、それぞれの既定のアプリケーションで開かれている間、.xaml ファイルは Studio のデザイナー パネルで開かれます。ダブルクリックするか、Enter を押してファイルを開きます。

📘

注:

[アクティビティ] パネル、[プロジェクト] パネル、およびコマンド パレットはあいまい検索をサポートします。これは、検索語が完全に一致していなくても結果のリストが返されることを意味します。検索用語が、わずかに不完全であるか、つづりが間違っているか、各単語の最初の文字だけが含まれているなどです。アクティビティ バーに dci を入力した場合、[画像をダブルクリック] アクティビティが返されます。

アクティビティにジャンプ

コマンド パレット[アクティビティに移動] 検索バー部分は、大規模なワークフローで特定のアクティビティを見つけてフォーカスするのに役立ちます。これには、Ctrl + J キーボード ショートカットを使用するか、F3 または CTRL + Shift + P ショートカットを使用して、[アクティビティに移動] を選択し、アクセスします。

[アクティビティにジャンプ] バーは、開いている場合にはデザイナー パネルで現在フォーカスされている .xaml ファイル内のすべてのアクティビティのリストが表示されます。

アクティビティの表示名または名前空間を入力します (例: [代入])。キーボードの矢印キーを使用してアクティビティを選択し、Enter を押してデザイナー パネルにフォーカスします。

[アクティビティにジャンプ] バーのアクティビティは、コンテナー、親、子のアクティビティの順に配置されています。

デザイナー パネル

デザイナー パネル上では、現在のオートメーション プロジェクトが表示され、これに変更を加えることができます。また、[変数][引数][インポート]にすばやくアクセスすることもできます。

表示したいアクティビティをダブルクリックしてダイアグラムの中でナビゲートすることが可能です。デザイナー パネルの見出しにはパスが階層リンクとして表示されます。スケールの異なる複数の表示を使用すると、一部のアクティビティの入力フィールドのテキストが適切に表示されないことがあります。

アクティビティは、Ctrl + C ショートカットまたはコンテキスト メニューを使用してテキスト エディターにコピーし、変更を受信したらデザイナー パネルにコピーして戻すことができます。

pan_modepan_mode アイコンをクリックし、スペース キーを押し、マウスの中ボタンを押して、パン モードを有効にします。ズーム ドロップダウンを使用してズーム レベルを変更し、reset_zoomreset_zoom アイコンをクリックして 100% にリセットします。

[画面に合わせる] fit_screenfit_screen アイコンは全体のワークフローがデザイナー パネルに収まるようにズームを変更します。overviewoverview アイコンをクリックして、プロジェクト全体の概要を取得し、フォーカスを調整してセクションを移動します。

コンテキスト メニュー

コンテキスト メニューを使用すると、シーケンスやフローチャートのようにワークフローにていくつかの操作を実行することができます。 ワークフロー内のアクティビティを右クリックして表示することができます。

📘

アクティビティを複数選択した場合、コンテキスト メニューは表示されません。

コンテキスト メニューのフィールドの説明

Option

Description

View Parent

Displays the parent of the target activity in the Designer panel.
Note: This option is only displayed for child-activities, if they are opened in the Designer panel.

Open

Opens the selected activity in the Designer panel. Has the same result as double-click.

Collapse

Collapses the activity thus reducing the displayed details to "Double-click to view". You can achieve the same result by clicking the Collapse button **Collapse****Collapse**.
Note: Only displayed for sequences.

Expand in Place

Expands the content of the activity, displaying its detailed content. You can achieve the same result by clicking the Expand button **Expand****Expand**.
Note: Only displayed for sequences.

Cut

Removes the selected activity and places it onto the Clipboard.

Copy

Copies the selected activity and places it onto the Clipboard. Activities from read-only files can be copied to another workflow or a .txt file. When copying multiple activities to clipboard, their order is reversed.

Paste

Inserts the content of the Clipboard at the current location.

Delete

Deletes the target activity.

Note: Since the Context menu is only displayed for a one-activity selection, you can use this command for more activities with the corresponding keyboard shortcut, Delete.

Annotations

Add, edit, delete, show and hide annotations added to activities in the workflow.

Copy as Image

Makes a screenshot of the content displayed in the Designer panel.

Note: If you want to make a screenshot of a child activity, make sure to firstly open it in the Designer panel.

Save as Image

Makes a screenshot of the content displayed in the Designer panel and prompts the user to set the details for saving it (Name, Type, Destination). Supported formats: JPG, PNG, GIF, XPS.

Create Variable

Creates a variable in the Variable panel.

Auto Arrange

Automatically arranges activities in a flowchart.

Remove Surrounding Sequence

Removes the selected Sequence activity from the Designer panel. The activities that it contains are moved to the parent sequence.

Surround with Try Catch (Ctrl + T)

Inserts the activity in a Try Catch statement.

Note: A Try Catch statement is used for handling exceptions caused by data or coding errors. The Try clause encloses the activity to be checked for exceptions. The Catches clause is the exception handler. The Finally clause is used for executing an activity regardless of the status of the first two clauses.

Extract as Workflow

Creates a new workflow containing the targeted activity with the purpose of breaking down a large project into smaller ones. In the place of the extracted activity an Invoke <new> workflow activity is created which enables you to edit and import arguments from the newly created workflow. The arguments are created automatically from the variables used in that activity. The Invoke <new> workflow activity automatically maps the local variables to invoke arguments for the extracted workflow.

Open Workflow

Opens a workflow created using the above option.

Enable Activity

Enables a previously disabled activity.

Disable Activity

Disables an activity, which is then placed inside a Comment out activity.

Toggle Breakpoint

Marks the selected activity as a breakpoint for debugging. Breakpoints can also be toggled by clicking the Breakpoint button in the Execute tab. You can trigger a breakpoint for one activity at a time.

Edit Breakpoint Settings

Opens the Breakpoint Settings window.

Run to this Activity

Debugs the project and stops before this particular activity is executed.

Run from this Activity

Starts debugging from this activity.

Show All Conditions

Displays all conditions defined in your project (Properties panel > Conditions).

Note: This option is only displayed for flowcharts when you right-click an empty space inside the project; it is not displayed if you right-click an activity in your flowchart.

Hide All Conditions

Hides all displayed conditions.

Note: This option is only displayed for flowcharts when you right-click an empty space inside the project; it is not displayed if you right-click an activity in your flowchart.

Set as Start Node

Connects the selected activity with the Start node.
Note: Only displayed for flowcharts.

Set as Initial State

Connects the State Machine specific activity to with the Start node.
Note: Only displayed for state machines.

コンテキスト メニューは、デザイナーパネルのタブに対しても表示されます。以下のオプションが選択可能です。

Option

Description

Close

Closes the active tab.

Close Others

Closes all tabs but the active one.

Close All Documents

Closes all tabs.

Float

Undocks the target tab and changes it to a floating state.

Pin Tab

Pins the target tab in the Designer panel.
Note: The tab pinned last is always moved in front of all other existing tabs (pinned or not). The position of a pinned tab can only be changed relative to other pinned tabs.

New Horizontal Tab Group

Splits the screen horizontally, enabling you to see two or more instances of the Designer panel within the same screen. The target project is moved onto the panel on the right.
Note: Only displayed when your project contains two or more tabs and, implicitly, workflows.

New Vertical Tab Group

Splits the screen vertically, enabling you to see two or more instances of the Designer panel within the same screen. The target project is moved onto the panel at the bottom.
Note: Only displayed when your project contains two or more tabs and, implicitly, workflows.

Move to Previous Tab Group

Moves the target tab onto the previous Designer panel displayed.
Note: Only displayed if you had used the New Vertical Tab Group or New Horizontal Tab Group options before.

Move to Next Tab Group

Moves the target tab onto the next Designer panel displayed.
Note: Only displayed if you had used the New Vertical Tab Group or New Horizontal Tab Group options before.

アクティビティ パネル

[アクティビティ] パネルには、現在のワークフローに追加できるアクティビティが表示されます。検索ボックスを使用すると、アクティビティを見つけて、ナビゲーション キーを使用して移動し、Enter を押して現在開いているプロジェクトにアクティビティを追加できます。

[アクティビティを表示] ボタンは、お気に入りのアクティビティ、最近使用したアクティビティ、使用可能なアクティビティ、非推奨のアクティビティを表示するオプションのリストを開きます。[お気に入りをピン留め] オプションでは、お気に入りのアクティビティをパネル上に常時表示します。

属するパッケージによるアクティビティをグループ化するには、[アクティビティを表示] ボタンをクリックして、[パッケージごとにグループ化] を選択します。これで、[アクティビティ] パネルにグループ化されます。

パネルのアクティビティにカーソルを置くと、そのアクティビティが属するパッケージとそのツールチップが表示されます。

パネル内のアクティビティを右クリックして、[テスト ベンチを作成] を選択して 1 つ以上のアクティビティをテストしてから、プロジェクトに追加します。この詳細はこちらをご覧ください。

📘

注:

検索ボックスでは、Studio で設定したインターフェイス言語にかかわらず、アクティビティのクラス名でアクティビティを特定できます。

[スニペット] パネル

[スニペット] パネルでは、オートメーションを簡単に再利用できます。既定で、複数のサンプルとスニペットが含まれています。

[フォルダーを追加] ボタンをクリックして、ハードディスク ドライブからディレクトリを選択することで、独自のフォルダーを追加できます。空のフォルダーは表示されません。

フォルダーを削除するには、フォルダーを右クリックして [削除] を選択します。

[プロジェクト] パネル

[プロジェクト] パネルでは、現在のプロジェクトの内容の確認、フォルダーの追加、ファイルの場所を開く、依存関係の管理、プロジェクト設定の調整などの操作が行えます。

Option

Description

Expand Allexpand_allexpand_all

Expands all nodes in the automation project.

Collapse Allcollapse_allcollapse_all

Collapses all nodes in the automation project.

Refreshrefreshrefresh

Refreshes the project.

Show All Filesshow_filesshow_files

Shows all files belonging to the automation project, including the project.json.

File Explorerfile_explorerfile_explorer

Opens the project's location on the machine.

Project Settingsproject_settingsproject_settings

Opens the Project Settings window for processes or libraries.

Remove Unused Screenshotsremove_screenshotsremove_screenshots

Removes screenshots that aren't used when running the automation project.

プロジェクトのコンテキスト メニュー

[プロジェクト] パネルの任意の場所を右クリックして、次の選択肢のあるコンテキスト メニューを開きます。

Option

Description

Open Project Folder

Opens the local folder containing the project.

Project Settings

Opens the Project Settings window for adjusting project preferences.

Add

Opens a list of items that can be added to the project: folder, sequence, flowchart, state machine or global handler.

Import Workflows

Imports .xaml files to the project and adds Imported in the file name if it coincides with the name of the main file.

Add to Source Control

Adds the current project to source control using Git Init, Copy to Git, Add to TFS, or Add to SVN options. Please note that this option is only visible when right-clicking the project node.

Open

Opens the selected files using the default program.

Open File Location

Opens the local folder containing the file.

Rename

Enables you to rename the selected file or folder, and opens the Rename Item window. The item is renamed in all occurrences.

Delete

Deletes the selected item only from your local machine.

Select for Compare

Selects the current file for comparison.

Compare with Selected

Compares the current file with the previously selected file using Compare Files.

Run

Runs the selected .xaml file.

Set as Main

Sets the selected .xaml file as Main in the project definition, meaning that the project execution starts with that file. There can only be one Main project file.

Make private or public

Makes the workflow contained in the library, either public or private. After publishing, the public workflow is available in the Activities panel.

Properties

Open the library’s Properties window for adding a tooltip and Help Link.

Set as Global Handler

Sets the .xaml file as the Global Exception Handler for the project. This is applicable to one workflow per project/process.

Remove Handler

Removes the Global Exception Handler tag from the .xaml file.

プロパティ パネル

プロパティパネルには状況に応じた内容が表示され、選択したアクティビティのプロパティを表示したり変更したりできます。同じワークフローで 2 つのアクティビティを選択した場合、[プロパティ] パネルから共通のプロパティを変更できます。

アウトライン パネル

[概要] パネルには、プロジェクトの下位層、使用可能なすべてのノードが表示されます。デザイナーパネルでアクティビティを選択して、このパネルでアクティビティを強調表示することができます。または、[概要] パネルで特定のアクティビティを選択して、そのアクティビティに移動することができます。

出力パネル

[出力] パネルでは、特に、[メッセージをログ] アクティビティまたは [1 行を書き込み] アクティビティの出力を表示できます。このパネルには、パッケージの例外も表示されます。

[出力] パネルのヘッダーのボタンをクリックすると、異なるログ レベル (エラー、警告) のメッセージを表示または非表示にすることができます。メッセージをダブルクリックすると、メッセージの詳細が表示されます。また、この情報をコピーすることもできます。

[出力] パネルでログを検索し、検索結果のリストから項目を選択すると、ログが強調表示されます。

[ログをエクスポート] ボタンは .txt ファイルにログをエクスポートするために使用されます。タイムスタンプとエラー メッセージの詳細もエクスポートします。絞り込まれたログのエクスポートが可能です。たとえば、トレース レベルのログのみをエクスポートする場合は、リストを絞り込んでから、[ログをエクスポート] ボタンを使用します。

デバッグ時には、アクティビティの実行が開始されてから終了する前のログが [出力] パネルに表示されます。これは、[デバッグ] タブの [アクティビティをログ] オプションから有効化できます。

[エラー リスト] パネルは、検証プロセス中にファイルまたはプロジェクトで見つかったエラーを「ワークフロー アナライザーについて」のルールによって生成されたエラーと一緒に表示します。

[出力] パネルに表示されるすべての情報は、[すべてクリア] ボタンで消去できます。ワークフローの実行時に、このパネルのログやその他のデータが消去されます。[出力] パネルには、一度に 2,000 行まで表示できます。

Orchestrator リソース パネル

ロボットが Orchestrator に接続されている場合、Studio の [Orchestrator リソース] パネルでアセット、キュー、プロセスを読み込むことができます。手順については、「ロボットを Orchestrator に接続」のページをご覧ください。

Orchestrator に接続されているロボットの種類が標準の場合、[Orchestrator リソース] パネルには、このロボットがプロビジョニングされたクラシック フォルダーのみを表示できます。

ロボットの種類がフローティングの場合、パネルには、このロボットがアクセスできるすべてのクラシック フォルダーとモダン フォルダーが表示されます。 Orchestrator でのロボットの作成について詳しくは、こちらをご覧ください 。

パネルには、Orchestrator クラシック フォルダーまたはモダン フォルダーにあるアセット、キュー、およびプロセスが表示されます。詳しくは、「フォルダーについて」をご覧ください。

📘

注:

手動でプロビジョニングされた従来のロボットを使用する場合、パネルに表示するには、対応するリソース (アセット、キュー、プロセス) に対して View 権限を付与する必要があります。ロールと権限のセットアップについて詳しくは、『Orchestrator ガイド』の「ロールについて」をご覧ください。

パネルにリソースを読み込むには、Studio のステータス バーで [更新] ボタンをクリックします。上の画像に示すように、矢印の横にあるテキストをクリックして、フォルダーを切り替えます。

ステータス バーのテキストにカーソルを置くと、Orchestrator の URL と現在のフォルダーの名前が表示されます。[Orchestrator リソース] パネル内の任意の項目を右クリックして、その名前をコピーし、そのようなリソースを操作するアクティビティで使用します。

1 年前に更新


ユーザー インターフェイス


改善の提案は、API リファレンスのページでは制限されています

改善を提案できるのは Markdown の本文コンテンツのみであり、API 仕様に行うことはできません。