Abonnieren

UiPath Studio

UiPath Studio-Anleitung

Die Benutzeroberfläche

UiPath Studio enthält mehrere Panels für den einfacheren Zugriff auf bestimmte Funktionalitäten. Diese können entweder angedockt werden, als schwebende Fenster fungieren oder die Option Automatisch ausblenden der Dropdownliste kann aktiviert werden.

Das Menüband

The ribbon is straightforward and can be minimized or expanded by clicking the Minimize / Expand button minimize_expandminimize_expand. It consists of the following three tabs:

  1. Start - Starten Sie ein neues Projekt ausgehend vor vordefinierten Vorlagen, oder öffnen Sie ein Projekt, an dem Sie kürzlich gearbeitet haben. Projekte können der Liste Zuletzt verwendete öffnen hinzugefügt oder aus ihr entfernt werden. Wenn Sie mit dem Mauszeiger darauf zeigen, wird die Beschreibung des Projekts angezeigt. Standardmäßig werden Projekte in C:\Users\<current_user>\Documents\UiPath erstellt. Mit der Schaltfläche Lokales Projekt öffnen suchen Sie nach project.json-Dateien.
11951195

📘

Hinweis:

Beim Aktualisieren von Studio auf eine neuere Version als v2018.3 wird die Projektliste Zuletzt verwendete öffnen zurückgesetzt.

  1. Design – Ergänzen Sie Ihr Projekt mit Sequences, Flowcharts und State Machines, installieren und verwalten Sie Aktivitätenpakete, erstellen Sie Interaktionen mit Elementen der grafischen Bedienoberfläche, exportieren Sie Workflows nach Excel, und veröffentlichen Sie Ihre Arbeit in Orchestrator oder benutzerdefinierten Feeds. Denken Sie daran, dass Assistenten und UI-Explorer im Menüband nur dann sichtbar sind, wenn Sie das Paket UiPath.UIAutomation.Activities installieren.
10951095
  1. Debuggen – Debuggen Sie Ihren Workflow. Setzen Sie Haltepunkte mit Debugging-Tools, überwachen Sie die Ausführung der Aktivitäten Schritt für Schritt, und passen Sie die Geschwindigkeit der Fehlersuche an. Öffnen Sie Protokolle, um die Ausführungsdetails und an dem Projekt vorgenommene Änderungen zu überprüfen. Weitere Informationen zum Debuggen finden Sie auf der Seite Über Debugging.
716716

📘

Hinweis:

Dateien, die nicht während der Ausführung des Automationsprojekts erstellt wurden, sind bei Veröffentlichung in Orchestrator schreibgeschützt. Wenn Ihr Geschäftsprozess es erfordert, dass Sie an einem bestimmten Punkt einer bestimmten Datei schreiben, achten Sie darauf, diese beim Projektdesign zu erstellen.

Die Registerkarte Extras (Tools)

The Tools tab can be used for installing extensions for Chrome, Firefox, Edge, Java, Silverlight, Citrix, and Windows Remote Desktop, and for launching the UI Explorer and Project Dependencies Mass Update Tool. For more information on extensions, check the About Extensions page.

13351335

The Project Dependencies Mass Update Tool is also located under the Tools tab, offering a user-interface tool for updating dependencies versions on multiple projects at once, located locally or in remote source control repositories.

Die Registerkarte Einstellungen (Settings)

Auf der Registerkarte Einstellungen (Settings) finden Sie Optionen zum Ändern der Sprache der Bedienoberfläche, des Themas oder der Einstellung globaler Präferenzen und die Verwaltung von Aktivitäts-Feeds.

Allgemein

Der Unterabschnitt Allgemein enthält die Option zum Ändern der Sprache der Bedienoberfläche für Studio und Robot durch Auswählen einer der verfügbaren Sprachen: Englisch, Japanisch, Französisch, Russisch, Chinesisch (vereinfacht), Deutsch, Spanisch, Spanisch (Lateinamerika), Portugiesisch (Portugal), Portugiesisch (Brasilien), Koreanisch oder Türkisch.

11251125

Das Thema der Studio-Bedienoberfläche kann im Dropdownmenü umgeschaltet werden. Wählen Sie entweder Leichtes (Light) oder Dunkles (Dark) Thema und starten Sie Studio neu, um die Änderungen zu übernehmen.

Studio erkennt Hohen Kontrast (High Contrast) auf dem Computer und schaltet nach dem Neustart in diesen Modus um.

12911291

📘

Hinweis:

Damit das dunkle Design funktioniert, müssen Automatisierungsprojekte mindestens UiPath.UIAutomation.Activities v18.4.2 und UiPath.System.Activities v18.4.1 als Abhängigkeiten haben.

Mit der Schaltfläche Einstellungen zurücksetzen werden alle allgemeinen und Designeinstellungen in Studio in den Standardzustand zurückgesetzt. Beachten Sie jedoch, dass dies keine Auswirkungen auf Feeds oder Favoriten-Aktivitäten hat.

Außerdem werden die folgenden Einstellungen auf den Standardzustand zurückgesetzt:

  • Die Liste der zuletzt verwendeten Dateien;
  • Die Liste der Favoriten-Aktivitäten;
  • Anpassungen des Studio-Layouts;
  • Die Option Bei Ausnahmen unterbrechen auf der Registerkarte Ausführen > Optionen;
  • Optionen von Aktivitäten anzeigen und angeheftete Aktivitäten im Aktivitätenbereich;
  • Vom Benutzer hinzugefügte Ordner im Bereich Snippets, das letzte Verzeichnis, in dem Sie ein Projekt geöffnet haben, und der Updatekanal, der auf Stabilumgestellt wird.

Design

Dieser Unterabschnitt enthält einen Satz globaler Einstellungen, die für alle Projekte gelten, welche in dieser Studio-Version geöffnet werden.

12831283

Speichern und Veröffentlichen

Mit dem automatischen Sicherungsintervall (Auto backup interval) können Sie ein regelmäßiges Intervall festlegen, mit dem die Projekte automatisch gespeichert werden. Dies ist nützlich für die Wiederherstellung der zuletzt gespeicherten Kopie des Workflows. Der Standardwert ist 30.000 Millisekunden. Der Mindestwert beträgt 10.000, der Höchstwert 9.999.999 ms.

Das Timeout für die Projektveröffentlichung (Project timeout) gibt die Zeitüberschreitung für die Veröffentlichung von Projekten an. Der Standardwert beträgt 30 Sekunden. Das maximale Timeout beträgt 999.999 Sekunden, das minimale 1 Sekunde.

In der Dropdownliste Verhalten beim Öffnen von Projekten können Sie auswählen, welche Dateien standardmäßig geöffnet werden sollen, wenn ein Projekt erneut geöffnet wird. Zur Auswahl stehen Zuletzt geöffnete Registerkarten behalten, Haupteinstiegspunkt öffnen und Keine Registerkarten.

The Enforce Analyzer on Publish toggle allows or restricts publishing of projects with Workflow Analyzer errors.

Execution

Die Größe der Ausgabekonsole liegt bei bis zu 9.999 Zeilen in einer einzelnen Sitzung, die im Panel Ausgabe angezeigt werden sollen. Der Standardwert beträgt 2.000 Zeilen. Der maximale Wert, der hinzugefügt werden kann, beträgt 9.999 Sekunden, der minimale 1 Zeile.

Mit der Umschaltfunktion Bei Ausführung minimieren (Minimize on run) können Sie Studio beim Ausführen von Projekten auf Maximieren oder Minimieren festlegen.

Activities Design Style

Der Schalter Angedockte Anmerkungen erstellen ermöglicht die Erstellung angedockter und unverankerter Anmerkungen für Aktivitäten im Projekt.

Locations

Um den Standardspeicherort zu ändern, an dem Projekte erstellt werden, fügen Sie einfach im Feld Projektpfad (Project Path) den neuen Pfad hinzu.

Im Feld Bibliotheks-URL veröffentlichen (Publish Library URL) können Sie einen Standardspeicherort hinzufügen, an dem alle Bibliotheken veröffentlicht werden, wenn die Option benutzerdefinierter Feed aktiviert ist.

Prozess-URL veröffentlichen (Publish Process URL) funktioniert genauso, nur für Prozesse. Es ermöglicht Ihnen, einen Standardspeicherort anzugeben, an dem alle Prozesse veröffentlicht werden, wenn die Option benutzerdefinierter Feed aktiviert ist.

11261126

Quellen verwalten

Verwalten Sie Feeds für Aktivitätspakete aus der Studio Backstage-Ansicht, ohne ein Projekt öffnen zu müssen. Dieser Abschnitt entspricht demjenigen im Fenster Pakete verwalten (Manage Packages), in den Sie Feeds projektweise anpassen können.

11251125

📘

Hinweis:

Der Aktivitäts-Feed Lokal (Local) ist per Standard aktiviert. Der Feed Orchestrator (Orchestrator) ist auch dann aktiviert, wenn der Roboter mit Orchestrator verbunden ist.

Lizenz und Profil

Use this tab to activate a Community or Enterprise license, or license Studio through Orchestrator.

11251125

Außerdem können Sie zwischen Studio- und StudioX-Profilen hin- und herwechseln.

999999

Die Registerkarte Hilfe (Help)

The Help tab directs you to product documentation, release notes, online resources, the Community Forum and the RPA Academy.

Überdies finden Sie auf der Seite Hilfe (Help) Hinweise zur Produktversion und zur Installation, zur Lizenzverfügbarkeit, zum Aktualisieren der Kanal- und Geräte-ID zusammen mit einer Schaltfläche Info kopieren (Copy Info) zum schnellen Kopieren von Details ins Clipboard.

298298

Das Menüband enthält eine Verknüpfung mit Hilfelinks, die über das unten abgebildete Symbol zugänglich sind:

226226

Feedback senden

There are two types of feedback that you can send directly from within Studio: Submit an idea for the product or Report a bug. Both are accessible from the ribbon by clicking the send_feedbacksend_feedback icon.

The Send Feedback feature must be used only for sending anonymous feedback to the product team. To contact our tech support team, please use the Contact Technical Support form.

688688

Wählen Sie im Dropdownmenü Ich möchte entweder Eine Idee für das Produkt übermitteln oder Einen Fehler melden aus. Wählen Sie im Abschnitt Für in dem Dropdownmenü eine der Optionen UiPath-Aktivitäten, UiPath Studio, UiPath Robot oder UiPath Orchestrator aus.

Fügen Sie Ihrer Anfrage einen Schweregrad hinzu, indem Sie im Dropdownmenü entweder Wünschenswert, Wichtig oder Kritisch auswählen. Fügen Sie im Feld Betreff einen kurzen Titel hinzu.

Fügen Sie eine detaillierte Beschreibung hinzu, und hängen Sie bis zu 6 Bilder, Videos oder Textdateien an, die jeweils kleiner als 10 MB sind.

Die Befehlspalette

Die Befehlspalette wird über die Tastenkombinationen Strg+Umschalt+P bzw. F3 oder per Klick auf die Suchschaltfläche. Sie umfasst die Suchleisten Aktivität hinzufügen, Universelle Suche, Zu Datei wechseln und Zu Aktivität wechseln.

892892

Aktivität hinzufügen

Die Suchleiste Aktivität hinzufügen wird mit der Tastenkombination Strg+Umschalt+T geöffnet. Sie können nach Aktivitäten in installierten Paketen suchen und diese nach der ausgewählten Aktivität in der Datei hinzufügen. Die Leiste weist den ersten fünf Ergebnissen automatisch Tastenkombinationen zu. Die vorherigen Ergebnisse bleiben erhalten.

942942

Click the plus_iconplus_icon icon at the top or bottom of an activity from a sequence to open the Add activity search bar.

Die universelle Suche

Die Leiste für die universelle Suche ermöglicht die Suche nach Snippets, Aktivitäten, Projektabhängigkeiten und Dateien, die Teil Ihres aktuellen Projekts sind.

946946

Option

Shortcut

Description

Current File

Ctrl + 1

Lists results from the currently opened file that match the search query.

All Files

Ctrl + 2

Lists results found in all files part of the current project that match the search query.

Activities

Ctrl + 3

Lists results from activities that match the search query.

Variables

Ctrl + 4

Finds variables in the current project that match the search query.

Arguments

Ctrl + 5

Finds arguments defined in the project that match the search query.

Imports

Ctrl + 6

Finds imported namespaces in the project that match the search query.

Project Files

Ctrl + 7

Finds files part of the current project that match the search query.

Dependencies

Ctrl + 8

Lists results found in dependencies installed to the project.

Snippets

Ctrl + 9

Finds snippet files that match the search query.

Die Suchergebnisse bleiben bis zum nächsten Öffnen der Suchleiste erhalten, falls Sie die universelle Suche oder Aktivität hinzufügen verwenden. Bei Zu Datei wechseln und Zu Aktivität wechseln bleibt die vorherige Suchanfrage nicht erhalten.

Doppelklicken Sie auf eine Aktivität, oder drücken Sie die Eingabetaste, um Sie der aktuell geöffneten Datei hinzuzufügen. Mit denselben Befehlen können Sie Dateien aus den Kategorien Alle Dateien und Projektdateien öffnen oder das gewünschte Suchergebnis fokussieren.

Beachten Sie, dass Suchergebnisse Inkonsistenzen enthalten können, wenn Pakete zuvor aus dem Projekt deinstalliert wurden. Darüber hinaus gibt die Leiste Universelle Suche Ergebnisse von Anmerkungen nur aus .xaml-Dateien zurück, die im Bereich Designer geöffnet wurden.

Zu Datei wechseln

Die Leiste Zu Datei wechseln sucht und öffnet Dateien aus dem aktuellen Projektordner. .xaml-Dateien werden in Studio im Panel Designer geöffnet. Andere Dateien, z. B. Screenshots oder Excel-Dateien werden in der jeweiligen Standardanwendung auf Ihrem Gerät geöffnet. Doppelklicken Sie, oder drücken Sie die Eingabetaste, um eine Datei zu öffnen.

943943

📘

Hinweis:

Die Panels Aktivitäten und Projekt sowie die Befehlspalette unterstützen die Fuzzy-Suche. Das bedeutet, dass eine Liste von Ergebnissen zurückgegeben wird, auch wenn die Suchbegriffe nicht genau übereinstimmen. Die Suchbegriffe können leicht unvollständig oder falsch geschrieben sein oder nur den ersten Buchstaben eines jeden Wortes enthalten. Beispiel: Wenn Sie dci in die Leiste Aktivitäten eingeben, wird die Aktivität Double Click Image zurückgegeben.

Zu Aktivität wechseln

Die Suchleiste Zu Aktivität wechseln ist Teil der Befehlspalette und hilft Ihnen, bestimmte Aktivitäten in umfangreichen Workflows zu finden und zu fokussieren. Öffnen Sie sie entweder mit der Tastenkombination Strg + J, oder indem Sie die Tastenkombinationen F3 und Strg + Umschalt + P verwenden und dann Zu Aktivität wechseln auswählen.

Wenn sie geöffnet ist, zeigt die Leiste Zu Aktivität wechseln die Liste aller Aktivitäten in der .xaml-Datei, die im Panel Designer aktuell fokussiert ist.

Geben Sie den Anzeigenamen oder den Namespace einer Aktivität ein, z. B. Assign. Wählen Sie mithilfe der Pfeiltasten die Aktivität aus, und drücken Sie die Eingabetaste, um sie im Panel Designer zu fokussieren.

Aktivitäten in der Leiste Zu Aktivität wechseln werden in der folgenden Reihenfolge sortiert: Container, übergeordnete Aktivitäten und untergeordnete Aktivitäten.

635635

Das Designer-Panel

The Designer panel displays your current automation project, enables you to make changes to it, and provides quick access to variables, arguments and imports.

Sie können innerhalb eines Diagramms navigieren, indem Sie auf die Aktivität doppelklicken, die Sie anzeigen möchten. Der Pfad wird als Breadcrumbs im Header des Bereichs Designer angezeigt. Beachten Sie, dass bei Verwendung mehrerer unterschiedlich skalierter Anzeigen der Text im Eingabefeld einiger Aktivitäten möglicherweise nicht korrekt angezeigt wird.

Aktivitäten können mit der Tastenkombination Strg+C oder dem Kontextmenü in einen Texteditor kopiert werden, Änderungen empfangen und dann zurück in das Panel Designer kopiert werden.

585585

Aktivieren Sie den Panoramamodus, indem Sie auf das Symbol pan_modepan_mode klicken, die Leertaste gedrückt halten oder die mittlere Maustaste drücken. Verwenden Sie die Zoom-Dropdown-Liste, um die Zoomstufe zu ändern, und klicken Sie auf das Symbol reset_zoomreset_zoom, um sie wieder auf 100% zurückzusetzen.

Das Symbol An Bildschirm anpassen fit_screenfit_screen ändert den Zoom so, dass der gesamte Workflow in das Designer-Panel passt. Klicken Sie auf das Symbol overviewoverview, um einen Überblick über das gesamte Projekt zu erhalten und durch die Abschnitte zu navigieren, indem Sie den Fokus einstellen.

822822

Das Kontextmenü

294294

Über das Kontextmenü können Sie mehrere Vorgänge in Ihrem Workflow ausführen, sei es eine Sequence oder ein Flowchart. Um es anzuzeigen, klicken Sie mit der rechten Maustaste auf eine Aktivität in Ihrem Workflow.

📘

Hinweis

Wenn Sie mehr Aktivitäten auswählen, wird das Menü überhaupt nicht angezeigt.

Feldbeschreibungen für das Kontextmenü

Option

Description

View Parent

Displays the parent of the target activity in the Designer panel.
Note: This option is only displayed for child-activities, if they are opened in the Designer panel.

Open

Opens the selected activity in the Designer panel. Has the same result as double-click.

Collapse

Collapses the activity thus reducing the displayed details to "Double-click to view". You can achieve the same result by clicking the Collapse button **Collapse****Collapse**.
Note: Only displayed for sequences.

Expand in Place

Expands the content of the activity, displaying its detailed content. You can achieve the same result by clicking the Expand button **Expand****Expand**.
Note: Only displayed for sequences.

Cut

Removes the selected activity and places it onto the Clipboard.

Copy

Copies the selected activity and places it onto the Clipboard. Activities from read-only files can be copied to another workflow or a .txt file. When copying multiple activities to clipboard, their order is reversed.

Paste

Inserts the content of the Clipboard at the current location.

Delete

Deletes the target activity.

Note: Since the Context menu is only displayed for a one-activity selection, you can use this command for more activities with the corresponding keyboard shortcut, Delete.

Annotations

Add, edit, delete, show and hide annotations added to activities in the workflow.

Copy as Image

Makes a screenshot of the content displayed in the Designer panel.

Note: If you want to make a screenshot of a child activity, make sure to firstly open it in the Designer panel.

Save as Image

Makes a screenshot of the content displayed in the Designer panel and prompts the user to set the details for saving it (Name, Type, Destination). Supported formats: JPG, PNG, GIF, XPS.

Create Variable

Creates a variable in the Variable panel.

Auto Arrange

Automatically arranges activities in a flowchart.

Remove Surrounding Sequence

Removes the selected Sequence activity from the Designer panel. The activities that it contains are moved to the parent sequence.

Surround with Try Catch (Ctrl + T)

Inserts the activity in a Try Catch statement.

Note: A Try Catch statement is used for handling exceptions caused by data or coding errors. The Try clause encloses the activity to be checked for exceptions. The Catches clause is the exception handler. The Finally clause is used for executing an activity regardless of the status of the first two clauses.

Extract as Workflow

Creates a new workflow containing the targeted activity with the purpose of breaking down a large project into smaller ones. In the place of the extracted activity an Invoke <new> workflow activity is created which enables you to edit and import arguments from the newly created workflow. The arguments are created automatically from the variables used in that activity. The Invoke <new> workflow activity automatically maps the local variables to invoke arguments for the extracted workflow.

Open Workflow

Opens a workflow created using the above option.

Enable Activity

Enables a previously disabled activity.

Disable Activity

Disables an activity, which is then placed inside a Comment out activity.

Toggle Breakpoint

Marks the selected activity as a breakpoint for debugging. Breakpoints can also be toggled by clicking the Breakpoint button in the Execute tab. You can trigger a breakpoint for one activity at a time.

Edit Breakpoint Settings

Opens the Breakpoint Settings window.

Run to this Activity

Debugs the project and stops before this particular activity is executed.

Run from this Activity

Starts debugging from this activity.

Show All Conditions

Displays all conditions defined in your project (Properties panel > Conditions).

Note: This option is only displayed for flowcharts when you right-click an empty space inside the project; it is not displayed if you right-click an activity in your flowchart.

Hide All Conditions

Hides all displayed conditions.

Note: This option is only displayed for flowcharts when you right-click an empty space inside the project; it is not displayed if you right-click an activity in your flowchart.

Set as Start Node

Connects the selected activity with the Start node.
Note: Only displayed for flowcharts.

Set as Initial State

Connects the State Machine specific activity to with the Start node.
Note: Only displayed for state machines.

Das Kontextmenü wird auch für Registerkarten im Panel Designer (Designer) angezeigt. Die folgenden Optionen sind verfügbar:

Option

Description

Close

Closes the active tab.

Close Others

Closes all tabs but the active one.

Close All Documents

Closes all tabs.

Float

Undocks the target tab and changes it to a floating state.

Pin Tab

Pins the target tab in the Designer panel.
Note: The tab pinned last is always moved in front of all other existing tabs (pinned or not). The position of a pinned tab can only be changed relative to other pinned tabs.

New Horizontal Tab Group

Splits the screen horizontally, enabling you to see two or more instances of the Designer panel within the same screen. The target project is moved onto the panel on the right.
Note: Only displayed when your project contains two or more tabs and, implicitly, workflows.

New Vertical Tab Group

Splits the screen vertically, enabling you to see two or more instances of the Designer panel within the same screen. The target project is moved onto the panel at the bottom.
Note: Only displayed when your project contains two or more tabs and, implicitly, workflows.

Move to Previous Tab Group

Moves the target tab onto the previous Designer panel displayed.
Note: Only displayed if you had used the New Vertical Tab Group or New Horizontal Tab Group options before.

Move to Next Tab Group

Moves the target tab onto the next Designer panel displayed.
Note: Only displayed if you had used the New Vertical Tab Group or New Horizontal Tab Group options before.

Das Aktivitäten-Panel

311311

The Activities panel shows available activities that can be added to the current workflow. Use the search box to find activities, navigate through them using navigation keys and press Enter to add an activity to the currently opened file.

Mit der Schaltfläche Aktivitäten anzeigen (Show Activities) öffnen Sie eine Liste mit Optionen zum Anzeigen von favorisierten, kürzlich verwendeten, verfügbaren und kompatiblen Aktivitäten. Die Option Favoriten anheften (Pin Favorites) ermöglicht Ihnen, alle favorisierten Aktivitäten jederzeit im Panel im Blick zu behalten.

Klicken Sie auf die Schaltfläche Aktivitäten anzeigen, und wählen Sie die Option Nach Paketen gruppieren aus, um Aktivitäten nach den Paketen zu gruppieren, zu denen sie gehören. Sie sind jetzt im Panel Aktivitäten gruppiert.

Wird mit der Maus auf eine Aktivität im Panel gezeigt, wird das Paket, zu dem sie gehört, und der Tooltip angezeigt.

446446

Right-click an activity in the panel and select Create Test Bench to test out one or more activities before adding them to a project. Read more about this here.

📘

Hinweis:

Im Suchfeld können Sie Aktivitäten nach Klassennamen suchen, ohne die in Studio eingestellte Bedienoberfläche zu berücksichtigen.

Das Snippets-Panel

392392

Im Snippets-Panel können Sie Automationen einfach wiederverwenden. Es enthält per Standard mehrere Beispiele und Snippets.

You can add your own by clicking the Add Folder button and selecting a directory from your hard drive. Empty folders are not displayed.

Um einen Ordner zu entfernen, klicken Sie mit der rechten Maustaste darauf und wählen Sie Entfernen (Remove) aus.

Das Projekt-Panel

392392

Im Panel Projekt (Project)können Sie den Inhalt des aktuellen Projekts anzeigen, Ordner hinzufügen, den Speicherort der Datei öffnen, Abhängigkeiten verwalten und Prozesseinstellungen anpassen.

Option

Description

Expand Allexpand_allexpand_all

Expands all nodes in the automation project.

Collapse Allcollapse_allcollapse_all

Collapses all nodes in the automation project.

Refreshrefreshrefresh

Refreshes the project.

Show All Filesshow_filesshow_files

Shows all files belonging to the automation project, including the project.json.

File Explorerfile_explorerfile_explorer

Opens the project's location on the machine.

Project Settingsproject_settingsproject_settings

Opens the Project Settings window for processes or libraries.

Remove Unused Screenshotsremove_screenshotsremove_screenshots

Removes screenshots that aren't used when running the automation project.

Kontextmenü für Projekte

Klicken Sie mit der rechten Maustaste an eine beliebige Stelle im Panel Projekt, um das Kontextmenü mit den folgenden Optionen zu öffnen:

Option

Description

Open Project Folder

Opens the local folder containing the project.

Project Settings

Opens the Project Settings window for adjusting project preferences.

Add

Opens a list of items that can be added to the project: folder, sequence, flowchart, state machine or global handler.

Import Workflows

Imports .xaml files to the project and adds Imported in the file name if it coincides with the name of the main file.

Add to Source Control

Adds the current project to source control using Git Init, Copy to Git, Add to TFS, or Add to SVN options. Please note that this option is only visible when right-clicking the project node.

Open

Opens the selected files using the default program.

Open File Location

Opens the local folder containing the file.

Rename

Enables you to rename the selected file or folder, and opens the Rename Item window. The item is renamed in all occurrences.

Delete

Deletes the selected item only from your local machine.

Select for Compare

Selects the current file for comparison.

Compare with Selected

Compares the current file with the previously selected file using Compare Files.

Run

Runs the selected .xaml file.

Set as Main

Sets the selected .xaml file as Main in the project definition, meaning that the project execution starts with that file. There can only be one Main project file.

Make private or public

Makes the workflow contained in the library, either public or private. After publishing, the public workflow is available in the Activities panel.

Properties

Open the library’s Properties window for adding a tooltip and Help Link.

Set as Global Handler

Sets the .xaml file as the Global Exception Handler for the project. This is applicable to one workflow per project/process.

Remove Handler

Removes the Global Exception Handler tag from the .xaml file.

Das Eigenschaften-Panel

383383

Das Panel Eigenschaften (Properties) ist kontextabhängig und ermöglicht das Anzeigen und Ändern der Eigenschaften einer ausgewählten Aktivität. Wenn Sie zwei Aktivitäten in ein- und demselben Workflow auswählen, können gemeinsame Eigenschaften aus dem Panel Eigenschaften (Properties) geändert werden.

Das Gliederungspanel

383383

Im Panel Gliederung werden die Projekthierarchie und alle verfügbaren Knoten angezeigt. Sie können Aktivitäten in diesem Panel markieren, indem Sie sie im Panel Designer auswählen, oder zu einer bestimmten Aktivität wechseln, indem Sie sie im Panel Gliederung auswählen.

Das Ausgabe-Panel

756756

Das Panel Ausgabe (Output) ermöglicht Ihnen unter anderem die Ausgabe der Aktivitäten Protokollnachricht (Log Message) oder Zeile schreiben (Write Line). Ausnahmen für Pakete werden in diesem Panel ebenfalls angezeigt.

Über das Panel Ausgabe (Output) können Sie Meldungen ein- oder ausblenden, die unterschiedliche Protokollierungsstufen (Fehler, Warnungen) aufweisen. Dazu müssen Sie auf die Schaltflächen im Panel-Kopf klicken. Durch Doppelklicken auf eine Nachricht werden weitere Details über diese angezeigt, mit der Option, Informationen zu kopieren.

Wenn Sie im Panel Ausgabe nach einem Protokoll suchen und ein Element der Suchergebnisliste auswählen, wird das Protokoll hervorgehoben.

Mit der Schaltfläche Protokolle exportieren exportieren Sie Protokolle in eine .txt-Datei. Zeitstempel und Fehlermeldungen werden ebenfalls exportiert. Es ist möglich, gefilterte Protokolle zu exportieren. Wenn Sie beispielsweise nur Protokolle der Verfolgungsebene exportieren möchten, filtern Sie die Liste, und benutzen Sie dann die Schaltfläche Protokolle exportieren.

Beim Debugging zeigt das Panel Ausgabe Protokolle für die Ausführungsstartzeit einer Aktivität bis zu deren Ende an. Dies können Sie mit der Option Aktivitäten protokollieren auf der Registerkarte Debuggen aktivieren.

The Error List panel displays errors found in the file or project during the validation process, together with errors generated by About Workflow Analyzer rules.

Mit der Schaltfläche Alle löschen (Clear All) löschen Sie alle Informationen, die im Panel Ausgabe (Output) angezeigt werden. Protokolle und andere in diesem Panel gespeicherte Daten werden beim Ausführen des Workflows gelöscht. Im PanelAusgabe (Output) werden bis zu 2.000 Zeilen gleichzeitig angezeigt.

Das Ressourcen-Panel von Orchestrator

The Orchestrator Resources panel in Studio can load assets, queues and processes, provided that the Robot is connected to Orchestrator. Read the Connecting Robots to Orchestrator page to find the steps.

Falls der mit dem Orchestrator verbundene Roboter den Typ Standard aufweist, dann kann im Panel Orchestrator-Ressourcen nur der klassische Ordner angezeigt werden, den der Roboter bereitgestellt hat.

Falls der Roboter den Typ Floating aufweist, dann zeigt das Panel alle klasischen und modernen Ordner an, auf dier der Roboter Zugriff hat. Weitere Informationen zur Erstellung von Robotern im Orchestrator findest du hier.

498498

The panel displays assets, queues, and processes found in Classic or Modern Folders in Orchestrator. Read more about Folders.

📘

Hinweis:

Wenn Sie einen klassischen, manuell bereitgestellten Roboter verwenden, müssen ihm View-Berechtigungen für die entsprechenden Ressourcen gewährt werden (d. h. Assets, Warteschlangen und Prozesse), damit sie im Panel angezeigt werden. Lesen Sie mehr über das Einrichten von Rollen und Berechtigungen in Orchestrator.

Um Ressourcen in das Panel zu laden, klicken Sie auf der Studio-Statusleiste auf die Schaltfläche Aktualisieren. Wechseln Sie zwischen Ordnern, indem Sie auf den Text neben dem Pfeil klicken, wie in der Abbildung oben gezeigt.

Zeigen Sie mit dem Mauszeiger auf den Text in der Statusleiste, um die Orchestrator-URL und den Namen des aktuellen Ordners anzuzeigen. Klicken Sie mit der rechten Maustaste auf ein beliebiges Element im Panel Orchestrator-Ressourcen, um seinen Namen zu kopieren und es in Aktivitäten zu verwenden, die mit solchen Ressourcen interagieren.

Vor ungefähr einem Jahr aktualisiert


Die Benutzeroberfläche


Auf API-Referenzseiten sind Änderungsvorschläge beschränkt

Sie können nur Änderungen an dem Textkörperinhalt von Markdown, aber nicht an der API-Spezifikation vorschlagen.