Abonnieren

UiPath Studio

UiPath Studio-Anleitung

Softwareanforderungen

📘

Wichtig!

Bitte beachten Sie, dass Studio nicht kompatibel ist mit Computern, auf denen das Update KB4055002 auf Windows 7 SP1 oder Windows Server 2008 R2 SP1 installiert ist, und unterbrochen wird. Wenn Sie diese Betriebssystem-Version nutzen, empfehlen wir Ihnen, dieses .Net Framework-Update manuell zu deinstallieren und die nächste Version zu installieren (KB 4055532).

Supported Versions

Particularities

Operating System

Windows 7

Update KB 2533623 (required by OCR and Computer Vision activities)

Windows 7 N

Windows 7 SP1

Update for Universal C Runtime
Microsoft Visual C++ 2015 Redistributable Update 3 x86 version (required for GIT source control functionality)

Windows 8.1

Microsoft Visual C++ 2015 Redistributable Update 3 x86 version (required for GIT source control functionality)
Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 x86 (required for SVN source control on Studio v2019.10.5 and up)

Windows 8.1 N

Windows 10

Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 x86 (required for SVN source control on Studio v2019.10.5 and up)

Windows 10 N

Windows Server 2008 R2

Update KB 963697
Update KB 2999226
Desktop Experience feature
Microsoft Visual C++ 2015 Redistributable Update 3 x86 version (required for GIT source control functionality)

Windows Server 2012 R2

Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 x86 (required for source control on Studio v2019.10.5 and up).
This component is installed by default with the operating system and should be reinstalled if removed.

Windows Server 2016

Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 x86 (required for source control on Studio v2019.10.5 and up).
This component is installed by default with the operating system and should be reinstalled if removed.

Windows Server 2019

Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 and 2019 x86 (required for source control on Studio v2019.10.5 and up).
This component is installed by default with the operating system and should be reinstalled if removed.

Citrix environments (!)

XenApp v6.5 or greater

XenDesktop v7.0 or greater

.NET Framework

Version 4.6.1 or greater

If your machine runs Windows OS in a language other than English, install the corresponding language pack for the .Net framework version you are using.
This is required for running Studio in any of the available languages. The .Net framework and related language pack version must correspond, and any conflicting .Net framework versions installed on the machine should be removed.

Web Browsers (for browser automation)

Internet Explorer v8.0 or greater

Google Chrome version 64 or greater

Automated with the extension for Chrome or the Webdriver protocol.

Mozilla Firefox version 52.0 or greater

Automated with the extension for Firefox or the Webdriver protocol.

Microsoft Edge on Windows 10 version 1803 or greater

Automated with the extension for Edge.

(!) Studio kann in Citrix-Umgebungen installiert werden, aber es können bestimmte Probleme auftreten:

  1. Die Lizenzinformation ist nicht beständig;
  2. Der Name des Computers ändert sich jedes Mal, wenn er erstellt wird oder der Benutzer sich anmeldet.

Das erste Problem tritt immer bei Citrix-Umgebungen auf. Bestimmte Problemumgehungen können jedoch helfen:

Wenn der Computername sich ändert, ist es möglich, einen Task zu erstellen, der die Lizenz jedes Mal aktiviert, wenn der VDI erstellt wird oder der Benutzer sich anmeldet. Außerdem kann eine Verknüpfung erstellt werden, die die Lizenz mithilfe der Befehlszeile aktiviert und dann Studio öffnet.

Wenn sich der Computername nicht ändert, können die Lizenzierungsinformationen an einem dauerhaften Speicherort für diese Instanz (falls vorhanden) gespeichert werden, auf die alle Benutzer Zugriff haben. Platzieren Sie dazu den vollständigen Pfad des dauerhaften Speicherorts in der Datei license.config unter den Tags <WorkDir> und <LicDir>, wie im folgenden Screenshot gezeigt:

10801080

You can also check out software requirements for Orchestrator and Robot.

Vor ungefähr einem Jahr aktualisiert


Softwareanforderungen


Auf API-Referenzseiten sind Änderungsvorschläge beschränkt

Sie können nur Änderungen an dem Textkörperinhalt von Markdown, aber nicht an der API-Spezifikation vorschlagen.