Subscribe

UiPath Robot

The UiPath Robot Guide

Software Requirements

Supported Versions

Operating System

Windows 7 update KB 2533623 (required by OCR and Computer Vision activities)
Windows 7 N
Windows 7 SP1 Update for Universal C Runtime
Windows 8.1
Windows 8.1 N
Windows 10
Windows 10 N
Windows Server 2008 R2 update KB 963697, KB 2999226, and the Desktop Experience feature
Windows Server 2012 R2
Windows Server 2016
Please note that Windows Server 2016 must be installed with the Desktop Experience feature. This feature can not be added after installation, and a complete reinstallation of the Windows Server 2016 in this case. You can find out more information here.
Windows Server 2019
Citrix environments (!) - click here for the full list.
XenApp v6.5 or greater
XenDesktop v7.0 or greater

.NET Framework

minimum: 4.6.1
Please note that if your machine runs Windows OS in a particular language (other than English), make sure to install the corresponding language pack for the .Net framework version you are using. This is required for running Studio in any of the available languages. The .Net framework and related language pack version must correspond, and any conflicting .Net framework versions installed on the machine should be removed.

Web Browser (for browser automations)

Internet Explorer v8.0 or greater.
Google Chrome version 64 or greater. Automated with the extension for Chrome or the Webdriver protocol.
Mozilla Firefox version 52.0 or greater. Automated with the extension for Firefox or the Webdriver protocol.
Microsoft Edge on Windows 10 version 1803 or greater. Automated with the extension for Edge.

(!) Robots can be installed in Citrix environments if they meet the following requirements:

  • They are licensed through Orchestrator and not locally;
  • The machine name does not change every time it is spawned.

Please note that if you license your Robot locally, in the Citrix environment, you have to do it every time you start the Citrix machine.

📘

Important!

In rare cases, the Robot stops working and throws an error which states that it does not have access to a temporary file. This is caused by a Windows 7 or Windows Server 2008 R2 issue and can be solved by installing this hotfix. Apply this hotfix only to systems that are experiencing the problem described.

You can also check out software requirements for Studio and Orchestrator.

Updated about a year ago



Software Requirements


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.