問題
Microsoft Office アプリケーション、特に Excel でオートメーションを構築または実行するときに、さまざまなエラーが発生する可能性があります。
症状
Excel
- StudioX プロファイルでアクティビティを設定し、プラス
メニューの [Excel 内で示す] を選択するときに、以下のいずれかのエラーが発生します。
- ブックを開くときにエラーが発生しました。Excel がインストールされていることをご確認ください。
- Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).::(ライブラリが登録されていません。(HRESULT からの例外: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).::)

- Excel アクティビティの実行時に以下のエラーが発生します。
ブックを開くときにエラーが発生しました。Excel がインストールされていることをご確認ください。Unable to cast COM object of type 'Microsoft.Office.Interop.Excel.ApplicationClass' to interface type 'Microsoft.Office.Interop.Excel._Application'. ('Microsoft.Office.Interop.Excel.ApplicationClass' の種類の COM オブジェクトを 'Microsoft.Office.Interop.Excel._Application' の種類のインターフェイスにキャストできません。)

Word
- Word アクティビティの実行時に以下のエラーが発生します。
ドキュメントを開くときにエラーが発生しました。Word アプリケーションがインストールされていることをご確認ください。既にインストールされている場合は、Office の修復が必要な可能性があります。

Outlook
- The following error occurs when an Outlook activity runs, or when you are configuring an activity in the StudioX profile and you are trying to access Outlook data such as folders or accounts from the Plus
menu:
Property accessor 'Account' on object 'UiPath.Mail.Activities.Business.OutlookApplicationCard' threw the following exception:'Unable to cast COM object of type 'Microsoft.Office.Interop.Outlook.ApplicationClass' to interface type 'Microsoft.Office.Interop.Outlook._Application'... (オブジェクト 'UiPath.Mail.Activities.Business.OutlookApplicationCard' に対するプロパティ アクセサー 'Account' が次の例外をスローしました。'Microsoft.Office.Interop.Outlook.ApplicationClass' の種類の COM オブジェクトを 'Microsoft.Office.Interop.Outlook._Application' の種類のインターフェイスにキャストできません。...)

PowerPoint
- プレゼンテーション アクティビティの実行時に以下のエラーが発生します。
Cannot open PowerPoint
RemoteException wrapping UiPath.Presentations.PowerPointException: Please make sure PowerPoint is installed.

原因
Microsoft Office のインストールの問題により、Windows レジストリの COM 相互運用の設定が適切に行われなくなる可能性があります。これは、以下の場合に発生します。
- Microsoft Office をインストールし、その後削除してから、旧バージョンの Office をインストールした場合。
- Microsoft Office が既にインストールされているところに、既にインストールされているバージョンの Office のものとは異なる Office コンポーネントが付属する Skype for Business がインストールされた場合。
解決策
Microsoft Office 修復ツールを使用して Windows レジストリをチェックし、オートメーション構築時のエラーの原因となる Microsoft Office アプリケーションの一般的な問題を修復します。Microsoft の Office 修復ツールを実行するためにも使用できます。このツールにより、お使いのマシンに対して実行したり、他のマシンにエクスポートしてデプロイできる、修復計画が生成されます。
注:
修復の実行には管理者権限が必要ですが、修復計画の生成には必要ありません。
Microsoft Office 修復ツールを使用する
-
[ホーム] (Studio の Backstage ビュー) > [ツール] > [アプリ] > [Microsoft Office 修復ツール] の順に選択します。修復ツールが開きます。
-
ウィンドウ上部のタブで、使用可能な各アクションを表示できます。以下のタブが用意されています。
- 各 Microsoft Office アプリケーションのタブ: Excel、Outlook、Word、PowerPoint
- Office の修復、および Office 2013 以降のバージョンの Microsoft Office 修復ツールについての情報
アクションごとに、アプリケーションのインストール パス、バージョン、32 ビット版か 64 ビット版かの情報が、修復ツールによって自動的に検出されます。検出された情報が正しいことを確認し、必要に応じて修正します。

- [修復計画を生成] をクリックします。実行する操作のリストが表示されます。

- 実行する修復操作を選択します。既定では、推奨されるすべての修復操作が選択されています。操作の詳細を表示するには、操作の横の
をクリックします。
- 修復計画で何をするかを選択します。
- 修復操作を実行 - マシン上でアクションを実行します。このオプションを選択すると、その結果がウィンドウの下部に表示されます。
- .reg ファイルを作成 - 修復の変更の完全なリストを表示するには、
.reg
ファイルを生成します。 - 設定をエクスポート - 他のマシンにデプロイ可能な修正計画を使用して、JSON ファイルを作成します。
レジストリを以前のステートに戻す
修復計画が実行されるたびに、以前の Windows レジストリ構成のバックアップが保存されます。Microsoft Office 修復ツールの実行後に予期しない問題が発生した場合は、以下を実行します。
- ツールを再び開いて [バックアップ] タブを選択します。実行された修復のリストが表示されます。
- レジストリの変更を元に戻す修復の横の [元に戻す] をクリックします。
1 年前に更新