Abonnieren

UiPath Studio

UiPath Studio-Anleitung

2021.10.3


Der UiPath-Ansatz zur Patches-Dokumentation


🛈 UiPath veröffentlicht regelmäßig Patches, die Korrekturen und Verbesserungen enthalten, wenn ein geschäftlicher Bedarf besteht. Die Dokumentation für eine bestimmte Version spiegelt den neuesten Patch auf dieser Version wider. Produktänderungen zwischen den Patches können in den Versionshinweisen überprüft werden.
Beispielsweise zeigt die Dokumentation von Studio 2020.10 im Mai 2021 den neuesten Patch, nämlich 2020.10.7.



Release date: 27 October 2021

What’s New

Unterstützung für .NET 5.0-Windows- und plattformübergreifende Projekte

Sie können jetzt Projekte erstellen, die mit .NET 5 kompatibel sind. Wenn Sie ein Projekt erstellen, wählen Sie die Projektkompatibilität aus – entweder Windows – Legacy (.NET Framework 4.6.1), Windows (.NET 5 mit Windows-Unterstützung) oder plattformübergreifend (.NET 5 mit plattformübergreifender Unterstützung). Die Standardoption ist Windows – Legacy, die Kompatibilität, die in früheren Versionen von Studio verwendet wurde.

Gut zu wissen:

  • Windows- und plattformübergreifende Projekte werden als 64-Bit-Prozesse ausgeführt, sodass Sie die Vorteile der 64-Bit-Architektur voll nutzen können. Das bedeutet, dass die Projekte nur auf 64-Bit-Betriebssystemen unterstützt werden. Windows – Legacy-Projekte werden als 32-Bit-Prozesse ausgeführt.
  • Plattformübergreifende Projekte können für die API-Automatisierung verwendet und sowohl unter Windows- als auch unter Linux-Betriebssystemen ausgeführt werden.
  • Projekte, die in Studio-Versionen 2021.4 und älter erstellt wurden, werden als Windows – Legacy-Projekte geöffnet.
  • Windows- und plattformübergreifende Projekte werden bei der Veröffentlichung kompiliert, was Leistungsverbesserungen bei der Ausführung und sicherere Pakete mit DLL-Dateien anstelle der Projektquelldateien mit sich bringt. Keine Sorge – wenn Sie die Quelldateien veröffentlichen möchten, haben Sie weiterhin die Möglichkeit, sie in die veröffentlichten Pakete aufzunehmen.
  • Windows- und plattformübergreifende Projekte können nur auf Robot v2021.10 oder höher ausgeführt werden.
  • Starting with this release, the activities packages included by default with Studio support both Windows - Legacy and Windows projects, while a limited number of packages support cross-platform projects. Only the packages and versions that support the selected project compatibility are available for installation from the Manage Packages window.
  • Organizations can deploy governance policies that define the default compatibility or enforce the use of specific compatibilities.
  • Bibliotheken können nur in Projekten installiert werden, die dieselbe Kompatibilität haben.
  • Alle Projekte, die im StudioX-Profil erstellt wurden, verwenden die Windows – Legacy-Kompatibilität.
  • Die Kompatibilität jedes Projekts wird rechts neben der Studio-Statusleiste unter Projekt-Panel > Abhängigkeiten-Knoten angezeigt, sowie im Eintrag jedes Projekts in der Liste Zuletzt verwendete öffnen unter Start (Studio Backstage-Ansicht) > Starten.
  • You can migrate your existing custom activities to .NET 5.

Ausführen und Debuggen von Projekten auf Remote-Robotern

You can now run and debug projects on robots that are running on other machines. The new Remote Debugging feature works with both Windows and Linux robots and gives you the option to either set up a TCP/IP connection to a remote robot or connect to an unattended robot via Orchestrator. When a connection is established and remote execution is enabled, all run and debug operations are performed on the remote robot. For more information, see Remote Debugging.

Die Profile von Studio und Studio Pro wurden zusammengeführt

Um die Arbeit mit Studio zu vereinfachen und den Zugriff auf die von Ihnen benötigten Funktionen zu erleichtern, wurde das Studio Pro-Profil abgeschafft. Das Studio-Profil enthält jetzt alle erweiterten Funktionen, die zuvor ausschließlich für das Studio Pro-Profil verfügbar waren, z. B. Testautomatisierung, mobile Automatisierung oder C#-Unterstützung. Zudem sind nun Studio Pro-Vorlagen in Studio verfügbar.

Gut zu wissen:

  • Wenn Sie auf diese Version aktualisieren und in der vorherigen Version das Studio Pro-Profil verwendet haben, werden die Einstellungen im Studio Pro-Profil in das Studio-Profil dieser Version migriert, auch wenn Sie in der vorherigen Version ebenfalls das Studio-Profil verwendet haben.
  • Studio ist kompatibel mit Projekten, die in älteren Studio- und Studio Pro-Versionen erstellt wurden.
  • Organisationen, die Governance verwenden, müssen vorhandene Studio Pro-Richtlinien wie folgt in das Studio-Profil migrieren:
    • For file-based governance, the parameters configured for the StudioPro profile must be moved to the Development profile.
    • For Automation Ops, move the settings in your existing Studio Pro policies to new Studio v2021.10 policies.
  • Eine neue Lizenz namens Automation Developer ist jetzt verfügbar und ersetzt die Lizenzen RPA Developer, RPA Developer Pro und Test Developer Pro, die in älteren Versionen verfügbar waren. Sie können Studio weiterhin verwenden, wenn Sie es mit einer der älteren Lizenzen aktivieren, die Zugriff auf Studio Pro gewährt haben.

Das Design von StudioX jetzt auch in Studio

The activities that were designed for StudioX are now also available by default in Studio, and you can use the Plus plus buttonplus button menu to interact with Excel and PowerPoint files, Outlook, Outlook 365, and Gmail accounts, or Google spreadsheets added to your automations.

When configuring activities, you can browse for and select data that matches the expected type of a property directly from the Plus plus buttonplus button menu of each property. Expressions are automatically generated without you having to manually enter them.

  • For Excel, as long as the modern design experience is enabled:

    • The modern StudioX activities are the Excel activities available by default in your projects, replacing the classic Excel App integration activities.
    • When you configure Excel activities inside the Use Excel File scope activity, you can browse the contents of the file and select data such as cells, ranges, tables, sheets, or charts from the menu. In addition, you can now install the Excel Add-in that allows you to switch between Studio and Excel to indicate the data you want to use in your automations from the file.
  • For PowerPoint, when you configure PowerPoint activities inside the Use PowerPoint Presentation scope activity, you can select data such as slides, shapes, or layouts from the menu.

  • For Mail, when you configure mail activities inside the Use Outlook 365, Use Gmail, or Use Desktop Outlook App scope activities, you can select Outlook folders, Gmail labels, the current mail in an iteration, or message fields such as Subject, Body, Body as HTML, Bcc, Cc, To, From, Date (as text), and Priority from the menu.

  • For Google Sheets, when you configure Sheets activities inside the Use Google Spreadsheet scope activity, you can select sheets and named ranges from the menu.

  • Bei Dateiaktivitäten im Systemaktivitätspaket können Sie beim Durchlaufen von Dateien oder Ordnern Datei- und Ordnereigenschaften aus dem Menü auswählen, z. B. Name, vollständiger Name, Datum der letzten Änderung, Datum des letzten Zugriffs oder Erstellungsdatum.

    When working with the Use Excel File and Use PowerPoint Presentation activities, if the file that will be used at runtime does not exist yet, you can still use the Plus plus buttonplus button menu by defining a file with the same structure as a template for use at design time.

Moderne Designumgebung standardmäßig aktiviert

The modern design experience is now enabled by default for all new Studio projects, allowing you to take advantage of the latest features in the UIAutomation activities package.

Um den Übergang zu erleichtern: Wenn Sie bei der Verwendung der modernen Umgebung nach einer klassischen Aktivität suchen, ist das moderne Gegenstück der Aktivität in den Suchergebnissen enthalten (z. B. ergibt die Suche nach der klassischen Aktivität Attach Browser die moderne Aktivität Use Application/Browser).

Wenn Sie dennoch die klassische Umgebung verwenden möchten, können Sie die moderne Umgebung auf globaler oder Projektebene deaktivieren oder im Panel Aktivitäten die Option Klassische anzeigen auswählen, um die klassischen Aktivitäten in einem Projekt verfügbar zu machen.

📘

Hinweis:

Wenn Sie ein Upgrade von Studio v2020.10 oder v2021.4 durchführen, dann wird die Einstellung „Modern“ für neue Projekte verwenden der vorherigen Version nicht geändert.

Bearbeiten von Aktivitätseigenschaften während des Debuggens

Debugging your projects has just become easier. You can now fix issues while debugging is paused by editing the properties of the current activity. Hover over a property in the Locals panel, click editedit, make adjustments in the Local Value window, and then resume debugging.

Erfassen von Telemetriedaten in Azure Application Insights

Studio can now send telemetry data to your Application Insights instance in Azure, allowing you to monitor and analyze how Studio is used in your organization. To enable this feature, all you need to do is provide the Application Insights instrumentation key in your governance policies. For more information, see Governance, in the Studio guide and Settings for Studio policies in the Automation Ops guide.

Integration mit dem Automation Hub

To create a smoother automation journey, we've made it easier to link Studio projects to ideas in Automation Hub. A new project property called Automation Hub URL enables you to link an existing project to an idea in Automation Hub. Alternatively, in Automation Hub you have the option to start a Studio project directly from ideas that are in the Development phase and have the status Not started. For more information, see Linking a Project to an Idea in Automation Hub.

Option zum Markieren von Prozessen als beaufsichtigte Automatisierungen

You can now indicate whether a process is designed for attended automation. Enable the Attended Automation project setting for processes that include UI Automation activities or other activities that require user interaction. Processes marked as attended automations should not be executed in unattended scenarios.

Exportieren von Workflow-Analyse-Ergebnissen

You now have the option to export the results of each workflow analysis to a JSON file in the project folder.

Neue Source Control-Funktionen

Authentifizieren durch Anmelden mit Ihrem GitHub-Konto

You can now sign in with your GitHub account to authenticate to remote Git repositories hosted on github.com. When using HTTPS to clone a remote repository or copy a project to a repository, a new option called Sign in with GitHub is available under Use Credentials. This feature requires the UiPath GitHub App to be installed in your organization or account.

Ändern der Anmeldeinformationen in Git

You can now change the credentials used to connect to remote Git repositories.

Erstellen einer Verzweigung aus vorherigem Git-Commit

You can now create a new branch from any previous commit. When viewing the history of a file, folder, or project, right-click a commit in the History window and select Create branch.

Governance für Git-Repositorys

Organizations can now enforce the use of specific Git repositories through governance policies. When a list of allowed repositories is enforced, Studio users will only be able to use remote Git repositories from that list. In the file-based governance model, use the AllowEditRepositories parameter to indicate whether users should use only allowed repositories and the Repositories parameter to define the list of allowed repositories. For Automation Ops, see Settings for Studio policies in the Automation Ops guide.

Repository-URL kopieren

Sie können jetzt schnell die Repository-URL für ein Projekt kopieren, das zu Source Control hinzugefügt wurde, indem Sie mit der rechten Maustaste auf den Projektknoten oder eine Datei im Projekt-Panel klicken und dann im Kontextmenü Repository-URL kopieren auswählen.

Änderungen bei der Installation und Aktualisierung

Aktualisierte Installationsprogramme

  • Um die Installation für Community-Benutzer konsistenter und flexibler zu machen, wurde das Installationsprogramm UiPathStudioSetup.exe der Community Edition abgeschafft. Das MSI-Installationsprogramm, das zuvor nur für die Enterprise Edition verfügbar war, wurde aktualisiert und ist jetzt auch für die Community Edition verfügbar (UiPathStudioCommunity.msi). Ab dieser Version haben Community-Benutzer auch die Möglichkeit, die Enterprise Edition von Studio zu installieren und mit einer Community-Lizenz zu aktivieren.

  • The Studio MSI installer has a new interface and gives you two setup options:

    • Schnell (empfohlen für Community-Benutzer) – Führen Sie die Installation für den aktuellen Benutzer in einer Standardkonfiguration durch, die einen Benutzermodus-Roboter enthält, ohne Einstellungen zu konfigurieren.
    • Benutzerdefiniert (empfohlen für Enterprise- und fortgeschrittene Benutzer) – Führen Sie die Installation pro Maschine durch, wählen Sie den Robotertyp und die zu installierenden Komponenten aus und konfigurieren Sie erweiterte Installationseinstellungen.

Automatisches Aktualisieren von Clientkomponenten über den Orchestrator

Ever thought how great it would be to always have your robots up to date? We have some great news then! You are now able to update Robot, Studio, and UiPath Assistant clients to newer versions from Orchestrator. This provides an easy way to deliver a version update to a large base of machines from a centralized location, helping remove user friction and streamlining the update process.

Neue Testautomatisierungsfunktionen

Test Explorer

Sind Sie bereit für das Testen auf Knopfdruck? Das Panel „Test Explorer“ gruppiert alle Testausführungen in einer einzigen Ansicht, inklusive Testentwicklung, Ausführung und Analyse. Im neuen Panel können Sie Tests basierend auf dem Ergebnisstatus filtern und Tests auf Grundlage von erfolgreichen/fehlgeschlagenen Szenarien ausführen oder debuggen. Die Aktivitätsabdeckung wurde als Unterpanel aufgenommen, um die Testfunktionen zusammenzuhalten.

To learn how it works, see Test Explorer.

Ausführungsvorlagen

Sie können Testfälle in dynamische Vorlagen zur Laufzeit einbetten, um die Instandhaltung der Testausführungssortierung, die testfallspezifische Wiederherstellung, die anpassbare Testfallberichterstattung sowie das Einrichten und Abbrechen zu reduzieren.

For more information, see Execution Templates.

Dateivorlagen

Sie können Vorlagen für Ihre Testfälle erstellen, sodass Sie diese in verschiedenen Tests wiederverwenden können.

For more information, see File Templates.

SAP Change Impact Mining

In Zusammenarbeit mit unserem UiPath Technologiepartner führen wir das Change Impact Mining für SAP ECC- und SAP S/4HANA-Projekte ein.

Das SAP Monitoring führt die Aktivität „SAP Session Attributes Change Trigger“ ein, um die Überwachung von SAP-Sitzungsattributen zu ermöglichen. Während der Laufzeit können Änderungen am SAP-Sitzungsattribut protokolliert werden. Sie können die SAP-Sitzungsattribute definieren. Standardmäßig ist die Überwachung für SAP-Transaktionen und SAP-Programme festgelegt.

Die SAP-Testprojektvorlage verwendet eine Ausführungsvorlage, mit der Sie sowohl den SAP-Testfall als auch das SAP Monitoring parallel ausführen können. Dadurch können Sie Informationen über ausgeführte SAP-Transaktionen und SAP-Programme sowie deren Abhängigkeiten während der Laufzeit sammeln. Alle gesammelten Informationen werden automatisch an den UiPath Test Manager übermittelt und auf Testfallebene sichtbar.

For more information, see the following:

Verbesserungen

Objekt-Repository

  • The App/Web Recorder now supports using the Object Repository when recording, enabling you to use already existing objects or create new ones.
  • Das Objekt-Repository verwendet jetzt die Computer Vision-Technologie für die Funktion Alle Elemente erfassen, die alle Elemente einer angegebenen Anwendung extrahieren und zu Ihrem Objekt-Repository hinzufügen kann. Dadurch kann der Zeitaufwand für die Verwendung des Objekt-Repository erheblich reduziert werden, da Sie nicht mehr jedes Element einzeln manuell hinzufügen müssen.
  • Mit der neuen Hervorhebungsfunktion im Objekt-Repository können Sie jedes Objekt hervorheben, das Sie auf dem Bildschirm erfasst haben, sodass Sie leichter erkennen können, mit welchem Element Sie gerade arbeiten.

Vorlage für das Robotic Enterprise Framework

Added 16 November 2021

Die Vorlage für das Robotic Enterprise Framework hat mehrere Verbesserungen erhalten:

  • Wir haben OrchestratorQueueName in der Config.xlsx-Datei und als Eingabeargument in Main.xaml hinzugefügt.
  • Die Process.xaml-Datei wurde in den Framework-Ordner verschoben.
  • Es wurde ein Problem behoben, das darin bestand, dass im Falle eines beendeten Prozesses für ein Warteschlangenelement der Status Erfolgreich gesetzt wurde:
    • Wir haben den Aufruf von Framework\SetTransactionStatus.xaml innerhalb des Finally-Blocks entfernt.
    • Ein Aufruf von Framework\SetTransactionStatus.xaml, umgeben von einer Try Catch-Aktivität, wurde nach dem Aufruf von Framework\Process.xaml für die erfolgreichen Fälle im selben Try-Block hinzugefügt.
    • Im Abschnitt Catch wurde für jeden Ausnahmetyp (Systemausnahme oder Betriebsregelausnahme) ein Aufruf von Framework\SetTransactionStatus.xaml umgeben von einer Try Catch-Aktivität hinzugefügt.
  • Wir haben eine maximale Anzahl aufeinanderfolgender Wiederholungsversuche hinzugefügt, um zu vermeiden, dass die Warteschlange für persistente Fehler verbraucht wird. In Config.xlsx wurde eine neue globale Variable namens ConsecutiveSystemExceptions und eine Konstante mit dem Namen MaxConsecutiveSystemExceptions hinzugefügt.
  • Falls die maximale aufeinanderfolgende Wiederholungsanzahl erreicht ist, wird der Auftrag jetzt als fehlgeschlagen (fehlerhaft) markiert. Dieses Verhalten kann aktiviert werden, indem der boolesche Wert ShouldMarkJobAsFaulted in Config.xlsx auf TRUE festgelegt wird (standardmäßig ist er auf FALSE festgelegt).
  • Fehlgeschlagene Warteschlangenelemente enthalten jetzt den Namen und Speicherort zugehöriger Screenshots.
  • Wir haben Wiederholungsmechanismen für die Aktivitäten Set Transaction Status und Get Transaction Item hinzugefügt, falls ein Fehler auftritt.
  • Die Bildschirmauflösung wird nun im Abschnitt „Init“ protokolliert.
  • Das Projekt entspricht nun den standardmäßigen Workflow-Analyseregeln.
  • Wir haben die Verwaltung von Assets verbessert. In früheren Versionen, als ein Asset im Blatt Assets der Config.xlsx-Datei deklariert wurde, das Asset jedoch im Orchestrator fehlte, gab es eine Protokollmeldung mit der Stufe „Warnung“. Der Prozess wurde fortgesetzt, auch wenn für diese Schlüssel Werte fehlten, und später im Prozess anfällig für Fehler war. Das Framework löst jetzt eine Ausnahme aus, wenn ein Asset nicht im Orchestrator gefunden wird und der Prozess in der Init-Phase angehalten wird.
  • Wir haben ein neues Testframework hinzugefügt, das die neuen Funktionen der Test Suite verwendet. Ein Ordner mit dem Namen Tests, der einige Testfälle im Zusammenhang mit den Workflows des Frameworks enthält, ist jetzt im Projektordner „REFramework“ enthalten.
  • Wir haben die Dokumentationsdatei im Ordner Dokumentation im REFramework-Projektordner mit allen neuen Verbesserungen aktualisiert.

Ausdrucks-Editor

  • Der Ausdrucks-Editor wird an derselben Position geöffnet, an der Sie das Fenster zum letzten Mal geschlossen haben.
  • Schaltflächen zum Maximieren/Wiederherstellen sind jetzt in der Titelleiste oben im Ausdrucks-Editor verfügbar, um die Fenstergröße schnell zu ändern.
  • Wenn Sie vergrößern oder verkleinern, um die Größe des Texts zu ändern (z. B. mit Strg + Scrollen), und dann das Fenster schließen, wird der Ausdrucks-Editor mit demselben Zoomfaktor geöffnet, den Sie beim letzten Schließen des Fensters verwendet haben.
  • Wenn Sie den Ausdrucks-Editor auf einer Anzeige mit einer niedrigeren Auflösung als der zuletzt verwendeten Fenstergröße des Ausdrucks-Editors öffnen, wird das Fenster automatisch auf seine Standardgröße zurückgesetzt, anstatt seine vorherige Größe zu behalten.

Veröffentlichen

  • Die Optionen Bei Veröffentlichung ignorieren/Als veröffentlichbar festlegen, die im Kontextmenü des Projekt-Panels verfügbar sind, wurden in Als privat festlegen/Als öffentlich festlegen umbenannt, wenn auf das Menü für Workflow-Dateien in Bibliotheksprojekten zugegriffen wird.
  • Der letzte Feed, in dem Sie veröffentlicht haben, ist jetzt der Standardspeicherort, der im Schritt Veröffentlichungsoptionen des Veröffentlichungsassistenten ausgewählt wurde. Der Speicherort bleibt so lange standardmäßig festgelegt, bis Sie einen anderen Ordner in der Studio-Statusleiste auswählen oder Studio neu starten.
  • You can now use governance policies to enforce the addition of release notes when publishing a project. In the file-based governance model, setting the value of the EnforceReleaseNotes parameter to true makes the Release Notes field in the Publish wizard a required field. For Automation Ops, see Settings for Studio policies in the Automation Ops guide.
  • Wenn Sie die Option auswählen, Quellen beim Veröffentlichen eines Projekts einzuschließen, werden die Dateien nun in der .nupkg-Datei im Ordner lib\net45 (für Windows-Legacy-Bibliotheken) oder im Ordner content (für Windows- und plattformübergreifende Bibliotheken und Projekte) gespeichert. Bei Windows-Legacy-Bibliotheken werden die Dateien auch weiterhin in der generierten Assembly-Datei gespeichert.

Testautomatisierung

  • Sie können in einem einzigen Schritt Testdaten zu mehreren Testfällen hinzufügen.
  • Wenn Sie Testdaten aktualisieren, können Sie vorhandene Daten in Ihren Testfällen überschreiben.
  • Sie können Ordner und Elemente mit Datenvarianten schneller erkennen, da diese mit einem aussagekräftigeren Symbol versehen sind.

Weitere Verbesserungen

  • Bei der Installation von Studio ist die Option zum Installieren der Erweiterung für Edge Chromium nun standardmäßig aktiviert, wenn Microsoft Edge Chromium bereits auf Ihrer Maschine installiert ist.
  • You can now configure the ST-SEC-009 - SecureString Misusage Workflow Analyzer rule to exclude activities that can input sensitive data but do not support the SecureString type.
  • Zusätzliche Informationen werden nun für jedes Projekt in der Liste der letzten Projekte unter Start (Studio Backstage-Ansicht) > Registerkarte Start angezeigt:
    • Für Ausdrücke verwendete Sprache (VB oder C#).
    • Projektkompatibilität (Windows-Legacy, Windows oder plattformübergreifend).
    • Source Control-Repository, unter dem sich das Projekt befindet (GIT, SVN oder TFS) oder lokal, wenn sich das Projekt nicht unter Source Control befindet.
      Wenn Sie von einer älteren Studio-Version aktualisieren, werden die Kompatibilitäts- und Source Control-Informationen für Projekte angezeigt, die Sie in der vorherigen Version erst geöffnet haben, nachdem Sie sie in der aktuellen Version geöffnet haben.
  • Sie können jetzt mit der Tastenkombination Strg + W die Workflowdatei schließen, die im Designer-Panel im Fokus steht.
  • You now have access to additional templates on which to base your automations. When you browse for templates in Home (Studio Backstage View) > Templates, the Marketplace location is now available, enabling you to select from a variety of pre-built templates published on the UiPath Marketplace.
  • Wenn Sie eine Datei innerhalb des Projekt-Panels in einem Projekt mit großer Struktur durch Ziehen verschieben, innerhalb des Panels scrollen und die Datei dann ablegen, dann bleibt die Ansicht des Projekt-Panels jetzt an dem Ort, zu dem die Datei verschoben wurde, anstatt an den ursprünglichen Ort der Datei zurückzukehren.
  • To make it easier to configure the If activity, the plus_iconplus_icon icon which allows quick access to the Add activity bar is now available inside the Then and Else branches of the activity.
  • The Add Activity search bar now uses AI to suggest activities you may want to add next based on the current context of the workflow. You can opt out of this by deselecting the Enable AI activity suggestions option in the Design settings, and organizations can control this setting using governance policies.

:warning: Erratum 3 March 2022: Removed an improvement incorrectly mentioning the change of the URL for the official package sources.

Bug Fixes

Bibliotheken

  • Es wurde ein Problem behoben, das dazu führte, dass Aktivitäten, die aus in Studio v2021.4 erstellten Bibliotheken generiert wurden, einen unerwarteten Namespace haben, wenn der Bibliotheksname einen Punkt (.) enthielt.
  • Wenn Sie eine Bibliothek als Projektabhängigkeit installieren, enthält das Panel Aktivitäten keinen unerwarteten zusätzlichen Ordner mehr in der Struktur für Aktivitäten aus dieser Bibliothek. Das Problem trat in Bibliotheken auf, die über Studio v2021.4 veröffentlicht wurden.
  • Die Fehlermeldung Ein Element mit demselben Schlüssel wurde bereits hinzugefügt tritt nicht mehr auf, wenn Sie versuchen, eine Bibliothek zu veröffentlichen, die die ServiceNow- und Mail-Pakete als Abhängigkeiten enthält.
  • Es wurde ein Problem behoben, das verhinderte, dass Anmerkungen, die den Stammaktivitäten in Dateien aus Bibliotheksprojekten hinzugefügt wurden, als Tooltips für die erzeugten Aktivitäten angezeigt wurden, wenn die Bibliotheken in Projekten installiert waren.

Benutzerfreundlichkeit

  • Die Eingabe der Zeichen {, [ und | in Ausdrücken funktioniert jetzt wie erwartet, wenn Sie eine französische Tastatur verwenden.
  • Ein Fehler tritt nicht mehr auf, wenn Sie die türkische Q-Tastatur verwenden und die Tastenkombinationen AltGr + 7 und AltGr + 8 drücken, um die Zeichen { und [ in Ausdrücken einzugeben.
  • Das Eingeben des @-Zeichens in Ausdrücke durch das Drücken der Tastenkombination AltGr + 2 funktioniert jetzt wie erwartet, wenn die niederländisch-belgische Tastatur verwendet wird.

Testautomatisierung

  • Die Aktivitätsabdeckung wurde für Dateien, die Pseudo-Aktivitäten enthielten, nicht korrekt berechnet.
  • Das Umgeben einer hereingezoomten Aktivität mit einem Pseudo-Objekt im Designer-Panel hat den Fokus nicht auf diese neue Aktion geändert.

Weitere Korrekturen

  • Es wurde ein Problem behoben, das dazu führte, dass Studio mit dem Fehler Sammlung wurde geändert; Aufzählung kann möglicherweise nicht ausgeführt werden zufällig nicht mehr reagierte.
  • Es wurde ein Problem behoben, das manchmal dazu führte, dass ein Fehler auftritt und Studio nicht mehr reagierte, wenn Sie Aktivitäten aus dem Aktivitäten-Panel gezogen und in einen Workflow abgelegt haben.
  • Es wurde ein Problem behoben, das dazu führen konnte, dass ein Fehler auftritt, wenn versucht wurde, ein neues Projekt mit der Hintergrundprozessvorlage zu erstellen.
  • Die Auswahl eines Elements aus dem Studio-Menüband erfordert keinen zweiten Klick mehr, wenn eine andere Anwendung im Fokus steht.
  • Wenn Sie mit mehreren Bildschirmen arbeiten und das Studio-Fenster auf einem Bildschirm maximieren, dann verdeckt das Fenster nicht länger Teile eines anderen Bildschirms.
  • Es wurde ein Problem behoben, das zu unerwartetem Verhalten führte, beispielsweise wurden Aktivitäten in der falschen Datei hinzugefügt, wenn zwei Workflowdateien nebeneinander in derselben Studio-Instanz geöffnet wurden.
  • Das Öffnen des Popup-Menüs Anmelden/Abmelden durch Klicken auf das Symbol in der Studio-Titelleiste funktioniert jetzt wie erwartet, unabhängig davon, welches Studio-Panel im Fokus steht.
  • Das UiPath.Activities.API SDK-Paket, das nur zum Entwickeln benutzerdefinierter Aktivitäten vorgesehen ist, kann nicht mehr als Projektabhängigkeit installiert werden.
  • Es wurde ein Problem behoben, durch das die Aktivität Try Catch System.InvalidOperationException-Fehler nicht verarbeiten konnte, die generiert wurden, wenn Bildaktivitäten wie Find Image die Pick Branch-Aktivitäten nicht auslösen konnten.
  • Wenn Sie die Aktivität Invoke Code mit der Sprache CSharp verwenden, die für den aufgerufenen Code festgelegt ist, dann geben Validierungsfehlermeldungen im Zusammenhang mit der Aktivität die Codezeilennummern, bei denen Fehler erkannt werden, nun korrekt an.
  • Es wurde ein Problem behoben, das dazu führte, dass Argumente, die im Dialogfeld Workflowargumente aufrufen der Aktivität Invoke Workflow File erstellt wurden (z. B. STRG + M in einem Wertefeld), erst sichtbar wurden, nachdem die Datei, in der die Aktivität enthalten ist, geschlossen und erneut geöffnet wurde.
  • Die Workflow-Analyse-Regel ST-USG-010 (Nicht verwendete Abhängigkeiten) erkennt keinen Verstoß mehr, wenn keine Aktivität aus einem Paket in einem Projekt, sondern eine Funktion aus dem Paket verwendet wird.
  • Wenn das Objekt-Repository in einem Projekt erzwungen wird, kann es nicht mehr über den Recorder deaktiviert werden.
  • Wenn das Panel Ausgabe, Fehlerliste, Verweise suchen oder Haltepunkte nicht fixiert ist und einen großen Bereich des Fensters abdeckt, während Studio maximiert ist, führt das Klicken auf die Schaltfläche Wiederherstellen in der Statusleiste zum Verkleinern von Studio dazu, dass das Panel nicht mehr das beinahe gesamte Fenster abdeckt und Studio nicht ordnungsgemäß angezeigt wird.

Aktualisiert vor 4 Monaten

2021.10.3



Der UiPath-Ansatz zur Patches-Dokumentation


🛈 UiPath veröffentlicht regelmäßig Patches, die Korrekturen und Verbesserungen enthalten, wenn ein geschäftlicher Bedarf besteht. Die Dokumentation für eine bestimmte Version spiegelt den neuesten Patch auf dieser Version wider. Produktänderungen zwischen den Patches können in den Versionshinweisen überprüft werden.
Beispielsweise zeigt die Dokumentation von Studio 2020.10 im Mai 2021 den neuesten Patch, nämlich 2020.10.7.



Auf API-Referenzseiten sind Änderungsvorschläge beschränkt

Sie können nur Änderungen an dem Textkörperinhalt von Markdown, aber nicht an der API-Spezifikation vorschlagen.