Subscribe

UiPath Installation and Upgrade

UiPath 安装和升级指南

Backward and Forward Compatibility

UiPath 方法


Activity Packages

活动包版本独立于 Studio、机器人或 Orchestrator 版本,但 Orchestrator 活动除外。例如,v2018.1 中引入的“启动作业”活动仅适用于 v2018.1 或更高版本的机器人。

Automation Projects

使用内部测试版或测试版 Studio 创建的项目可能与更新的 Studio 版本不兼容,也不能由更新的机器人执行。
我们支持向后兼容性(但官方发行说明中宣布的重大更改除外),并且符合产品生命周期
使用旧版本 Studio 创建的项目可以在更新的机器人上执行。例如,使用 Studio v2018.4 创建的项目应能在 v2019.10 机器人或更高版本上运行。
我们不支持向前兼容性。使用更新版本的 Studio 创建的项目可能无法在较旧的机器人上执行。例如,在 Studio v2019.10 中创建的项目可能不适用于 v2018.4 机器人。

Technical Compatibility Matrix


以下矩阵根据 Studio、机器人和 Orchestrator 的版本和 Orchestrator 的交付模型提供有关三者之间互操作性的信息。除非另有特别提及,否则此矩阵中隐式支持修补程序。

如果不升级,您只能使用最小安装版本的机器人或 Orchestrator 的功能。

It is usually recommended to first upgrade your Orchestrator and then your Robots. In this scenario, the Robots have to be reconnected to Orchestrator after the update.

📘

Important!

某些版本不再受支持。有关详细信息,请参阅产品生命周期。如果其中一个产品不受支持,我们不支持两种产品之间的互操作性。

Studio/Robot

Studio 和机器人总是需要有相同的版本。

Studio 20.10.x

Studio 20.4.x

Studio 19.10.x

Studio 18.4.x

Robot 20.10.x

:white-check-mark:

:x:

:x:

:x:

Robot 20.4.x

:x:

:white-check-mark:

:x:

:x:

Robot 19.10.x

:x:

:x:

:white-check-mark:

:x:

Robot 18.4.x

:x:

:x:

:x:

:white-check-mark:

Orchestrator/Robot

使用传统文件夹来保持完全向后兼容性,这些文件夹维护了与以前的业务流程处理版本相同的功能,确保现有资源和集成能够不间断地运行。

Taking advantage of the additional features and capabilities of modern folders does, however, require the use of the latest Robot and Activities versions (UiPath.System.Activities v19.10.1 or higher). See details here. See a comparison between modern folders and classic folders on the Key Features and Behavior page.

内部部署 Orchestrator

Orch 20.10.x

Orch 20.4.x

Orch 19.10.x

Orch 18.4.x

Robot 20.10.x

:white-check-mark:

:white-check-mark:

:white-check-mark:

:x:

Robot 20.4.x

:white-check-mark: 5

:white-check-mark:

:white-check-mark: 4

:x:

Robot 19.10.x

:white-check-mark: 2, 5

:white-check-mark: 2

:white-check-mark:

:white-check-mark:

Robot 18.4.x

:white-check-mark: 2, 3, 5, 6

:white-check-mark: 1, 2, 3

:white-check-mark: 1, 3

:white-check-mark: 1

1 - If the Scalability.SignalR.AuthenticationEnabled parameter is set to true, you can only use v2018.4.4 Robots or above. For more information, see this page.
2 - Robots v2019.10 and older cannot execute unattended processes in modern folders.
3 - Robots v2019.4 and older only work with classic folders.
4 - TLS 1.1 / TLS 1.2 must be enabled.
5 - Robots 2018.4.4+ and 2020.4- connect to Orchestrator via Long Polling only.
6 - Robot SignalR authentication is not configurable and is enabled by default to ensure secure communication between Orchestrator and Robots. As such, you can only use v2018.4.4 Robots or above.

Automation Cloud Orchestrator

对于驻留在 Automation Cloud 中的 Orchestrator 服务,我们确保与最新的三个机器人企业版本向后兼容。如果您使用的是最旧的机器人版本,我们建议您作出必要的安排,并在 UiPath 发布下一个机器人版本前提前升级。

Cloud Orch

Latest Robot Version
Mainstream Support

:white-check-mark:

Penultimate Robot Version
Mainstream Support

:white-check-mark:

Antepenultimate Robot Version
Extended Support

:white-check-mark:

假设您在 2021 年 3 月(即 21.4 版本发布之前)使用 Orchestrator 服务,如果您使用的是 19.10 机器人,您需要注意以下事实:在 21.4 版本发布之后,19.10 机器人不再具有扩展支持,不再保证能够与 Automation Cloud Orchestrator 服务一起使用。

📘

Important!

某些版本不再受支持。有关详细信息,请参阅产品生命周期。如果其中一个产品不受支持,我们不支持两种产品之间的互操作性。

Updated 2 months ago


Backward and Forward Compatibility


Suggested Edits are limited on API Reference Pages

You can only suggest edits to Markdown body content, but not to the API spec.